]> git.pld-linux.org Git - packages/ghc-void.git/blame - ghc-void.spec
- up to 0.7.3
[packages/ghc-void.git] / ghc-void.spec
CommitLineData
7c07c347
JB
1#
2# Conditional build:
3%bcond_without prof # profiling library
4#
5%define pkgname void
6Summary: A Haskell 98 logically uninhabited data type
7Summary(pl.UTF-8): Logicznie niezamieszkały typ danych Haskella 98
8Name: ghc-%{pkgname}
c8d7a1f8 9Version: 0.7.3
7c07c347
JB
10Release: 1
11License: BSD
12Group: Development/Languages
13#Source0Download: http://hackage.haskell.org/package/void
14Source0: http://hackage.haskell.org/package/%{pkgname}-%{version}/%{pkgname}-%{version}.tar.gz
c8d7a1f8 15# Source0-md5: 62eb3c78a01d7545551f7961ec5f2340
7c07c347
JB
16URL: http://hackage.haskell.org/package/void
17BuildRequires: ghc >= 6.12.3
18BuildRequires: ghc-base >= 3
7c07c347
JB
19BuildRequires: ghc-hashable >= 1.1
20BuildRequires: ghc-semigroups >= 0.8.2
21%if %{with prof}
22BuildRequires: ghc-prof >= 6.12.3
23BuildRequires: ghc-base-prof >= 3
7c07c347
JB
24BuildRequires: ghc-hashable-prof >= 1.1
25BuildRequires: ghc-semigroups-prof >= 0.8.2
26%endif
27BuildRequires: rpmbuild(macros) >= 1.608
28Requires(post,postun): /usr/bin/ghc-pkg
29%requires_eq ghc
30Requires: ghc-base >= 3
7c07c347
JB
31Requires: ghc-hashable >= 1.1
32Requires: ghc-semigroups >= 0.8.2
33BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35# debuginfo is not useful for ghc
36%define _enable_debug_packages 0
37
38# don't compress haddock files
39%define _noautocompressdoc *.haddock
40
41%description
42A Haskell 98 logically uninhabited data type, used to indicate that a
43given term should not exist.
44
45%description -l pl.UTF-8
46Logicznie niezamieszkały typ danych Haskella 98, służący do
47oznaczenia, że dana formuła (term) nie powinna istnieć.
48
49%package prof
50Summary: Profiling %{pkgname} library for GHC
51Summary(pl.UTF-8): Biblioteka profilująca %{pkgname} dla GHC
52Group: Development/Libraries
53Requires: %{name} = %{version}-%{release}
54Requires: ghc-base-prof >= 3
7c07c347
JB
55Requires: ghc-hashable-prof >= 1.1
56Requires: ghc-semigroups-prof >= 0.8.2
57
58%description prof
59Profiling %{pkgname} library for GHC. Should be installed when
60GHC's profiling subsystem is needed.
61
62%description prof -l pl.UTF-8
63Biblioteka profilująca %{pkgname} dla GHC. Powinna być zainstalowana
64kiedy potrzebujemy systemu profilującego z GHC.
65
66%package doc
67Summary: HTML documentation for ghc %{pkgname} package
68Summary(pl.UTF-8): Dokumentacja w formacie HTML dla pakietu ghc %{pkgname}
69Group: Documentation
70
71%description doc
72HTML documentation for ghc %{pkgname} package.
73
74%description doc -l pl.UTF-8
75Dokumentacja w formacie HTML dla pakietu ghc %{pkgname}.
76
77%prep
78%setup -q -n %{pkgname}-%{version}
79
80%build
81runhaskell Setup.lhs configure -v2 \
82 %{?with_prof:--enable-library-profiling} \
83 --prefix=%{_prefix} \
84 --libdir=%{_libdir} \
85 --libexecdir=%{_libexecdir} \
86 --docdir=%{_docdir}/%{name}-%{version}
87
88runhaskell Setup.lhs build
89runhaskell Setup.lhs haddock --executables
90
91%install
92rm -rf $RPM_BUILD_ROOT
93install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
94
95runhaskell Setup.lhs copy --destdir=$RPM_BUILD_ROOT
96
97# work around automatic haddock docs installation
98%{__rm} -rf %{name}-%{version}-doc
99cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version} %{name}-%{version}-doc
100%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
101
102runhaskell Setup.lhs register \
103 --gen-pkg-config=$RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
104
105%clean
106rm -rf $RPM_BUILD_ROOT
107
108%post
109%ghc_pkg_recache
110
111%postun
112%ghc_pkg_recache
113
114%files
115%defattr(644,root,root,755)
116%doc CHANGELOG.markdown LICENSE README.markdown
117%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
118%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}
c8d7a1f8
JR
119%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSvoid-%{version}-*.so
120%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSvoid-%{version}-*.a
121%exclude %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSvoid-%{version}-*_p.a
7c07c347 122%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data
7c07c347
JB
123%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Void
124%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Void/*.hi
c8d7a1f8 125%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Void/*.dyn_hi
7c07c347
JB
126
127%if %{with prof}
128%files prof
129%defattr(644,root,root,755)
c8d7a1f8 130%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSvoid-%{version}-*_p.a
7c07c347
JB
131%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Void/*.p_hi
132%endif
133
134%files doc
135%defattr(644,root,root,755)
136%doc %{name}-%{version}-doc/*
This page took 0.127854 seconds and 4 git commands to generate.