]> git.pld-linux.org Git - packages/ghc-unordered-containers.git/blame - ghc-unordered-containers.spec
rebuild with ghc 8.10.7
[packages/ghc-unordered-containers.git] / ghc-unordered-containers.spec
CommitLineData
2a4fbf61
JB
1#
2# Conditional build:
3%bcond_without prof # profiling library
4#
5%define pkgname unordered-containers
6Summary: Efficient hashing-based container types
7Summary(pl.UTF-8): Typy wydajnych kontenerów opartych na haszowaniu
8Name: ghc-%{pkgname}
dabae992 9Version: 0.2.10.0
f13058e7 10Release: 2
2a4fbf61
JB
11License: BSD
12Group: Development/Languages
13#Source0Download: http://hackage.haskell.org/package/unordered-containers
14Source0: http://hackage.haskell.org/package/%{pkgname}-%{version}/%{pkgname}-%{version}.tar.gz
dabae992
JR
15# Source0-md5: 5994101f6b1f19b264dcfdf863f57324
16Patch0: hashable-1.3.patch
2a4fbf61
JB
17URL: http://hackage.haskell.org/package/unordered-containers
18BuildRequires: ghc >= 6.12.3
19BuildRequires: ghc-base >= 4
2a4fbf61
JB
20BuildRequires: ghc-deepseq >= 1.1
21BuildRequires: ghc-hashable >= 1.0.1.1
22%if %{with prof}
23BuildRequires: ghc-prof >= 6.12.3
24BuildRequires: ghc-base-prof >= 4
2a4fbf61
JB
25BuildRequires: ghc-deepseq-prof >= 1.1
26BuildRequires: ghc-hashable-prof >= 1.0.1.1
27%endif
28BuildRequires: rpmbuild(macros) >= 1.608
29Requires(post,postun): /usr/bin/ghc-pkg
30%requires_eq ghc
31Requires: ghc-base >= 4
2a4fbf61
JB
32Requires: ghc-deepseq >= 1.1
33Requires: ghc-hashable >= 1.0.1.1
34BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36# debuginfo is not useful for ghc
37%define _enable_debug_packages 0
38
39# don't compress haddock files
40%define _noautocompressdoc *.haddock
41
42%description
43Efficient hashing-based container types. The containers have been
44optimized for performance critical use, both in terms of large data
45quantities and high speed.
46
47%description -l pl.UTF-8
48Typy wydajnych kontenerów opartych na haszowaniu. Kontenery zostały
49zoptymalizowane pod kątem zastosowań krytycznych wydajnościowo,
50zarówno pod względem dużych ilości danych, jak i dużej szybkości.
51
52%package prof
53Summary: Profiling %{pkgname} library for GHC
54Summary(pl.UTF-8): Biblioteka profilująca %{pkgname} dla GHC
55Group: Development/Libraries
56Requires: %{name} = %{version}-%{release}
57Requires: ghc-base-prof >= 4
2a4fbf61
JB
58Requires: ghc-deepseq-prof >= 1.1
59Requires: ghc-hashable-prof >= 1.0.1.1
60
61%description prof
62Profiling %{pkgname} library for GHC. Should be installed when
63GHC's profiling subsystem is needed.
64
65%description prof -l pl.UTF-8
66Biblioteka profilująca %{pkgname} dla GHC. Powinna być zainstalowana
67kiedy potrzebujemy systemu profilującego z GHC.
68
69%package doc
70Summary: HTML documentation for %{pkgname} ghc package
71Summary(pl.UTF-8): Dokumentacja w formacie HTML dla pakietu ghc %{pkgname}
72Group: Documentation
73
74%description doc
75HTML documentation for %{pkgname} ghc package.
76
77%description doc -l pl.UTF-8
78Dokumentacja w formacie HTML dla pakietu ghc %{pkgname}.
79
80%prep
81%setup -q -n %{pkgname}-%{version}
dabae992 82%patch -p1
2a4fbf61
JB
83
84%build
85runhaskell Setup.hs configure -v2 \
86 %{?with_prof:--enable-library-profiling} \
87 --prefix=%{_prefix} \
88 --libdir=%{_libdir} \
89 --libexecdir=%{_libexecdir} \
90 --docdir=%{_docdir}/%{name}-%{version}
91
92runhaskell Setup.hs build
93runhaskell Setup.hs haddock --executables
94
95%install
96rm -rf $RPM_BUILD_ROOT
97install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
98
99runhaskell Setup.hs copy --destdir=$RPM_BUILD_ROOT
100
101# work around automatic haddock docs installation
102%{__rm} -rf %{name}-%{version}-doc
103cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version} %{name}-%{version}-doc
104%{__rm} -rf $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
105
106runhaskell Setup.hs register \
107 --gen-pkg-config=$RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
108
109%clean
110rm -rf $RPM_BUILD_ROOT
111
112%post
113%ghc_pkg_recache
114
115%postun
116%ghc_pkg_recache
117
118%files
119%defattr(644,root,root,755)
120%doc LICENSE
121%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
122%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}
dabae992
JR
123%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSunordered-containers-%{version}-*.so
124%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSunordered-containers-%{version}-*.a
125%exclude %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSunordered-containers-%{version}-*_p.a
2a4fbf61 126%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data
dabae992
JR
127%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/*.hi
128%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/*.dyn_hi
2a4fbf61
JB
129%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/HashMap
130%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/HashMap/*.hi
dabae992
JR
131%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/HashMap/*.dyn_hi
132%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/HashMap/Strict
133%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/HashMap/Strict/*.hi
134%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/HashMap/Strict/*.dyn_hi
135%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/HashSet
136%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/HashSet/*.hi
137%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/HashSet/*.dyn_hi
2a4fbf61
JB
138
139%if %{with prof}
140%files prof
141%defattr(644,root,root,755)
dabae992
JR
142%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSunordered-containers-%{version}-*_p.a
143%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/*.p_hi
2a4fbf61 144%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/HashMap/*.p_hi
dabae992
JR
145%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/HashMap/Strict/*.p_hi
146%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/HashSet/*.p_hi
2a4fbf61
JB
147%endif
148
149%files doc
150%defattr(644,root,root,755)
151%doc %{name}-%{version}-doc/*
This page took 0.269406 seconds and 4 git commands to generate.