]> git.pld-linux.org Git - packages/ghc-tls.git/blame - ghc-tls.spec
rebuild with ghc 8.10.7
[packages/ghc-tls.git] / ghc-tls.spec
CommitLineData
b94c26c6
JR
1#
2# Conditional build:
3%bcond_without prof # profiling library
4#
5%define pkgname tls
6Summary: TLS/SSL protocol native implementation (Server and Client)
7Name: ghc-%{pkgname}
8Version: 1.5.4
c403141a 9Release: 2
b94c26c6
JR
10License: BSD
11Group: Development/Languages
12#Source0Download: http://hackage.haskell.org/package/tls
13Source0: http://hackage.haskell.org/package/%{pkgname}-%{version}/%{pkgname}-%{version}.tar.gz
14# Source0-md5: 44202fa7069aa7d04c983787fa015491
15URL: http://hackage.haskell.org/package/tls
16BuildRequires: ghc >= 6.12.3
17BuildRequires: ghc-asn1-encoding
18BuildRequires: ghc-asn1-types >= 0.2.0
19BuildRequires: ghc-async >= 2.0
419a53c8 20BuildRequires: ghc-cereal >= 0.5.3
b94c26c6
JR
21BuildRequires: ghc-cryptonite >= 0.25
22BuildRequires: ghc-data-default-class
23BuildRequires: ghc-hourglass
24BuildRequires: ghc-memory >= 0.14.6
419a53c8 25BuildRequires: ghc-network >= 2.4.0.0
b94c26c6
JR
26BuildRequires: ghc-transformers
27BuildRequires: ghc-x509 >= 1.7.5
28BuildRequires: ghc-x509-store >= 1.6
29BuildRequires: ghc-x509-validation >= 1.6.5
30%if %{with prof}
31BuildRequires: ghc-prof
32BuildRequires: ghc-asn1-encoding-prof
33BuildRequires: ghc-asn1-types-prof >= 0.2.0
34BuildRequires: ghc-async-prof >= 2.0
419a53c8 35BuildRequires: ghc-cereal-prof >= 0.5.3
b94c26c6
JR
36BuildRequires: ghc-cryptonite-prof >= 0.25
37BuildRequires: ghc-data-default-class-prof
38BuildRequires: ghc-hourglass-prof
39BuildRequires: ghc-memory-prof >= 0.14.6
419a53c8 40BuildRequires: ghc-network-prof >= 2.4.0.0
b94c26c6
JR
41BuildRequires: ghc-transformers-prof
42BuildRequires: ghc-x509-prof >= 1.7.5
43BuildRequires: ghc-x509-store-prof >= 1.6
44BuildRequires: ghc-x509-validation-prof >= 1.6.5
45%endif
46BuildRequires: rpmbuild(macros) >= 1.608
47%requires_eq ghc
48Requires(post,postun): /usr/bin/ghc-pkg
49Requires: ghc-asn1-encoding
50Requires: ghc-asn1-types >= 0.2.0
51Requires: ghc-async >= 2.0
419a53c8 52Requires: ghc-cereal >= 0.5.3
b94c26c6
JR
53Requires: ghc-cryptonite >= 0.25
54Requires: ghc-data-default-class
55Requires: ghc-hourglass
56Requires: ghc-memory >= 0.14.6
419a53c8 57Requires: ghc-network >= 2.4.0.0
b94c26c6
JR
58Requires: ghc-transformers
59Requires: ghc-x509 >= 1.7.5
60Requires: ghc-x509-store >= 1.6
61Requires: ghc-x509-validation >= 1.6.5
62BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
63
64# debuginfo is not useful for ghc
65%define _enable_debug_packages 0
66
67# don't compress haddock files
68%define _noautocompressdoc *.haddock
69
70%description
71Native Haskell TLS and SSL protocol implementation for server and
72client.
73
74This provides a high-level implementation of a sensitive security
75protocol, eliminating a common set of security issues through the use
76of the advanced type system, high level constructions and common
77Haskell features.
78
79Currently implement the SSL3.0, TLS1.0, TLS1.1, TLS1.2 and TLS 1.3
80protocol, and support RSA and Ephemeral (Elliptic curve and regular)
81Diffie Hellman key exchanges, and many extensions.
82
83%package prof
84Summary: Profiling %{pkgname} library for GHC
85Summary(pl.UTF-8): Biblioteka profilująca %{pkgname} dla GHC
86Group: Development/Libraries
87Requires: %{name} = %{version}-%{release}
88Requires: ghc-asn1-encoding-prof
89Requires: ghc-asn1-types-prof >= 0.2.0
90Requires: ghc-async-prof >= 2.0
419a53c8 91Requires: ghc-cereal-prof >= 0.5.3
b94c26c6
JR
92Requires: ghc-cryptonite-prof >= 0.25
93Requires: ghc-data-default-class-prof
94Requires: ghc-hourglass-prof
95Requires: ghc-memory-prof >= 0.14.6
419a53c8 96Requires: ghc-network-prof >= 2.4.0.0
b94c26c6
JR
97Requires: ghc-transformers-prof
98Requires: ghc-x509-prof >= 1.7.5
99Requires: ghc-x509-store-prof >= 1.6
100Requires: ghc-x509-validation-prof >= 1.6.5
101
102%description prof
103Profiling %{pkgname} library for GHC. Should be installed when
104GHC's profiling subsystem is needed.
105
106%description prof -l pl.UTF-8
107Biblioteka profilująca %{pkgname} dla GHC. Powinna być zainstalowana
108kiedy potrzebujemy systemu profilującego z GHC.
109
110%prep
111%setup -q -n %{pkgname}-%{version}
112
113%build
114runhaskell Setup.hs configure -v2 \
115 %{?with_prof:--enable-library-profiling} \
116 --prefix=%{_prefix} \
117 --libdir=%{_libdir} \
118 --libexecdir=%{_libexecdir} \
119 --docdir=%{_docdir}/%{name}-%{version}
120
2022f17b 121runhaskell Setup.hs build %{?_smp_mflags}
b94c26c6
JR
122runhaskell Setup.hs haddock --executables
123
124%install
125rm -rf $RPM_BUILD_ROOT
126install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
127
128runhaskell Setup.hs copy --destdir=$RPM_BUILD_ROOT
129
130# work around automatic haddock docs installation
131%{__rm} -rf %{name}-%{version}-doc
132cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version} %{name}-%{version}-doc
133%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
134
135runhaskell Setup.hs register \
136 --gen-pkg-config=$RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
137
138%clean
139rm -rf $RPM_BUILD_ROOT
140
141%post
142%ghc_pkg_recache
143
144%postun
145%ghc_pkg_recache
146
147%files
148%defattr(644,root,root,755)
149%doc CHANGELOG.md %{name}-%{version}-doc/*
150%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
151%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}
152%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.so
153%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.a
154%exclude %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*_p.a
155
156%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Network
157%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Network/*.hi
158%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Network/*.dyn_hi
159%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Network/TLS
160%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Network/TLS/*.hi
161%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Network/TLS/*.dyn_hi
162%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Network/TLS/Context
163%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Network/TLS/Context/*.hi
164%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Network/TLS/Context/*.dyn_hi
165%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Network/TLS/Crypto
166%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Network/TLS/Crypto/*.hi
167%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Network/TLS/Crypto/*.dyn_hi
168%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Network/TLS/Extra
169%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Network/TLS/Extra/*.hi
170%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Network/TLS/Extra/*.dyn_hi
171%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Network/TLS/Handshake
172%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Network/TLS/Handshake/*.hi
173%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Network/TLS/Handshake/*.dyn_hi
174%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Network/TLS/Record
175%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Network/TLS/Record/*.hi
176%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Network/TLS/Record/*.dyn_hi
177%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Network/TLS/Util
178%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Network/TLS/Util/*.hi
179%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Network/TLS/Util/*.dyn_hi
180
181%if %{with prof}
182%files prof
183%defattr(644,root,root,755)
184%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*_p.a
185%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Network/*.p_hi
186%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Network/TLS/*.p_hi
187%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Network/TLS/Context/*.p_hi
188%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Network/TLS/Crypto/*.p_hi
189%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Network/TLS/Extra/*.p_hi
190%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Network/TLS/Handshake/*.p_hi
191%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Network/TLS/Record/*.p_hi
192%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Network/TLS/Util/*.p_hi
193%endif
This page took 0.084615 seconds and 4 git commands to generate.