]> git.pld-linux.org Git - packages/ghc-th-abstraction.git/blame - ghc-th-abstraction.spec
rebuild with ghc 8.10.7
[packages/ghc-th-abstraction.git] / ghc-th-abstraction.spec
CommitLineData
5867f0c2
JR
1#
2# Conditional build:
3%bcond_without prof # profiling library
4#
5%define pkgname th-abstraction
6Summary: Nicer interface for reified information about data types
7Name: ghc-%{pkgname}
8Version: 0.3.2.0
b030c683 9Release: 2
5867f0c2
JR
10License: BSD-Like
11Group: Development/Languages
12#Source0Download: http://hackage.haskell.org/package/th-abstraction
13Source0: http://hackage.haskell.org/package/%{pkgname}-%{version}/%{pkgname}-%{version}.tar.gz
14# Source0-md5: 3625dd90af376cb3fedb8acc3feaf02d
15URL: http://hackage.haskell.org/package/th-abstraction
16BuildRequires: ghc >= 6.12.3
17BuildRequires: ghc-base >= 3
18BuildRequires: ghc-containers >= 0.4
19BuildRequires: ghc-ghc-prim
20BuildRequires: ghc-template-haskell >= 2.5
21%if %{with prof}
22BuildRequires: ghc-prof >= 6.12.3
23BuildRequires: ghc-base-prof >= 3
24BuildRequires: ghc-containers-prof >= 0.4
25BuildRequires: ghc-ghc-prim-prof
26BuildRequires: ghc-template-haskell-prof >= 2.4
27%endif
28BuildRequires: rpmbuild(macros) >= 1.608
29Requires(post,postun): /usr/bin/ghc-pkg
30%requires_eq ghc
31Requires: ghc-base >= 3
32Requires: ghc-containers >= 0.4
33Requires: ghc-ghc-prim
34Requires: ghc-template-haskell >= 2.4
35BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37# debuginfo is not useful for ghc
38%define _enable_debug_packages 0
39
40# don't compress haddock files
41%define _noautocompressdoc *.haddock
42
43%description
44This package normalizes variations in the interface for inspecting
45datatype information via Template Haskell so that packages and support
46a single, easier to use informational datatype while supporting many
47versions of Template Haskell.
48
49%package prof
50Summary: Profiling %{pkgname} library for GHC
51Summary(pl.UTF-8): Biblioteka profilująca %{pkgname} dla GHC.
52Group: Development/Libraries
53Requires: %{name} = %{version}-%{release}
54Requires: ghc-base-prof >= 3
55Requires: ghc-containers-prof >= 0.4
56Requires: ghc-ghc-prim-prof
57Requires: ghc-template-haskell-prof >= 2.4
58
59%description prof
60Profiling %{pkgname} library for GHC. Should be installed when GHC's
61profiling subsystem is needed.
62
63%description prof -l pl.UTF-8
64Biblioteka profilująca %{pkgname} dla GHC. Powinna być zainstalowana
65kiedy potrzebujemy systemu profilującego z GHC.
66
67%prep
68%setup -q -n %{pkgname}-%{version}
69
70%build
71runhaskell Setup.hs configure -v2 \
72 %{?with_prof:--enable-library-profiling} \
73 --prefix=%{_prefix} \
74 --libdir=%{_libdir} \
75 --libexecdir=%{_libexecdir} \
76 --docdir=%{_docdir}/%{name}-%{version}
77
78runhaskell Setup.hs build
79runhaskell Setup.hs haddock --executables
80
81%install
82rm -rf $RPM_BUILD_ROOT
83install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
84
85runhaskell Setup.hs copy --destdir=$RPM_BUILD_ROOT
86
87# work around automatic haddock docs installation
88%{__rm} -rf %{name}-%{version}-doc
89cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version} %{name}-%{version}-doc
90%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
91
92runhaskell Setup.hs register \
93 --gen-pkg-config=$RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
94
95%clean
96rm -rf $RPM_BUILD_ROOT
97
98%post
99%ghc_pkg_recache
100
101%postun
102%ghc_pkg_recache
103
104%files
105%defattr(644,root,root,755)
106%doc ChangeLog.md LICENSE README.md
107%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
108%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}
109%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSth-abstraction-%{version}-*.so
110%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSth-abstraction-%{version}-*.a
111%exclude %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSth-abstraction-%{version}-*_p.a
112%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Language
113%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Language/Haskell
114%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Language/Haskell/TH
115%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Language/Haskell/TH/*.hi
116%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Language/Haskell/TH/*.dyn_hi
117%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Language/Haskell/TH/Datatype
118%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Language/Haskell/TH/Datatype/*.hi
119%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Language/Haskell/TH/Datatype/*.dyn_hi
120
121%files prof
122%defattr(644,root,root,755)
123%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSth-abstraction-%{version}-*_p.a
124%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Language/Haskell/TH/*.p_hi
125%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Language/Haskell/TH/Datatype/*.p_hi
This page took 0.581025 seconds and 4 git commands to generate.