]> git.pld-linux.org Git - packages/ghc-tagsoup.git/blame - ghc-tagsoup.spec
- up to 0.14.8
[packages/ghc-tagsoup.git] / ghc-tagsoup.spec
CommitLineData
5d1ff2cb
JB
1#
2# Conditional build:
3%bcond_without prof # profiling library
4#
5%define pkgname tagsoup
6Summary: Parsing and extracting information from (possibly malformed) HTML/XML documents
7Summary(pl.UTF-8): Analiza i wydobywanie informacji z (niekoniecznie poprawnych) dokumentów HTML/XML
8Name: ghc-%{pkgname}
26af6b9e 9Version: 0.14.8
5d1ff2cb
JB
10Release: 1
11License: BSD
12Group: Development/Languages
13#Source0Download: http://hackage.haskell.org/package/tagsoup
14Source0: http://hackage.haskell.org/package/%{pkgname}-%{version}/%{pkgname}-%{version}.tar.gz
26af6b9e 15# Source0-md5: 20f2c2d500086d113d19b7ca55f927a1
5d1ff2cb
JB
16URL: http://hackage.haskell.org/package/tagsoup
17BuildRequires: ghc >= 6.12.3
18BuildRequires: ghc-base >= 4
19BuildRequires: ghc-base < 5
20BuildRequires: ghc-bytestring
21BuildRequires: ghc-containers
22BuildRequires: ghc-text
23%if %{with prof}
24BuildRequires: ghc-prof >= 6.12.3
25BuildRequires: ghc-base-prof >= 4
26BuildRequires: ghc-base-prof < 5
27BuildRequires: ghc-bytestring-prof
28BuildRequires: ghc-containers-prof
29BuildRequires: ghc-text-prof
30%endif
31BuildRequires: rpmbuild(macros) >= 1.608
32Requires(post,postun): /usr/bin/ghc-pkg
33%requires_eq ghc
34Requires: ghc-base >= 4
35Requires: ghc-base < 5
36Requires: ghc-bytestring
37Requires: ghc-containers
38Requires: ghc-text
39BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41# debuginfo is not useful for ghc
42%define _enable_debug_packages 0
43
44# don't compress haddock files
45%define _noautocompressdoc *.haddock
46
47%description
48TagSoup is a library for parsing HTML/XML. It supports the HTML 5
49specification, and can be used to parse either well-formed XML, or
50unstructured and malformed HTML from the web. The library also
51provides useful functions to extract information from an HTML
52document, making it ideal for screen-scraping.
53
54%description -l pl.UTF-8
55TagSoup to biblioteka do analizy formatu HTML/XML. Obsługuje
56specyfikację HTML 5 i może być używana do analizy dobrze
57sformułowanego XML-a lub niestrukturalnego, źle sformułowanego HTML-a
58z sieci. Biblioteka udostępnia także przydatne funkcje do wydobywania
59informacji z dokumentów HTML, co czyni ją idealną do wycinków.
60
61%package prof
62Summary: Profiling %{pkgname} library for GHC
63Summary(pl.UTF-8): Biblioteka profilująca %{pkgname} dla GHC
64Group: Development/Libraries
65Requires: %{name} = %{version}-%{release}
66Requires: ghc-base-prof >= 4
67Requires: ghc-base-prof < 5
68Requires: ghc-bytestring-prof
69Requires: ghc-containers-prof
70Requires: ghc-text-prof
71
72%description prof
73Profiling %{pkgname} library for GHC. Should be installed when
74GHC's profiling subsystem is needed.
75
76%description prof -l pl.UTF-8
77Biblioteka profilująca %{pkgname} dla GHC. Powinna być zainstalowana
78kiedy potrzebujemy systemu profilującego z GHC.
79
80%package doc
81Summary: HTML documentation for ghc %{pkgname} package
82Summary(pl.UTF-8): Dokumentacja w formacie HTML dla pakietu ghc %{pkgname}
83Group: Documentation
84
85%description doc
86HTML documentation for ghc %{pkgname} package.
87
88%description doc -l pl.UTF-8
89Dokumentacja w formacie HTML dla pakietu ghc %{pkgname}.
90
91%prep
92%setup -q -n %{pkgname}-%{version}
93
94%build
95runhaskell Setup.hs configure -v2 \
96 %{?with_prof:--enable-library-profiling} \
97 --prefix=%{_prefix} \
98 --libdir=%{_libdir} \
99 --libexecdir=%{_libexecdir} \
100 --docdir=%{_docdir}/%{name}-%{version}
101
102runhaskell Setup.hs build
103runhaskell Setup.hs haddock --executables
104
105%install
106rm -rf $RPM_BUILD_ROOT
107install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
108
109runhaskell Setup.hs copy --destdir=$RPM_BUILD_ROOT
110
111# work around automatic haddock docs installation
112%{__rm} -rf %{name}-%{version}-doc
113cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version} %{name}-%{version}-doc
114%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
115
116runhaskell Setup.hs register \
117 --gen-pkg-config=$RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
118
119%clean
120rm -rf $RPM_BUILD_ROOT
121
122%post
123%ghc_pkg_recache
124
125%postun
126%ghc_pkg_recache
127
128%files
129%defattr(644,root,root,755)
26af6b9e 130%doc CHANGES.txt LICENSE README.md
5d1ff2cb
JB
131%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
132%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}
26af6b9e
JR
133%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHStagsoup-%{version}-*.so
134%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHStagsoup-%{version}-*.a
135%exclude %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHStagsoup-%{version}-*_p.a
5d1ff2cb
JB
136%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text
137%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/StringLike.hi
26af6b9e 138%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/StringLike.dyn_hi
5d1ff2cb
JB
139%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/HTML
140%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/HTML/TagSoup.hi
26af6b9e 141%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/HTML/TagSoup.dyn_hi
5d1ff2cb
JB
142%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/HTML/TagSoup
143%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/HTML/TagSoup/*.hi
26af6b9e 144%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/HTML/TagSoup/*.dyn_hi
5d1ff2cb
JB
145
146
147%if %{with prof}
148%files prof
149%defattr(644,root,root,755)
26af6b9e 150%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHStagsoup-%{version}-*_p.a
5d1ff2cb
JB
151%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/StringLike.p_hi
152%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/HTML/TagSoup.p_hi
153%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/HTML/TagSoup/*.p_hi
154%endif
155
156%files doc
157%defattr(644,root,root,755)
158%doc %{name}-%{version}-doc/*
This page took 0.11663 seconds and 4 git commands to generate.