]> git.pld-linux.org Git - packages/ghc-snap-core.git/blame - ghc-snap-core.spec
- updated to 0.9.5.0, pl, unified
[packages/ghc-snap-core.git] / ghc-snap-core.spec
CommitLineData
67ba6e81
JB
1#
2# Conditional build:
3%bcond_without prof # profiling library
4#
543a17fb
JR
5%define pkgname snap-core
6Summary: Snap: A Haskell Web Framework (core interfaces and types)
67ba6e81 7Summary(pl.UTF-8): Snap - szkielet WWW dla Haskella (główne interfejsy i typy)
543a17fb 8Name: ghc-%{pkgname}
67ba6e81
JB
9Version: 0.9.5.0
10Release: 1
543a17fb
JR
11License: BSD
12Group: Development/Languages
67ba6e81
JB
13#Source0Download: http://hackage.haskell.org/package/snap-core
14Source0: http://hackage.haskell.org/package/%{pkgname}-%{version}/%{pkgname}-%{version}.tar.gz
15# Source0-md5: e347d1aeee7a2990d211b9d1556c125d
16Patch0: %{name}-deps.patch
17URL: http://hackage.haskell.org/package/snap-core
543a17fb 18BuildRequires: ghc >= 6.12.3
67ba6e81
JB
19BuildRequires: ghc-HUnit >= 1.2
20BuildRequires: ghc-HUnit < 2
21BuildRequires: ghc-MonadCatchIO-transformers >= 0.2.1
22BuildRequires: ghc-MonadCatchIO-transformers < 0.4
23BuildRequires: ghc-attoparsec >= 0.10
24BuildRequires: ghc-attoparsec < 0.11
25BuildRequires: ghc-attoparsec-enumerator >= 0.3
26BuildRequires: ghc-attoparsec-enumerator < 0.4
27BuildRequires: ghc-base >= 4
28BuildRequires: ghc-base < 5
543a17fb 29BuildRequires: ghc-blaze-builder >= 0.2.1.4
67ba6e81
JB
30BuildRequires: ghc-blaze-builder < 0.4
31BuildRequires: ghc-blaze-builder-enumerator >= 0.2
32BuildRequires: ghc-blaze-builder-enumerator < 0.3
33BuildRequires: ghc-bytestring >= 0.9
34BuildRequires: ghc-bytestring < 0.11
543a17fb 35BuildRequires: ghc-case-insensitive >= 0.3
67ba6e81
JB
36BuildRequires: ghc-case-insensitive < 1.2
37BuildRequires: ghc-containers >= 0.3
38BuildRequires: ghc-containers < 1.0
39BuildRequires: ghc-deepseq >= 1.1
40BuildRequires: ghc-deepseq < 1.4
41BuildRequires: ghc-directory >= 1
42BuildRequires: ghc-directory < 2
43BuildRequires: ghc-enumerator >= 0.4.15
44BuildRequires: ghc-enumerator < 0.5
45BuildRequires: ghc-filepath >= 1.1
46BuildRequires: ghc-filepath < 2.0
47BuildRequires: ghc-hashable >= 1.2.1
48BuildRequires: ghc-hashable < 1.3
49BuildRequires: ghc-mtl >= 2.0
50BuildRequires: ghc-mtl < 2.2
51BuildRequires: ghc-random >= 1
52BuildRequires: ghc-random < 2
53BuildRequires: ghc-regex-posix >= 0.95
54BuildRequires: ghc-regex-posix < 1
55BuildRequires: ghc-text >= 0.11
56BuildRequires: ghc-time >= 1.0
57BuildRequires: ghc-time < 1.5
58BuildRequires: ghc-unix >= 2.4
59BuildRequires: ghc-unix < 3.0
60BuildRequires: ghc-unix-compat >= 0.2
61BuildRequires: ghc-unix-compat < 0.5
62BuildRequires: ghc-unordered-containers >= 0.1.4.3
63BuildRequires: ghc-unordered-containers < 0.3
64BuildRequires: ghc-vector >= 0.6
65BuildRequires: ghc-vector < 0.11
66BuildRequires: ghc-zlib-enum >= 0.2.1
67BuildRequires: ghc-zlib-enum < 0.3
68%if %{with prof}
69BuildRequires: ghc-prof >= 6.12.3
543a17fb 70BuildRequires: ghc-HUnit-prof >= 1.2
67ba6e81 71BuildRequires: ghc-HUnit-prof < 2
543a17fb 72BuildRequires: ghc-MonadCatchIO-transformers-prof >= 0.2.1
67ba6e81
JB
73BuildRequires: ghc-MonadCatchIO-transformers-prof < 0.4
74BuildRequires: ghc-attoparsec-prof >= 0.10
75BuildRequires: ghc-attoparsec-prof < 0.11
76BuildRequires: ghc-attoparsec-enumerator-prof >= 0.3
77BuildRequires: ghc-attoparsec-enumerator-prof < 0.4
78BuildRequires: ghc-base-prof >= 4
79BuildRequires: ghc-base-prof < 5
80BuildRequires: ghc-blaze-builder-prof >= 0.2.1.4
81BuildRequires: ghc-blaze-builder-prof < 0.4
82BuildRequires: ghc-blaze-builder-enumerator-prof >= 0.2
83BuildRequires: ghc-blaze-builder-enumerator-prof < 0.3
84BuildRequires: ghc-bytestring-prof >= 0.9
85BuildRequires: ghc-bytestring-prof < 0.11
86BuildRequires: ghc-case-insensitive-prof >= 0.3
87BuildRequires: ghc-case-insensitive-prof < 1.2
88BuildRequires: ghc-containers-prof >= 0.3
89BuildRequires: ghc-containers-prof < 1.0
90BuildRequires: ghc-deepseq-prof >= 1.1
91BuildRequires: ghc-deepseq-prof < 1.4
92BuildRequires: ghc-directory-prof >= 1
93BuildRequires: ghc-directory-prof < 2
94BuildRequires: ghc-enumerator-prof >= 0.4.15
95BuildRequires: ghc-enumerator-prof < 0.5
96BuildRequires: ghc-filepath-prof >= 1.1
97BuildRequires: ghc-filepath-prof < 2.0
98BuildRequires: ghc-hashable-prof >= 1.2.1
99BuildRequires: ghc-hashable-prof < 1.3
543a17fb 100BuildRequires: ghc-mtl-prof >= 2.0
67ba6e81
JB
101BuildRequires: ghc-mtl-prof < 2.2
102BuildRequires: ghc-random-prof >= 1
103BuildRequires: ghc-random-prof < 2
543a17fb 104BuildRequires: ghc-regex-posix-prof >= 0.95
67ba6e81
JB
105BuildRequires: ghc-regex-posix-prof < 1
106BuildRequires: ghc-text-prof >= 0.11
107BuildRequires: ghc-time-prof >= 1.0
108BuildRequires: ghc-time-prof < 1.5
109BuildRequires: ghc-unix-prof >= 2.4
110BuildRequires: ghc-unix-prof < 3.0
543a17fb 111BuildRequires: ghc-unix-compat-prof >= 0.2
67ba6e81 112BuildRequires: ghc-unix-compat-prof < 0.5
543a17fb 113BuildRequires: ghc-unordered-containers-prof >= 0.1.4.3
67ba6e81 114BuildRequires: ghc-unordered-containers-prof < 0.3
543a17fb 115BuildRequires: ghc-vector-prof >= 0.6
67ba6e81 116BuildRequires: ghc-vector-prof < 0.11
543a17fb 117BuildRequires: ghc-zlib-enum-prof >= 0.2.1
67ba6e81
JB
118BuildRequires: ghc-zlib-enum-prof < 0.3
119%endif
543a17fb 120BuildRequires: rpmbuild(macros) >= 1.608
543a17fb 121Requires(post,postun): /usr/bin/ghc-pkg
67ba6e81 122%requires_releq ghc
543a17fb 123Requires: ghc-HUnit >= 1.2
67ba6e81 124Requires: ghc-HUnit < 2
543a17fb 125Requires: ghc-MonadCatchIO-transformers >= 0.2.1
67ba6e81
JB
126Requires: ghc-MonadCatchIO-transformers < 0.4
127Requires: ghc-attoparsec >= 0.10
128Requires: ghc-attoparsec < 0.11
129Requires: ghc-attoparsec-enumerator >= 0.3
130Requires: ghc-attoparsec-enumerator < 0.4
131Requires: ghc-base >= 4
132Requires: ghc-base < 5
133Requires: ghc-blaze-builder >= 0.2.1.4
134Requires: ghc-blaze-builder < 0.4
135Requires: ghc-blaze-builder-enumerator >= 0.2
136Requires: ghc-blaze-builder-enumerator < 0.3
137Requires: ghc-bytestring >= 0.9
138Requires: ghc-bytestring < 0.11
139Requires: ghc-case-insensitive >= 0.3
140Requires: ghc-case-insensitive < 1.2
141Requires: ghc-containers >= 0.3
142Requires: ghc-containers < 1.0
143Requires: ghc-deepseq >= 1.1
144Requires: ghc-deepseq < 1.4
145Requires: ghc-directory >= 1
146Requires: ghc-directory < 2
147Requires: ghc-enumerator >= 0.4.15
148Requires: ghc-enumerator < 0.5
149Requires: ghc-filepath >= 1.1
150Requires: ghc-filepath < 2.0
151Requires: ghc-hashable >= 1.2.1
152Requires: ghc-hashable < 1.3
543a17fb 153Requires: ghc-mtl >= 2.0
67ba6e81
JB
154Requires: ghc-mtl < 2.2
155Requires: ghc-random >= 1
156Requires: ghc-random < 2
543a17fb 157Requires: ghc-regex-posix >= 0.95
67ba6e81
JB
158Requires: ghc-regex-posix < 1
159Requires: ghc-text >= 0.11
160Requires: ghc-time >= 1.0
161Requires: ghc-time < 1.5
162Requires: ghc-unix >= 2.4
163Requires: ghc-unix < 3.0
543a17fb 164Requires: ghc-unix-compat >= 0.2
67ba6e81 165Requires: ghc-unix-compat < 0.5
543a17fb 166Requires: ghc-unordered-containers >= 0.1.4.3
67ba6e81 167Requires: ghc-unordered-containers < 0.3
543a17fb 168Requires: ghc-vector >= 0.6
67ba6e81 169Requires: ghc-vector < 0.11
543a17fb 170Requires: ghc-zlib-enum >= 0.2.1
67ba6e81 171Requires: ghc-zlib-enum < 0.3
543a17fb
JR
172BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
173
174# debuginfo is not useful for ghc
175%define _enable_debug_packages 0
176
67ba6e81 177# don't compress haddock files
543a17fb
JR
178%define _noautocompressdoc *.haddock
179
180%description
181Snap is a simple and fast web development framework and server written
67ba6e81
JB
182in Haskell. For more information you can visit the Snap project
183website at <http://snapframework.com/>.
184
185%description -l pl.UTF-8
186Snap to prosty i szybki szkielet programistyczny oraz serwer WWW,
187napisany w Haskellu. Więcej informacji można znaleźć na stronie
188projektu: <http://snapframework.com/>.
543a17fb
JR
189
190%package prof
191Summary: Profiling %{pkgname} library for GHC
192Summary(pl.UTF-8): Biblioteka profilująca %{pkgname} dla GHC.
193Group: Development/Libraries
194Requires: %{name} = %{version}-%{release}
67ba6e81
JB
195Requires: ghc-HUnit-prof >= 1.2
196Requires: ghc-HUnit-prof < 2
197Requires: ghc-MonadCatchIO-transformers-prof >= 0.2.1
198Requires: ghc-MonadCatchIO-transformers-prof < 0.4
199Requires: ghc-attoparsec-prof >= 0.10
200Requires: ghc-attoparsec-prof < 0.11
201Requires: ghc-attoparsec-enumerator-prof >= 0.3
202Requires: ghc-attoparsec-enumerator-prof < 0.4
203Requires: ghc-base-prof >= 4
204Requires: ghc-base-prof < 5
205Requires: ghc-blaze-builder-prof >= 0.2.1.4
206Requires: ghc-blaze-builder-prof < 0.4
207Requires: ghc-blaze-builder-enumerator-prof >= 0.2
208Requires: ghc-blaze-builder-enumerator-prof < 0.3
209Requires: ghc-bytestring-prof >= 0.9
210Requires: ghc-bytestring-prof < 0.11
211Requires: ghc-case-insensitive-prof >= 0.3
212Requires: ghc-case-insensitive-prof < 1.2
213Requires: ghc-containers-prof >= 0.3
214Requires: ghc-containers-prof < 1.0
215Requires: ghc-deepseq-prof >= 1.1
216Requires: ghc-deepseq-prof < 1.4
217Requires: ghc-directory-prof >= 1
218Requires: ghc-directory-prof < 2
219Requires: ghc-enumerator-prof >= 0.4.15
220Requires: ghc-enumerator-prof < 0.5
221Requires: ghc-filepath-prof >= 1.1
222Requires: ghc-filepath-prof < 2.0
223Requires: ghc-hashable-prof >= 1.2.1
224Requires: ghc-hashable-prof < 1.3
225Requires: ghc-mtl-prof >= 2.0
226Requires: ghc-mtl-prof < 2.2
227Requires: ghc-random-prof >= 1
228Requires: ghc-random-prof < 2
229Requires: ghc-regex-posix-prof >= 0.95
230Requires: ghc-regex-posix-prof < 1
231Requires: ghc-text-prof >= 0.11
232Requires: ghc-time-prof >= 1.0
233Requires: ghc-time-prof < 1.5
234Requires: ghc-unix-prof >= 2.4
235Requires: ghc-unix-prof < 3.0
236Requires: ghc-unix-compat-prof >= 0.2
237Requires: ghc-unix-compat-prof < 0.5
238Requires: ghc-unordered-containers-prof >= 0.1.4.3
239Requires: ghc-unordered-containers-prof < 0.3
240Requires: ghc-vector-prof >= 0.6
241Requires: ghc-vector-prof < 0.11
242Requires: ghc-zlib-enum-prof >= 0.2.1
243Requires: ghc-zlib-enum-prof < 0.3
543a17fb
JR
244
245%description prof
67ba6e81
JB
246Profiling %{pkgname} library for GHC. Should be installed when GHC's
247profiling subsystem is needed.
543a17fb
JR
248
249%description prof -l pl.UTF-8
250Biblioteka profilująca %{pkgname} dla GHC. Powinna być zainstalowana
251kiedy potrzebujemy systemu profilującego z GHC.
252
253%prep
254%setup -q -n %{pkgname}-%{version}
67ba6e81 255%patch0 -p1
543a17fb
JR
256
257%build
67ba6e81
JB
258runhaskell Setup.hs configure -v2 \
259 %{?with_prof:--enable-library-profiling} \
543a17fb
JR
260 --prefix=%{_prefix} \
261 --libdir=%{_libdir} \
262 --libexecdir=%{_libexecdir} \
263 --docdir=%{_docdir}/%{name}-%{version}
264
265runhaskell Setup.hs build
266runhaskell Setup.hs haddock --executables
267
268%install
269rm -rf $RPM_BUILD_ROOT
270install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
271
272runhaskell Setup.hs copy --destdir=$RPM_BUILD_ROOT
273
274# work around automatic haddock docs installation
275%{__rm} -rf %{name}-%{version}-doc
276cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version} %{name}-%{version}-doc
277%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
278
279runhaskell Setup.hs register \
67ba6e81 280 --gen-pkg-config=$RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
543a17fb
JR
281
282%clean
283rm -rf $RPM_BUILD_ROOT
284
285%post
286%ghc_pkg_recache
287
288%postun
289%ghc_pkg_recache
290
291%files
292%defattr(644,root,root,755)
67ba6e81 293%doc CONTRIBUTORS README* %{name}-%{version}-doc/*
543a17fb
JR
294%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
295%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}
67ba6e81
JB
296%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/HSsnap-core-%{version}.o
297%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSsnap-core-%{version}.a
543a17fb
JR
298%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Snap
299%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Snap/*.hi
300%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Snap/Internal
301%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Snap/Internal/*.hi
302%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Snap/Internal/Http
303%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Snap/Internal/Http/*.hi
304%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Snap/Internal/Iteratee
305%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Snap/Internal/Iteratee/*.hi
306%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Snap/Internal/Parsing
307%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Snap/Internal/Parsing/*.hi
308%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Snap/Internal/Test
309%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Snap/Internal/Test/*.hi
310%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Snap/Types
311%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Snap/Types/*.hi
312%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Snap/Util
313%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Snap/Util/*.hi
314
315%files prof
316%defattr(644,root,root,755)
67ba6e81 317%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSsnap-core-%{version}_p.a
543a17fb
JR
318%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Snap/*.p_hi
319%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Snap/Internal/*.p_hi
320%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Snap/Internal/Http/*.p_hi
321%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Snap/Internal/Iteratee/*.p_hi
322%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Snap/Internal/Parsing/*.p_hi
323%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Snap/Internal/Test/*.p_hi
324%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Snap/Types/*.p_hi
325%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Snap/Util/*.p_hi
This page took 0.088975 seconds and 4 git commands to generate.