]> git.pld-linux.org Git - packages/ghc-skylighting-core.git/blame - ghc-skylighting-core.spec
rebuild with ghc 8.10.7
[packages/ghc-skylighting-core.git] / ghc-skylighting-core.spec
CommitLineData
5da8b73f
JR
1#
2# Conditional build:
3%bcond_without prof # profiling library
4#
5%define pkgname skylighting-core
6Summary: Syntax highlighting library
7Name: ghc-%{pkgname}
8Version: 0.8.4
60126d63 9Release: 2
5da8b73f
JR
10License: BSD
11Group: Development/Languages
12#Source0Download: http://hackage.haskell.org/package/skylighting-core
13Source0: http://hackage.haskell.org/package/%{pkgname}-%{version}/%{pkgname}-%{version}.tar.gz
14# Source0-md5: 2db93ad3dda9e34b3b917835c56a0920
15URL: http://hackage.haskell.org/package/skylighting-core
16BuildRequires: ghc >= 6.12.3
17BuildRequires: ghc-aeson >= 1.0
18BuildRequires: ghc-ansi-terminal >= 0.7
19BuildRequires: ghc-attoparsec
20BuildRequires: ghc-base64-bytestring
21BuildRequires: ghc-blaze-html >= 0.5
22BuildRequires: ghc-case-insensitive
23BuildRequires: ghc-colour >= 2.0
24BuildRequires: ghc-hxt
25BuildRequires: ghc-regex-pcre
26BuildRequires: ghc-safe
27BuildRequires: ghc-transformers
28BuildRequires: ghc-utf8-string
29%if %{with prof}
30BuildRequires: ghc-prof
31BuildRequires: ghc-aeson-prof >= 1.0
32BuildRequires: ghc-ansi-terminal-prof >= 0.7
33BuildRequires: ghc-attoparsec-prof
34BuildRequires: ghc-base64-bytestring-prof
35BuildRequires: ghc-blaze-html-prof >= 0.5
36BuildRequires: ghc-case-insensitive-prof
37BuildRequires: ghc-colour-prof >= 2.0
38BuildRequires: ghc-hxt-prof
39BuildRequires: ghc-regex-pcre-prof
40BuildRequires: ghc-safe-prof
41BuildRequires: ghc-transformers-prof
42BuildRequires: ghc-utf8-string-prof
43%endif
44BuildRequires: rpmbuild(macros) >= 1.608
45%requires_eq ghc
46Requires(post,postun): /usr/bin/ghc-pkg
47Requires: ghc-aeson >= 1.0
48Requires: ghc-ansi-terminal >= 0.7
49Requires: ghc-attoparsec
50Requires: ghc-base64-bytestring
51Requires: ghc-blaze-html >= 0.5
52Requires: ghc-case-insensitive
53Requires: ghc-colour >= 2.0
54Requires: ghc-hxt
55Requires: ghc-regex-pcre
56Requires: ghc-safe
57Requires: ghc-transformers
58Requires: ghc-utf8-string
59BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
60
61# debuginfo is not useful for ghc
62%define _enable_debug_packages 0
63
64# don't compress haddock files
65%define _noautocompressdoc *.haddock
66
67%description
68This package provides the core functionality of the Skylighting
69project, a Haskell syntax highlighting library with support for KDE
70XML syntax highlighting descriptions.
71
72%package prof
73Summary: Profiling %{pkgname} library for GHC
74Summary(pl.UTF-8): Biblioteka profilująca %{pkgname} dla GHC
75Group: Development/Libraries
76Requires: %{name} = %{version}-%{release}
77Requires: ghc-aeson-prof >= 1.0
78Requires: ghc-ansi-terminal-prof >= 0.7
79Requires: ghc-attoparsec-prof
80Requires: ghc-base64-bytestring-prof
81Requires: ghc-blaze-html-prof >= 0.5
82Requires: ghc-case-insensitive-prof
83Requires: ghc-colour-prof >= 2.0
84Requires: ghc-hxt-prof
85Requires: ghc-regex-pcre-prof
86Requires: ghc-safe-prof
87Requires: ghc-transformers-prof
88Requires: ghc-utf8-string-prof
89
90%description prof
91Profiling %{pkgname} library for GHC. Should be installed when
92GHC's profiling subsystem is needed.
93
94%description prof -l pl.UTF-8
95Biblioteka profilująca %{pkgname} dla GHC. Powinna być zainstalowana
96kiedy potrzebujemy systemu profilującego z GHC.
97
98%prep
99%setup -q -n %{pkgname}-%{version}
100
101%build
102runhaskell Setup.hs configure -v2 \
103 %{?with_prof:--enable-library-profiling} \
104 --flags="system-pcre" \
105 --prefix=%{_prefix} \
106 --libdir=%{_libdir} \
107 --libexecdir=%{_libexecdir} \
108 --docdir=%{_docdir}/%{name}-%{version}
109
110runhaskell Setup.hs build
111runhaskell Setup.hs haddock --executables
112
113%install
114rm -rf $RPM_BUILD_ROOT
115install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
116
117runhaskell Setup.hs copy --destdir=$RPM_BUILD_ROOT
118
119# work around automatic haddock docs installation
120%{__rm} -rf %{name}-%{version}-doc
121cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version} %{name}-%{version}-doc
122%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
123
124runhaskell Setup.hs register \
125 --gen-pkg-config=$RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
126
127%clean
128rm -rf $RPM_BUILD_ROOT
129
130%post
131%ghc_pkg_recache
132
133%postun
134%ghc_pkg_recache
135
136%files
137%defattr(644,root,root,755)
138%doc changelog.md README.md %{name}-%{version}-doc/*
139%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
140%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}
141%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.so
142%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.a
143%exclude %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*_p.a
144
145%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Skylighting
146%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Skylighting/*.hi
147%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Skylighting/*.dyn_hi
148%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Skylighting/Format
149%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Skylighting/Format/*.hi
150%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Skylighting/Format/*.dyn_hi
151
152%if %{with prof}
153%files prof
154%defattr(644,root,root,755)
155%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*_p.a
156%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Skylighting/*.p_hi
157%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Skylighting/Format/*.p_hi
158%endif
This page took 0.098088 seconds and 4 git commands to generate.