]> git.pld-linux.org Git - packages/ghc-regex-posix.git/blame - ghc-regex-posix.spec
- up to 0.96.0.0
[packages/ghc-regex-posix.git] / ghc-regex-posix.spec
CommitLineData
80f13c58
JB
1#
2# Conditional build:
3%bcond_without prof # profiling library
4#
5%define pkgname regex-posix
6Summary: Replaces/Enhances Text.Regex
7Summary(pl.UTF-8): Podmiana/rozszerzenie Text.Regex
8Name: ghc-%{pkgname}
0e50eeef 9Version: 0.96.0.0
80f13c58
JB
10Release: 1
11License: BSD
12Group: Development/Languages
13#Source0Download: http://hackage.haskell.org/package/regex-posix
14Source0: http://hackage.haskell.org/package/%{pkgname}-%{version}/%{pkgname}-%{version}.tar.gz
0e50eeef
JR
15# Source0-md5: 1bd179e9b1804171f8a2797ea399c1b9
16Patch0: ghc-8.10.patch
80f13c58
JB
17URL: http://hackage.haskell.org/package/regex-posix
18BuildRequires: ghc >= 6.12.3
19BuildRequires: ghc-array
20BuildRequires: ghc-base >= 3
21BuildRequires: ghc-bytestring
22BuildRequires: ghc-containers
23BuildRequires: ghc-regex-base >= 0.93
24%if %{with prof}
25BuildRequires: ghc-prof >= 6.12.3
26BuildRequires: ghc-array-prof
27BuildRequires: ghc-base-prof >= 3
28BuildRequires: ghc-bytestring-prof
29BuildRequires: ghc-containers-prof
30BuildRequires: ghc-regex-base-prof >= 0.93
31%endif
32BuildRequires: rpmbuild(macros) >= 1.608
33Requires(post,postun): /usr/bin/ghc-pkg
34%requires_eq ghc
35Requires: ghc-array
36Requires: ghc-base >= 3
37Requires: ghc-bytestring
38Requires: ghc-containers
39Requires: ghc-regex-base >= 0.93
40BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42# debuginfo is not useful for ghc
43%define _enable_debug_packages 0
44
45# don't compress haddock files
46%define _noautocompressdoc *.haddock
47
48%description
49The posix regex backend for regex-base.
50
51%description -l pl.UTF-8
52Backend wyrażeń regularnych zgodnych z POSIX dla regex-base.
53
54%package prof
55Summary: Profiling %{pkgname} library for GHC
56Summary(pl.UTF-8): Biblioteka profilująca %{pkgname} dla GHC
57Group: Development/Libraries
58Requires: %{name} = %{version}-%{release}
59BuildRequires: ghc-array-prof
60BuildRequires: ghc-base-prof >= 3
61BuildRequires: ghc-bytestring-prof
62BuildRequires: ghc-containers-prof
63BuildRequires: ghc-regex-base-prof >= 0.93
64
65%description prof
66Profiling %{pkgname} library for GHC. Should be installed when GHC's
67profiling subsystem is needed.
68
69%description prof -l pl.UTF-8
70Biblioteka profilująca %{pkgname} dla GHC. Powinna być zainstalowana
71kiedy potrzebujemy systemu profilującego z GHC.
72
73%package doc
74Summary: HTML documentation for ghc %{pkgname} package
75Summary(pl.UTF-8): Dokumentacja w formacie HTML dla pakietu ghc %{pkgname}
76Group: Documentation
77
78%description doc
79HTML documentation for ghc %{pkgname} package.
80
81%description doc -l pl.UTF-8
82Dokumentacja w formacie HTML dla pakietu ghc %{pkgname}.
83
84%prep
85%setup -q -n %{pkgname}-%{version}
0e50eeef 86%patch0 -p1
80f13c58
JB
87
88%build
89runhaskell Setup.hs configure -v2 \
90 %{?with_prof:--enable-library-profiling} \
91 --prefix=%{_prefix} \
92 --libdir=%{_libdir} \
93 --libexecdir=%{_libexecdir} \
94 --docdir=%{_docdir}/%{name}-%{version}
95
96runhaskell Setup.hs build
97runhaskell Setup.hs haddock --executables
98
99%install
100rm -rf $RPM_BUILD_ROOT
101install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
102
103runhaskell Setup.hs copy --destdir=$RPM_BUILD_ROOT
104
105# work around automatic haddock docs installation
106%{__rm} -rf %{name}-%{version}-doc
107cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version} %{name}-%{version}-doc
108%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
109
110runhaskell Setup.hs register \
111 --gen-pkg-config=$RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
112
113%clean
114rm -rf $RPM_BUILD_ROOT
115
116%post
117%ghc_pkg_recache
118
119%postun
120%ghc_pkg_recache
121
122%files
123%defattr(644,root,root,755)
124%doc LICENSE
125%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
126%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}
0e50eeef
JR
127%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSregex-posix-%{version}-*.so
128%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSregex-posix-%{version}-*.a
129%exclude %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSregex-posix-%{version}-*_p.a
130%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.hi
131%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.dyn_hi
80f13c58
JB
132%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text
133%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Regex
0e50eeef
JR
134%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Regex/*.hi
135%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Regex/*.dyn_hi
80f13c58
JB
136%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Regex/Posix
137%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Regex/Posix/*.hi
0e50eeef 138%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Regex/Posix/*.dyn_hi
80f13c58
JB
139%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Regex/Posix/ByteString
140%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Regex/Posix/ByteString/*.hi
0e50eeef 141%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Regex/Posix/ByteString/*.dyn_hi
80f13c58
JB
142
143%if %{with prof}
144%files prof
145%defattr(644,root,root,755)
0e50eeef
JR
146%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSregex-posix-%{version}-*_p.a
147%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.p_hi
148%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Regex/*.p_hi
80f13c58
JB
149%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Regex/Posix/*.p_hi
150%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Regex/Posix/ByteString/*.p_hi
151%endif
152
153%files doc
154%defattr(644,root,root,755)
155%doc %{name}-%{version}-doc/*
This page took 0.654867 seconds and 4 git commands to generate.