]> git.pld-linux.org Git - packages/ghc-pango.git/blame - ghc-pango.spec
- sane deps
[packages/ghc-pango.git] / ghc-pango.spec
CommitLineData
fa710fca
JR
1%define pkgname pango
2Summary: Binding to the Pango text rendering engine
3Name: ghc-%{pkgname}
4Version: 0.12.3
5Release: 0.1
6License: LGPL v2.1
7Group: Development/Languages
8Source0: http://hackage.haskell.org/packages/archive/%{pkgname}/%{version}/%{pkgname}-%{version}.tar.gz
9# Source0-md5: 1ef3132cb569703d5b1bc262c9d86fe3
10URL: http://hackage.haskell.org/package/pango/
11BuildRequires: ghc >= 6.12.3
12BuildRequires: ghc-prof
13BuildRequires: ghc-glib
14BuildRequires: ghc-cairo
15BuildRequires: gtk2hs
16BuildRequires: rpmbuild(macros) >= 1.608
69053748 17%requires_eq ghc
fa710fca
JR
18Requires(post,postun): /usr/bin/ghc-pkg
19BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21# debuginfo is not useful for ghc
22%define _enable_debug_packages 0
23
24# don't compress haddoc files
25%define _noautocompressdoc *.haddock
26
27%description
28This package provides a wrapper around the Pango C library that allows
29high-quality rendering of Unicode text. It can be used either with
30Cairo to output text in PDF, PS or other documents or with Gtk+ to
31display text on-screen.
32
33%package prof
34Summary: Profiling %{pkgname} library for GHC
35Summary(pl.UTF-8): Biblioteka profilująca %{pkgname} dla GHC.
36Group: Development/Libraries
37Requires: %{name} = %{version}-%{release}
38
39%description prof
40Profiling %{pkgname} library for GHC. Should be installed when
41GHC's profiling subsystem is needed.
42
43%description prof -l pl.UTF-8
44Biblioteka profilująca %{pkgname} dla GHC. Powinna być zainstalowana
45kiedy potrzebujemy systemu profilującego z GHC.
46
47%prep
48%setup -q -n %{pkgname}-%{version}
49
50%build
51runhaskell Setup.hs configure -v2 --enable-library-profiling \
52 --prefix=%{_prefix} \
53 --libdir=%{_libdir} \
54 --libexecdir=%{_libexecdir} \
55 --docdir=%{_docdir}/%{name}-%{version}
56
57runhaskell Setup.hs build
58runhaskell Setup.hs haddock --executables
59
60%install
61rm -rf $RPM_BUILD_ROOT
62install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
63
64runhaskell Setup.hs copy --destdir=$RPM_BUILD_ROOT
65
66# work around automatic haddock docs installation
67rm -rf %{name}-%{version}-doc
68cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version} %{name}-%{version}-doc
69
70runhaskell Setup.hs register \
71 --gen-pkg-config=$RPM_BUILD_ROOT/%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
72
73%clean
74rm -rf $RPM_BUILD_ROOT
75
76%post
77%ghc_pkg_recache
78
79%postun
80%ghc_pkg_recache
81
82%files
83%defattr(644,root,root,755)
84%doc NEWS
85%doc %{name}-%{version}-doc/*
86%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
87%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}
88%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.o
89%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.a
90%exclude %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*_p.a
91
92%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/PACKAGE
93%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/PACKAGE/*.hi
94
95%files prof
96%defattr(644,root,root,755)
97%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*_p.a
98%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/PACKAGE/*.p_hi
This page took 0.068023 seconds and 4 git commands to generate.