]> git.pld-linux.org Git - packages/ghc-mmorph.git/blame - ghc-mmorph.spec
- up to 1.1.3
[packages/ghc-mmorph.git] / ghc-mmorph.spec
CommitLineData
d4e14f0f
JB
1#
2# Conditional build:
3%bcond_without prof # profiling library
4#
5%define pkgname mmorph
6Summary: Monad morphisms
7Summary(pl.UTF-8): Morfizm monad
8Name: ghc-%{pkgname}
da0a94d7 9Version: 1.1.3
d4e14f0f
JB
10Release: 1
11License: BSD
12Group: Development/Languages
13#Source0Download: http://hackage.haskell.org/package/mmorph
14Source0: http://hackage.haskell.org/package/%{pkgname}-%{version}/%{pkgname}-%{version}.tar.gz
da0a94d7 15# Source0-md5: 29bb471c81368f7c2575ac4c49bd0216
d4e14f0f
JB
16URL: http://hackage.haskell.org/package/mmorph
17BuildRequires: ghc >= 6.12.3
18BuildRequires: ghc-base >= 4
d4e14f0f 19BuildRequires: ghc-transformers >= 0.2.0.0
da0a94d7 20BuildRequires: ghc-transformers-compat >= 0.3
d4e14f0f
JB
21%if %{with prof}
22BuildRequires: ghc-prof >= 6.12.3
23BuildRequires: ghc-base-prof >= 4
d4e14f0f 24BuildRequires: ghc-transformers-prof >= 0.2.0.0
da0a94d7 25BuildRequires: ghc-transformers-compat-prof >= 0.3
d4e14f0f
JB
26%endif
27BuildRequires: rpmbuild(macros) >= 1.608
28Requires(post,postun): /usr/bin/ghc-pkg
29%requires_eq ghc
30Requires: ghc-base >= 4
d4e14f0f 31Requires: ghc-transformers >= 0.2.0.0
da0a94d7 32Requires: ghc-transformers-compat >= 0.3
d4e14f0f
JB
33BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35# debuginfo is not useful for ghc
36%define _enable_debug_packages 0
37
38# don't compress haddock files
39%define _noautocompressdoc *.haddock
40
41%description
42This library provides monad morphism utilities, most commonly used for
43manipulating monad transformer stacks.
44
45%description -l pl.UTF-8
46Ta biblioteka dostarcza narzędzia do morfizmu monad, najczęściej
47używane do operacji na stosach transformatorów monad.
48
49%package prof
50Summary: Profiling %{pkgname} library for GHC
51Summary(pl.UTF-8): Biblioteka profilująca %{pkgname} dla GHC
52Group: Development/Libraries
53Requires: %{name} = %{version}-%{release}
54Requires: ghc-base-prof >= 4
d4e14f0f 55Requires: ghc-transformers-prof >= 0.2.0.0
da0a94d7 56Requires: ghc-transformers-compat-prof >= 0.3
d4e14f0f
JB
57
58%description prof
59Profiling %{pkgname} library for GHC. Should be installed when
60GHC's profiling subsystem is needed.
61
62%description prof -l pl.UTF-8
63Biblioteka profilująca %{pkgname} dla GHC. Powinna być zainstalowana
64kiedy potrzebujemy systemu profilującego z GHC.
65
66%package doc
67Summary: HTML documentation for ghc %{pkgname} package
68Summary(pl.UTF-8): Dokumentacja w formacie HTML dla pakietu ghc %{pkgname}
69Group: Documentation
70
71%description doc
72HTML documentation for ghc %{pkgname} package.
73
74%description doc -l pl.UTF-8
75Dokumentacja w formacie HTML dla pakietu ghc %{pkgname}.
76
77%prep
78%setup -q -n %{pkgname}-%{version}
79
80%build
81runhaskell Setup.hs configure -v2 \
82 %{?with_prof:--enable-library-profiling} \
83 --prefix=%{_prefix} \
84 --libdir=%{_libdir} \
85 --libexecdir=%{_libexecdir} \
86 --docdir=%{_docdir}/%{name}-%{version}
87
88runhaskell Setup.hs build
89runhaskell Setup.hs haddock --executables
90
91%install
92rm -rf $RPM_BUILD_ROOT
93install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
94
95runhaskell Setup.hs copy --destdir=$RPM_BUILD_ROOT
96
97# work around automatic haddock docs installation
98%{__rm} -rf %{name}-%{version}-doc
99cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version} %{name}-%{version}-doc
100%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
101
102runhaskell Setup.hs register \
103 --gen-pkg-config=$RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
104
105%clean
106rm -rf $RPM_BUILD_ROOT
107
108%post
109%ghc_pkg_recache
110
111%postun
112%ghc_pkg_recache
113
114%files
115%defattr(644,root,root,755)
116%doc LICENSE
117%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
118%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}
da0a94d7
JR
119%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSmmorph-%{version}-*.so
120%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSmmorph-%{version}-*.a
121%exclude %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSmmorph-%{version}-*_p.a
d4e14f0f
JB
122%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control
123%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control/Monad
da0a94d7
JR
124%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control/Monad/*.hi
125%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control/Monad/*.dyn_hi
126%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control/Monad/Trans
127%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control/Monad/Trans/*.hi
128%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control/Monad/Trans/*.dyn_hi
d4e14f0f
JB
129
130%if %{with prof}
131%files prof
132%defattr(644,root,root,755)
da0a94d7
JR
133%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSmmorph-%{version}-*_p.a
134%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control/Monad/*.p_hi
135%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control/Monad/Trans/*.p_hi
d4e14f0f
JB
136%endif
137
138%files doc
139%defattr(644,root,root,755)
140%doc %{name}-%{version}-doc/*
This page took 0.082035 seconds and 4 git commands to generate.