]> git.pld-linux.org Git - packages/ghc-jira-wiki-markup.git/blame - ghc-jira-wiki-markup.spec
rebuild with ghc 8.10.7
[packages/ghc-jira-wiki-markup.git] / ghc-jira-wiki-markup.spec
CommitLineData
862a403a
JR
1#
2# Conditional build:
3%bcond_without prof # profiling library
4#
5%define pkgname jira-wiki-markup
6Summary: Handle Jira wiki markup
7Name: ghc-%{pkgname}
8Version: 1.3.0
0326852d 9Release: 2
862a403a
JR
10License: MIT
11Group: Development/Languages
12#Source0Download: http://hackage.haskell.org/package/jira-wiki-markup
13Source0: http://hackage.haskell.org/package/%{pkgname}-%{version}/%{pkgname}-%{version}.tar.gz
14# Source0-md5: 0e8c20759654d476e246df7d8118c4e8
15URL: http://hackage.haskell.org/package/jira-wiki-markup
16BuildRequires: ghc >= 6.12.3
17%if %{with prof}
18BuildRequires: ghc-prof
19%endif
20BuildRequires: rpmbuild(macros) >= 1.608
21%requires_eq ghc
22Requires(post,postun): /usr/bin/ghc-pkg
23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25# debuginfo is not useful for ghc
26%define _enable_debug_packages 0
27
28# don't compress haddock files
29%define _noautocompressdoc *.haddock
30
31%description
32Parse jira wiki text into an abstract syntax tree for easy
33transformation to other formats.
34
35%package prof
36Summary: Profiling %{pkgname} library for GHC
37Summary(pl.UTF-8): Biblioteka profilująca %{pkgname} dla GHC
38Group: Development/Libraries
39Requires: %{name} = %{version}-%{release}
40
41%description prof
42Profiling %{pkgname} library for GHC. Should be installed when
43GHC's profiling subsystem is needed.
44
45%description prof -l pl.UTF-8
46Biblioteka profilująca %{pkgname} dla GHC. Powinna być zainstalowana
47kiedy potrzebujemy systemu profilującego z GHC.
48
49%prep
50%setup -q -n %{pkgname}-%{version}
51
52cat >Setup.lhs<<'EOF'
53#!/usr/bin/env runhaskell
54> import Distribution.Simple
55> main = defaultMain
56EOF
57
58%build
59runhaskell Setup.lhs configure -v2 \
60 %{?with_prof:--enable-library-profiling} \
61 --prefix=%{_prefix} \
62 --libdir=%{_libdir} \
63 --libexecdir=%{_libexecdir} \
64 --docdir=%{_docdir}/%{name}-%{version}
65
66runhaskell Setup.lhs build
67runhaskell Setup.lhs haddock
68
69%install
70rm -rf $RPM_BUILD_ROOT
71install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
72
73runhaskell Setup.lhs copy --destdir=$RPM_BUILD_ROOT
74
75# work around automatic haddock docs installation
76%{__rm} -rf %{name}-%{version}-doc
77cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version} %{name}-%{version}-doc
78%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
79
80runhaskell Setup.lhs register \
81 --gen-pkg-config=$RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
82
83%clean
84rm -rf $RPM_BUILD_ROOT
85
86%post
87%ghc_pkg_recache
88
89%postun
90%ghc_pkg_recache
91
92%files
93%defattr(644,root,root,755)
94%doc CHANGELOG.md README.md %{name}-%{version}-doc/*
95%attr(755,root,root) %{_bindir}/jira-wiki-markup
96%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
97%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}
98%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.so
99%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.a
100%exclude %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*_p.a
101
102%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text
103%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Jira
104%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Jira/*.hi
105%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Jira/*.dyn_hi
106%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Jira/Parser
107%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Jira/Parser/*.hi
108%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Jira/Parser/*.dyn_hi
109
110%if %{with prof}
111%files prof
112%defattr(644,root,root,755)
113%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*_p.a
114%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Jira/*.p_hi
115%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Jira/Parser/*.p_hi
116%endif
This page took 0.074277 seconds and 4 git commands to generate.