]> git.pld-linux.org Git - packages/ghc-haskell-src-exts.git/blame - ghc-haskell-src-exts.spec
- release 3
[packages/ghc-haskell-src-exts.git] / ghc-haskell-src-exts.spec
CommitLineData
a480dca3 1%define pkgname haskell-src-exts
89afe562
JR
2Summary: Manipulating Haskell source: abstract syntax, lexer, parser, and pretty-printer
3Name: ghc-%{pkgname}
4Version: 1.9.6
bf2a9bfc 5Release: 3
89afe562
JR
6License: BSD
7Group: Development/Languages
8Source0: http://hackage.haskell.org/packages/archive/%{pkgname}/%{version}/%{pkgname}-%{version}.tar.gz
9# Source0-md5: 5e73836ab3414ec029e93903b26563ca
a480dca3 10URL: http://hackage.haskell.org/package/haskell-src-exts/
89afe562
JR
11BuildRequires: cpphs
12BuildRequires: ghc >= 6.12.3
a480dca3 13BuildRequires: rpmbuild(macros) >= 1.608
89afe562
JR
14Requires: cpphs
15%requires_releq ghc
16BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
89afe562
JR
18%description
19Haskell-Source with Extensions (HSE, haskell-src-exts) is an extension
20of the standard haskell-src package, and handles most registered
21syntactic extensions to Haskell, including:
22
23* Multi-parameter type classes with functional dependencies
24* Indexed type families (including associated types)
25* Empty data declarations
26* GADTs
27* Implicit parameters
28* Template Haskell
29
30and a few more. All extensions implemented in GHC are supported.
31Apart from these standard extensions, it also handles regular patterns
32as per the HaRP extension as well as HSX-style embedded XML syntax.
33
34%prep
35%setup -q -n %{pkgname}-%{version}
36
37%build
38runhaskell Setup.hs configure -v2 \
39 --prefix=%{_prefix} \
40 --libdir=%{_libdir} \
41 --libexecdir=%{_libexecdir} \
42 --docdir=%{_docdir}/%{name}-%{version}
43
44runhaskell Setup.hs build
45runhaskell Setup.hs haddock --executables
46
47%install
48rm -rf $RPM_BUILD_ROOT
49install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
50
51runhaskell Setup.hs copy --destdir=$RPM_BUILD_ROOT
52
53# work around automatic haddock docs installation
54rm -rf %{name}-%{version}-doc
55cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version} %{name}-%{version}-doc
56
57runhaskell Setup.hs register \
58 --gen-pkg-config=$RPM_BUILD_ROOT/%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
59
60%clean
61rm -rf $RPM_BUILD_ROOT
62
63%post
a480dca3 64%ghc_pkg_recache
89afe562
JR
65
66%postun
a480dca3 67%ghc_pkg_recache
89afe562
JR
68
69%files
70%defattr(644,root,root,755)
2056cc9d 71%doc CHANGELOG
89afe562
JR
72%doc %{name}-%{version}-doc/html
73%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
74%{_libdir}/%{ghcdir}/%{pkgname}-%{version}
This page took 0.073684 seconds and 4 git commands to generate.