]> git.pld-linux.org Git - packages/ghc-haskell-src-exts.git/blame - ghc-haskell-src-exts.spec
- 1.11.1
[packages/ghc-haskell-src-exts.git] / ghc-haskell-src-exts.spec
CommitLineData
a480dca3 1%define pkgname haskell-src-exts
89afe562
JR
2Summary: Manipulating Haskell source: abstract syntax, lexer, parser, and pretty-printer
3Name: ghc-%{pkgname}
9dfd0974
JR
4Version: 1.11.1
5Release: 1
89afe562
JR
6License: BSD
7Group: Development/Languages
8Source0: http://hackage.haskell.org/packages/archive/%{pkgname}/%{version}/%{pkgname}-%{version}.tar.gz
9dfd0974 9# Source0-md5: c0c8f214de2e712455a5a250b7f898a9
a480dca3 10URL: http://hackage.haskell.org/package/haskell-src-exts/
89afe562
JR
11BuildRequires: cpphs
12BuildRequires: ghc >= 6.12.3
a480dca3 13BuildRequires: rpmbuild(macros) >= 1.608
89afe562 14Requires: cpphs
f8a7566b 15%requires_eq ghc
89afe562
JR
16BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
f8a7566b
ER
18# debuginfo is not useful for ghc
19%define _enable_debug_packages 0
20
89afe562
JR
21%description
22Haskell-Source with Extensions (HSE, haskell-src-exts) is an extension
23of the standard haskell-src package, and handles most registered
24syntactic extensions to Haskell, including:
25
26* Multi-parameter type classes with functional dependencies
27* Indexed type families (including associated types)
28* Empty data declarations
29* GADTs
30* Implicit parameters
31* Template Haskell
32
33and a few more. All extensions implemented in GHC are supported.
34Apart from these standard extensions, it also handles regular patterns
35as per the HaRP extension as well as HSX-style embedded XML syntax.
36
f8a7566b
ER
37%package doc
38Summary: HTML documentation for %{pkgname}
39Summary(pl.UTF-8): Dokumentacja w formacie HTML dla %{pkgname}
40Group: Documentation
41
42%description doc
43HTML documentation for %{pkgname}.
44
45%description doc -l pl.UTF-8
46Dokumentacja w formacie HTML dla %{pkgname}.
47
89afe562
JR
48%prep
49%setup -q -n %{pkgname}-%{version}
50
51%build
52runhaskell Setup.hs configure -v2 \
53 --prefix=%{_prefix} \
54 --libdir=%{_libdir} \
55 --libexecdir=%{_libexecdir} \
56 --docdir=%{_docdir}/%{name}-%{version}
57
58runhaskell Setup.hs build
59runhaskell Setup.hs haddock --executables
60
61%install
62rm -rf $RPM_BUILD_ROOT
63install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
64
65runhaskell Setup.hs copy --destdir=$RPM_BUILD_ROOT
66
67# work around automatic haddock docs installation
68rm -rf %{name}-%{version}-doc
f8a7566b 69cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/html %{name}-%{version}-doc
89afe562
JR
70
71runhaskell Setup.hs register \
72 --gen-pkg-config=$RPM_BUILD_ROOT/%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
73
74%clean
75rm -rf $RPM_BUILD_ROOT
76
77%post
a480dca3 78%ghc_pkg_recache
89afe562
JR
79
80%postun
a480dca3 81%ghc_pkg_recache
89afe562
JR
82
83%files
84%defattr(644,root,root,755)
2056cc9d 85%doc CHANGELOG
89afe562
JR
86%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
87%{_libdir}/%{ghcdir}/%{pkgname}-%{version}
f8a7566b
ER
88
89%files doc
90%defattr(644,root,root,755)
91%doc %{name}-%{version}-doc/*
This page took 0.115441 seconds and 4 git commands to generate.