]> git.pld-linux.org Git - packages/ghc-haskell-src-exts.git/blame - ghc-haskell-src-exts.spec
- up to 1.13.5
[packages/ghc-haskell-src-exts.git] / ghc-haskell-src-exts.spec
CommitLineData
a480dca3 1%define pkgname haskell-src-exts
89afe562
JR
2Summary: Manipulating Haskell source: abstract syntax, lexer, parser, and pretty-printer
3Name: ghc-%{pkgname}
80abe821
JR
4Version: 1.13.5
5Release: 1
89afe562
JR
6License: BSD
7Group: Development/Languages
8Source0: http://hackage.haskell.org/packages/archive/%{pkgname}/%{version}/%{pkgname}-%{version}.tar.gz
80abe821 9# Source0-md5: 102727a2b64c8157424a1654225b95e2
a480dca3 10URL: http://hackage.haskell.org/package/haskell-src-exts/
89afe562 11BuildRequires: cpphs
55b90c8d 12BuildRequires: cpphs-prof
89afe562 13BuildRequires: ghc >= 6.12.3
a480dca3 14BuildRequires: rpmbuild(macros) >= 1.608
89afe562 15Requires: cpphs
f8a7566b 16%requires_eq ghc
a43a39d9 17Obsoletes: ghc-haskell-src-exts-doc
89afe562
JR
18BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
f8a7566b
ER
20# debuginfo is not useful for ghc
21%define _enable_debug_packages 0
71a15fe1 22%define _noautocompressdoc *.haddock
f8a7566b 23
89afe562
JR
24%description
25Haskell-Source with Extensions (HSE, haskell-src-exts) is an extension
26of the standard haskell-src package, and handles most registered
27syntactic extensions to Haskell, including:
28
29* Multi-parameter type classes with functional dependencies
30* Indexed type families (including associated types)
31* Empty data declarations
32* GADTs
33* Implicit parameters
34* Template Haskell
35
36and a few more. All extensions implemented in GHC are supported.
37Apart from these standard extensions, it also handles regular patterns
38as per the HaRP extension as well as HSX-style embedded XML syntax.
39
55b90c8d
JR
40%package prof
41Summary: Profiling %{pkgname} library for GHC
42Summary(pl.UTF-8): Biblioteka profilująca %{pkgname} dla GHC.
43Group: Development/Libraries
44Requires: %{name} = %{version}-%{release}
45Requires: cpphs-prof
46
47%description prof
48Profiling %{pkgname} library for GHC. Should be installed when
49GHC's profiling subsystem is needed.
50
51%description prof -l pl.UTF-8
52Biblioteka profilująca %{pkgname} dla GHC. Powinna być zainstalowana
53kiedy potrzebujemy systemu profilującego z GHC.
54
89afe562
JR
55%prep
56%setup -q -n %{pkgname}-%{version}
57
58%build
55b90c8d 59runhaskell Setup.hs configure -v2 --enable-library-profiling \
89afe562
JR
60 --prefix=%{_prefix} \
61 --libdir=%{_libdir} \
62 --libexecdir=%{_libexecdir} \
63 --docdir=%{_docdir}/%{name}-%{version}
64
65runhaskell Setup.hs build
66runhaskell Setup.hs haddock --executables
67
68%install
69rm -rf $RPM_BUILD_ROOT
70install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
71
72runhaskell Setup.hs copy --destdir=$RPM_BUILD_ROOT
73
74# work around automatic haddock docs installation
80abe821 75%{__rm} -rf %{name}-%{version}-doc
a43a39d9 76cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version} %{name}-%{version}-doc
80abe821 77%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
89afe562
JR
78
79runhaskell Setup.hs register \
80 --gen-pkg-config=$RPM_BUILD_ROOT/%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
81
82%clean
83rm -rf $RPM_BUILD_ROOT
84
85%post
a480dca3 86%ghc_pkg_recache
89afe562
JR
87
88%postun
a480dca3 89%ghc_pkg_recache
89afe562
JR
90
91%files
92%defattr(644,root,root,755)
2056cc9d 93%doc CHANGELOG
a43a39d9 94%doc %{name}-%{version}-doc/*
89afe562 95%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
55b90c8d
JR
96%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}
97%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.o
98%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.a
99%exclude %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*_p.a
0a6878c9
JR
100%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Language
101%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Language/Haskell
102%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Language/Haskell/Exts
103%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Language/Haskell/Exts/Annotated
55b90c8d
JR
104%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Language/Haskell/*.hi
105%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Language/Haskell/Exts/*.hi
106%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Language/Haskell/Exts/Annotated/*.hi
107
108%files prof
109%defattr(644,root,root,755)
110%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*_p.a
111%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Language/Haskell/*.p_hi
112%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Language/Haskell/Exts/*.p_hi
113%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Language/Haskell/Exts/Annotated/*.p_hi
This page took 0.045397 seconds and 4 git commands to generate.