]> git.pld-linux.org Git - packages/ghc-haskell-src-exts.git/blame - ghc-haskell-src-exts.spec
- up to 1.23.0
[packages/ghc-haskell-src-exts.git] / ghc-haskell-src-exts.spec
CommitLineData
327b22f4
JB
1#
2# Conditional build:
3%bcond_without prof # profiling library
4#
a480dca3 5%define pkgname haskell-src-exts
89afe562 6Summary: Manipulating Haskell source: abstract syntax, lexer, parser, and pretty-printer
327b22f4 7Summary(pl.UTF-8): Operacje na źródłach w Haskellu: abstraksyjna składnia, analiza leksykalna i składniowa, wypisywanie
89afe562 8Name: ghc-%{pkgname}
696fc5ff
JR
9Version: 1.23.0
10Release: 1
89afe562
JR
11License: BSD
12Group: Development/Languages
327b22f4
JB
13#Source0Download: http://hackage.haskell.org/package/haskell-src-exts
14Source0: http://hackage.haskell.org/package/%{pkgname}-%{version}/%{pkgname}-%{version}.tar.gz
696fc5ff 15# Source0-md5: d21622063b81240b6804e31f7d9f2498
327b22f4
JB
16URL: http://hackage.haskell.org/package/haskell-src-exts
17BuildRequires: cpphs >= 1.3
89afe562 18BuildRequires: ghc >= 6.12.3
327b22f4 19BuildRequires: ghc-array >= 0.1
983bcc2d
JP
20BuildRequires: ghc-base >= 4.5
21BuildRequires: ghc-base < 5
327b22f4
JB
22BuildRequires: ghc-pretty >= 1.0
23%if %{with prof}
24BuildRequires: cpphs-prof >= 1.3
25BuildRequires: ghc-prof >= 6.12.3
26BuildRequires: ghc-array-prof >= 0.1
983bcc2d
JP
27BuildRequires: ghc-base-prof >= 4.5
28BuildRequires: ghc-base-prof < 5
327b22f4
JB
29BuildRequires: ghc-pretty-prof >= 1.0
30%endif
a480dca3 31BuildRequires: rpmbuild(macros) >= 1.608
f8a7566b 32%requires_eq ghc
327b22f4
JB
33Requires(post,postun): /usr/bin/ghc-pkg
34Requires: cpphs >= 1.3
35Requires: ghc-array >= 0.1
983bcc2d
JP
36Requires: ghc-base >= 4.5
37Requires: ghc-base < 5
327b22f4 38Requires: ghc-pretty >= 1.0
a43a39d9 39Obsoletes: ghc-haskell-src-exts-doc
89afe562
JR
40BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
f8a7566b
ER
42# debuginfo is not useful for ghc
43%define _enable_debug_packages 0
327b22f4
JB
44
45# don't compress haddock files
71a15fe1 46%define _noautocompressdoc *.haddock
f8a7566b 47
89afe562
JR
48%description
49Haskell-Source with Extensions (HSE, haskell-src-exts) is an extension
50of the standard haskell-src package, and handles most registered
51syntactic extensions to Haskell, including:
52
53* Multi-parameter type classes with functional dependencies
54* Indexed type families (including associated types)
55* Empty data declarations
56* GADTs
57* Implicit parameters
58* Template Haskell
59
60and a few more. All extensions implemented in GHC are supported.
61Apart from these standard extensions, it also handles regular patterns
62as per the HaRP extension as well as HSX-style embedded XML syntax.
63
327b22f4
JB
64%description -l pl.UTF-8
65Haskell-Source with Extensions (HSE, haskell-src-exts) to rozszerzenie
66standardowego pakietu haskell-src, obsługujące większość
67zarejestrowanych rozszerzeń składniowych do Haskella, w tym:
68
69- wieloparametrowe klasy typów z zależnościami funkcyjnymi
70- rodziny typów indeksowanych (w tym asocjacyjnych)
71- deklaracje pustych danych
72- GADT
73- parametry implikowane
74- Template Haskell
75
76i kilka innych. Obsługiwane są wszystkie rozszerzenia zaimplementowane
77w GHC. Poza tymi rozszerzeniami, pakiet obsługuje wzorce regularne
78zgodne z rozszerzeniem HaRP, a także składnię osadzonego XML-a w stylu
79HSX.
80
55b90c8d
JR
81%package prof
82Summary: Profiling %{pkgname} library for GHC
83Summary(pl.UTF-8): Biblioteka profilująca %{pkgname} dla GHC.
84Group: Development/Libraries
85Requires: %{name} = %{version}-%{release}
327b22f4
JB
86Requires: cpphs-prof >= 1.3
87Requires: ghc-array-prof >= 0.1
983bcc2d
JP
88Requires: ghc-base-prof >= 4.5
89Requires: ghc-base-prof < 5
327b22f4 90Requires: ghc-pretty-prof >= 1.0
55b90c8d
JR
91
92%description prof
327b22f4
JB
93Profiling %{pkgname} library for GHC. Should be installed when GHC's
94profiling subsystem is needed.
55b90c8d
JR
95
96%description prof -l pl.UTF-8
97Biblioteka profilująca %{pkgname} dla GHC. Powinna być zainstalowana
98kiedy potrzebujemy systemu profilującego z GHC.
99
89afe562
JR
100%prep
101%setup -q -n %{pkgname}-%{version}
102
103%build
327b22f4
JB
104runhaskell Setup.hs configure -v2 \
105 %{?with_prof:--enable-library-profiling} \
89afe562
JR
106 --prefix=%{_prefix} \
107 --libdir=%{_libdir} \
108 --libexecdir=%{_libexecdir} \
109 --docdir=%{_docdir}/%{name}-%{version}
110
111runhaskell Setup.hs build
112runhaskell Setup.hs haddock --executables
113
114%install
115rm -rf $RPM_BUILD_ROOT
116install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
117
118runhaskell Setup.hs copy --destdir=$RPM_BUILD_ROOT
119
120# work around automatic haddock docs installation
80abe821 121%{__rm} -rf %{name}-%{version}-doc
a43a39d9 122cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version} %{name}-%{version}-doc
80abe821 123%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
89afe562
JR
124
125runhaskell Setup.hs register \
327b22f4 126 --gen-pkg-config=$RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
89afe562
JR
127
128%clean
129rm -rf $RPM_BUILD_ROOT
130
131%post
a480dca3 132%ghc_pkg_recache
89afe562
JR
133
134%postun
a480dca3 135%ghc_pkg_recache
89afe562
JR
136
137%files
138%defattr(644,root,root,755)
327b22f4 139%doc CHANGELOG %{name}-%{version}-doc/*
89afe562 140%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
55b90c8d 141%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}
696fc5ff
JR
142%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHShaskell-src-exts-%{version}-*.so
143%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHShaskell-src-exts-%{version}-*.a
144%exclude %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHShaskell-src-exts-%{version}-*_p.a
0a6878c9
JR
145%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Language
146%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Language/Haskell
55b90c8d 147%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Language/Haskell/*.hi
696fc5ff 148%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Language/Haskell/*.dyn_hi
327b22f4 149%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Language/Haskell/Exts
55b90c8d 150%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Language/Haskell/Exts/*.hi
696fc5ff
JR
151%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Language/Haskell/Exts/*.dyn_hi
152%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Language/Preprocessor
153%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Language/Preprocessor/*.hi
154%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Language/Preprocessor/*.dyn_hi
55b90c8d 155
983bcc2d 156%if %{with prof}
55b90c8d
JR
157%files prof
158%defattr(644,root,root,755)
696fc5ff 159%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHShaskell-src-exts-%{version}-*_p.a
55b90c8d
JR
160%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Language/Haskell/*.p_hi
161%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Language/Haskell/Exts/*.p_hi
696fc5ff 162%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Language/Preprocessor/*.p_hi
983bcc2d 163%endif
This page took 0.089621 seconds and 4 git commands to generate.