]> git.pld-linux.org Git - packages/ghc-haskell-src-exts.git/blame - ghc-haskell-src-exts.spec
- rel 1
[packages/ghc-haskell-src-exts.git] / ghc-haskell-src-exts.spec
CommitLineData
89afe562
JR
1%define pkgname haskell-src-exts
2Summary: Manipulating Haskell source: abstract syntax, lexer, parser, and pretty-printer
3Name: ghc-%{pkgname}
4Version: 1.9.6
2056cc9d 5Release: 1
89afe562
JR
6License: BSD
7Group: Development/Languages
8Source0: http://hackage.haskell.org/packages/archive/%{pkgname}/%{version}/%{pkgname}-%{version}.tar.gz
9# Source0-md5: 5e73836ab3414ec029e93903b26563ca
10URL: http://hackage.haskell.org/package/%{pkgname}/
11BuildRequires: cpphs
12BuildRequires: ghc >= 6.12.3
13Requires: cpphs
14%requires_releq ghc
15BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17%define ghcdir ghc-%(/usr/bin/ghc --numeric-version)
18
19%description
20Haskell-Source with Extensions (HSE, haskell-src-exts) is an extension
21of the standard haskell-src package, and handles most registered
22syntactic extensions to Haskell, including:
23
24* Multi-parameter type classes with functional dependencies
25* Indexed type families (including associated types)
26* Empty data declarations
27* GADTs
28* Implicit parameters
29* Template Haskell
30
31and a few more. All extensions implemented in GHC are supported.
32Apart from these standard extensions, it also handles regular patterns
33as per the HaRP extension as well as HSX-style embedded XML syntax.
34
35%prep
36%setup -q -n %{pkgname}-%{version}
37
38%build
39runhaskell Setup.hs configure -v2 \
40 --prefix=%{_prefix} \
41 --libdir=%{_libdir} \
42 --libexecdir=%{_libexecdir} \
43 --docdir=%{_docdir}/%{name}-%{version}
44
45runhaskell Setup.hs build
46runhaskell Setup.hs haddock --executables
47
48%install
49rm -rf $RPM_BUILD_ROOT
50install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
51
52runhaskell Setup.hs copy --destdir=$RPM_BUILD_ROOT
53
54# work around automatic haddock docs installation
55rm -rf %{name}-%{version}-doc
56cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version} %{name}-%{version}-doc
57
58runhaskell Setup.hs register \
59 --gen-pkg-config=$RPM_BUILD_ROOT/%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
60
61%clean
62rm -rf $RPM_BUILD_ROOT
63
64%post
65/usr/bin/ghc-pkg recache
66
67%postun
68/usr/bin/ghc-pkg recache
69
70%files
71%defattr(644,root,root,755)
2056cc9d 72%doc CHANGELOG
89afe562
JR
73%doc %{name}-%{version}-doc/html
74%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
75%{_libdir}/%{ghcdir}/%{pkgname}-%{version}
This page took 0.078437 seconds and 4 git commands to generate.