]> git.pld-linux.org Git - packages/ghc-conduit.git/blame - ghc-conduit.spec
rebuild with ghc 8.10.7
[packages/ghc-conduit.git] / ghc-conduit.spec
CommitLineData
5c44ed1b
JB
1#
2# Conditional build:
3%bcond_without prof # profiling library
4#
5%define pkgname conduit
6Summary: Streaming data processing library
7Summary(pl.UTF-8): Biblioteka przetwarzania danych strumieniowych
8Name: ghc-%{pkgname}
2e4469e6 9Version: 1.3.2
4f50af28 10Release: 2
5c44ed1b
JB
11License: BSD
12Group: Development/Languages
13#Source0Download: http://hackage.haskell.org/package/conduit
14Source0: http://hackage.haskell.org/package/%{pkgname}-%{version}/%{pkgname}-%{version}.tar.gz
2e4469e6 15# Source0-md5: 162fbaa267a0412d98b0536e71bccd6a
5c44ed1b
JB
16URL: http://hackage.haskell.org/package/conduit
17BuildRequires: ghc >= 6.12.3
18BuildRequires: ghc-base >= 4.3
2e4469e6 19BuildRequires: ghc-bytestring
5c44ed1b 20BuildRequires: ghc-directory
2e4469e6
JR
21BuildRequires: ghc-exceptions
22BuildRequires: ghc-filepath
23BuildRequires: ghc-mono-traversable >= 1.0.7
5c44ed1b 24BuildRequires: ghc-mtl
2e4469e6
JR
25BuildRequires: ghc-primitive
26BuildRequires: ghc-resourcet >= 1.2
27BuildRequires: ghc-text
28BuildRequires: ghc-transformers >= 0.4
29BuildRequires: ghc-unix
30BuildRequires: ghc-unliftio-core
31BuildRequires: ghc-vector
5c44ed1b
JB
32%if %{with prof}
33BuildRequires: ghc-prof >= 6.12.3
34BuildRequires: ghc-base-prof >= 4.3
2e4469e6 35BuildRequires: ghc-bytestring-prof
5c44ed1b 36BuildRequires: ghc-directory-prof
2e4469e6
JR
37BuildRequires: ghc-exceptions-prof
38BuildRequires: ghc-filepath-prof
39BuildRequires: ghc-mono-traversable-prof >= 1.0.7
5c44ed1b 40BuildRequires: ghc-mtl-prof
2e4469e6
JR
41BuildRequires: ghc-primitive-prof
42BuildRequires: ghc-resourcet-prof >= 1.2
43BuildRequires: ghc-text-prof
44BuildRequires: ghc-transformers-prof >= 0.4
45BuildRequires: ghc-unix-prof
46BuildRequires: ghc-unliftio-core-prof
47BuildRequires: ghc-vector-prof
5c44ed1b
JB
48%endif
49BuildRequires: rpmbuild(macros) >= 1.608
50Requires(post,postun): /usr/bin/ghc-pkg
51%requires_eq ghc
52Requires: ghc-base >= 4.3
2e4469e6 53Requires: ghc-bytestring
5c44ed1b 54Requires: ghc-directory
2e4469e6
JR
55Requires: ghc-exceptions
56Requires: ghc-filepath
57Requires: ghc-mono-traversable >= 1.0.7
5c44ed1b 58Requires: ghc-mtl
2e4469e6
JR
59Requires: ghc-primitive
60Requires: ghc-resourcet >= 1.2
61Requires: ghc-text
62Requires: ghc-transformers >= 0.4
63Requires: ghc-unix
64Requires: ghc-unliftio-core
65Requires: ghc-vector
5c44ed1b
JB
66BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
67
68# debuginfo is not useful for ghc
69%define _enable_debug_packages 0
70
71# don't compress haddock files
72%define _noautocompressdoc *.haddock
73
74%description
75conduit is a solution to the streaming data problem, allowing for
76production, transformation, and consumption of streams of data in
77constant memory. It is an alternative to lazy I/O which guarantees
78deterministic resource handling, and fits in the same general solution
79space as enumerator/iteratee and pipes.
80
81%description -l pl.UTF-8
82conduit to rozwiązanie problemu danych strumieniowych, pozwalające na
83produkcję, przekształcanie oraz konsumpcję strumieni danych ze stałą
84złożonością pamięciową. Jest to alternatywa dla leniwego we/wy,
85gwarantująca deterministyczną obsługę zasobów, mieszcząca się w tej
86samej przestrzeni rozwiązań ogólnych, co enumerator/iteratee oraz
87potoki.
88
89%package prof
90Summary: Profiling %{pkgname} library for GHC
91Summary(pl.UTF-8): Biblioteka profilująca %{pkgname} dla GHC
92Group: Development/Libraries
93Requires: %{name} = %{version}-%{release}
94Requires: ghc-base-prof >= 4.3
2e4469e6 95Requires: ghc-bytestring-prof
5c44ed1b 96Requires: ghc-directory-prof
2e4469e6
JR
97Requires: ghc-exceptions-prof
98Requires: ghc-filepath-prof
99Requires: ghc-mono-traversable-prof >= 1.0.7
5c44ed1b 100Requires: ghc-mtl-prof
2e4469e6
JR
101Requires: ghc-primitive-prof
102Requires: ghc-resourcet-prof >= 1.2
103Requires: ghc-text-prof
104Requires: ghc-transformers-prof >= 0.4
105Requires: ghc-unix-prof
106Requires: ghc-unliftio-core-prof
107Requires: ghc-vector-prof
5c44ed1b
JB
108
109%description prof
110Profiling %{pkgname} library for GHC. Should be installed when
111GHC's profiling subsystem is needed.
112
113%description prof -l pl.UTF-8
114Biblioteka profilująca %{pkgname} dla GHC. Powinna być zainstalowana
115kiedy potrzebujemy systemu profilującego z GHC.
116
117%package doc
118Summary: HTML documentation for ghc %{pkgname} package
119Summary(pl.UTF-8): Dokumentacja w formacie HTML dla pakietu ghc %{pkgname}
120Group: Documentation
121
122%description doc
123HTML documentation for ghc %{pkgname} package.
124
125%description doc -l pl.UTF-8
126Dokumentacja w formacie HTML dla pakietu ghc %{pkgname}.
127
128%prep
129%setup -q -n %{pkgname}-%{version}
130
131%build
132runhaskell Setup.lhs configure -v2 \
133 %{?with_prof:--enable-library-profiling} \
134 --prefix=%{_prefix} \
135 --libdir=%{_libdir} \
136 --libexecdir=%{_libexecdir} \
137 --docdir=%{_docdir}/%{name}-%{version}
138
139runhaskell Setup.lhs build
140runhaskell Setup.lhs haddock --executables
141
142%install
143rm -rf $RPM_BUILD_ROOT
144install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
145
146runhaskell Setup.lhs copy --destdir=$RPM_BUILD_ROOT
147
148# work around automatic haddock docs installation
149%{__rm} -rf %{name}-%{version}-doc
150cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version} %{name}-%{version}-doc
151%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
152
153runhaskell Setup.lhs register \
154 --gen-pkg-config=$RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
155
156%clean
157rm -rf $RPM_BUILD_ROOT
158
159%post
160%ghc_pkg_recache
161
162%postun
163%ghc_pkg_recache
164
165%files
166%defattr(644,root,root,755)
167%doc LICENSE
168%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
169%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}
2e4469e6
JR
170%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSconduit-%{version}-*.so
171%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSconduit-%{version}-*.a
172%exclude %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSconduit-%{version}-*_p.a
173
174%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.hi
175%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.dyn_hi
5c44ed1b 176%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data
2e4469e6
JR
177%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/*.hi
178%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/*.dyn_hi
5c44ed1b
JB
179%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Conduit
180%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Conduit/*.hi
2e4469e6
JR
181%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Conduit/*.dyn_hi
182%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Conduit/Combinators
183%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Conduit/Combinators/*.hi
184%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Conduit/Combinators/*.dyn_hi
185%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Conduit/Internal
186%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Conduit/Internal/*.hi
187%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Conduit/Internal/*.dyn_hi
188%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Conduit/Internal/List
189%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Conduit/Internal/List/*.hi
190%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Conduit/Internal/List/*.dyn_hi
191%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Streaming
192%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Streaming/*.hi
193%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Streaming/*.dyn_hi
194
5c44ed1b
JB
195
196%if %{with prof}
197%files prof
198%defattr(644,root,root,755)
2e4469e6
JR
199%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSconduit-%{version}-*_p.a
200%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.p_hi
201%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/*.p_hi
5c44ed1b 202%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Conduit/*.p_hi
2e4469e6
JR
203%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Conduit/Combinators/*.p_hi
204%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Conduit/Internal/*.p_hi
205%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Conduit/Internal/List/*.p_hi
206%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Streaming/*.p_hi
5c44ed1b
JB
207%endif
208
209%files doc
210%defattr(644,root,root,755)
211%doc %{name}-%{version}-doc/*
This page took 0.085203 seconds and 4 git commands to generate.