]> git.pld-linux.org Git - packages/ghc-bytestring-mmap.git/blame - ghc-bytestring-mmap.spec
rebuild with ghc 8.10.7
[packages/ghc-bytestring-mmap.git] / ghc-bytestring-mmap.spec
CommitLineData
ea9436ba
JB
1#
2# Conditional build:
3%bcond_without prof # profiling library
4#
5%define pkgname bytestring-mmap
6Summary: mmap support for strict ByteStrings
7Summary(pl.UTF-8): Obsługa mmap dla ścisłych ByteStringów
8Name: ghc-%{pkgname}
9Version: 0.2.2
d5688b54 10Release: 3
ea9436ba
JB
11License: BSD
12Group: Development/Languages
13#Source0Download: http://hackage.haskell.org/package/bytestring-mmap
14Source0: http://hackage.haskell.org/package/%{pkgname}-%{version}/%{pkgname}-%{version}.tar.gz
15# Source0-md5: deabf8e1b20aed80b03e8b4dc44182ac
16URL: http://hackage.haskell.org/package/bytestring-mmap
17BuildRequires: ghc >= 6.12.3
18BuildRequires: ghc-base >= 3
19BuildRequires: ghc-base < 6
20BuildRequires: ghc-bytestring >= 0.9
21BuildRequires: ghc-unix
22%if %{with prof}
23BuildRequires: ghc-prof >= 6.12.3
24BuildRequires: ghc-base-prof >= 3
25BuildRequires: ghc-base-prof < 6
26BuildRequires: ghc-bytestring-prof >= 0.9
27BuildRequires: ghc-unix-prof
28%endif
29BuildRequires: rpmbuild(macros) >= 1.608
30Requires(post,postun): /usr/bin/ghc-pkg
31%requires_eq ghc
32Requires: ghc-base >= 3
33Requires: ghc-base < 6
34Requires: ghc-bytestring >= 0.9
35Requires: ghc-unix
36BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38# debuginfo is not useful for ghc
39%define _enable_debug_packages 0
40
41# don't compress haddock files
42%define _noautocompressdoc *.haddock
43
44%description
45This library provides a wrapper to mmap(2), allowing files or devices
46to be lazily loaded into memory as strict or lazy ByteStrings, using
47the virtual memory subsystem to do on-demand loading.
48
49%description -l pl.UTF-8
50Ta biblioteka dostarcza obudowanie mmap(2), pozwalające na leniwe
51wczytywanie plików lub urządzeń do pamięci jako ścisłe lub leniwe
52łańcuchy bajtów (typ ByteString), przy użyciu podsystemu pamięci
53wirtualnej w celu wczytywania na żądanie.
54
55%package prof
56Summary: Profiling %{pkgname} library for GHC
57Summary(pl.UTF-8): Biblioteka profilująca %{pkgname} dla GHC
58Group: Development/Libraries
59Requires: %{name} = %{version}-%{release}
60Requires: ghc-base-prof >= 3
61Requires: ghc-base-prof < 6
62Requires: ghc-bytestring-prof >= 0.9
63Requires: ghc-unix-prof
64
65%description prof
66Profiling %{pkgname} library for GHC. Should be installed when
67GHC's profiling subsystem is needed.
68
69%description prof -l pl.UTF-8
70Biblioteka profilująca %{pkgname} dla GHC. Powinna być zainstalowana
71kiedy potrzebujemy systemu profilującego z GHC.
72
73%package doc
74Summary: HTML documentation for ghc %{pkgname} package
75Summary(pl.UTF-8): Dokumentacja w formacie HTML dla pakietu ghc %{pkgname}
76Group: Documentation
77
78%description doc
79HTML documentation for ghc %{pkgname} package.
80
81%description doc -l pl.UTF-8
82Dokumentacja w formacie HTML dla pakietu ghc %{pkgname}.
83
84%prep
85%setup -q -n %{pkgname}-%{version}
86
87%build
88runhaskell Setup.lhs configure -v2 \
89 %{?with_prof:--enable-library-profiling} \
90 --prefix=%{_prefix} \
91 --libdir=%{_libdir} \
92 --libexecdir=%{_libexecdir} \
93 --docdir=%{_docdir}/%{name}-%{version}
94
95runhaskell Setup.lhs build
96runhaskell Setup.lhs haddock --executables
97
98%install
99rm -rf $RPM_BUILD_ROOT
100install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
101
102runhaskell Setup.lhs copy --destdir=$RPM_BUILD_ROOT
103
104# work around automatic haddock docs installation
105%{__rm} -rf %{name}-%{version}-doc
106cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version} %{name}-%{version}-doc
107%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
108
109runhaskell Setup.lhs register \
110 --gen-pkg-config=$RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
111
112%clean
113rm -rf $RPM_BUILD_ROOT
114
115%post
116%ghc_pkg_recache
117
118%postun
119%ghc_pkg_recache
120
121%files
122%defattr(644,root,root,755)
123%doc LICENSE
124%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
125%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}
dbe36b3a
JR
126%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSbytestring-mmap-%{version}-*.so
127%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSbytestring-mmap-%{version}-*.a
128%exclude %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSbytestring-mmap-%{version}-*_p.a
ea9436ba
JB
129%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/include
130%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/System
131%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/System/IO
132%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/System/IO/Posix
133%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/System/IO/Posix/MMap.hi
dbe36b3a 134%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/System/IO/Posix/MMap.dyn_hi
ea9436ba
JB
135%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/System/IO/Posix/MMap
136%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/System/IO/Posix/MMap/*.hi
dbe36b3a 137%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/System/IO/Posix/MMap/*.dyn_hi
ea9436ba
JB
138
139%if %{with prof}
140%files prof
141%defattr(644,root,root,755)
dbe36b3a 142%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSbytestring-mmap-%{version}-*_p.a
ea9436ba
JB
143%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/System/IO/Posix/MMap.p_hi
144%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/System/IO/Posix/MMap/*.p_hi
145%endif
146
147%files doc
148%defattr(644,root,root,755)
149%doc %{name}-%{version}-doc/*
This page took 0.079587 seconds and 4 git commands to generate.