]> git.pld-linux.org Git - packages/ghc-blaze-markup.git/blame - ghc-blaze-markup.spec
- release 2 (by relup.sh)
[packages/ghc-blaze-markup.git] / ghc-blaze-markup.spec
CommitLineData
5707391e
JB
1#
2# Conditional build:
3%bcond_without prof # profiling library
4#
5%define pkgname blaze-markup
6Summary: A blazingly fast markup combinator library for Haskell
7Summary(pl.UTF-8): Biblioteka olśniewająco szybkiego kombinatora dodającego znaczniki
8Name: ghc-%{pkgname}
8703019e 9Version: 0.8.2.5
3404cec9 10Release: 2
5707391e
JB
11License: BSD
12Group: Development/Languages
13#Source0Download: http://hackage.haskell.org/package/blaze-markup
14Source0: http://hackage.haskell.org/package/%{pkgname}-%{version}/%{pkgname}-%{version}.tar.gz
8703019e 15# Source0-md5: 75ad355f7d3c32881997b4164ac95e3b
5707391e
JB
16URL: http://hackage.haskell.org/package/blaze-markup
17BuildRequires: ghc >= 6.12.3
18BuildRequires: ghc-base >= 4
19BuildRequires: ghc-base < 5
8703019e
JR
20BuildRequires: ghc-blaze-builder >= 0.3
21BuildRequires: ghc-blaze-builder < 0.5
5707391e
JB
22BuildRequires: ghc-bytestring >= 0.9
23BuildRequires: ghc-bytestring < 0.11
24BuildRequires: ghc-text >= 0.10
8703019e 25BuildRequires: ghc-text < 1.3
5707391e
JB
26%if %{with prof}
27BuildRequires: ghc-prof
28BuildRequires: ghc-base-prof >= 4
29BuildRequires: ghc-base-prof < 5
8703019e
JR
30BuildRequires: ghc-blaze-builder-prof >= 0.3
31BuildRequires: ghc-blaze-builder-prof < 0.5
5707391e
JB
32BuildRequires: ghc-bytestring-prof >= 0.9
33BuildRequires: ghc-bytestring-prof < 0.11
34BuildRequires: ghc-text-prof >= 0.10
8703019e 35BuildRequires: ghc-text-prof < 1.3
5707391e
JB
36%endif
37BuildRequires: rpmbuild(macros) >= 1.608
38Requires(post,postun): /usr/bin/ghc-pkg
bda21b2f 39%requires_eq ghc
5707391e
JB
40Requires: ghc-base >= 4
41Requires: ghc-base < 5
8703019e
JR
42Requires: ghc-blaze-builder >= 0.3
43Requires: ghc-blaze-builder < 0.5
5707391e
JB
44Requires: ghc-bytestring >= 0.9
45Requires: ghc-bytestring < 0.11
46Requires: ghc-text >= 0.10
8703019e 47Requires: ghc-text < 1.3
5707391e
JB
48BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50# debuginfo is not useful for ghc
51%define _enable_debug_packages 0
52
53# don't compress haddock files
54%define _noautocompressdoc *.haddock
55
56%description
57Core modules of a blazingly fast markup combinator library for the
58Haskell programming language.
59
60%description -l pl.UTF-8
61Podstawowe moduły biblioteki olśniewająco szybkiego kombinatora
62dodającego znaczniki dla języka programowania Haskell.
63
64%package prof
65Summary: Profiling %{pkgname} library for GHC
66Summary(pl.UTF-8): Biblioteka profilująca %{pkgname} dla GHC
67Group: Development/Libraries
68Requires: %{name} = %{version}-%{release}
69Requires: ghc-base-prof >= 4
70Requires: ghc-base-prof < 5
8703019e
JR
71Requires: ghc-blaze-builder-prof >= 0.3
72Requires: ghc-blaze-builder-prof < 0.5
5707391e
JB
73Requires: ghc-bytestring-prof >= 0.9
74Requires: ghc-bytestring-prof < 0.11
75Requires: ghc-text-prof >= 0.10
8703019e 76Requires: ghc-text-prof < 1.3
5707391e
JB
77
78%description prof
79Profiling %{pkgname} library for GHC. Should be installed when
80GHC's profiling subsystem is needed.
81
82%description prof -l pl.UTF-8
83Biblioteka profilująca %{pkgname} dla GHC. Powinna być zainstalowana
84kiedy potrzebujemy systemu profilującego z GHC.
85
86%package doc
87Summary: HTML documentation for %{pkgname} ghc package
88Summary(pl.UTF-8): Dokumentacja w formacie HTML dla pakietu ghc %{pkgname}
89Group: Documentation
90
91%description doc
92HTML documentation for %{pkgname} ghc package.
93
94%description doc -l pl.UTF-8
95Dokumentacja w formacie HTML dla pakietu ghc %{pkgname}.
96
97%prep
98%setup -q -n %{pkgname}-%{version}
99
100%build
101runhaskell Setup.hs configure -v2 \
102 %{?with_prof:--enable-library-profiling} \
103 --prefix=%{_prefix} \
104 --libdir=%{_libdir} \
105 --libexecdir=%{_libexecdir} \
106 --docdir=%{_docdir}/%{name}-%{version}
107
108runhaskell Setup.hs build
109runhaskell Setup.hs haddock --executables
110
111%install
112rm -rf $RPM_BUILD_ROOT
113install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
114
115runhaskell Setup.hs copy --destdir=$RPM_BUILD_ROOT
116
117# work around automatic haddock docs installation
118%{__rm} -rf %{name}-%{version}-doc
119cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version} %{name}-%{version}-doc
120%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
121
122runhaskell Setup.hs register \
123 --gen-pkg-config=$RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
124
125%clean
126rm -rf $RPM_BUILD_ROOT
127
128%post
129%ghc_pkg_recache
130
131%postun
132%ghc_pkg_recache
133
134%files
135%defattr(644,root,root,755)
136%doc LICENSE
137%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
138%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}
8703019e
JR
139%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSblaze-markup-%{version}-*.so
140%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSblaze-markup-%{version}-*.a
141%exclude %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSblaze-markup-%{version}-*_p.a
5707391e
JB
142%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text
143%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Blaze.hi
8703019e 144%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Blaze.dyn_hi
5707391e
JB
145%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Blaze
146%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Blaze/*.hi
8703019e 147%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Blaze/*.dyn_hi
5707391e
JB
148%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Blaze/Renderer
149%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Blaze/Renderer/*.hi
8703019e 150%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Blaze/Renderer/*.dyn_hi
5707391e
JB
151
152%if %{with prof}
153%files prof
154%defattr(644,root,root,755)
8703019e 155%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSblaze-markup-%{version}-*_p.a
5707391e
JB
156%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Blaze.p_hi
157%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Blaze/*.p_hi
158%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Blaze/Renderer/*.p_hi
159%endif
160
161%files doc
162%defattr(644,root,root,755)
163%doc %{name}-%{version}-doc/*
This page took 0.081663 seconds and 4 git commands to generate.