]> git.pld-linux.org Git - packages/ghc-blaze-builder-enumerator.git/blame - ghc-blaze-builder-enumerator.spec
- pl, unified, added prof bcond, release 2
[packages/ghc-blaze-builder-enumerator.git] / ghc-blaze-builder-enumerator.spec
CommitLineData
3d9f2152
JB
1#
2# Conditional build:
3%bcond_without prof # profiling library
4#
3ea44407
JR
5%define pkgname blaze-builder-enumerator
6Summary: Enumeratees for the incremental conversion of builders to bytestrings
3d9f2152 7Summary(pl.UTF-8): Funkcje enumeratee do przyrostowej konwersji builderów do łańcuchów bajtów
3ea44407
JR
8Name: ghc-%{pkgname}
9Version: 0.2.0.5
3d9f2152 10Release: 2
3ea44407
JR
11License: BSD
12Group: Development/Languages
3d9f2152
JB
13#Source0Download: http://hackage.haskell.org/package/blaze-builder-enumerator
14Source0: http://hackage.haskell.org/package/%{pkgname}-%{version}/%{pkgname}-%{version}.tar.gz
3ea44407 15# Source0-md5: 735b6422d93043554db61297e047a5f5
3d9f2152 16URL: http://hackage.haskell.org/package/blaze-builder-enumerator
3ea44407 17BuildRequires: ghc >= 6.12.3
3d9f2152
JB
18BuildRequires: ghc-base >= 4
19BuildRequires: ghc-base < 5
20BuildRequires: ghc-blaze-builder >= 0.2.1.4
21BuildRequires: ghc-blaze-builder < 0.4
22BuildRequires: ghc-bytestring >= 0.9
23BuildRequires: ghc-bytestring < 0.11
24BuildRequires: ghc-enumerator >= 0.4.3.1
25BuildRequires: ghc-enumerator < 0.5
26BuildRequires: ghc-transformers >= 0.2
27BuildRequires: ghc-transformers < 0.4
28%if %{with prof}
29BuildRequires: ghc-prof >= 6.12.3
30BuildRequires: ghc-base-prof >= 4
31BuildRequires: ghc-base-prof < 5
32BuildRequires: ghc-blaze-builder-prof >= 0.2.1.4
33BuildRequires: ghc-blaze-builder-prof < 0.4
34BuildRequires: ghc-bytestring-prof >= 0.9
35BuildRequires: ghc-bytestring-prof < 0.11
36BuildRequires: ghc-enumerator-prof >= 0.4.3.1
37BuildRequires: ghc-enumerator-prof < 0.5
38BuildRequires: ghc-transformers-prof >= 0.2
39BuildRequires: ghc-transformers-prof < 0.4
40%endif
3ea44407 41BuildRequires: rpmbuild(macros) >= 1.608
3ea44407 42Requires(post,postun): /usr/bin/ghc-pkg
3d9f2152
JB
43%requires_releq ghc
44Requires: ghc-base >= 4
45Requires: ghc-base < 5
46Requires: ghc-blaze-builder >= 0.2.1.4
47Requires: ghc-blaze-builder < 0.4
48Requires: ghc-bytestring >= 0.9
49Requires: ghc-bytestring < 0.11
50Requires: ghc-enumerator >= 0.4.3.1
51Requires: ghc-enumerator < 0.5
52Requires: ghc-transformers >= 0.2
53Requires: ghc-transformers < 0.4
3ea44407
JR
54BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
55
56# debuginfo is not useful for ghc
57%define _enable_debug_packages 0
58
3d9f2152 59# don't compress haddock files
3ea44407
JR
60%define _noautocompressdoc *.haddock
61
62%description
3d9f2152
JB
63This package integrates the builders from the blaze-builder package
64with the enumerator package. It provides infrastructure and
65enumeratees for incrementally executing builders and pass the filled
66chunks to a bytestring iteratee.
67
68%description -l pl.UTF-8
69Ten pakiet integruje buildery z pakietu blaze-builder z pakietem
70enumerator. Dostarcza infrastrukturę i funkcje enumeratee do
71przyrostowego wywoływania builderów i przekazywania wypełnionych
72porcji do funkcji iteratee łańcucha bajtów.
3ea44407
JR
73
74%package prof
75Summary: Profiling %{pkgname} library for GHC
76Summary(pl.UTF-8): Biblioteka profilująca %{pkgname} dla GHC.
77Group: Development/Libraries
78Requires: %{name} = %{version}-%{release}
3d9f2152
JB
79Requires: ghc-base-prof >= 4
80Requires: ghc-base-prof < 5
81Requires: ghc-blaze-builder-prof >= 0.2.1.4
82Requires: ghc-blaze-builder-prof < 0.4
83Requires: ghc-bytestring-prof >= 0.9
84Requires: ghc-bytestring-prof < 0.11
85Requires: ghc-enumerator-prof >= 0.4.3.1
86Requires: ghc-enumerator-prof < 0.5
87Requires: ghc-transformers-prof >= 0.2
88Requires: ghc-transformers-prof < 0.4
3ea44407
JR
89
90%description prof
3d9f2152
JB
91Profiling %{pkgname} library for GHC. Should be installed when GHC's
92profiling subsystem is needed.
3ea44407
JR
93
94%description prof -l pl.UTF-8
95Biblioteka profilująca %{pkgname} dla GHC. Powinna być zainstalowana
96kiedy potrzebujemy systemu profilującego z GHC.
97
98%prep
99%setup -q -n %{pkgname}-%{version}
100
101%build
3d9f2152
JB
102runhaskell Setup.hs configure -v2 \
103 %{?with_prof:--enable-library-profiling} \
3ea44407
JR
104 --prefix=%{_prefix} \
105 --libdir=%{_libdir} \
106 --libexecdir=%{_libexecdir} \
107 --docdir=%{_docdir}/%{name}-%{version}
108
109runhaskell Setup.hs build
110runhaskell Setup.hs haddock --executables
111
112%install
113rm -rf $RPM_BUILD_ROOT
114install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
115
116runhaskell Setup.hs copy --destdir=$RPM_BUILD_ROOT
117
118# work around automatic haddock docs installation
119%{__rm} -rf %{name}-%{version}-doc
120cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version} %{name}-%{version}-doc
121%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
122
123runhaskell Setup.hs register \
3d9f2152 124 --gen-pkg-config=$RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
3ea44407
JR
125
126%clean
127rm -rf $RPM_BUILD_ROOT
128
129%post
130%ghc_pkg_recache
131
132%postun
133%ghc_pkg_recache
134
135%files
136%defattr(644,root,root,755)
3d9f2152 137%doc CHANGES %{name}-%{version}-doc/*
3ea44407
JR
138%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
139%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}
3d9f2152
JB
140%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/HSblaze-builder-enumerator-%{version}.o
141%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSblaze-builder-enumerator-%{version}.a
3ea44407
JR
142%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Blaze
143%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Blaze/ByteString
144%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Blaze/ByteString/Builder
145%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Blaze/ByteString/Builder/*.hi
146
147%files prof
148%defattr(644,root,root,755)
3d9f2152 149%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSblaze-builder-enumerator-%{version}_p.a
3ea44407 150%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Blaze/ByteString/Builder/*.p_hi
This page took 0.085154 seconds and 4 git commands to generate.