]> git.pld-linux.org Git - packages/ghc-base-unicode-symbols.git/blame - ghc-base-unicode-symbols.spec
rebuild with ghc 8.10.7
[packages/ghc-base-unicode-symbols.git] / ghc-base-unicode-symbols.spec
CommitLineData
6cfb0820
JB
1#
2# Conditional build:
3%bcond_without prof # profiling library
4#
d03809a2 5%define pkgname base-unicode-symbols
6cfb0820
JB
6Summary: New symbols for a number of functions, operators and types
7Summary(pl.UTF-8): Nowe symbole dla wielu funkcji, operatorów i typów
d03809a2 8Name: ghc-%{pkgname}
d56be603 9Version: 0.2.4.2
ca402798 10Release: 2
d03809a2
CM
11License: BSD
12Group: Development/Languages
6cfb0820
JB
13#Source0Download: http://hackage.haskell.org/package/base-unicode-symbols
14Source0: http://hackage.haskell.org/package/%{pkgname}-%{version}/%{pkgname}-%{version}.tar.gz
d56be603 15# Source0-md5: 8f6bf2b5f9dd94d3d8913e770c3989d3
6cfb0820 16URL: http://hackage.haskell.org/package/base-unicode-symbols
d03809a2 17BuildRequires: ghc >= 6.12.3
6cfb0820
JB
18BuildRequires: ghc-base >= 3.0
19BuildRequires: ghc-base < 5
20%if %{with prof}
21BuildRequires: ghc-prof >= 6.12.3
22BuildRequires: ghc-base-prof >= 3.0
23BuildRequires: ghc-base-prof < 5
24%endif
d03809a2 25BuildRequires: rpmbuild(macros) >= 1.608
6cfb0820 26Requires(post,postun): /usr/bin/ghc-pkg
d03809a2 27%requires_eq ghc
6cfb0820
JB
28Requires: ghc-base >= 3.0
29Requires: ghc-base < 5
d03809a2
CM
30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32# debuginfo is not useful for ghc
33%define _enable_debug_packages 0
34
6cfb0820
JB
35# don't compress haddock files
36%define _noautocompressdoc *.haddock
37
d03809a2
CM
38%description
39This package defines new symbols for a number of functions, operators
40and types in the base package.
41
42All symbols are documented with their actual definition and
43information regarding their Unicode code point. They should be
44completely interchangeable with their definitions.
45
46For further Unicode goodness you can enable the UnicodeSyntax language
6cfb0820
JB
47extension. This extension enables Unicode characters to be used to
48stand for certain ASCII character sequences, i.e. U+2192 instead of
49->, U+2200 instead of forall and many others.
50
51%description -l en.UTF-8
52This package defines new symbols for a number of functions, operators
53and types in the base package.
54
55All symbols are documented with their actual definition and
56information regarding their Unicode code point. They should be
57completely interchangeable with their definitions.
58
59For further Unicode goodness you can enable the UnicodeSyntax language
60extension. This extension enables Unicode characters to be used to
d03809a2
CM
61stand for certain ASCII character sequences, i.e. → instead of ->, ∀
62instead of forall and many others.
63
6cfb0820
JB
64%description -l pl.UTF-8
65Ten pakiet definiuje nowe symbole dla wielu funkcji, operatorów i
66typów z pakietu base.
67
68Wszystkie symbole są udokumentowane wraz z ich definicją i informacją
69o ich kodzie Unicode. Powinny być całkowicie wymienne z ich
70definicjami.
71
72W celu jeszcze większego wykorzystania zalet Unicode, można włączyć
73rozszerzenie języka UnicodeSyntax. Pozwala ono na używanie znaków
74Unicode dla różnych sekwencji znaków ASCII, np. → zamiast ->, ∀
75zamiast forall itd.
76
77%package prof
78Summary: Profiling %{pkgname} library for GHC
79Summary(pl.UTF-8): Biblioteka profilująca %{pkgname} dla GHC
80Group: Development/Libraries
81Requires: %{name} = %{version}-%{release}
82Requires: ghc-base-prof >= 3.0
83Requires: ghc-base-prof < 5
84
85%description prof
86Profiling %{pkgname} library for GHC. Should be installed when
87GHC's profiling subsystem is needed.
88
89%description prof -l pl.UTF-8
90Biblioteka profilująca %{pkgname} dla GHC. Powinna być zainstalowana
91kiedy potrzebujemy systemu profilującego z GHC.
92
d03809a2 93%package doc
6cfb0820
JB
94Summary: HTML documentation for ghc %{pkgname} package
95Summary(pl.UTF-8): Dokumentacja w formacie HTML dla pakietu ghc %{pkgname}
d03809a2
CM
96Group: Documentation
97
98%description doc
6cfb0820 99HTML documentation for ghc %{pkgname} package.
d03809a2
CM
100
101%description doc -l pl.UTF-8
6cfb0820 102Dokumentacja w formacie HTML dla pakietu ghc %{pkgname}.
d03809a2
CM
103
104%prep
105%setup -q -n %{pkgname}-%{version}
106
107%build
108runhaskell Setup.hs configure -v2 \
6cfb0820 109 %{?with_prof:--enable-library-profiling} \
d03809a2
CM
110 --prefix=%{_prefix} \
111 --libdir=%{_libdir} \
112 --libexecdir=%{_libexecdir} \
113 --docdir=%{_docdir}/%{name}-%{version}
114
115runhaskell Setup.hs build
116runhaskell Setup.hs haddock --executables
117
118%install
119rm -rf $RPM_BUILD_ROOT
120install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
121
122runhaskell Setup.hs copy --destdir=$RPM_BUILD_ROOT
123
124# work around automatic haddock docs installation
6cfb0820 125%{__rm} -rf %{name}-%{version}-doc
d03809a2 126cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/html %{name}-%{version}-doc
6cfb0820 127%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
d03809a2
CM
128
129runhaskell Setup.hs register \
6cfb0820 130 --gen-pkg-config=$RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
d03809a2
CM
131
132%clean
133rm -rf $RPM_BUILD_ROOT
134
135%post
136%ghc_pkg_recache
137
138%postun
139%ghc_pkg_recache
140
141%files
142%defattr(644,root,root,755)
143%doc LICENSE
144%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
6cfb0820 145%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}
d56be603
JR
146%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSbase-unicode-symbols-%{version}-*.so
147%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSbase-unicode-symbols-%{version}-*.a
148%exclude %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSbase-unicode-symbols-%{version}-*_p.a
6cfb0820
JB
149%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control
150%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control/Applicative
d56be603
JR
151%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control/Applicative/*.hi
152%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control/Applicative/*.dyn_hi
6cfb0820 153%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control/Arrow
d56be603
JR
154%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control/Arrow/*.hi
155%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control/Arrow/*.dyn_hi
6cfb0820 156%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control/Category
d56be603
JR
157%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control/Category/*.hi
158%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control/Category/*.dyn_hi
6cfb0820 159%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control/Monad
d56be603
JR
160%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control/Monad/*.hi
161%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control/Monad/*.dyn_hi
6cfb0820
JB
162%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data
163%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Bool
d56be603
JR
164%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Bool/*.hi
165%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Bool/*.dyn_hi
6cfb0820 166%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Eq
d56be603
JR
167%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Eq/*.hi
168%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Eq/*.dyn_hi
6cfb0820 169%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Foldable
d56be603
JR
170%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Foldable/*.hi
171%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Foldable/*.dyn_hi
6cfb0820 172%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Function
d56be603
JR
173%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Function/*.hi
174%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Function/*.dyn_hi
6cfb0820 175%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/List
d56be603
JR
176%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/List/*.hi
177%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/List/*.dyn_hi
6cfb0820 178%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Monoid
d56be603
JR
179%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Monoid/*.hi
180%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Monoid/*.dyn_hi
6cfb0820 181%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Ord
d56be603
JR
182%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Ord/*.hi
183%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Ord/*.dyn_hi
184%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/String
185%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/String/*.hi
186%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/String/*.dyn_hi
187%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Numeric
188%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Numeric/Natural
189%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Numeric/Natural/*.hi
190%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Numeric/Natural/*.dyn_hi
6cfb0820 191%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Prelude
d56be603
JR
192%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Prelude/*.hi
193%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Prelude/*.dyn_hi
6cfb0820
JB
194
195%if %{with prof}
196%files prof
197%defattr(644,root,root,755)
d56be603
JR
198%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSbase-unicode-symbols-%{version}-*_p.a
199%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control/Applicative/*.p_hi
200%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control/Arrow/*.p_hi
201%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control/Category/*.p_hi
202%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control/Monad/*.p_hi
203%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Bool/*.p_hi
204%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Eq/*.p_hi
205%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Foldable/*.p_hi
206%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Function/*.p_hi
207%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/List/*.p_hi
208%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Monoid/*.p_hi
209%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Ord/*.p_hi
210%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/String/*.p_hi
211%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Numeric/Natural/*.p_hi
212%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Prelude/*.p_hi
6cfb0820 213%endif
d03809a2
CM
214
215%files doc
216%defattr(644,root,root,755)
217%doc %{name}-%{version}-doc/*
This page took 0.09275 seconds and 4 git commands to generate.