]> git.pld-linux.org Git - packages/ghc-base-orphans.git/blame - ghc-base-orphans.spec
rebuild with ghc 8.10.7
[packages/ghc-base-orphans.git] / ghc-base-orphans.spec
CommitLineData
db27cf5d
JR
1#
2# Conditional build:
3%bcond_without prof # profiling library
4#
5%define pkgname base-orphans
6Summary: Backwards-compatible orphan instances for base
7Name: ghc-%{pkgname}
8Version: 0.8.2
27ccda6d 9Release: 2
db27cf5d
JR
10License: MIT
11Group: Development/Languages
12#Source0Download: http://hackage.haskell.org/package/base-orphans
13Source0: http://hackage.haskell.org/package/%{pkgname}-%{version}/%{pkgname}-%{version}.tar.gz
14# Source0-md5: 3de80a9b42b3b2662e8f1e08c861ddaa
15URL: http://hackage.haskell.org/package/base-orphans
16BuildRequires: ghc >= 6.12.3
17%if %{with prof}
18BuildRequires: ghc-prof
19%endif
20BuildRequires: rpmbuild(macros) >= 1.608
21%requires_eq ghc
22Requires(post,postun): /usr/bin/ghc-pkg
23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25# debuginfo is not useful for ghc
26%define _enable_debug_packages 0
27
28# don't compress haddock files
29%define _noautocompressdoc *.haddock
30
31%description
32base-orphans defines orphan instances that mimic instances available
33in later versions of base to a wider (older) range of compilers.
34base-orphans does not export anything except the orphan instances
35themselves and complements base-compat. See the README for what
36instances are covered:
37https://github.com/haskell-compat/base-orphans#readme.
38See also the what is not covered section.
39
40%package prof
41Summary: Profiling %{pkgname} library for GHC
42Summary(pl.UTF-8): Biblioteka profilująca %{pkgname} dla GHC
43Group: Development/Libraries
44Requires: %{name} = %{version}-%{release}
45
46%description prof
47Profiling %{pkgname} library for GHC. Should be installed when
48GHC's profiling subsystem is needed.
49
50%description prof -l pl.UTF-8
51Biblioteka profilująca %{pkgname} dla GHC. Powinna być zainstalowana
52kiedy potrzebujemy systemu profilującego z GHC.
53
54%prep
55%setup -q -n %{pkgname}-%{version}
56
57%build
58runhaskell Setup.hs configure -v2 \
59 %{?with_prof:--enable-library-profiling} \
60 --prefix=%{_prefix} \
61 --libdir=%{_libdir} \
62 --libexecdir=%{_libexecdir} \
63 --docdir=%{_docdir}/%{name}-%{version}
64
65runhaskell Setup.hs build
66runhaskell Setup.hs haddock --executables
67
68%install
69rm -rf $RPM_BUILD_ROOT
70install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
71
72runhaskell Setup.hs copy --destdir=$RPM_BUILD_ROOT
73
74# work around automatic haddock docs installation
75%{__rm} -rf %{name}-%{version}-doc
76cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version} %{name}-%{version}-doc
77%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
78
79runhaskell Setup.hs register \
80 --gen-pkg-config=$RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
81
82%clean
83rm -rf $RPM_BUILD_ROOT
84
85%post
86%ghc_pkg_recache
87
88%postun
89%ghc_pkg_recache
90
91%files
92%defattr(644,root,root,755)
93%doc CHANGES.markdown README.markdown %{name}-%{version}-doc/*
94%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
95%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}
96%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.so
97%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.a
98%exclude %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*_p.a
99
100%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data
101%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/*.hi
102%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/*.dyn_hi
103%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Orphans
104%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Orphans/*.hi
105%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Orphans/*.dyn_hi
106
107%if %{with prof}
108%files prof
109%defattr(644,root,root,755)
110%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*_p.a
111%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/*.p_hi
112%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Orphans/*.p_hi
113%endif
This page took 0.112867 seconds and 4 git commands to generate.