]> git.pld-linux.org Git - packages/ghc-alsa-core.git/blame - ghc-alsa-core.spec
rebuild with ghc 8.10.7
[packages/ghc-alsa-core.git] / ghc-alsa-core.spec
CommitLineData
63aa5307
JP
1%define pkgname alsa-core
2Summary: A Haskell binding to the alsa-core graphics library
3Name: ghc-%{pkgname}
4Version: 0.5.0.1
ecb869a6 5Release: 3
63aa5307
JP
6License: BSD
7Group: Development/Languages
8Source0: http://hackage.haskell.org/packages/archive/%{pkgname}/%{version}/%{pkgname}-%{version}.tar.gz
9# Source0-md5: 60af8328663a5d6ecaaf92dd32cf0710
10URL: http://hackage.haskell.org/package/alsa-core/
11BuildRequires: alsa-lib-devel >= 1.0.14
12BuildRequires: ghc >= 6.12.3
13BuildRequires: ghc-extensible-exceptions
14BuildRequires: rpmbuild(macros) >= 1.608
15%requires_eq ghc
16Requires: ghc-extensible-exceptions
17BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19# debuginfo is not useful for ghc
20%define _enable_debug_packages 0
21
22%description
23A Haskell binding to the alsa-core graphics library.
24
25%package doc
26Summary: HTML documentation for %{pkgname}
27Summary(pl.UTF-8): Dokumentacja w formacie HTML dla %{pkgname}
28Group: Documentation
29
30%description doc
31HTML documentation for %{pkgname}.
32
33%description doc -l pl.UTF-8
34Dokumentacja w formacie HTML dla %{pkgname}.
35
36%prep
37%setup -q -n %{pkgname}-%{version}
38
39%build
40runhaskell Setup.lhs configure -v2 \
41 --prefix=%{_prefix} \
42 --libdir=%{_libdir} \
43 --libexecdir=%{_libexecdir} \
44 --docdir=%{_docdir}/%{name}-%{version}
45
46runhaskell Setup.lhs build
47runhaskell Setup.lhs haddock --executables
48
49%install
50rm -rf $RPM_BUILD_ROOT
51install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
52
53runhaskell Setup.lhs copy --destdir=$RPM_BUILD_ROOT
54
55# work around automatic haddock docs installation
56rm -rf %{name}-%{version}-doc
57cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/html %{name}-%{version}-doc
58%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
59
60runhaskell Setup.lhs register \
61 --gen-pkg-config=$RPM_BUILD_ROOT/%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
62
63%clean
64rm -rf $RPM_BUILD_ROOT
65
66%post
67%ghc_pkg_recache
68
69%postun
70%ghc_pkg_recache
71
72%files
73%defattr(644,root,root,755)
74%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
75%{_libdir}/%{ghcdir}/%{pkgname}-%{version}
76
77%files doc
78%defattr(644,root,root,755)
79%doc %{name}-%{version}-doc/*
This page took 0.073404 seconds and 4 git commands to generate.