]> git.pld-linux.org Git - packages/ghc-aeson.git/blame - ghc-aeson.spec
rebuild with ghc 8.10.7
[packages/ghc-aeson.git] / ghc-aeson.spec
CommitLineData
90bb36d7
JB
1#
2# Conditional build:
3%bcond_without prof # profiling library
4#
5%define pkgname aeson
6Summary: Fast JSON parsing and encoding
7Summary(pl.UTF-8): Szybkie analizowanie i kodowanie JSON
8Name: ghc-%{pkgname}
b1df0668 9Version: 1.4.7.1
6e7018e2 10Release: 2
90bb36d7
JB
11License: BSD
12Group: Development/Languages
13#Source0Download: http://hackage.haskell.org/package/aeson
14Source0: http://hackage.haskell.org/package/%{pkgname}-%{version}/%{pkgname}-%{version}.tar.gz
b1df0668 15# Source0-md5: b83f55bb279c0659228931816c7a3af1
90bb36d7 16URL: http://hackage.haskell.org/package/aeson
7e533398
JP
17BuildRequires: ghc >= 8.6
18BuildRequires: ghc-attoparsec >= 0.13.2.2
19BuildRequires: ghc-base >= 4.7.0.0
b1df0668 20BuildRequires: ghc-base-compat-batteries >= 0.10.0
7e533398
JP
21BuildRequires: ghc-bytestring >= 0.10.4.0
22BuildRequires: ghc-containers >= 0.5.5.1
23BuildRequires: ghc-deepseq >= 1.3.0.0
24BuildRequires: ghc-dlist >= 0.8.0.4
25BuildRequires: ghc-ghc-prim >= 0.2
26BuildRequires: ghc-hashable >= 1.2.7.0
27BuildRequires: ghc-primitive >= 0.6.3.0
28BuildRequires: ghc-scientific >= 0.3.6.2
29BuildRequires: ghc-tagged >= 0.8.5
30BuildRequires: ghc-template-haskell >= 2.9.0.0
31BuildRequires: ghc-text >= 1.2.3.0
32BuildRequires: ghc-th-abstraction >= 0.2.8.0
33BuildRequires: ghc-time >= 1.4
b1df0668 34BuildRequires: ghc-time-compat >= 1.9.2.2
7e533398 35BuildRequires: ghc-unordered-containers >= 0.2.8.0
b1df0668 36BuildRequires: ghc-uuid-types >= 1.0.3
7e533398 37BuildRequires: ghc-vector >= 0.12.0.1
90bb36d7
JB
38%if %{with prof}
39BuildRequires: ghc-prof >= 6.12.3
7e533398
JP
40BuildRequires: ghc-attoparsec-prof >= 0.13.2.2
41BuildRequires: ghc-base-prof >= 4.7.0.0
b1df0668 42BuildRequires: ghc-base-compat-batteries-prof >= 0.10.0
7e533398
JP
43BuildRequires: ghc-bytestring-prof >= 0.10.4.0
44BuildRequires: ghc-containers-prof >= 0.5.5.1
45BuildRequires: ghc-deepseq-prof >= 1.3.0.0
46BuildRequires: ghc-dlist-prof >= 0.8.0.4
47BuildRequires: ghc-ghc-prim-prof >= 0.2
48BuildRequires: ghc-hashable-prof >= 1.2.7.0
49BuildRequires: ghc-primitive-prof >= 0.6.3.0
50BuildRequires: ghc-scientific-prof >= 0.3.6.2
51BuildRequires: ghc-tagged-prof >= 0.8.5
52BuildRequires: ghc-template-haskell-prof >= 2.9.0.0
53BuildRequires: ghc-text-prof >= 1.2.3.0
54BuildRequires: ghc-th-abstraction-prof >= 0.2.8.0
55BuildRequires: ghc-time-prof >= 1.4
b1df0668 56BuildRequires: ghc-time-compat-prof >= 1.9.2.2
7e533398 57BuildRequires: ghc-unordered-containers-prof >= 0.2.8.0
b1df0668 58BuildRequires: ghc-uuid-types-prof >= 1.0.3
7e533398 59BuildRequires: ghc-vector-prof >= 0.12.0.1
90bb36d7
JB
60%endif
61BuildRequires: rpmbuild(macros) >= 1.608
62Requires(post,postun): /usr/bin/ghc-pkg
63%requires_eq ghc
7e533398
JP
64Requires: ghc-attoparsec >= 0.13.2.2
65Requires: ghc-base >= 4.7.0.0
b1df0668 66Requires: ghc-base-compat-batteries >= 0.10.0
7e533398
JP
67Requires: ghc-bytestring >= 0.10.4.0
68Requires: ghc-containers >= 0.5.5.1
69Requires: ghc-deepseq >= 1.3.0.0
70Requires: ghc-dlist >= 0.8.0.4
71Requires: ghc-ghc-prim >= 0.2
72Requires: ghc-hashable >= 1.2.7.0
73Requires: ghc-primitive >= 0.6.3.0
74Requires: ghc-scientific >= 0.3.6.2
75Requires: ghc-tagged >= 0.8.5
76Requires: ghc-template-haskell >= 2.9.0.0
77Requires: ghc-text >= 1.2.3.0
78Requires: ghc-th-abstraction >= 0.2.8.0
79Requires: ghc-time >= 1.4
b1df0668 80Requires: ghc-time-compat >= 1.9.2.2
7e533398 81Requires: ghc-unordered-containers >= 0.2.8.0
b1df0668 82Requires: ghc-uuid-types >= 1.0.3
7e533398 83Requires: ghc-vector >= 0.12.0.1
90bb36d7
JB
84BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
85
86# debuginfo is not useful for ghc
87%define _enable_debug_packages 0
88
89# don't compress haddock files
90%define _noautocompressdoc *.haddock
91
92%description
93A JSON parsing and encoding library optimized for ease of use and high
94performance.
95
96%description -l pl.UTF-8
97Biblioteka do analizy i kodowania JSON zoptymalizowana pod kątem
98łatwości użycia i dużej wydajności.
99
100%package prof
101Summary: Profiling %{pkgname} library for GHC
102Summary(pl.UTF-8): Biblioteka profilująca %{pkgname} dla GHC
103Group: Development/Libraries
104Requires: %{name} = %{version}-%{release}
7e533398
JP
105Requires: ghc-attoparsec-prof >= 0.13.2.2
106Requires: ghc-base-prof >= 4.7.0.0
b1df0668 107Requires: ghc-base-compat-batteries-prof >= 0.10.0
7e533398
JP
108Requires: ghc-bytestring-prof >= 0.10.4.0
109Requires: ghc-containers-prof >= 0.5.5.1
110Requires: ghc-deepseq-prof >= 1.3.0.0
111Requires: ghc-dlist-prof >= 0.8.0.4
112Requires: ghc-ghc-prim-prof >= 0.2
113Requires: ghc-hashable-prof >= 1.2.7.0
114Requires: ghc-primitive-prof >= 0.6.3.0
115Requires: ghc-scientific-prof >= 0.3.6.2
116Requires: ghc-tagged-prof >= 0.8.5
117Requires: ghc-template-haskell-prof >= 2.9.0.0
118Requires: ghc-text-prof >= 1.2.3.0
119Requires: ghc-th-abstraction-prof >= 0.2.8.0
120Requires: ghc-time-prof >= 1.4
b1df0668 121Requires: ghc-time-compat-prof >= 1.9.2.2
7e533398 122Requires: ghc-unordered-containers-prof >= 0.2.8.0
b1df0668 123Requires: ghc-uuid-types-prof >= 1.0.3
7e533398 124Requires: ghc-vector-prof >= 0.12.0.1
90bb36d7
JB
125
126%description prof
127Profiling %{pkgname} library for GHC. Should be installed when
128GHC's profiling subsystem is needed.
129
130%description prof -l pl.UTF-8
131Biblioteka profilująca %{pkgname} dla GHC. Powinna być zainstalowana
132kiedy potrzebujemy systemu profilującego z GHC.
133
134%package doc
135Summary: HTML documentation for %{pkgname} ghc package
136Summary(pl.UTF-8): Dokumentacja w formacie HTML dla pakietu ghc %{pkgname}
137Group: Documentation
138
139%description doc
140HTML documentation for %{pkgname} ghc package.
141
142%description doc -l pl.UTF-8
143Dokumentacja w formacie HTML dla pakietu ghc %{pkgname}.
144
145%prep
146%setup -q -n %{pkgname}-%{version}
147
148%build
149runhaskell Setup.lhs configure -v2 \
150 %{?with_prof:--enable-library-profiling} \
151 --prefix=%{_prefix} \
152 --libdir=%{_libdir} \
153 --libexecdir=%{_libexecdir} \
154 --docdir=%{_docdir}/%{name}-%{version}
155
156runhaskell Setup.lhs build
157runhaskell Setup.lhs haddock --executables
158
159%install
160rm -rf $RPM_BUILD_ROOT
161install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
162
163runhaskell Setup.lhs copy --destdir=$RPM_BUILD_ROOT
164
165# work around automatic haddock docs installation
166%{__rm} -rf %{name}-%{version}-doc
167cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version} %{name}-%{version}-doc
168%{__rm} -rf $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
169
170runhaskell Setup.lhs register \
171 --gen-pkg-config=$RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
172
173%clean
174rm -rf $RPM_BUILD_ROOT
175
176%post
177%ghc_pkg_recache
178
179%postun
180%ghc_pkg_recache
181
182%files
183%defattr(644,root,root,755)
184%doc LICENSE README.markdown
185%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
186%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}
b1df0668
JR
187%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSaeson-%{version}-*.so
188%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSaeson-%{version}-*.a
189%exclude %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSaeson-%{version}-*_p.a
90bb36d7 190%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data
b1df0668
JR
191%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/*.hi
192%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/*.dyn_hi
90bb36d7
JB
193%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Aeson
194%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Aeson/*.hi
b1df0668
JR
195%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Aeson/*.dyn_hi
196%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Aeson/Encoding
197%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Aeson/Encoding/*.hi
198%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Aeson/Encoding/*.dyn_hi
199%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Aeson/Internal
200%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Aeson/Internal/*.hi
201%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Aeson/Internal/*.dyn_hi
90bb36d7
JB
202%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Aeson/Parser
203%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Aeson/Parser/*.hi
b1df0668
JR
204%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Aeson/Parser/*.dyn_hi
205%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Aeson/QQ
206%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Aeson/QQ/*.hi
207%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Aeson/QQ/*.dyn_hi
90bb36d7
JB
208%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Aeson/Types
209%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Aeson/Types/*.hi
b1df0668
JR
210%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Aeson/Types/*.dyn_hi
211%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Attoparsec
212%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Attoparsec/*.hi
213%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Attoparsec/*.dyn_hi
214%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Attoparsec/Time
215%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Attoparsec/Time/*.hi
216%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Attoparsec/Time/*.dyn_hi
90bb36d7
JB
217
218%if %{with prof}
219%files prof
220%defattr(644,root,root,755)
b1df0668
JR
221%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSaeson-%{version}-*_p.a
222%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/*.p_hi
90bb36d7 223%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Aeson/*.p_hi
b1df0668
JR
224%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Aeson/Encoding/*.p_hi
225%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Aeson/Internal/*.p_hi
90bb36d7 226%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Aeson/Parser/*.p_hi
b1df0668 227%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Aeson/QQ/*.p_hi
90bb36d7 228%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Aeson/Types/*.p_hi
b1df0668
JR
229%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Attoparsec/*.p_hi
230%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Attoparsec/Time/*.p_hi
90bb36d7
JB
231%endif
232
233%files doc
234%defattr(644,root,root,755)
235%doc %{name}-%{version}-doc/*
This page took 0.092251 seconds and 4 git commands to generate.