]> git.pld-linux.org Git - packages/ghc-X11.git/blame - ghc-X11.spec
rebuild with ghc 8.10.7
[packages/ghc-X11.git] / ghc-X11.spec
CommitLineData
ed1824f2
JP
1%define pkgname X11
2Summary: A Haskell binding to the X11 graphics library
3Name: ghc-%{pkgname}
0ac0e52e 4Version: 1.9.1
466f7975 5Release: 2
ed1824f2
JP
6License: BSD
7Group: Development/Languages
8Source0: http://hackage.haskell.org/packages/archive/%{pkgname}/%{version}/%{pkgname}-%{version}.tar.gz
0ac0e52e 9# Source0-md5: 71af9399de42c9e41b52020499947833
ed1824f2 10URL: http://hackage.haskell.org/package/X11/
d2b99d65
JP
11BuildRequires: autoconf
12BuildRequires: automake
ed1824f2
JP
13BuildRequires: ghc >= 6.12.3
14BuildRequires: ghc-data-default
15BuildRequires: rpmbuild(macros) >= 1.608
d2b99d65
JP
16BuildRequires: xorg-lib-libX11-devel
17BuildRequires: xorg-lib-libXext-devel
18BuildRequires: xorg-lib-libXinerama-devel
19BuildRequires: xorg-lib-libXrandr-devel
20BuildRequires: xorg-lib-libXScrnSaver-devel
21BuildRequires: xorg-proto-xproto-devel
ed1824f2
JP
22%requires_eq ghc
23Requires: ghc-data-default
24BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26# debuginfo is not useful for ghc
27%define _enable_debug_packages 0
28
29%description
30A Haskell binding to the X11 graphics library.
31
32%package doc
33Summary: HTML documentation for %{pkgname}
34Summary(pl.UTF-8): Dokumentacja w formacie HTML dla %{pkgname}
35Group: Documentation
36
37%description doc
38HTML documentation for %{pkgname}.
39
40%description doc -l pl.UTF-8
41Dokumentacja w formacie HTML dla %{pkgname}.
42
43%prep
44%setup -q -n %{pkgname}-%{version}
45
46%build
d2b99d65
JP
47%{__aclocal}
48%{__autoconf}
49%{__autoheader}
ed1824f2
JP
50runhaskell Setup.hs configure -v2 \
51 --prefix=%{_prefix} \
52 --libdir=%{_libdir} \
53 --libexecdir=%{_libexecdir} \
54 --docdir=%{_docdir}/%{name}-%{version}
55
56runhaskell Setup.hs build
57runhaskell Setup.hs haddock --executables
58
59%install
60rm -rf $RPM_BUILD_ROOT
61install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
62
63runhaskell Setup.hs copy --destdir=$RPM_BUILD_ROOT
64
65# work around automatic haddock docs installation
66rm -rf %{name}-%{version}-doc
67cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/html %{name}-%{version}-doc
68%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
69
70runhaskell Setup.hs register \
71 --gen-pkg-config=$RPM_BUILD_ROOT/%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
72
73%clean
74rm -rf $RPM_BUILD_ROOT
75
76%post
77%ghc_pkg_recache
78
79%postun
80%ghc_pkg_recache
81
82%files
83%defattr(644,root,root,755)
84%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
85%{_libdir}/%{ghcdir}/%{pkgname}-%{version}
86
87%files doc
88%defattr(644,root,root,755)
89%doc %{name}-%{version}-doc/*
This page took 0.090034 seconds and 4 git commands to generate.