]> git.pld-linux.org Git - packages/ghc-MonadCatchIO-transformers.git/blame - ghc-MonadCatchIO-transformers.spec
- updated to 0.3.1.0, pl, unified
[packages/ghc-MonadCatchIO-transformers.git] / ghc-MonadCatchIO-transformers.spec
CommitLineData
19029398
JB
1#
2# Conditional build:
3%bcond_without prof # profiling library
4#
ef63cb44
JR
5%define pkgname MonadCatchIO-transformers
6Summary: Monad-transformer compatible version of the Control.Exception module
19029398 7Summary(pl.UTF-8): Wersja modułu Control.Exception zgodna z transformatorami monad
ef63cb44 8Name: ghc-%{pkgname}
19029398 9Version: 0.3.1.0
ef63cb44
JR
10Release: 1
11License: BSD
12Group: Development/Languages
19029398
JB
13#Source0Download: http://hackage.haskell.org/package/MonadCatchIO-transformers
14Source0: http://hackage.haskell.org/package/%{pkgname}-%{version}/%{pkgname}-%{version}.tar.gz
15# Source0-md5: 3b54254de4a192fdbdea06d2950cac8d
16URL: http://hackage.haskell.org/package/MonadCatchIO-transformers
ef63cb44 17BuildRequires: ghc >= 6.12.3
19029398
JB
18BuildRequires: ghc-base < 4.8
19BuildRequires: ghc-extensible-exceptions >= 0.1
20BuildRequires: ghc-extensible-exceptions < 0.2
21BuildRequires: ghc-monads-tf >= 0.1
22BuildRequires: ghc-monads-tf < 0.2
23BuildRequires: ghc-transformers >= 0.2
24BuildRequires: ghc-transformers < 0.4
25%if %{with prof}
26BuildRequires: ghc-prof >= 6.12.3
27BuildRequires: ghc-base-prof < 4.8
28BuildRequires: ghc-extensible-exceptions-prof >= 0.1
29BuildRequires: ghc-extensible-exceptions-prof < 0.2
30BuildRequires: ghc-monads-tf-prof >= 0.1
31BuildRequires: ghc-monads-tf-prof < 0.2
32BuildRequires: ghc-transformers-prof >= 0.2
33BuildRequires: ghc-transformers-prof < 0.4
34%endif
ef63cb44
JR
35BuildRequires: rpmbuild(macros) >= 1.608
36%requires_releq ghc
37Requires(post,postun): /usr/bin/ghc-pkg
19029398
JB
38Requires: ghc-base < 4.8
39Requires: ghc-extensible-exceptions >= 0.1
40Requires: ghc-extensible-exceptions < 0.2
41Requires: ghc-monads-tf >= 0.1
42Requires: ghc-monads-tf < 0.2
43Requires: ghc-transformers >= 0.2
44Requires: ghc-transformers < 0.4
ef63cb44
JR
45BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47# debuginfo is not useful for ghc
48%define _enable_debug_packages 0
49
50# don't compress haddoc files
51%define _noautocompressdoc *.haddock
52
53%description
54Provides functions to throw and catch exceptions. Unlike the functions
55from Control.Exception, which work in IO, these work in any stack of
56monad transformers (from the transformers package) with IO as the base
57monad. You can extend this functionality to other monads, by creating
58an instance of the MonadCatchIO class.
59
19029398
JB
60%description -l pl.UTF-8
61Ten pakiet dostarcza funkcje do rzucania i przechwytywania wyjątków. W
62przeciwieństwie do funkcji z Control.Exceptions, działających w IO, te
63działają w dowolnym stosie transformatorów monad (z pakietu
64transformers) z IO jako podstawową monadą. Można rozszerzać tę
65funkcjonalność na inne monady poprzez tworzenie instancji klasy
66MonadCatchIO.
67
ef63cb44
JR
68%package prof
69Summary: Profiling %{pkgname} library for GHC
70Summary(pl.UTF-8): Biblioteka profilująca %{pkgname} dla GHC.
71Group: Development/Libraries
72Requires: %{name} = %{version}-%{release}
19029398
JB
73Requires: ghc-base-prof < 4.8
74Requires: ghc-extensible-exceptions-prof >= 0.1
75Requires: ghc-extensible-exceptions-prof < 0.2
76Requires: ghc-monads-tf-prof >= 0.1
77Requires: ghc-monads-tf-prof < 0.2
78Requires: ghc-transformers-prof >= 0.2
79Requires: ghc-transformers-prof < 0.4
ef63cb44
JR
80
81%description prof
82Profiling %{pkgname} library for GHC. Should be installed when
83GHC's profiling subsystem is needed.
84
85%description prof -l pl.UTF-8
86Biblioteka profilująca %{pkgname} dla GHC. Powinna być zainstalowana
87kiedy potrzebujemy systemu profilującego z GHC.
88
89%prep
90%setup -q -n %{pkgname}-%{version}
91
92%build
19029398
JB
93runhaskell Setup.hs configure -v2 \
94 %{?with_prof:--enable-library-profiling} \
ef63cb44
JR
95 --prefix=%{_prefix} \
96 --libdir=%{_libdir} \
97 --libexecdir=%{_libexecdir} \
98 --docdir=%{_docdir}/%{name}-%{version}
99
100runhaskell Setup.hs build
101runhaskell Setup.hs haddock --executables
102
103%install
104rm -rf $RPM_BUILD_ROOT
105install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
106
107runhaskell Setup.hs copy --destdir=$RPM_BUILD_ROOT
108
109# work around automatic haddock docs installation
110%{__rm} -rf %{name}-%{version}-doc
111cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version} %{name}-%{version}-doc
112%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
113
114runhaskell Setup.hs register \
19029398 115 --gen-pkg-config=$RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
ef63cb44
JR
116
117%clean
118rm -rf $RPM_BUILD_ROOT
119
120%post
121%ghc_pkg_recache
122
123%postun
124%ghc_pkg_recache
125
126%files
127%defattr(644,root,root,755)
128%doc %{name}-%{version}-doc/*
129%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
130%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}
19029398
JB
131%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/HSMonadCatchIO-transformers-%{version}.o
132%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSMonadCatchIO-transformers-%{version}.a
ef63cb44
JR
133%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control
134%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control/Monad
19029398
JB
135%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control/Monad/CatchIO.hi
136%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control/Monad/CatchIO
137%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control/Monad/CatchIO/*.hi
ef63cb44
JR
138
139%files prof
140%defattr(644,root,root,755)
19029398
JB
141%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSMonadCatchIO-transformers-%{version}_p.a
142%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control/Monad/CatchIO.p_hi
143%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Control/Monad/CatchIO/*.p_hi
This page took 0.09669 seconds and 4 git commands to generate.