]> git.pld-linux.org Git - packages/gdal.git/blame - gdal.spec
rebuild with perl 5.34.0
[packages/gdal.git] / gdal.spec
CommitLineData
954ec354 1# TODO:
8b360036 2# - be reasonable about devel dependencies - you do not need all of them to
cfcb08ee 3# use gdal (probably a gdal module or driver shall not imply devel
4# dependency)
c64d9529
JB
5# - MongoCXX (mongo/client/dbclient.h, -lmongoclient -lboost_system -lboost_thread -lboost_regex)
6# - rasterlite2
7# - sfcgal >= 1.2.2
d3d190a4 8# - libjpeg12 (needs patching to use system one, --with-jpeg12 is not sufficient as of 1.9.2)
9b4989ae 9# - libkml (1.3.0 needed, not released yet)
954ec354 10# - wait for newer pcidsk, switch to external again
d3d190a4 11# - csharp, java
9b4989ae
JB
12# - additional, proprietary(?) formats support:
13# - FMEObjects (http://www.safe.com/support/support-resources/fme-downloads/)
14# - ESRI FileGDBAPI (http://resources.arcgis.com/content/geodatabases/10.0/file-gdb-api)
15# - ECW (http://www.erdas.com/products/ecw/ERDASECWJPEG2000SDK/Details.aspx)
16# - Kakadu/JPEG2000 (http://www.kakadusoftware.com/)
17# - MrSID (http://www.lizardtech.com/developer/)
c64d9529 18# - LuraTech JP2Lura
9b4989ae 19# - MSG/EUMETSAT (http://www.eumetsat.int/Home/Main/DataAccess/SupportSoftwareTools/index.htm)
9b4989ae 20# - Ingres (--with-ingres=/path)
0316feee 21# - Informix DB (--with-idb)
9b4989ae
JB
22# - DWGdirect (members only? http://www.opendwg.org/)
23# - ESRI SDE (http://www.esri.com/software/arcgis/arcsde/index.html)
c64d9529 24# - Teigha DWG/DGN (https://www.opendesign.com/products/drawings?)
655672e5 25#
26# Conditional build:
d3d190a4 27%bcond_without armadillo # Armadillo support for faster TPS transform
779b0eec 28%bcond_without crnlib # DDS support via crunch/crnlib
4537079d 29%bcond_without epsilon # EPSILON wavelet compression support
779b0eec 30%bcond_without fyba # SOSI geodata support using FYBA
0a5f35eb 31%bcond_with grass # GRASS support (note: dependency loop; use gdal-grass.spec instead)
4537079d 32%bcond_without gta # GTA format support
77dfc6fa 33%bcond_without kea # KEA format support
d3d190a4 34%bcond_without mysql # MySQL DB support
0316feee 35%bcond_with oci # ORACLE OCI DB and Georaster support
d3d190a4
JB
36%bcond_without odbc # ODBC DB support
37%bcond_without opencl # OpenCL (GPU) support
c9c08280 38%bcond_without openjpeg # OpenJPEG 2 (JPEG2000) support
4537079d
JB
39%bcond_with podofo # PDF support via podofo instead of poppler
40%bcond_without poppler # PDF support via poppler
16d32926 41%bcond_with rasdaman # Rasdaman support
45593023 42%bcond_with spatialite # SpatiaLite support
d3d190a4
JB
43%bcond_without xerces # Xerces support
44%bcond_without java # Java and MDB support
315a1c4a 45
fac7da6f
JB
46%if %{with podofo}
47%undefine with_poppler
48%endif
faf5649c 49Summary: Geospatial Data Abstraction Library
a28c1bee 50Summary(pl.UTF-8): Biblioteka abstrakcji danych dotyczących powierzchni Ziemi
faf5649c 51Name: gdal
a7c55bf4 52Version: 3.0.4
892fc580 53Release: 13
faf5649c
JB
54License: BSD-like
55Group: Libraries
a707ba6a 56Source0: https://github.com/OSGeo/gdal/releases/download/v%{version}/%{name}-%{version}.tar.gz
a7c55bf4 57# Source0-md5: c6bbb5caca06e96bd97a32918e0aa9aa
f5a12c65 58Patch0: %{name}-perl.patch
957f985a
JR
59Patch1: %{name}-pc.patch
60Patch2: %{name}-dds.patch
61Patch3: %{name}-rasdaman.patch
62Patch4: %{name}-pluginsdir.patch
63Patch5: libx32.patch
99dd8e93 64Patch7: decl.patch
2fa5c055 65Patch8: %{name}_tirpcinc.patch
634a6a3d 66Patch9: jasper.patch
f61696cf 67Patch10: gcc11.patch
9b5c0fd4 68URL: http://www.gdal.org/
c64d9529
JB
69# 1.x or 2.x supported
70BuildRequires: CharLS-devel
d3d190a4
JB
71%{?with_opencl:BuildRequires: OpenCL-devel >= 1.0}
72%{?with_armadillo:BuildRequires: armadillo-devel}
69051332
JB
73BuildRequires: autoconf >= 2.52
74BuildRequires: automake
6b59fa88 75BuildRequires: cfitsio-devel
6a3158ac 76%{?with_crnlib:BuildRequires: crnlib-devel}
c64d9529 77BuildRequires: cryptopp-devel
9b4989ae 78BuildRequires: curl-devel
9d161bc4 79BuildRequires: doxygen >= 1.4.2
209aac6b 80%{?with_epsilon:BuildRequires: epsilon-compressor-devel}
69051332 81BuildRequires: expat-devel >= 1.95.0
779b0eec 82%{?with_fyba:BuildRequires: fyba-devel}
4537079d 83BuildRequires: freexl-devel >= 1.0
0316feee
JB
84BuildRequires: gcc >= 6:4.1
85BuildRequires: geos-devel >= 3.1.0
b459f4d7 86BuildRequires: giflib-devel >= 4.0
779b0eec 87%{?with_grass:BuildRequires: grass-devel >= 6.4}
c64d9529 88BuildRequires: hdf-devel >= 4.2.5
69051332 89BuildRequires: hdf5-devel
6b59fa88 90BuildRequires: jasper-devel
86101836 91%{?with_java:BuildRequires: jdk >= 11}
9b4989ae 92%{?with_java:BuildRequires: jpackage-utils}
0316feee 93BuildRequires: json-c-devel >= 0.11
77dfc6fa 94%{?with_kea:BuildRequires: kealib-devel}
8fd908ab 95BuildRequires: libcsf-devel >= 2.0-0.041111.6
4058fbc3 96BuildRequires: libdap-devel >= 3.10
b3cbf6a3 97BuildRequires: libgeotiff-devel >= 1.2.1
b88bb9ef 98%{?with_gta:BuildRequires: libgta-devel}
6b59fa88 99BuildRequires: libjpeg-devel >= 6b
9b4989ae 100#BuildRequires: libkml-devel >= 1.3.0
e354fe40 101BuildRequires: libpng-devel >= 2:1.2.8
4537079d 102%{?with_spatialite:BuildRequires: libspatialite-devel}
b3cbf6a3 103BuildRequires: libstdc++-devel
954ec354 104BuildRequires: libtiff-devel >= 4.0
957f985a 105BuildRequires: libtirpc-devel
69051332 106BuildRequires: libtool
e2b089e1 107BuildRequires: libuuid-devel
9b4989ae 108BuildRequires: libwebp-devel
0316feee 109BuildRequires: libxml2-devel >= 2
c64d9529 110#%{?with_mysql:BuildRequires: mysql-devel >= 4}
952dc496 111%{?with_mysql:BuildRequires: /usr/bin/mysql_config}
80114ba8 112BuildRequires: netcdf-devel >= 4.1
6b59fa88 113BuildRequires: ogdi-devel >= 3.1
c64d9529 114%{?with_openjpeg:BuildRequires: openjpeg2-devel >= 2.1.0}
0316feee
JB
115# 8.1.7 for DB support, 10.0.1 for georaster
116%{?with_oci:BuildRequires: oracle-instantclient-devel >= 10.0.1}
954ec354 117#BuildRequires: pcidsk-devel > 0.3
c64d9529 118BuildRequires: pcre-devel
a0ffd9c4 119BuildRequires: perl-devel
c64d9529 120BuildRequires: pkgconfig >= 1:0.21
fac7da6f 121%{?with_podofo:BuildRequires: podofo-devel}
0077f857 122%{?with_poppler:BuildRequires: poppler-devel >= 0.24}
9b4989ae
JB
123# ensure it's compiled with PQescapeStringConn support
124BuildRequires: postgresql-backend-devel >= 8.1.4
125BuildRequires: postgresql-devel >= 8.1.4
126BuildRequires: proj-devel >= 4
9a2dbbce 127BuildRequires: python-devel >= 1:2.5
017b03bb 128BuildRequires: python-numpy-devel >= 1:1.0.0
9b4989ae 129BuildRequires: python-setuptools
c64d9529 130BuildRequires: qhull-devel >= 2012
779b0eec 131%{?with_rasdaman:BuildRequires: rasdaman-devel}
479cb83c 132BuildRequires: rpm-pythonprov
9b4989ae 133BuildRequires: rpmbuild(macros) >= 1.344
b88bb9ef 134BuildRequires: sed >= 4.0
9b4989ae 135BuildRequires: sqlite3-devel >= 3.0.0
479cb83c 136BuildRequires: swig-perl
9a2dbbce 137BuildRequires: swig-python >= 1.3
479cb83c 138BuildRequires: texlive-dvips
139BuildRequires: texlive-latex
9831286f 140%{?with_odbc:BuildRequires: unixODBC-devel >= 2.2.15}
c64d9529 141%{?with_xerces:BuildRequires: xerces-c-devel >= 3.1.0}
9b4989ae 142BuildRequires: xz-devel
faf5649c 143BuildRequires: zlib-devel >= 1.1.4
c64d9529
JB
144# for ZSTD compression in TIFF
145BuildRequires: zstd-devel
4537079d 146Requires: freexl >= 1.0
0316feee 147Requires: geos >= 3.1.0
c64d9529 148Requires: hdf >= 4.2.5
b3cbf6a3 149Requires: libgeotiff >= 1.2.1
e354fe40 150Requires: libpng >= 2:1.2.8
954ec354 151Requires: libtiff >= 4.0
c64d9529
JB
152%{?with_openjpeg:Requires: openjpeg2 >= 2.1.0}
153Requires: qhull >= 2012
154%{?with_xerces:Requires: xerces-c >= 3.1.0}
faf5649c
JB
155BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
156
157%description
158GDAL is a translator library for raster geospatial data formats that
159is released under an Open Source license. As a library, it presents a
160single abstract data model to the calling application for all
161supported formats. The related OGR library (which lives within the
162GDAL source tree) provides a similar capability for simple features
163vector data.
f05c79e8 164
d34f2ec8
JR
165%description -l pl.UTF-8
166GDAL to biblioteka konwertująca między formatami rastrowych danych
167dotyczących powierzchni Ziemi, udostępniona na licencji Open Source.
168Jako biblioteka udostępnia aplikacjom jeden abstrakcyjny model danych
169do wszystkich obsługiwanych formatów. Powiązana z nią biblioteka OGR
170(której źródła są dołączone do drzewa źródeł GDAL) daje podobne
171możliwości dla danych wektorowych.
faf5649c 172
6b59fa88
JB
173%package devel
174Summary: GDAL library header files
a28c1bee 175Summary(pl.UTF-8): Pliki nagłówkowe biblioteki GDAL
6b59fa88 176Group: Development/Libraries
1673a634 177Requires: %{name} = %{version}-%{release}
c64d9529 178Requires: CharLS-devel
d3d190a4
JB
179%{?with_opencl:Requires: OpenCL-devel >= 1.0}
180%{?with_armadillo:Requires: armadillo-devel}
b3cbf6a3 181Requires: cfitsio-devel
6a3158ac 182%{?with_crnlib:Requires: crnlib-devel}
c64d9529 183Requires: cryptopp-devel
209aac6b
JB
184Requires: curl-devel
185%{?with_epsilon:Requires: epsilon-compressor-devel}
779b0eec 186%{?with_fyba:Requires: fyba-devel}
69051332 187Requires: expat-devel >= 1.95.0
4537079d 188Requires: freexl-devel >= 1.0
0316feee 189Requires: geos-devel >= 3.1.0
209aac6b 190Requires: giflib-devel >= 4.0
c64d9529 191Requires: hdf-devel >= 4.2.5
69051332 192Requires: hdf5-devel
b3cbf6a3 193Requires: jasper-devel
0316feee 194Requires: json-c-devel >= 0.11
77dfc6fa 195%{?with_kea:Requires: kealib-devel}
d4d7a2c6 196Requires: libcsf-devel
4058fbc3 197Requires: libdap-devel >= 3.10
b3cbf6a3 198Requires: libgeotiff-devel >= 1.2.1
209aac6b
JB
199%{?with_gta:Requires: libgta-devel}
200Requires: libjpeg-devel >= 6b
e354fe40 201Requires: libpng-devel >= 2:1.2.8
4537079d 202%{?with_spatialite:Requires: libspatialite-devel}
b3cbf6a3 203Requires: libstdc++-devel
954ec354 204Requires: libtiff-devel >= 4.0
209aac6b
JB
205Requires: libuuid-devel
206Requires: libwebp-devel
0316feee 207Requires: libxml2-devel >= 2
952dc496 208%{?with_mysql:Requires: /usr/bin/mysql_config}
9b4989ae 209Requires: netcdf-devel >= 4
b3cbf6a3 210Requires: ogdi-devel >= 3.1
c64d9529 211%{?with_openjpeg:Requires: openjpeg2-devel >= 2.1.0}
954ec354 212#Requires: pcidsk-devel > 0.3
c64d9529 213Requires: pcre-devel
209aac6b 214%{?with_podofo:Requires: podofo-devel}
0077f857 215%{?with_poppler:Requires: poppler-devel >= 0.24}
b3cbf6a3 216Requires: postgresql-devel
209aac6b 217Requires: proj-devel >= 4
c64d9529 218Requires: qhull-devel >= 2012
779b0eec 219%{?with_rasdaman:Requires: rasdaman-devel}
9b4989ae 220Requires: sqlite3-devel >= 3.0.0
655672e5 221%{?with_odbc:Requires: unixODBC-devel}
c64d9529 222%{?with_xerces:Requires: xerces-c-devel >= 3.1.0}
209aac6b
JB
223Requires: xz-devel
224Requires: zlib-devel >= 1.1.4
c64d9529 225Requires: zstd-devel
6b59fa88
JB
226
227%description devel
228GDAL library header files.
229
d34f2ec8
JR
230%description devel -l pl.UTF-8
231Pliki nagłówkowe biblioteki GDAL.
6b59fa88
JB
232
233%package static
234Summary: GDAL static libraries
a28c1bee 235Summary(pl.UTF-8): Statyczne biblioteki GDAL
6b59fa88 236Group: Development/Libraries
1673a634 237Requires: %{name}-devel = %{version}-%{release}
6b59fa88
JB
238
239%description static
240GDAL static libraries.
241
d34f2ec8 242%description static -l pl.UTF-8
6b59fa88
JB
243Statyczne biblioteki GDAL.
244
a0ffd9c4
JB
245%package -n perl-gdal
246Summary: Perl bindings for GDAL
247Summary(pl.UTF-8): Wiązania Perla do pakietu GDAL
248Group: Development/Languages/Perl
249Requires: %{name} = %{version}-%{release}
250
251%description -n perl-gdal
252Perl bindings for GDAL - Geo::GDAL, Geo::OGR and Geo::OSR modules.
253
254%description -n perl-gdal -l pl.UTF-8
017b03bb 255Wiązania Perla do pakietu GDAL - moduły Geo::GDAL, Geo::OGR, Geo::OSR.
a0ffd9c4 256
6b59fa88
JB
257%package -n python-gdal
258Summary: GDAL Python module
a28c1bee 259Summary(pl.UTF-8): Moduł Pythona GDAL
6b59fa88 260Group: Libraries/Python
1673a634 261Requires: %{name} = %{version}-%{release}
315a1c4a 262Requires: python-libs
6b59fa88
JB
263
264%description -n python-gdal
265GDAL Python module.
266
d34f2ec8
JR
267%description -n python-gdal -l pl.UTF-8
268Moduł Pythona GDAL.
6b59fa88 269
faf5649c
JB
270%prep
271%setup -q
272%patch0 -p1
957f985a 273%patch1 -p1
f1b5abea 274%patch2 -p1
957f985a
JR
275%patch3 -p1
276%patch4 -p1
277%patch5 -p1
99dd8e93 278%patch7 -p1
2fa5c055 279%patch8 -p1
634a6a3d 280%patch9 -p2
f61696cf 281%patch10 -p2
0316feee 282
c64d9529
JB
283# need to regenerate (old ones don't support perl 5.10)
284%{__rm} swig/perl/{gdal_wrap.cpp,gdalconst_wrap.c,ogr_wrap.cpp,osr_wrap.cpp}
315a1c4a 285
f4952e6f 286# our man path
be8ee7be 287sed -i -e 's#^mandir=.*##g' configure.ac
f4952e6f 288
4058fbc3 289%{__rm} -r man
4ed54fac 290
be8ee7be 291%{__sed} -i -e 's,DODS_INC="-I.*,DODS_INC="$(pkg-config --cflags libdap)",' configure.ac
b88bb9ef 292
7c13b21a
JR
293sed -E -i -e '1s,#!\s*/usr/bin/env\s+python2(\s|$),#!%{__python}\1,' \
294 -e '1s,#!\s*/usr/bin/env\s+python(\s|$),#!%{__python}\1,' \
295 -e '1s,#!\s*/usr/bin/python(\s|$),#!%{__python}\1,' \
296 swig/python/scripts/epsg_tr.py \
297 swig/python/scripts/esri2wkt.py \
298 swig/python/scripts/gcps2vec.py \
299 swig/python/scripts/gcps2wld.py \
300 swig/python/scripts/gdal2tiles.py \
301 swig/python/scripts/gdal2xyz.py \
302 swig/python/scripts/gdal_auth.py \
303 swig/python/scripts/gdal_calc.py \
304 swig/python/scripts/gdal_edit.py \
305 swig/python/scripts/gdal_fillnodata.py \
306 swig/python/scripts/gdal_merge.py \
307 swig/python/scripts/gdal_pansharpen.py \
308 swig/python/scripts/gdal_polygonize.py \
309 swig/python/scripts/gdal_proximity.py \
310 swig/python/scripts/gdal_retile.py \
311 swig/python/scripts/gdal_sieve.py \
312 swig/python/scripts/gdalchksum.py \
313 swig/python/scripts/gdalcompare.py \
314 swig/python/scripts/gdalident.py \
315 swig/python/scripts/gdalimport.py \
316 swig/python/scripts/gdalmove.py \
317 swig/python/scripts/mkgraticule.py \
318 swig/python/scripts/ogrmerge.py \
319 swig/python/scripts/pct2rgb.py \
320 swig/python/scripts/rgb2pct.py
321
faf5649c 322%build
e6a24827
JP
323cp -f /usr/share/gettext/config.rpath .
324
e6e33a1a
JR
325%ifarch %{x8664}
326jvm_arch=amd64
327%endif
328%ifarch %{ix86}
329jvm_arch=i386
330%endif
331%ifarch x32
332jvm_arch=x32
333%endif
334
69051332 335%{__libtoolize}
69051332 336%{__aclocal} -I m4
faf5649c 337%{__autoconf}
0a5f35eb 338%{__autoheader}
6b59fa88 339%configure \
e582c3b1 340 --includedir=%{_includedir}/gdal \
5014b82a 341 --datadir=%{_datadir}/gdal \
d4d7a2c6 342 --with-dods-root=/usr \
d3d190a4 343 %{?with_armadillo:--with-armadillo} \
6f52dc7d 344 %{?with_crnlib:--with-dds} \
209aac6b 345 %{?with_epsilon:--with-epsilon} \
0316feee 346 %{?with_grass:--with-grass} \
b88bb9ef 347 %{!?with_gta:--without-gta} \
69051332 348 --with-hide-internal-symbols \
9b4989ae
JB
349 %{?with_java:--with-java=%{java_home}} \
350 --with-liblzma \
77dfc6fa 351 %{!?with_kea:--without-kea} \
86101836 352 %{?with_java:--with-mdb --with-jvm-lib-add-rpath --with-jvm-lib=%{java_home}/lib/server} \
d3d190a4 353 %{?with_mysql:--with-mysql} \
0316feee 354 %{?with_oci:--with-oci --with-oci-include=/usr/include/oracle/client --with-oci-lib=%{_libdir}} \
d3d190a4 355 %{?with_opencl:--with-opencl} \
a0ffd9c4 356 --with-perl \
fac7da6f
JB
357 %{?with_podofo:--with-podofo} \
358 %{?with_poppler:--with-poppler} \
69051332 359 --with-python \
779b0eec 360 %{?with_rasdaman:--with-rasdaman=%{_libdir}/rasdaman} \
779b0eec 361 %{?with_fyba:--with-sosi} \
4537079d 362 %{?with_spatialite:--with-spatialite} \
69051332 363 --with-sqlite3 \
9b4989ae 364 --with-webp \
655672e5 365 %{?with_xerces:--with-xerces} \
c64d9529 366 --with-xerces-inc=/usr/include \
80faacbe 367 --with-xerces-lib="-lxerces-c" \
69051332 368 --without-libgrass
954ec354 369# --with-pcidsk=/usr (needs > 0.3)
779b0eec 370# csharp builds, but has no configure option nor install target
faf5649c 371
69051332 372# regenerate where needed
825dc3dc 373%{__make} -j1 -C swig/perl generate
69051332 374
45593023 375%{__make} \
779b0eec
JB
376 %{?with_grass:GRASS_INCLUDE="-I/usr/include/grass64"} \
377 %{?with_fyba:SOSI_INC="-I/usr/include/fyba"}
a0ffd9c4 378
825dc3dc 379%{__make} -j1 docs
3a591acf 380
f5a12c65
JK
381%{__make} -j1 man
382
faf5649c
JB
383%install
384rm -rf $RPM_BUILD_ROOT
faf5649c 385
825dc3dc 386%{__make} -j1 install install-man \
3a591acf
JB
387 DESTDIR=$RPM_BUILD_ROOT
388
c64d9529
JB
389# TODO: remove libgdal.la when gdal.pc gets maintained Requires.private/Libs.private list
390
388b39cb
ER
391rm -rf _html
392cp -a html _html
faf5649c 393
374370d5
JB
394%py_comp $RPM_BUILD_ROOT%{py_sitedir}
395%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
396%py_postclean
5014b82a 397
017b03bb
ER
398%{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
399%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/.packlist
400%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/Const/.packlist
401%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OGR/.packlist
402%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OSR/.packlist
403
faf5649c
JB
404%clean
405rm -rf $RPM_BUILD_ROOT
406
6b59fa88
JB
407%post -p /sbin/ldconfig
408%postun -p /sbin/ldconfig
409
faf5649c
JB
410%files
411%defattr(644,root,root,755)
c0a384ef 412%doc NEWS PROVENANCE.TXT
4058fbc3
JB
413%attr(755,root,root) %{_bindir}/epsg_tr.py
414%attr(755,root,root) %{_bindir}/esri2wkt.py
415%attr(755,root,root) %{_bindir}/gcps2vec.py
416%attr(755,root,root) %{_bindir}/gcps2wld.py
417%attr(755,root,root) %{_bindir}/gdal2tiles.py
418%attr(755,root,root) %{_bindir}/gdal2xyz.py
4058fbc3 419%attr(755,root,root) %{_bindir}/gdaladdo
6f52dc7d 420%attr(755,root,root) %{_bindir}/gdal_auth.py
4058fbc3 421%attr(755,root,root) %{_bindir}/gdalbuildvrt
6f52dc7d 422%attr(755,root,root) %{_bindir}/gdal_calc.py
4058fbc3 423%attr(755,root,root) %{_bindir}/gdalchksum.py
0316feee 424%attr(755,root,root) %{_bindir}/gdalcompare.py
6f52dc7d 425%attr(755,root,root) %{_bindir}/gdal_contour
4058fbc3 426%attr(755,root,root) %{_bindir}/gdaldem
6f52dc7d 427%attr(755,root,root) %{_bindir}/gdal_edit.py
4058fbc3 428%attr(755,root,root) %{_bindir}/gdalenhance
6f52dc7d
JR
429%attr(755,root,root) %{_bindir}/gdal_fillnodata.py
430%attr(755,root,root) %{_bindir}/gdal_grid
4058fbc3
JB
431%attr(755,root,root) %{_bindir}/gdalident.py
432%attr(755,root,root) %{_bindir}/gdalimport.py
433%attr(755,root,root) %{_bindir}/gdalinfo
954ec354 434%attr(755,root,root) %{_bindir}/gdallocationinfo
4058fbc3 435%attr(755,root,root) %{_bindir}/gdalmanage
6f52dc7d 436%attr(755,root,root) %{_bindir}/gdal_merge.py
f4952e6f 437%attr(755,root,root) %{_bindir}/gdalmove.py
6f52dc7d
JR
438%attr(755,root,root) %{_bindir}/gdal_pansharpen.py
439%attr(755,root,root) %{_bindir}/gdal_polygonize.py
440%attr(755,root,root) %{_bindir}/gdal_proximity.py
441%attr(755,root,root) %{_bindir}/gdal_rasterize
442%attr(755,root,root) %{_bindir}/gdal_retile.py
f4952e6f 443%attr(755,root,root) %{_bindir}/gdalserver
6f52dc7d 444%attr(755,root,root) %{_bindir}/gdal_sieve.py
9b4989ae 445%attr(755,root,root) %{_bindir}/gdalsrsinfo
4058fbc3
JB
446%attr(755,root,root) %{_bindir}/gdaltindex
447%attr(755,root,root) %{_bindir}/gdaltransform
6f52dc7d 448%attr(755,root,root) %{_bindir}/gdal_translate
4058fbc3 449%attr(755,root,root) %{_bindir}/gdalwarp
6f52dc7d
JR
450%attr(755,root,root) %{_bindir}/gnmanalyse
451%attr(755,root,root) %{_bindir}/gnmmanage
4058fbc3
JB
452%attr(755,root,root) %{_bindir}/mkgraticule.py
453%attr(755,root,root) %{_bindir}/nearblack
454%attr(755,root,root) %{_bindir}/ogr2ogr
455%attr(755,root,root) %{_bindir}/ogrinfo
0316feee 456%attr(755,root,root) %{_bindir}/ogrlineref
6f52dc7d 457%attr(755,root,root) %{_bindir}/ogrmerge.py
4058fbc3
JB
458%attr(755,root,root) %{_bindir}/ogrtindex
459%attr(755,root,root) %{_bindir}/pct2rgb.py
460%attr(755,root,root) %{_bindir}/rgb2pct.py
461%attr(755,root,root) %{_bindir}/testepsg
5014b82a 462%attr(755,root,root) %{_libdir}/libgdal.so.*.*.*
a707ba6a 463%attr(755,root,root) %ghost %{_libdir}/libgdal.so.26
0a5f35eb 464%dir %{_libdir}/gdalplugins
6b59fa88 465%{_datadir}/gdal
4058fbc3 466%{_mandir}/man1/gdal2tiles.1*
0316feee 467%{_mandir}/man1/gdal_calc.1*
4058fbc3 468%{_mandir}/man1/gdal_contour.1*
f4952e6f 469%{_mandir}/man1/gdal_edit.1*
4058fbc3
JB
470%{_mandir}/man1/gdal_fillnodata.1*
471%{_mandir}/man1/gdal_grid.1*
472%{_mandir}/man1/gdal_merge.1*
f4952e6f
AM
473%{_mandir}/man1/gdal_polygonize.1*
474%{_mandir}/man1/gdal_proximity.1*
4058fbc3
JB
475%{_mandir}/man1/gdal_rasterize.1*
476%{_mandir}/man1/gdal_retile.1*
477%{_mandir}/man1/gdal_sieve.1*
478%{_mandir}/man1/gdal_translate.1*
479%{_mandir}/man1/gdal_utilities.1*
480%{_mandir}/man1/gdaladdo.1*
481%{_mandir}/man1/gdalbuildvrt.1*
0316feee 482%{_mandir}/man1/gdalcompare.1*
4058fbc3
JB
483%{_mandir}/man1/gdaldem.1*
484%{_mandir}/man1/gdalinfo.1*
954ec354 485%{_mandir}/man1/gdallocationinfo.1*
f4952e6f
AM
486%{_mandir}/man1/gdalmanage.1*
487%{_mandir}/man1/gdalmove.1*
9b4989ae 488%{_mandir}/man1/gdalsrsinfo.1*
4058fbc3
JB
489%{_mandir}/man1/gdaltindex.1*
490%{_mandir}/man1/gdaltransform.1*
491%{_mandir}/man1/gdalwarp.1*
492%{_mandir}/man1/nearblack.1*
493%{_mandir}/man1/ogr2ogr.1*
494%{_mandir}/man1/ogr_utilities.1*
495%{_mandir}/man1/ogrinfo.1*
0316feee 496%{_mandir}/man1/ogrlineref.1*
4058fbc3
JB
497%{_mandir}/man1/ogrtindex.1*
498%{_mandir}/man1/pct2rgb.1*
499%{_mandir}/man1/rgb2pct.1*
6f52dc7d
JR
500%{_mandir}/man1/gdal_pansharpen.1*
501%{_mandir}/man1/gnm_utilities.1*
502%{_mandir}/man1/gnmanalyse.1*
503%{_mandir}/man1/gnmmanage.1*
504%{_mandir}/man1/ogrmerge.1*
6b59fa88
JB
505
506%files devel
507%defattr(644,root,root,755)
388b39cb 508%doc _html/*
5014b82a 509%attr(755,root,root) %{_bindir}/gdal-config
6b59fa88 510%attr(755,root,root) %{_libdir}/libgdal.so
5014b82a 511%{_libdir}/libgdal.la
0316feee 512%{_pkgconfigdir}/gdal.pc
e582c3b1 513%{_includedir}/gdal
5014b82a 514%{_mandir}/man1/gdal-config.1*
6b59fa88
JB
515
516%files static
517%defattr(644,root,root,755)
9b5c0fd4 518%{_libdir}/libgdal.a
6b59fa88 519
a0ffd9c4
JB
520%files -n perl-gdal
521%defattr(644,root,root,755)
522%dir %{perl_vendorarch}/Geo
523%{perl_vendorarch}/Geo/GDAL.pm
524%dir %{perl_vendorarch}/Geo/GDAL
525%{perl_vendorarch}/Geo/GDAL/Const.pm
526%{perl_vendorarch}/Geo/OGR.pm
527%{perl_vendorarch}/Geo/OSR.pm
528%dir %{perl_vendorarch}/auto/Geo
529%dir %{perl_vendorarch}/auto/Geo/GDAL
a0ffd9c4
JB
530%attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/GDAL.so
531%dir %{perl_vendorarch}/auto/Geo/GDAL/Const
a0ffd9c4 532%attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/Const/Const.so
6f52dc7d
JR
533%dir %{perl_vendorarch}/auto/Geo/GNM
534%attr(755,root,root) %{perl_vendorarch}/auto/Geo/GNM/GNM.so
a0ffd9c4 535%dir %{perl_vendorarch}/auto/Geo/OGR
a0ffd9c4
JB
536%attr(755,root,root) %{perl_vendorarch}/auto/Geo/OGR/OGR.so
537%dir %{perl_vendorarch}/auto/Geo/OSR
a0ffd9c4 538%attr(755,root,root) %{perl_vendorarch}/auto/Geo/OSR/OSR.so
38239d5e 539%{_mandir}/man3/Geo::GDAL.3pm*
6f52dc7d 540%{perl_vendorarch}/Geo/GNM.pm
a0ffd9c4 541
6b59fa88
JB
542%files -n python-gdal
543%defattr(644,root,root,755)
9a2dbbce
JB
544%{py_sitedir}/gdal.py[co]
545%{py_sitedir}/gdalconst.py[co]
546%{py_sitedir}/gdalnumeric.py[co]
9a2dbbce
JB
547%{py_sitedir}/ogr.py[co]
548%{py_sitedir}/osr.py[co]
69051332
JB
549%{py_sitedir}/GDAL-*.egg-info
550%dir %{py_sitedir}/osgeo
551%attr(755,root,root) %{py_sitedir}/osgeo/_gdal.so
552%attr(755,root,root) %{py_sitedir}/osgeo/_gdal_array.so
553%attr(755,root,root) %{py_sitedir}/osgeo/_gdalconst.so
6f52dc7d 554%attr(755,root,root) %{py_sitedir}/osgeo/_gnm.so
69051332
JB
555%attr(755,root,root) %{py_sitedir}/osgeo/_ogr.so
556%attr(755,root,root) %{py_sitedir}/osgeo/_osr.so
557%{py_sitedir}/osgeo/*.py[co]
This page took 0.204441 seconds and 4 git commands to generate.