]> git.pld-linux.org Git - packages/ffms2.git/blame - ffms2.spec
- updated to 2.23
[packages/ffms2.git] / ffms2.spec
CommitLineData
8d93948c
ER
1#
2# Conditional build:
3%bcond_without static_libs # don't build static libraries
ffd255af 4%bcond_without avresample # avresample support via libavresample
8d93948c 5
f99faf48
JB
6Summary: FFmpegSource - FFmpeg wrapper library
7Summary(pl.UTF-8): FFmpegSource - biblioteka obudowująca FFmpeg
8d93948c 8Name: ffms2
3373fec7
JB
9Version: 2.23
10Release: 1
f99faf48
JB
11License: MIT (ffmpegsource itself), GPL v3+ (forced by ffmpeg)
12Group: Libraries
3373fec7 13#Source0Download: https://github.com/FFMS/ffms2/releases
8d93948c 14Source0: https://github.com/FFMS/ffms2/archive/%{version}/%{name}-%{version}.tar.gz
3373fec7 15# Source0-md5: e7728ae581e278ade6bc9f204faaff9e
8d93948c 16URL: https://github.com/FFMS/ffms2
f99faf48 17BuildRequires: autoconf >= 2.58
ffd255af 18BuildRequires: automake >= 1:1.11
ce23f194 19# PKG_CHECK_MODULES(LIBAV, [libavformat >= 53.20.0 libavcodec >= 53.24.0 libswscale >= 0.7.0 libavutil >= 51.21.0 ])
7d6fea5e 20BuildRequires: ffmpeg-devel >= 0.9
3373fec7 21# libavresample >= 1.0.0 or libswresample >= 1.0.0
ffd255af 22%{?with_avresample:BuildRequires: ffmpeg-devel >= 1.1}
f99faf48
JB
23BuildRequires: libstdc++-devel
24BuildRequires: libtool >= 2:2.0
f99faf48 25BuildRequires: pkgconfig >= 1:0.22
f36cd6f2
JB
26BuildRequires: rpmbuild(macros) >= 1.566
27BuildRequires: sed >= 4.0
f99faf48 28BuildRequires: zlib-devel
8d93948c 29Obsoletes: ffmpegsource < 2.20
f99faf48
JB
30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32%description
33FFmpegSource (usually known as FFMS or FFMS2) is a cross-platform
34wrapper library around FFmpeg, plus some additional components to deal
35with file formats FFmpeg's libavformat has (or used to have) problems
36with. It gives you an easy, convenient way to say "open and decompress
37this media file for me, I don't care how you do it" and get frame- and
38sample-accurate access (usually), without having to bother with the
39sometimes less than straightforward and less than perfectly documented
40FFmpeg API.
41
42%description -l pl.UTF-8
43FFmpegSource (zwykle zwana FFMS lub FFMS2) to wieloplatformowa
44biblioteka obudowująca FFmpeg wraz z paroma dodatkowymi komponentami
45mającymi radzić sobie z formatami plików, z którymi libavformat z
46FFmpeg ma (lub miał) problemy. Umożliwia w łatwy sposób zażądanie
47"otwórz i zdekompresuj ten plik, nieważne jak" i uzyskanie dostępu
8d93948c
ER
48(zwykle) z dokładnością do ramek i próbek, bez potrzeby zajmowania się
49często złożonym, nie najlepiej udokumentowanym API FFmpeg.
f99faf48
JB
50
51%package devel
52Summary: Header files for FFmpegSource library
53Summary(pl.UTF-8): Pliki nagłówkowe biblioteki FFmpegSource
54Group: Development/Libraries
55Requires: %{name} = %{version}-%{release}
ffd255af
JB
56%if %{with avresample}
57Requires: ffmpeg-devel >= 1.1
58%else
7d6fea5e 59Requires: ffmpeg-devel >= 0.9
ffd255af 60%endif
f99faf48
JB
61Requires: libstdc++-devel
62Requires: zlib-devel
8d93948c
ER
63Provides: ffmpegsource-devel = %{version}-%{release}
64Obsoletes: ffmpegsource-devel < 2.20
f99faf48
JB
65
66%description devel
67Header files for FFmpegSource library.
68
69%description devel -l pl.UTF-8
70Pliki nagłówkowe biblioteki FFmpegSource.
71
72%package static
73Summary: Static FFmpegSource library
74Summary(pl.UTF-8): Statyczna biblioteka FFmpegSource
75Group: Development/Libraries
76Requires: %{name}-devel = %{version}-%{release}
8d93948c 77Obsoletes: ffmpegsource-static < 2.20
f99faf48
JB
78
79%description static
80Static FFmpegSource library.
81
82%description static -l pl.UTF-8
83Statyczna biblioteka FFmpegSource.
84
85%prep
8d93948c 86%setup -q
f99faf48
JB
87
88%build
3373fec7 89CXXFLAGS="%{rpmcxxflags} -Wall -Wextra"
f99faf48
JB
90%{__libtoolize}
91%{__aclocal} -I m4
92%{__autoconf}
93%{__autoheader}
94%{__automake}
95%configure \
ffd255af 96 --enable-avresample%{!?with_avresample:=no} \
8d93948c 97 --disable-silent-rules \
ffd255af
JB
98 --enable-shared \
99 %{__enable_disable static_libs static}
cf17c716 100
8d93948c 101%{__make}
f99faf48
JB
102
103%install
104rm -rf $RPM_BUILD_ROOT
3373fec7 105
f99faf48
JB
106%{__make} install \
107 DESTDIR=$RPM_BUILD_ROOT
108
3373fec7
JB
109# obsoleted by pkg-config
110%{__rm} $RPM_BUILD_ROOT%{_libdir}/libffms2.la
111
8d93948c
ER
112%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
113
f99faf48
JB
114%clean
115rm -rf $RPM_BUILD_ROOT
116
117%post -p /sbin/ldconfig
118%postun -p /sbin/ldconfig
119
120%files
121%defattr(644,root,root,755)
ffd255af 122%doc COPYING README.md
f99faf48
JB
123%attr(755,root,root) %{_bindir}/ffmsindex
124%attr(755,root,root) %{_libdir}/libffms2.so.*.*.*
3373fec7 125%attr(755,root,root) %ghost %{_libdir}/libffms2.so.4
f99faf48
JB
126
127%files devel
128%defattr(644,root,root,755)
3373fec7 129%doc doc/ffms2-*.md
f99faf48 130%attr(755,root,root) %{_libdir}/libffms2.so
f99faf48
JB
131%{_includedir}/ffms.h
132%{_includedir}/ffmscompat.h
133%{_pkgconfigdir}/ffms2.pc
134
8d93948c 135%if %{with static_libs}
f99faf48
JB
136%files static
137%defattr(644,root,root,755)
138%{_libdir}/libffms2.a
8d93948c 139%endif
This page took 0.070566 seconds and 4 git commands to generate.