]> git.pld-linux.org Git - packages/ettercap.git/blame - ettercap.spec
- new URLs, updated to 0.8.3
[packages/ettercap.git] / ettercap.spec
CommitLineData
3f3d70e0
AG
1#
2# Conditional build:
f8c47986
JB
3%bcond_without geoip # GeoIP support
4%bcond_without gtk # gtk-based frontend
5%bcond_with gtk2 # use GTK+ 2.x instead of 3.x
6%bcond_with lua # experimental Lua support
7a769489 7#
26f54874 8Summary: ettercap - a ncurses-based sniffer/interceptor utility
09b437f4
ER
9Summary(pl.UTF-8): ettercap - oparte o ncurses narzędzie do sniffowania/przechwytywania
10Summary(pt_BR.UTF-8): ettercap e um interceptador/sniffer paseado em ncurses
0e21442b 11Name: ettercap
f8c47986
JB
12Version: 0.8.3
13Release: 1
65c513b5 14Epoch: 1
f8c47986 15License: GPL v2+ with OpenSSL exception
0e21442b 16Group: Networking/Utilities
f8c47986
JB
17#Source0Download: https://github.com/Ettercap/ettercap/releases
18Source0: https://github.com/Ettercap/ettercap/releases/download/v%{version}/%{name}-%{version}.tar.gz
19# Source0-md5: 6b27d329a509e65fef9044c95a2dde35
20Patch0: %{name}-buildtype.patch
21Patch1: %{name}-gtk3.patch
22Patch2: %{name}-link.patch
23URL: https://www.ettercap-project.org/
24%{?with_geoip:BuildRequires: GeoIP-devel}
25BuildRequires: bison
26BuildRequires: cmake >= 2.8
27BuildRequires: curl-devel >= 7.26.0
28BuildRequires: flex
29%if %{with gtk}
30%{?with_gtk2:BuildRequires: gtk+2-devel >= 2:2.10}
31%{!?with_gtk2:BuildRequires: gtk+3-devel >= 3.12.0}
32%endif
33BuildRequires: libbsd-devel
34BuildRequires: libnet-devel >= 1:1.1.5
7a769489 35BuildRequires: libpcap-devel
f8c47986 36%{?with_lua:BuildRequires: luajit-devel >= 2.0.0}
9fb25dec
ER
37BuildRequires: ncurses-ext-devel
38BuildRequires: openssl-devel >= 0.9.7d
7a769489 39BuildRequires: pcre-devel
597fc980 40BuildRequires: pkgconfig
f8c47986
JB
41BuildRequires: zlib-devel
42Requires: curl-libs >= 7.26.0
43%if %{with gtk}
44%{?with_gtk2:Requires: gtk+2 >= 2:2.10}
45%{!?with_gtk2:Requires: gtk+3 >= 3.12.0}
46%endif
47Requires: libnet >= 1:1.1.5
2d753dd0 48BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
0e21442b 49
2183bd99
TP
50%define specflags -fomit-frame-pointer
51
0e21442b 52%description
36a3928d 53ettercap is a network sniffer/interceptor/logger for ethernet LANs
54(both switched or not). It supports active and passive dissection of
55many protocols (even ciphered ones, like SSH and HTTPS). Data
56injection in an established connection and filtering (substitute or
57drop a packet) on the fly is also possible, keeping the connection
26f54874 58synchronized. Many sniffing modes were implemented to give you a
36a3928d 59powerful and complete sniffing suite. Plugins are supported. It has
60the ability to check whether you are in a switched LAN or not, and to
61use OS fingerprints (active or passive) to let you know the geometry
26f54874
JB
62of the LAN. The passive scan of the LAN retrieves infos about: hosts
63in the lan, open ports, services version, type of the host (gateway,
36a3928d 64router or simple host) and extimated distance in hop.
0e21442b 65
aa81fd7c
JR
66%description -l pl.UTF-8
67ettercap jest wieloczynnościowym snifferem/przechwytywaczem/loggerem
68dla sieci LAN (opartych na switchach lub hubach). Obsługuje aktywną i
69pasywną analizę wielu protokołów (nawet szyfrowanych, jak SSH czy
70HTTPS). Możliwe jest także wstrzykiwanie lub filtrowanie danych
71(podmiana lub usunięcie pakietu) w locie, przy podtrzymaniu
72synchronizacji połączenia. Program ma zaimplementowane wiele trybów
73sniffowania, aby dać potężne i kompletne narzędzie. Obsługiwane są
74wtyczki. Program ma możliwość sprawdzania, czy pracuje w sieci ze
75switchami oraz używania odcisków systemów (aktywnego lub pasywnego) do
3f3d70e0 76poznania geometrii sieci. Pasywne skanowanie sieci uzyskuje informacje
aa81fd7c
JR
77o: hostach w sieci, otwartych portach, wersjach usług, rodzajach
78hostów (bramki, routery lub zwykłe komputery) oraz przybliżonych
79odległościach (w hopach).
d2dd519f 80
aa81fd7c
JR
81%description -l pt_BR.UTF-8
82ettercap é um sniffer/interceptor/logger de rede para redes locais
83(com uso de switches ou não). Suporta operações ativas e passivas de
84vários protocolos (mesmo os criptografados, como SSH e HTTPS). Também
85é possível injeção de dados em uma conexão estabelecida e filtragem
86(substituição ou descarte de um pacote) em tempo real mantendo a
87conexão sincronizada. Muitos modos de sniffing foram implementadas
88para proporcionar a você um completo conjunto de sniffing. Plugins são
89suportados. Tem a habilidade de verificar se você está em uma rede
90local com switches ou não. Utiliza fingerprints do Sistema Operacional
91(ativo ou passivo) para permitir que você conheça a geometria da rede
92local. A varredura passiva da rede local obtém informações sobre:
93hosts na rede local, portas abertas, versão de serviços, tipo de host
94(gateway, router ou um computador) e a distância estimada no hop.
36a3928d 95
0e21442b 96%prep
f8c47986
JB
97%setup -q
98%patch0 -p1
cfaadd6a 99%patch1 -p1
100%patch2 -p1
0e21442b
GS
101
102%build
f8c47986
JB
103install -d build
104cd build
105%cmake .. \
106 -DBUNDLED_LIBS=OFF \
107 %{!?with_geoip:-DENABLE_GEOIP=OFF} \
108 %{!?with_gtk:-DENABLE_GTK=OFF} \
109 -DENABLE_IPV6=ON
110 %{?with_lua:-DENABLE_LUA=ON} \
111 %{?with_gtk2:-DGTK_BUILD_TYPE=GTK2}
112
0e21442b 113%{__make}
0e21442b
GS
114
115%install
116rm -rf $RPM_BUILD_ROOT
0663f6ee 117
f8c47986 118%{__make} -C build install \
45d6bacc 119 DESTDIR=$RPM_BUILD_ROOT
0e21442b 120
f8c47986
JB
121# API not exported
122%{__rm} $RPM_BUILD_ROOT%{_libdir}/libettercap*.so
123
0e21442b
GS
124%clean
125rm -rf $RPM_BUILD_ROOT
126
f8c47986
JB
127%post -p /sbin/ldconfig
128%postun -p /sbin/ldconfig
129
0e21442b
GS
130%files
131%defattr(644,root,root,755)
f8c47986
JB
132%doc AUTHORS CHANGELOG LICENSE.OPENSSL README README.{BINARIES,BUGS} THANKS TODO doc/*
133%attr(755,root,root) %{_bindir}/ettercap
134%attr(755,root,root) %{_bindir}/ettercap-pkexec
135%attr(755,root,root) %{_bindir}/etterfilter
136%attr(755,root,root) %{_bindir}/etterlog
137%attr(755,root,root) %{_libdir}/libettercap.so.*.*.*
138%attr(755,root,root) %ghost %{_libdir}/libettercap.so.0
139%attr(755,root,root) %{_libdir}/libettercap-ui.so.*.*.*
140%attr(755,root,root) %ghost %{_libdir}/libettercap-ui.so.0
9fb25dec 141%dir %{_libdir}/ettercap
f8c47986
JB
142%attr(755,root,root) %{_libdir}/ettercap/ec_*.so
143%dir %{_sysconfdir}/ettercap
144%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ettercap/etter.conf
145%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ettercap/etter.dns
146%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ettercap/etter.mdns
147%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ettercap/etter.nbns
148%{_datadir}/appdata/ettercap.appdata.xml
7658ab6d 149%{_datadir}/ettercap
f8c47986
JB
150%{_datadir}/polkit-1/actions/org.pkexec.ettercap.policy
151%{_desktopdir}/ettercap.desktop
152%{_pixmapsdir}/ettercap.svg
153%{_mandir}/man5/etter.conf.5*
154%{_mandir}/man8/ettercap.8*
155%{_mandir}/man8/ettercap-pkexec.8*
156%{_mandir}/man8/ettercap_curses.8*
157%{_mandir}/man8/ettercap_plugins.8*
158%{_mandir}/man8/etterfilter.8*
159%{_mandir}/man8/etterlog.8*
This page took 0.09174 seconds and 4 git commands to generate.