]> git.pld-linux.org Git - packages/elektra.git/blame - elektra.spec
- files update
[packages/elektra.git] / elektra.spec
CommitLineData
088942e6 1# TODO: use system nickel (in src/plugins/ni), inih (src/plugins/ini)
de7f9f03
JB
2#
3# Conditonal build:
f33e068e 4%bcond_with full # "full" variant (libelektra-full with all plugins linked in)
c89b1889 5%bcond_without java # Java support: JNA binding and JNI plugin (needs Java 8)
088942e6
JB
6%bcond_without glib # GLib/GObject binding
7%bcond_without lua # Lua (5.2) support: binding and plugin
8%bcond_without python2 # Python 2 support: binding and plugin
9%bcond_without python3 # Python 3 support: binding and plugin
10%bcond_without qt # Qt GUI
de7f9f03 11#
b511c548 12Summary: A key/value pair database to store software configurations
3afb30a1 13Summary(pl.UTF-8): Baza kluczy/wartości do przechowywania konfiguracji oprogramowania
08a1423c 14Name: elektra
27ae2dbf
JR
15Version: 0.8.19
16Release: 1
08a1423c 17License: BSD
b511c548 18Group: Applications/System
de7f9f03 19Source0: http://www.libelektra.org/ftp/elektra/releases/%{name}-%{version}.tar.gz
27ae2dbf 20# Source0-md5: 6669e765c834e259fb7570f126b85d7e
088942e6
JB
21Patch1: %{name}-no-markdown.patch
22Patch2: %{name}-no-deb.patch
de7f9f03 23URL: http://www.libelektra.org/
088942e6
JB
24%if %{with qt}
25BuildRequires: Qt5Core-devel >= 5
26BuildRequires: Qt5Gui-devel >= 5
27BuildRequires: Qt5Qml-devel >= 5
28BuildRequires: Qt5Quick-devel >= 5
29BuildRequires: Qt5Widgets-devel >= 5
30BuildRequires: Qt5Test-devel >= 5
31%endif
32BuildRequires: augeas-devel >= 1.0
33BuildRequires: boost-devel
34BuildRequires: cmake >= 2.8.8
f33e068e 35BuildRequires: dbus-devel
de7f9f03 36BuildRequires: doxygen
0c175270 37BuildRequires: gettext-tools
088942e6
JB
38%{?with_glib:BuildRequires: glib2-devel >= 1:2.36}
39%{?with_glib:BuildRequires: gobject-introspection-devel >= 1.38}
c89b1889 40# for binding
088942e6
JB
41%{?with_java:BuildRequires: java-jna}
42%{?with_java:BuildRequires: jdk >= 1.8}
c89b1889
JB
43# jawt for plugin
44%{?with_java:BuildRequires: jre-X11 >= 1.8}
088942e6
JB
45BuildRequires: libgcrypt-devel
46%{?with_qt:BuildRequires: libmarkdown-devel}
de7f9f03 47BuildRequires: libstdc++-devel
088942e6 48BuildRequires: libxml2-devel >= 2.0
b0fec8fa 49BuildRequires: libxslt-progs
088942e6 50%{?with_lua:BuildRequires: lua52-devel >= 5.2}
de7f9f03 51BuildRequires: pkgconfig
088942e6
JB
52%{?with_python2:BuildRequires: python-devel >= 1:2.7}
53%{?with_python3:BuildRequires: python3-devel >= 1:3.2}
3b20dccf 54BuildRequires: ronn
088942e6
JB
55BuildRequires: rpm-pythonprov
56BuildRequires: rpmbuild(macros) >= 1.612
57BuildRequires: swig >= 2
58%if %{with python2} || %{with python3}
59BuildRequires: swig-python >= 2
60%endif
61BuildRequires: systemd-devel
62BuildRequires: tcl-devel
f33e068e 63BuildRequires: yajl-devel
de7f9f03 64Requires: %{name}-libs = %{version}-%{release}
731cdbee 65Requires: mktemp
08a1423c 66Obsoletes: registry
a1ae6c6c 67BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
68
69%description
b511c548 70The Elektra Project provides a framework to store generic
71configuration data in an hierarchical key-value pair database, instead
72of a human-readable only text file.
a1ae6c6c 73
74This way any software can read/save his configuration using a
75consistent API. Also, applications can be aware of other applications
76configurations, leveraging easy application integration.
77
9b93ecfb 78%description -l pl.UTF-8
ff4dd69b 79Projekt Elektra dostarcza szkielet do przechowywania typowych danych
9b93ecfb
JR
80konfiguracyjnych w postaci klucz-wartość w hierarchicznej bazie
81danych, zamiast w pliku tekstowym czytelnym tylko dla człowieka.
85fe0e6b 82
9b93ecfb
JR
83W ten sposób oprogramowanie może odczytywać/zapisywać konfigurację za
84pomocą spójnego API. Dodatkowo aplikacje mogą być zorientowane w
85konfiguracji innych aplikacji, ułatwiając ich integrację.
a1ae6c6c 86
088942e6
JB
87%package gui
88Summary: Qt based GUI for Elektra
89Summary(pl.UTF-8): Oparty na Qt graficzny interfejs do Elektry
90Group: X11/Applications
91Requires: %{name} = %{version}-%{release}
92
93%description gui
94Qt based GUI for Elektra.
95
96%description gui -l pl.UTF-8
97Oparty na Qt graficzny interfejs do Elektry.
98
c89b1889
JB
99%package plugin-jni
100Summary: Java JNI plugin for Elektra
101Summary(pl.UTF-8): Wtyczka Java JNI dla Elektry
102Group: Libraries
103Requires: %{name} = %{version}-%{release}
104# jawt
105Requires: jre-X11 >= 1.8
106
107%description plugin-jni
108Java JNI plugin for Elektra. It allows to use plugins written in Java.
109
110%description plugin-jni -l pl.UTF-8
111Wtyczka Java JNI dla Elektry. Pozwala na używanie wtyczek napisanych w
112Javie.
113
114%package plugin-lua
115Summary: Lua plugin for Elektra
116Summary(pl.UTF-8): Wtyczka Lua dla Elektry
117Group: Libraries
118Requires: %{name} = %{version}-%{release}
119Requires: lua52-libs >= 5.2
120
121%description plugin-lua
122Lua plugin for Elektra. It allows to use plugins written in Lua.
123
124%description plugin-lua -l pl.UTF-8
125Wtyczka Lua dla Elektry. Pozwala na używanie wtyczek napisanych w Lua.
126
127%package plugin-python2
128Summary: Python 2 plugin for Elektra
129Summary(pl.UTF-8): Wtyczka Python 2 dla Elektry
130Group: Libraries
131Requires: %{name} = %{version}-%{release}
132Requires: python-libs >= 1:2.7
133
134%description plugin-python2
135Python 2 plugin for Elektra. It allows to use plugins written in
136Python 2.
137
138%description plugin-python2 -l pl.UTF-8
139Wtyczka 2 Python dla Elektry. Pozwala na używanie wtyczek napisanych w
140Pythonie 2.
141
142%package plugin-python3
143Summary: Python plugin for Elektra
144Summary(pl.UTF-8): Wtyczka Python dla Elektry
145Group: Libraries
146Requires: %{name} = %{version}-%{release}
147Requires: python3-libs >= 1:3.2
148
149%description plugin-python3
150Python 3 plugin for Elektra. It allows to use plugins written in
151Python 3.
152
153%description plugin-python3 -l pl.UTF-8
154Wtyczka Python 3 dla Elektry. Pozwala na używanie wtyczek napisanych w
155Pythonie 3.
156
088942e6
JB
157%package -n bash-completion-elektra
158Summary: Bash completion for Elektra commands
159Summary(pl.UTF-8): Bashowe uzupełnianie parametrów dla poleceń z pakietu Elektra
160Group: Applications/Shells
161Requires: %{name} = %{version}-%{release}
162Requires: bash-completion
163
164%description -n bash-completion-elektra
165Bash completion for Elektra kdb command.
166
167%description -n bash-completion-elektra -l pl.UTF-8
168Bashowe uzupełnianie parametrów dla polecenai kdb z pakietu Elektra.
169
de7f9f03
JB
170%package libs
171Summary: Elektra Project libraries
172Summary(pl.UTF-8): Biblioteki projektu Elektra
173Group: Libraries
f33e068e 174Obsoletes: elektra-cpp < 0.8
de7f9f03 175Conflicts: elektra < 0.7
a1ae6c6c 176
de7f9f03 177%description libs
b511c548 178The Elektra Project provides a framework to store generic
179configuration data in an hierarchical key-value pair database, instead
180of a human-readable only text file.
a1ae6c6c 181
182This way any software can read/save his configuration using a
183consistent API. Also, applications can be aware of other applications
184configurations, leveraging easy application integration.
185
de7f9f03 186This package contains Elektra shared libraries.
a1ae6c6c 187
de7f9f03 188%description libs -l pl.UTF-8
ff4dd69b 189Projekt Elektra dostarcza szkielet do przechowywania typowych danych
9b93ecfb
JR
190konfiguracyjnych w postaci klucz-wartość w hierarchicznej bazie
191danych, zamiast w pliku tekstowym czytelnym tylko dla człowieka.
85fe0e6b 192
9b93ecfb
JR
193W ten sposób oprogramowanie może odczytywać/zapisywać konfigurację za
194pomocą spójnego API. Dodatkowo aplikacje mogą być zorientowane w
195konfiguracji innych aplikacji, ułatwiając ich integrację.
85fe0e6b 196
de7f9f03
JB
197Ten pakiet zawiera biblioteki współdzielone Elektry.
198
199%package devel
200Summary: Include files and API documentation for Elektra Project
201Summary(pl.UTF-8): Pliki nagłówkowe i dokumentacja API projektu Elektra
202Group: Development/Libraries
203Requires: %{name}-libs = %{version}-%{release}
204
205%description devel
206This package contains the include files and API manual pages to use
207the Elektra API in C.
208
209%description devel -l pl.UTF-8
9b93ecfb
JR
210Ten pakiet zawiera pliki nagłówkowe oraz strony podręcznika
211systemowego opisującego sposób użycia API Elektry w C.
a1ae6c6c 212
b511c548 213%package static
de7f9f03
JB
214Summary: Static libraries for Elektra Project
215Summary(pl.UTF-8): Statyczne biblioteki projektu Elektra
85fe0e6b 216Group: Development/Libraries
de7f9f03 217Requires: %{name}-devel = %{version}-%{release}
a1ae6c6c 218
b511c548 219%description static
de7f9f03 220This package contains static libraries for Elektra Project.
a1ae6c6c 221
de7f9f03
JB
222%description static -l pl.UTF-8
223Ten pakiet zawiera statyczne biblioteki projektu Elektra.
a1ae6c6c 224
de7f9f03
JB
225%package cpp-devel
226Summary: Header files of C++ interface for Elektra library
227Summary(pl.UTF-8): Pliki nagłówkowe interfejsu C++ do biblioteki Elektra
228Group: Development/Libraries
f33e068e 229Requires: %{name}-devel = %{version}-%{release}
de7f9f03 230Requires: libstdc++-devel
f33e068e 231Obsoletes: elektra-cpp-static < 0.8
de7f9f03
JB
232
233%description cpp-devel
234Header files of C++ interface for Elektra library.
235
236%description cpp-devel -l pl.UTF-8
237Pliki nagłówkowe interfejsu C++ do biblioteki Elektra.
238
088942e6
JB
239%package glib
240Summary: GLib/GObject binding for Elektra
241Summary(pl.UTF-8): Wiązanie GLib/GObject do Elektry
242Group: Libraries
243Requires: %{name}-libs = %{version}-%{release}
244Requires: glib2 >= 1:2.36
245
246%description glib
247GLib/GObject binding for Elektra.
248
249%description glib -l pl.UTF-8
250Wiązanie GLib/GObject do Elektry.
251
252%package glib-devel
253Summary: GLib/GObject binding for Elektra - development files
254Summary(pl.UTF-8): Wiązanie GLib/GObject do Elektry - pliki programistyczne
255Group: Libraries
256Requires: %{name}-devel = %{version}-%{release}
257Requires: glib2-devel >= 1:2.36
258
259%description glib-devel
260GLib/GObject binding for Elektra - development files.
261
262%description glib-devel -l pl.UTF-8
263Wiązanie GLib/GObject do Elektry - pliki programistyczne.
264
c89b1889
JB
265%package -n java-elektra
266Summary: Java binding for Elektra
267Summary(pl.UTF-8): Wiązanie języka Java dla Elektry
268Group: Libraries
269Requires: %{name}-libs = %{version}-%{release}
270Requires: java-jna
271Requires: jre
272
273%description -n java-elektra
274Java binding for Elektra.
275
276%description -n java-elektra -l pl.UTF-8
277Wiązanie języka Java dla Elektry.
278
088942e6
JB
279%package -n lua-elektra
280Summary: Lua binding for Elektra
281Summary(pl.UTF-8): Wiązanie języka Lua dla Elektry
282Group: Libraries
283Requires: %{name}-libs = %{version}-%{release}
284Requires: lua52-libs >= 5.2
285
286%description -n lua-elektra
287Lua binding for Elektra.
288
289%description -n lua-elektra -l pl.UTF-8
290Wiązanie języka Lua dla Elektry.
291
292%package -n lua-elektra-glib
293Summary: Lua/GI binding for Elektra
294Summary(pl.UTF-8): Wiązanie Lua/GI dla Elektry
295Group: Libraries
296Requires: %{name}-glib = %{version}-%{release}
297Requires: lua52-libs >= 5.2
298#R: lua52-lgi ?
299
300%description -n lua-elektra-glib
301Lua/GI binding for Elektra.
302
303%description -n lua-elektra-glib -l pl.UTF-8
304Wiązanie Lua/GI dla Elektry.
305
306%package -n python-elektra
307Summary: Python 2 binding for Elektra
308Summary(pl.UTF-8): Wiązanie Pythona 2 dla Elektry
309Group: Libraries
310Requires: %{name}-libs = %{version}-%{release}
311Requires: python-libs >= 1:2.7
312
313%description -n python-elektra
314Python 2 binding for Elektra.
315
316%description -n python-elektra -l pl.UTF-8
317Wiązanie Pythona 2 dla Elektry.
318
319%package -n python3-elektra
320Summary: Python 3 binding for Elektra
321Summary(pl.UTF-8): Wiązanie Pythona 3 dla Elektry
322Group: Libraries
323Requires: %{name}-libs = %{version}-%{release}
324Requires: python3-libs >= 1:3.2
325
326%description -n python3-elektra
327Python 3 binding for Elektra.
328
329%description -n python3-elektra -l pl.UTF-8
330Wiązanie Pythona 3 dla Elektry.
331
332%package -n python3-elektra-glib
333Summary: Python 3 GI binding for Elektra
334Summary(pl.UTF-8): Wiązanie Pythona 3 GI dla Elektry
335Group: Libraries
336Requires: %{name}-glib = %{version}-%{release}
337Requires: python3-pygobject3 >= 3
338
339%description -n python3-elektra-glib
340Python 3 GI binding for Elektra.
341
342%description -n python3-elektra-glib -l pl.UTF-8
343Wiązanie Pythona 3 GI dla Elektry.
344
a1ae6c6c 345%prep
de7f9f03 346%setup -q
088942e6
JB
347%patch1 -p1
348%patch2 -p1
a1ae6c6c 349
350%build
f33e068e
JB
351install -d build
352cd build
353%cmake .. \
088942e6 354 -DBINDINGS="cpp%{?with_glib:;glib%{?with_lua:;gi_lua}%{?with_python3:;gi_python}}%{?with_java:;jna}%{?with_lua:;swig_lua}%{?with_python2:;swig_python2}%{?with_python3:;swig_python}" \
f33e068e 355 %{!?with_full:-DBUILD_FULL=OFF} \
088942e6 356 -DINSTALL_TESTING=FALSE \
f33e068e 357 -DPLUGINS=ALL \
088942e6 358 -DTARGET_CMAKE_FOLDER=%{_datadir}/cmake/Modules \
3e0386dc
AM
359 -DTOOLS="kdb;race%{?with_gen:;gen}%{?with_qt:;qt-gui}" \
360 -DBUILD_STATIC=ON
f33e068e 361
f870a14f 362%{__make} -j1
a1ae6c6c 363
364%install
365rm -rf $RPM_BUILD_ROOT
ff4dd69b 366
f33e068e
JB
367%{__make} -C build install \
368 DESTDIR=$RPM_BUILD_ROOT
de7f9f03 369
f33e068e
JB
370install -D src/plugins/xmltool/xmlschema/elektra.xsd $RPM_BUILD_ROOT%{_datadir}/sgml/elektra/elektra.xsd
371
3e0386dc
AM
372install -d $RPM_BUILD_ROOT/etc/bash_completion.d
373mv $RPM_BUILD_ROOT{%{bash_compdir}/kdb,/etc/bash_completion.d/kdb}
374
088942e6
JB
375%if %{with python2}
376%py_comp $RPM_BUILD_ROOT%{py_sitedir}
377%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
378%py_postclean
379%endif
380
381%if %{with python3}
382%py3_comp $RPM_BUILD_ROOT%{py3_sitedir}
383%py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}
384%endif
385
de7f9f03 386# prepare docs
f33e068e 387%{__rm} -rf installed-doc
de7f9f03 388install -d installed-doc
f33e068e 389%{__mv} $RPM_BUILD_ROOT%{_docdir}/%{name}-api installed-doc/elektra-api
de7f9f03 390
27ae2dbf 391%{__rm} $RPM_BUILD_ROOT%{_mandir}/man3/{README_md,doc_*_md,md_doc_*,md_src_*}.3elektra
de7f9f03 392
a1ae6c6c 393%clean
394rm -rf $RPM_BUILD_ROOT
395
de7f9f03
JB
396%post libs -p /sbin/ldconfig
397%postun libs -p /sbin/ldconfig
398
088942e6
JB
399%post glib -p /sbin/ldconfig
400%postun glib -p /sbin/ldconfig
401
a1ae6c6c 402%files
403%defattr(644,root,root,755)
3e0386dc 404%doc doc/{AUTHORS,DESIGN.md,GOALS.md,NEWS.md,SECURITY.md,todo}
f33e068e
JB
405# doc/standards installed-doc/scripts
406%attr(755,root,root) %{_bindir}/kdb
407%if %{with full}
408%attr(755,root,root) %{_bindir}/kdb-full
de7f9f03 409%endif
f33e068e 410%dir %{_libdir}/elektra
088942e6
JB
411# R: augeas-libs
412%attr(755,root,root) %{_libdir}/elektra/libelektra-augeas.so
3e0386dc
AM
413%attr(755,root,root) %{_libdir}/elektra/libelektra-base64.so
414%attr(755,root,root) %{_libdir}/elektra/libelektra-blockresolver.so
415%attr(755,root,root) %{_libdir}/elektra/libelektra-boolean.so
416%attr(755,root,root) %{_libdir}/elektra/libelektra-c.so
417%attr(755,root,root) %{_libdir}/elektra/libelektra-cachefilter.so
f33e068e 418%attr(755,root,root) %{_libdir}/elektra/libelektra-ccode.so
088942e6
JB
419%attr(755,root,root) %{_libdir}/elektra/libelektra-conditionals.so
420%attr(755,root,root) %{_libdir}/elektra/libelektra-constants.so
421%attr(755,root,root) %{_libdir}/elektra/libelektra-counter.so
422# R: libgcrypt
3e0386dc
AM
423%attr(755,root,root) %{_libdir}/elektra/libelektra-crypto_gcrypt.so
424%attr(755,root,root) %{_libdir}/elektra/libelektra-crypto_openssl.so
088942e6 425%attr(755,root,root) %{_libdir}/elektra/libelektra-csvstorage.so
3e0386dc 426%attr(755,root,root) %{_libdir}/elektra/libelektra-curlget.so
f33e068e
JB
427# R: dbus
428%attr(755,root,root) %{_libdir}/elektra/libelektra-dbus.so
3e0386dc 429%attr(755,root,root) %{_libdir}/elektra/libelektra-desktop.so
f33e068e 430%attr(755,root,root) %{_libdir}/elektra/libelektra-doc.so
3e0386dc 431%attr(755,root,root) %{_libdir}/elektra/libelektra-dpkg.so
f33e068e 432%attr(755,root,root) %{_libdir}/elektra/libelektra-dump.so
088942e6 433%attr(755,root,root) %{_libdir}/elektra/libelektra-enum.so
f33e068e 434%attr(755,root,root) %{_libdir}/elektra/libelektra-error.so
3e0386dc 435%attr(755,root,root) %{_libdir}/elektra/libelektra-fcrypt.so
088942e6 436%attr(755,root,root) %{_libdir}/elektra/libelektra-filecheck.so
f33e068e 437%attr(755,root,root) %{_libdir}/elektra/libelektra-fstab.so
3e0386dc 438%attr(755,root,root) %{_libdir}/elektra/libelektra-gitresolver.so
f33e068e
JB
439%attr(755,root,root) %{_libdir}/elektra/libelektra-glob.so
440%attr(755,root,root) %{_libdir}/elektra/libelektra-hexcode.so
441%attr(755,root,root) %{_libdir}/elektra/libelektra-hidden.so
442%attr(755,root,root) %{_libdir}/elektra/libelektra-hosts.so
443%attr(755,root,root) %{_libdir}/elektra/libelektra-iconv.so
088942e6
JB
444# uses internal inih library
445%attr(755,root,root) %{_libdir}/elektra/libelektra-ini.so
3e0386dc 446%attr(755,root,root) %{_libdir}/elektra/libelektra-iterate.so
088942e6
JB
447# R: systemd-libs
448%attr(755,root,root) %{_libdir}/elektra/libelektra-journald.so
449%attr(755,root,root) %{_libdir}/elektra/libelektra-keytometa.so
450%attr(755,root,root) %{_libdir}/elektra/libelektra-line.so
451%attr(755,root,root) %{_libdir}/elektra/libelektra-lineendings.so
452%attr(755,root,root) %{_libdir}/elektra/libelektra-list.so
453%attr(755,root,root) %{_libdir}/elektra/libelektra-logchange.so
088942e6 454%attr(755,root,root) %{_libdir}/elektra/libelektra-mathcheck.so
3e0386dc 455%attr(755,root,root) %{_libdir}/elektra/libelektra-mozprefs.so
f33e068e 456%attr(755,root,root) %{_libdir}/elektra/libelektra-network.so
088942e6
JB
457%attr(755,root,root) %{_libdir}/elektra/libelektra-noresolver.so
458# uses internal nickel library
f33e068e
JB
459%attr(755,root,root) %{_libdir}/elektra/libelektra-ni.so
460%attr(755,root,root) %{_libdir}/elektra/libelektra-null.so
3e0386dc 461%attr(755,root,root) %{_libdir}/elektra/libelektra-passwd.so
f33e068e 462%attr(755,root,root) %{_libdir}/elektra/libelektra-path.so
3e0386dc 463%attr(755,root,root) %{_libdir}/elektra/libelektra-profile.so
088942e6
JB
464%attr(755,root,root) %{_libdir}/elektra/libelektra-regexstore.so
465%attr(755,root,root) %{_libdir}/elektra/libelektra-rename.so
f33e068e 466%attr(755,root,root) %{_libdir}/elektra/libelektra-resolver.so
088942e6 467%attr(755,root,root) %{_libdir}/elektra/libelektra-resolver_fm_*.so
3e0386dc
AM
468%attr(755,root,root) %{_libdir}/elektra/libelektra-required.so
469%attr(755,root,root) %{_libdir}/elektra/libelektra-semlock.so
470%attr(755,root,root) %{_libdir}/elektra/libelektra-shell.so
471%attr(755,root,root) %{_libdir}/elektra/libelektra-simplespeclang.so
f33e068e 472%attr(755,root,root) %{_libdir}/elektra/libelektra-simpleini.so
3e0386dc
AM
473%attr(755,root,root) %{_libdir}/elektra/libelektra-spec.so
474%attr(755,root,root) %{_libdir}/elektra/libelektra-storage.so
f33e068e 475%attr(755,root,root) %{_libdir}/elektra/libelektra-struct.so
088942e6 476%attr(755,root,root) %{_libdir}/elektra/libelektra-sync.so
f33e068e
JB
477%attr(755,root,root) %{_libdir}/elektra/libelektra-syslog.so
478%attr(755,root,root) %{_libdir}/elektra/libelektra-tcl.so
479%attr(755,root,root) %{_libdir}/elektra/libelektra-template.so
480%attr(755,root,root) %{_libdir}/elektra/libelektra-timeofday.so
481%attr(755,root,root) %{_libdir}/elektra/libelektra-tracer.so
482%attr(755,root,root) %{_libdir}/elektra/libelektra-type.so
483%attr(755,root,root) %{_libdir}/elektra/libelektra-uname.so
484%attr(755,root,root) %{_libdir}/elektra/libelektra-validation.so
088942e6 485%attr(755,root,root) %{_libdir}/elektra/libelektra-wresolver.so
f33e068e
JB
486# R: libxml2
487%attr(755,root,root) %{_libdir}/elektra/libelektra-xmltool.so
488# R: yajl
489%attr(755,root,root) %{_libdir}/elektra/libelektra-yajl.so
85892bd2
JB
490%dir %{_libdir}/elektra/tool_exec
491%attr(755,root,root) %{_libdir}/elektra/tool_exec/benchmark-createtree
3e0386dc 492%attr(755,root,root) %{_libdir}/elektra/tool_exec/configure-firefox
85892bd2
JB
493%attr(755,root,root) %{_libdir}/elektra/tool_exec/convert-fstab
494%attr(755,root,root) %{_libdir}/elektra/tool_exec/convert-hosts
495%attr(755,root,root) %{_libdir}/elektra/tool_exec/convert-inittab
496%attr(755,root,root) %{_libdir}/elektra/tool_exec/convert-users
497%attr(755,root,root) %{_libdir}/elektra/tool_exec/elektra-merge
498%attr(755,root,root) %{_libdir}/elektra/tool_exec/elektra-mount
499%attr(755,root,root) %{_libdir}/elektra/tool_exec/elektra-umount
3e0386dc 500%attr(755,root,root) %{_libdir}/elektra/tool_exec/elektrify-open
85892bd2
JB
501%attr(755,root,root) %{_libdir}/elektra/tool_exec/elektrify-getenv
502%attr(755,root,root) %{_libdir}/elektra/tool_exec/example-xorg
3e0386dc
AM
503%dir %{_libdir}/elektra/tool_exec/ffconfig
504%attr(755,root,root) %{_libdir}/elektra/tool_exec/ffconfig/setupConfig
505%attr(755,root,root) %{_libdir}/elektra/tool_exec/ffconfig/setupHomepage
506%attr(755,root,root) %{_libdir}/elektra/tool_exec/ffconfig/setupProxy
507%attr(755,root,root) %{_libdir}/elektra/tool_exec/ffconfig/writeConfigFiles
508%attr(755,root,root) %{_libdir}/elektra/tool_exec/find-tools
509%attr(755,root,root) %{_libdir}/elektra/tool_exec/install-sh-completion
85892bd2
JB
510%attr(755,root,root) %{_libdir}/elektra/tool_exec/list-tools
511%attr(755,root,root) %{_libdir}/elektra/tool_exec/mount-augeas
512%attr(755,root,root) %{_libdir}/elektra/tool_exec/mount-info
513%attr(755,root,root) %{_libdir}/elektra/tool_exec/mount-kde
514%attr(755,root,root) %{_libdir}/elektra/tool_exec/mount-openicc
85892bd2
JB
515%attr(755,root,root) %{_libdir}/elektra/tool_exec/race
516%attr(755,root,root) %{_libdir}/elektra/tool_exec/umount-all
3e0386dc 517%attr(755,root,root) %{_libdir}/elektra/tool_exec/upgrade-bootstrap
f33e068e 518%{_datadir}/sgml/elektra
3b20dccf
JB
519%{_mandir}/man1/kdb.1*
520%{_mandir}/man1/kdb-check.1*
521%{_mandir}/man1/kdb-convert.1*
522%{_mandir}/man1/kdb-cp.1*
3b20dccf
JB
523%{_mandir}/man1/kdb-export.1*
524%{_mandir}/man1/kdb-file.1*
525%{_mandir}/man1/kdb-fstab.1*
526%{_mandir}/man1/kdb-get.1*
527%{_mandir}/man1/kdb-getmeta.1*
528%{_mandir}/man1/kdb-help.1*
529%{_mandir}/man1/kdb-import.1*
530%{_mandir}/man1/kdb-info.1*
531%{_mandir}/man1/kdb-introduction.1*
532%{_mandir}/man1/kdb-list.1*
533%{_mandir}/man1/kdb-list-tools.1*
534%{_mandir}/man1/kdb-ls.1*
535%{_mandir}/man1/kdb-lsmeta.1*
536%{_mandir}/man1/kdb-merge.1*
537%{_mandir}/man1/kdb-mount.1*
538%{_mandir}/man1/kdb-mv.1*
539%{_mandir}/man1/kdb-remount.1*
540%{_mandir}/man1/kdb-rm.1*
541%{_mandir}/man1/kdb-set.1*
542%{_mandir}/man1/kdb-setmeta.1*
543%{_mandir}/man1/kdb-sget.1*
544%{_mandir}/man1/kdb-shell.1*
545%{_mandir}/man1/kdb-test.1*
546%{_mandir}/man1/kdb-umount.1*
547%{_mandir}/man1/kdb-vset.1*
548%{_mandir}/man7/elektra-*.7*
de7f9f03 549
088942e6
JB
550%if 0
551%files gen ?
552%defattr(644,root,root,755)
85892bd2 553%attr(755,root,root) %{_libdir}/elektra/tool_exec/gen
088942e6
JB
554%{py_sitescriptdir}/elektra_gen-%{version}-py*.egg-info
555# FIXME: should be in elektra_gen subdir
556%{py_sitescriptdir}/support
557%{_datadir}/elektra/templates
558%endif
559
560%files gui
561%defattr(644,root,root,755)
3e0386dc 562%attr(755,root,root) %{_bindir}/elektra-qt-editor
85892bd2 563%attr(755,root,root) %{_libdir}/elektra/tool_exec/qt-gui
3e0386dc
AM
564%{_datadir}/appdata/org.libelektra.elektra-qt-editor.appdata.xml
565%{_desktopdir}/org.libelektra.elektra-qt-editor.desktop
566%{_iconsdir}/hicolor/scalable/apps/elektra-symbolic.svg
567%{_iconsdir}/hicolor/scalable/apps/elektra.svg
3b20dccf 568%{_mandir}/man1/kdb-qt-gui.1*
088942e6 569
c89b1889
JB
570%if %{with java}
571%files plugin-jni
572%defattr(644,root,root,755)
573# R: jre with jawt
574%attr(755,root,root) %{_libdir}/elektra/libelektra-jni.so
575%endif
576
577%if %{with lua}
578%files plugin-lua
579%defattr(644,root,root,755)
580# R: lua52-libs
581%attr(755,root,root) %{_libdir}/elektra/libelektra-lua.so
582%endif
583
584%if %{with python2}
585%files plugin-python2
586%defattr(644,root,root,755)
587# R: python-libs
588%attr(755,root,root) %{_libdir}/elektra/libelektra-python2.so
589%endif
590
591%if %{with python3}
592%files plugin-python3
593%defattr(644,root,root,755)
594# R: python3-libs
595%attr(755,root,root) %{_libdir}/elektra/libelektra-python.so
596%endif
597
088942e6
JB
598%files -n bash-completion-elektra
599%defattr(644,root,root,755)
600/etc/bash_completion.d/kdb
601
de7f9f03
JB
602%files libs
603%defattr(644,root,root,755)
f33e068e
JB
604%attr(755,root,root) %{_libdir}/libelektra.so.*.*.*
605%attr(755,root,root) %ghost %{_libdir}/libelektra.so.4
3e0386dc
AM
606%attr(755,root,root) %{_libdir}/libelektra-core.so.*.*.*
607%attr(755,root,root) %ghost %{_libdir}/libelektra-core.so.4
608%attr(755,root,root) %{_libdir}/libelektra-ease.so.*.*.*
609%attr(755,root,root) %ghost %{_libdir}/libelektra-ease.so.4
610%attr(755,root,root) %{_libdir}/libelektra-kdb.so.*.*.*
611%attr(755,root,root) %ghost %{_libdir}/libelektra-kdb.so.4
612%attr(755,root,root) %{_libdir}/libelektra-meta.so.*.*.*
613%attr(755,root,root) %ghost %{_libdir}/libelektra-meta.so.4
614%attr(755,root,root) %{_libdir}/libelektra-plugin.so.*.*.*
615%attr(755,root,root) %ghost %{_libdir}/libelektra-plugin.so.4
616%attr(755,root,root) %{_libdir}/libelektra-proposal.so.*.*.*
617%attr(755,root,root) %ghost %{_libdir}/libelektra-proposal.so.4
618%attr(755,root,root) %{_libdir}/libelektratools.so.*.*.*
619%attr(755,root,root) %ghost %{_libdir}/libelektratools.so.2
f33e068e
JB
620%if %{with full}
621%attr(755,root,root) %{_libdir}/libelektra-full.so.*.*.*
622%attr(755,root,root) %ghost %{_libdir}/libelektra-full.so.4
623%endif
a1ae6c6c 624
625%files devel
626%defattr(644,root,root,755)
088942e6 627%doc doc/API.md installed-doc/elektra-api/html
de7f9f03 628%attr(755,root,root) %{_libdir}/libelektra.so
f33e068e
JB
629%if %{with full}
630%attr(755,root,root) %{_libdir}/libelektra-full.so
631%endif
632%dir %{_includedir}/elektra
088942e6 633%{_includedir}/elektra/kdb*.h
de7f9f03 634%{_pkgconfigdir}/elektra.pc
088942e6
JB
635%{_datadir}/cmake/Modules/ElektraConfig*.cmake
636%{_datadir}/cmake/Modules/ElektraTargetsLibelektra*.cmake
637%{_mandir}/man3/api.3elektra*
f33e068e
JB
638%{_mandir}/man3/deprecated.3elektra*
639%{_mandir}/man3/kdb*.3elektra*
640%{_mandir}/man3/key*.3elektra*
088942e6 641%{_mandir}/man3/meta.3elektra*
f33e068e 642%{_mandir}/man3/plugin.3elektra*
088942e6 643%{_mandir}/man3/proposal.3elektra*
a1ae6c6c 644
b511c548 645%files static
85fe0e6b 646%defattr(644,root,root,755)
f33e068e 647%{_libdir}/libelektra-static.a
37555a25 648%{_libdir}/libelektratools-static.a
de7f9f03
JB
649
650%files cpp-devel
651%defattr(644,root,root,755)
f33e068e 652%{_includedir}/elektra/*.hpp
088942e6
JB
653%{_includedir}/elektra/helper
654%{_includedir}/elektra/merging
37555a25 655# libelektratools API man pages
088942e6
JB
656%{_mandir}/man3/automergeconfiguration.hpp.3elektra*
657%{_mandir}/man3/automergestrategy.cpp.3elektra*
658%{_mandir}/man3/automergestrategy.hpp.3elektra*
659%{_mandir}/man3/comparison.cpp.3elektra*
660%{_mandir}/man3/comparison.hpp.3elektra*
37555a25
JB
661%{_mandir}/man3/backend.hpp.3elektra*
662%{_mandir}/man3/backends.hpp.3elektra*
088942e6
JB
663%{_mandir}/man3/importmergeconfiguration.hpp.3elektra*
664%{_mandir}/man3/interactivemergestrategy.cpp.3elektra*
665%{_mandir}/man3/interactivemergestrategy.hpp.3elektra*
666%{_mandir}/man3/mergeconfiguration.hpp.3elektra*
667%{_mandir}/man3/mergeconflict.hpp.3elektra*
668%{_mandir}/man3/mergeconflictstrategy.cpp.3elektra*
669%{_mandir}/man3/mergeconflictstrategy.hpp.3elektra*
670%{_mandir}/man3/mergeresult.cpp.3elektra*
671%{_mandir}/man3/mergeresult.hpp.3elektra*
672%{_mandir}/man3/mergetask.hpp.3elektra*
673%{_mandir}/man3/mergetestutils.cpp.3elektra*
674%{_mandir}/man3/metamergestrategy.cpp.3elektra*
675%{_mandir}/man3/metamergestrategy.hpp.3elektra*
676%{_mandir}/man3/newkeystrategy.cpp.3elektra*
677%{_mandir}/man3/newkeystrategy.hpp.3elektra*
678%{_mandir}/man3/onesidemergeconfiguration.hpp.3elektra*
679%{_mandir}/man3/onesidestrategy.cpp.3elektra*
680%{_mandir}/man3/onesidestrategy.hpp.3elektra*
681%{_mandir}/man3/onesidevaluestrategy.cpp.3elektra*
682%{_mandir}/man3/overwritemergeconfiguration.hpp.3elektra*
37555a25
JB
683%{_mandir}/man3/modules.cpp.3elektra*
684%{_mandir}/man3/modules.hpp.3elektra*
685%{_mandir}/man3/plugin.cpp.3elektra*
686%{_mandir}/man3/plugin.hpp.3elektra*
687%{_mandir}/man3/plugins.cpp.3elektra*
688%{_mandir}/man3/plugins.hpp.3elektra*
689%{_mandir}/man3/src_backend.cpp.3elektra*
088942e6
JB
690%{_mandir}/man3/testtool_*.cpp.3elektra*
691%{_mandir}/man3/threewaymerge.cpp.3elektra*
692%{_mandir}/man3/threewaymerge.hpp.3elektra*
37555a25 693%{_mandir}/man3/toolexcept.hpp.3elektra*
088942e6
JB
694
695%if %{with glib}
696%files glib
697%defattr(644,root,root,755)
698%attr(755,root,root) %{_libdir}/libgelektra-4.0.so
699%{_libdir}/girepository-1.0/GElektra-4.0.typelib
700
701%files glib-devel
702%defattr(644,root,root,755)
703%{_datadir}/gir-1.0/GElektra-4.0.gir
704%{_includedir}/elektra/gelektra-*.h
705%{_pkgconfigdir}/gelektra-4.0.pc
706%endif
707
c89b1889
JB
708%if %{with java}
709%files -n java-elektra
710%defattr(644,root,root,755)
a0e8445f
JB
711%{_javadir}/libelektra-1.jar
712%{_javadir}/libelektra.jar
c89b1889
JB
713%endif
714
088942e6
JB
715%if %{with lua}
716%files -n lua-elektra
717%defattr(644,root,root,755)
718%attr(755,root,root) %{_libdir}/lua/5.2/kdb.so
719
720%if %{with glib}
721%files -n lua-elektra-glib
722%defattr(644,root,root,755)
723%dir %{_datadir}/lua/5.2/lgi
724%dir %{_datadir}/lua/5.2/lgi/override
725%{_datadir}/lua/5.2/lgi/override/GElektra.lua
726%endif
727%endif
728
729%if %{with python2}
730%files -n python-elektra
731%defattr(644,root,root,755)
732%attr(755,root,root) %{py_sitedir}/_kdb.so
733%{py_sitedir}/kdb.py[co]
734%endif
735
736%if %{with python3}
737%files -n python3-elektra
738%defattr(644,root,root,755)
739%attr(755,root,root) %{py3_sitedir}/_kdb.so
740%{py3_sitedir}/kdb.py
741%{py3_sitedir}/__pycache__/kdb.cpython-*.py[co]
742
743%if %{with glib}
744%files -n python3-elektra-glib
745%defattr(644,root,root,755)
746%{py3_sitedir}/gi/overrides/GElektra.py
747%{py3_sitedir}/gi/overrides/__pycache__/GElektra.cpython-*.py[co]
748%endif
749%endif
This page took 0.202732 seconds and 4 git commands to generate.