]> git.pld-linux.org Git - packages/eigen3.git/blame - eigen3.spec
- subpackage with python pretty printers for gdb added
[packages/eigen3.git] / eigen3.spec
CommitLineData
63a0bbb0
BS
1#
2# Conditional build:
3%bcond_with tests
4%bcond_without gdb # GDB pretty printers
5
86cdc95d
JB
6Summary: C++ template library for linear algebra
7Summary(pl.UTF-8): Biblioteka szablonów C++ do algebry liniowej
8Name: eigen3
46a7de9a 9Version: 3.2.4
63a0bbb0 10Release: 1
86cdc95d
JB
11License: LGPL v3+ or GPL v2+
12Group: Development/Libraries
3859e214 13#Source0Download: http://eigen.tuxfamily.org/index.php?title=Main_Page
fd4e6ee4 14Source0: https://bitbucket.org/eigen/eigen/get/%{version}.tar.bz2
46a7de9a 15# Source0-md5: 4c4b5ed9a388a1e475166d575af25477
86cdc95d
JB
16Patch0: %{name}-buildtype.patch
17URL: http://eigen.tuxfamily.org/
46a7de9a 18BuildRequires: cmake >= 2.8.2
63a0bbb0 19%{?with_gdb:BuildRequires: python-modules}
86cdc95d
JB
20BuildRequires: rpmbuild(macros) >= 1.605
21Requires: libstdc++-devel
22BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24%description
25Eigen is a C++ template library for linear algebra: vectors, matrices,
26and related algorithms. It is versatile, fast, elegant and
27compiler-friendly.
28
29Eigen handles, without code duplication and in a completely integrated
30way:
31 - both fixed-size and dynamic-size matrices and vectors
32 - both dense and sparse (the latter is still experimental) matrices
33 and vectors
34 - both plain matrices/vectors and abstract expressions
35 - both column-major (the default) and row-major matrix storage
36 - both basic matrix/vector manipulation and many more advanced,
37 specialized modules providing algorithms for linear algebra,
38 geometry, quaternions, or advanced array manipulation.
39
40%description -l pl.UTF-8
41Eigen to biblioteka szablonów C++ do algebry liniowej: wektorów,
42macierzy i związanych z nimi algorytmów. Jest elastyczna, szybka,
43elegancka i przyjazna dla kompilatorów.
44
45Obsługuje bez powielania kodu i w całkowicie zintegrowany sposób:
46 - macierze i wektory o stałym i dynamicznym rozmiarze
47 - macierze i wektory gęste i rzadkie (te drugie jeszcze
48 eksperymentalnie)
49 - zwykłe macierze/wektory jak i abstrakcyjne wyrażenia
50 - przechowywanie danych kolumnowe (domyślne) oraz wierszowe
51 - podstawowe operacje na macierzach/wektorach, jak i wiele
52 bardziej zaawansowanych, specjalizowanych modułów z algorytmami
53 algebry liniowej, geometrii, kwaternionów i zaawansowanych operacji
54 na tablicach.
55
63a0bbb0
BS
56%package gdb
57Summary: eigen3 pretty printers for GDB
58Summary(pl.UTF-8): Funkcje wypisujące dane eigen3 dla GDB
59Group: Development/Debuggers
60
61%description gdb
62This package contains Python scripts for GDB pretty printing of the
63eigen3 types/containers.
64To use it add:
65
66python
67from eigen3.printers import register_eigen_printers
68register_eigen_printers (None)
69end
70
71to a ~/.gdbinit file.
72
73%description gdb -l pl.UTF-8
74Ten pakiet zawiera skrypty Pythona dla GDB służące do ładnego
75wypisywania typów i kontenerów eigen3.
76Aby użyć skryptów trzeba dodać:
77
78python
79from eigen3.printers import register_eigen_printers
80register_eigen_printers (None)
81end
82
83do pliku ~/.gdbinit .
84
86cdc95d 85%prep
46a7de9a 86%setup -q -n eigen-eigen-10219c95fe65
86cdc95d
JB
87%patch0 -p1
88
89%build
90install -d build
91cd build
92%cmake .. \
93 -DCMAKE_CXX_COMPILER_WORKS=1 \
46a7de9a 94 -DCMAKE_CXX_COMPILER="%{__cxx}"
86cdc95d
JB
95
96%{__make}
97
63a0bbb0
BS
98%if %{with tests}
99%{__make} check 2>&1 ||:
100%endif
101
86cdc95d
JB
102%install
103rm -rf $RPM_BUILD_ROOT
104
105%{__make} -C build install \
106 DESTDIR=$RPM_BUILD_ROOT
107
63a0bbb0
BS
108%if %{with gdb}
109install -D debug/gdb/printers.py $RPM_BUILD_ROOT%{_datadir}/gdb/python/%{name}/printers.py
110touch $RPM_BUILD_ROOT%{_datadir}/gdb/python/%{name}/__init__.py
111%py_comp $RPM_BUILD_ROOT%{_datadir}/gdb/python/%{name}
112%py_ocomp $RPM_BUILD_ROOT%{_datadir}/gdb/python/%{name}
113%py_postclean %{_datadir}/gdb/python/%{name}
114%endif
115
86cdc95d
JB
116%clean
117rm -rf $RPM_BUILD_ROOT
118
119%files
120%defattr(644,root,root,755)
121%{_includedir}/eigen3
122%{_npkgconfigdir}/eigen3.pc
63a0bbb0
BS
123
124%if %{with gdb}
125%files gdb
126%defattr(644,root,root,755)
127%{_datadir}/gdb/python/%{name}
128%endif
This page took 0.074501 seconds and 4 git commands to generate.