]> git.pld-linux.org Git - packages/dropbox.git/blame - dropbox.spec
up to 57.4.89
[packages/dropbox.git] / dropbox.spec
CommitLineData
eec680ba
ER
1# TODO
2# - avoid dropboxd relaunching itself with newer version if there's update available (disable auto updating):
3# glen 25034 19.9 1.5 1496132 81256 pts/46 Sl+ 11:02 1:02 /home/glen/.dropbox-dist/dropbox /newerversion
9dd470b7
ER
4# NOTES:
5# - Upstream Dropbox Support (https://www.dropbox.com/ticket)
77d2e1b5 6# - Release Notes (check new versions here): https://www.dropbox.com/release_notes
9dd470b7 7# - Download instructions (click the download link to find current version):
14bae0cf 8# http://www.dropbox.com/downloading?os=lnx
84f5c3ef 9# http://wiki.dropbox.com/TipsAndTricks/TextBasedLinuxInstall
da4b87b9
ER
10Summary: Sync and backup files between computers
11Name: dropbox
d78295a9 12# https://www.dropboxforum.com/hc/en-us/community/posts/206682016-New-Versioning-Scheme
6cecb0b6 13Version: 57.4.89
7f499e9b 14Release: 1
da4b87b9
ER
15License: Proprietary
16Group: Daemons
6cecb0b6
ER
17Source0: https://clientupdates.dropboxstatic.com/dbx-releng/client/%{name}-lnx.x86-%{version}.tar.gz
18# NoSource0-md5: 588d447e23c863610c187edb06ad00cd
da4b87b9 19NoSource: 0
6cecb0b6
ER
20Source1: https://clientupdates.dropboxstatic.com/dbx-releng/client/%{name}-lnx.x86_64-%{version}.tar.gz
21# NoSource1-md5: 4db20dc1a388d8a7b5dd08d11f7ea2db
da4b87b9 22NoSource: 1
6cecb0b6 23URL: https://www.dropbox.com/
da4b87b9
ER
24BuildRequires: rpmbuild(macros) >= 1.566
25BuildRequires: sed >= 4.0
26BuildRequires: tar >= 1:1.15.1
6b9a4628 27BuildRequires: unzip
5fe51dfe 28BuildRequires: zip
8c0a6f53 29Conflicts: nautilus-dropbox < 0.6.3-2
da4b87b9
ER
30ExclusiveArch: %{ix86} %{x8664}
31BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33# generate no Provides from private modules
34%define _noautoprovfiles %{_libdir}/%{name}
35
6cecb0b6 36# libicu-42, but pld th already has 59+
d4b9c773
ER
37%define icu_libs libicudata.so.42 libicui18n.so.42 libicuuc.so.42
38
da4b87b9 39# provided by package itself, but autodeps disabled
38baf4d5 40%define _noautoreq libwx_.*.so %{icu_libs} libffi.so.6 librsync.so.1
da4b87b9
ER
41
42# a zip and executable at the same time
43%define _noautostrip .*/library.zip\\|.*/dropbox
44
45# debuginfo wouldn't be useful
46%define _enable_debug_packages 0
47
b70c96ae 48# prelinked library, it is missing some cairo symbols
d4b9c773 49#define skip_post_check_so libwx_gtk2ud_core-2.8.so.0
b70c96ae 50
da4b87b9
ER
51%description
52Dropbox is software that syncs your files online and across your
53computers.
54
55Put your files into your Dropbox on one computer, and they'll be
56instantly available on any of your other computers that you've
57installed Dropbox on (Windows, Mac, and Linux too!) Because a copy of
58your files are stored on Dropbox's secure servers, you can also access
59them from any computer or mobile device using the Dropbox website.
60
eec680ba
ER
61%package gui
62Summary: Gtk+2 GUI of Dropbox
63Group: X11/Applications
64Requires: %{name} = %{version}-%{release}
65
66%description gui
67Gtk+2 Systray of Dropbox Daemon status.
68
da4b87b9
ER
69%prep
70%setup -qcT
71%ifarch %{ix86}
72%{__tar} --strip-components=1 -xzf %{SOURCE0}
73%endif
74%ifarch %{x8664}
75%{__tar} --strip-components=1 -xzf %{SOURCE1}
76%endif
27fd1422 77mv dropbox-lnx.*-%{version}/* .
da4b87b9 78
84f5c3ef 79# no need to package this
284b53dc
ER
80# altho system python is also 2.7, don't know how to enforce using it system libs
81#%{__rm} -r distribute-0.6.26-py2.7.egg
77d2e1b5
ER
82
83# libraries to be taken from system
d78295a9 84# for a in *.so*; do ls -ld /lib64/$a /us?/lib64/$a; done 2>/dev/null
2033761e 85%{__rm} libpopt.so.0 libdrm.so.2 libGL.so.1
3893feea 86%{__rm} libffi.so.6
d78295a9
ER
87%{__rm} libX11-xcb.so.1
88%{__rm} libQt5{Core,DBus,Gui,Network,OpenGL,PrintSupport,Qml,Quick,Sql,WebKit,WebKitWidgets,Widgets,XcbQpa}.so.5
89%{__rm} qt.conf
90%{__rm} -r plugins
84f5c3ef 91
3893feea 92# keep librsync, won't finish syncing if not using upstream copy
5dd25d12 93test -f librsync.so.1
3893feea 94
6cecb0b6 95%if 1
84f5c3ef 96# fun, let's delete non-linux files from archive
6cecb0b6 97unzip -l python-packages-35.zip | \
8669a5fc
ER
98 grep -E '(arch|dropbox)/(mac|win32)|_(win32|mac)\.py|pymac|ui/cocoa|unittest' | \
99 grep -vE 'pymac/(__init__|constants|types|lazydll|lazyframework)\.py' | \
100 grep -vE 'dropbox/mac/(version|__init__).py' | \
9ece03ce 101 awk '{print $NF}' > lib.delete
6cecb0b6
ER
102zip python-packages-35.zip -d $(cat lib.delete)
103rm lib.delete
104%endif
bd07dff0 105
da4b87b9
ER
106%install
107rm -rf $RPM_BUILD_ROOT
108install -d $RPM_BUILD_ROOT%{_bindir}
77d2e1b5 109ln -s %{_libdir}/%{name}/dropboxd $RPM_BUILD_ROOT%{_bindir}/dropboxd
da4b87b9
ER
110
111# install everything else
77d2e1b5
ER
112install -d $RPM_BUILD_ROOT%{_libdir}/%{name}
113cp -a . $RPM_BUILD_ROOT%{_libdir}/%{name}
da4b87b9
ER
114
115# in doc
77d2e1b5 116%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/{ACKNOWLEDGEMENTS,VERSION,README}
da4b87b9
ER
117
118%clean
119rm -rf $RPM_BUILD_ROOT
120
121%files
122%defattr(644,root,root,755)
14bae0cf 123%doc ACKNOWLEDGEMENTS VERSION README
da4b87b9 124%attr(755,root,root) %{_bindir}/dropboxd
77d2e1b5 125%dir %{_libdir}/%{name}
6cecb0b6 126%attr(755,root,root) %{_libdir}/%{name}/*-linux-gnu.so
77d2e1b5
ER
127%attr(755,root,root) %{_libdir}/%{name}/dropbox
128%attr(755,root,root) %{_libdir}/%{name}/dropboxd
6cecb0b6
ER
129%attr(755,root,root) %{_libdir}/%{name}/libdropbox_sqlite_ext.so
130%attr(755,root,root) %{_libdir}/%{name}/libicudata.so.*
131%attr(755,root,root) %{_libdir}/%{name}/libicui18n.so.*
132%attr(755,root,root) %{_libdir}/%{name}/libicuuc.so.*
133%attr(755,root,root) %{_libdir}/%{name}/librsync.so.1
134%{_libdir}/%{name}/python-packages-*.zip
77d2e1b5 135
dbd4f1f7
ER
136# need +x bits for .so files
137%defattr(-,root,root,-)
dbd4f1f7 138
d4b9c773
ER
139# GUI parts
140%exclude %{_libdir}/%{name}/PyQt5.*.so
eec680ba
ER
141
142%files gui
143%defattr(644,root,root,755)
d4b9c773 144%attr(755,root,root) %{_libdir}/%{name}/PyQt5.*.so
6cecb0b6 145%attr(755,root,root) %{_libdir}/%{name}/wmctrl
77d2e1b5
ER
146%dir %{_libdir}/%{name}/images
147%{_libdir}/%{name}/images/emblems
148%{_libdir}/%{name}/images/hicolor
e2a81b70 149%{_libdir}/%{name}/resources
This page took 0.058294 seconds and 4 git commands to generate.