]> git.pld-linux.org Git - packages/dropbox.git/blame - dropbox.spec
Package libffi.so.6
[packages/dropbox.git] / dropbox.spec
CommitLineData
eec680ba
ER
1# TODO
2# - avoid dropboxd relaunching itself with newer version if there's update available (disable auto updating):
3# glen 25034 19.9 1.5 1496132 81256 pts/46 Sl+ 11:02 1:02 /home/glen/.dropbox-dist/dropbox /newerversion
9dd470b7
ER
4# NOTES:
5# - Upstream Dropbox Support (https://www.dropbox.com/ticket)
77d2e1b5 6# - Release Notes (check new versions here): https://www.dropbox.com/release_notes
9dd470b7 7# - Download instructions (click the download link to find current version):
14bae0cf 8# http://www.dropbox.com/downloading?os=lnx
84f5c3ef 9# http://wiki.dropbox.com/TipsAndTricks/TextBasedLinuxInstall
da4b87b9
ER
10Summary: Sync and backup files between computers
11Name: dropbox
d78295a9 12# https://www.dropboxforum.com/hc/en-us/community/posts/206682016-New-Versioning-Scheme
f2abb7e5 13Version: 89.4.278
2c70e7ec 14Release: 2
da4b87b9
ER
15License: Proprietary
16Group: Daemons
6cecb0b6 17Source0: https://clientupdates.dropboxstatic.com/dbx-releng/client/%{name}-lnx.x86-%{version}.tar.gz
f2abb7e5 18# NoSource0-md5: c8f19efec158b4aec27ac65aea4b2c95
da4b87b9 19NoSource: 0
6cecb0b6 20Source1: https://clientupdates.dropboxstatic.com/dbx-releng/client/%{name}-lnx.x86_64-%{version}.tar.gz
f2abb7e5 21# NoSource1-md5: 2c285eeeec6c95f68b4082e1f60b1fe6
da4b87b9 22NoSource: 1
6cecb0b6 23URL: https://www.dropbox.com/
da4b87b9
ER
24BuildRequires: rpmbuild(macros) >= 1.566
25BuildRequires: sed >= 4.0
26BuildRequires: tar >= 1:1.15.1
6b9a4628 27BuildRequires: unzip
5fe51dfe 28BuildRequires: zip
8c0a6f53 29Conflicts: nautilus-dropbox < 0.6.3-2
da4b87b9
ER
30ExclusiveArch: %{ix86} %{x8664}
31BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33# generate no Provides from private modules
34%define _noautoprovfiles %{_libdir}/%{name}
35
6cecb0b6 36# libicu-42, but pld th already has 59+
d4b9c773
ER
37%define icu_libs libicudata.so.42 libicui18n.so.42 libicuuc.so.42
38
da4b87b9 39# provided by package itself, but autodeps disabled
f2abb7e5 40%define _noautoreq libwx_.*.so %{icu_libs} libffi.so.6 librsync.so.1 libdropbox_apex.so libdropbox_nucleus.so libdropbox_tprt.so
da4b87b9
ER
41
42# a zip and executable at the same time
43%define _noautostrip .*/library.zip\\|.*/dropbox
44
45# debuginfo wouldn't be useful
46%define _enable_debug_packages 0
47
b70c96ae 48# prelinked library, it is missing some cairo symbols
d4b9c773 49#define skip_post_check_so libwx_gtk2ud_core-2.8.so.0
b70c96ae 50
da4b87b9
ER
51%description
52Dropbox is software that syncs your files online and across your
53computers.
54
55Put your files into your Dropbox on one computer, and they'll be
56instantly available on any of your other computers that you've
57installed Dropbox on (Windows, Mac, and Linux too!) Because a copy of
58your files are stored on Dropbox's secure servers, you can also access
59them from any computer or mobile device using the Dropbox website.
60
eec680ba
ER
61%package gui
62Summary: Gtk+2 GUI of Dropbox
63Group: X11/Applications
64Requires: %{name} = %{version}-%{release}
65
66%description gui
67Gtk+2 Systray of Dropbox Daemon status.
68
da4b87b9
ER
69%prep
70%setup -qcT
71%ifarch %{ix86}
72%{__tar} --strip-components=1 -xzf %{SOURCE0}
73%endif
74%ifarch %{x8664}
75%{__tar} --strip-components=1 -xzf %{SOURCE1}
76%endif
27fd1422 77mv dropbox-lnx.*-%{version}/* .
da4b87b9 78
84f5c3ef 79# no need to package this
284b53dc
ER
80# altho system python is also 2.7, don't know how to enforce using it system libs
81#%{__rm} -r distribute-0.6.26-py2.7.egg
77d2e1b5
ER
82
83# libraries to be taken from system
d78295a9 84# for a in *.so*; do ls -ld /lib64/$a /us?/lib64/$a; done 2>/dev/null
2033761e 85%{__rm} libpopt.so.0 libdrm.so.2 libGL.so.1
d78295a9
ER
86%{__rm} libX11-xcb.so.1
87%{__rm} libQt5{Core,DBus,Gui,Network,OpenGL,PrintSupport,Qml,Quick,Sql,WebKit,WebKitWidgets,Widgets,XcbQpa}.so.5
88%{__rm} qt.conf
89%{__rm} -r plugins
84f5c3ef 90
3893feea 91# keep librsync, won't finish syncing if not using upstream copy
5dd25d12 92test -f librsync.so.1
3893feea 93
6cecb0b6 94%if 1
84f5c3ef 95# fun, let's delete non-linux files from archive
5f7a680f 96d=.delete-lib.txt
f2abb7e5 97unzip -l python-packages.zip | \
8669a5fc
ER
98 grep -E '(arch|dropbox)/(mac|win32)|_(win32|mac)\.py|pymac|ui/cocoa|unittest' | \
99 grep -vE 'pymac/(__init__|constants|types|lazydll|lazyframework)\.py' | \
5f7a680f
ER
100 grep -vE 'dropbox/mac/(version|__init__)\.py' | \
101 grep -vF 'dropbox/client/features/files/local/operations/_mac.py' | \
102 awk '{print $NF}' > $d
f2abb7e5 103zip python-packages.zip -d $(cat $d)
6cecb0b6 104%endif
bd07dff0 105
da4b87b9
ER
106%install
107rm -rf $RPM_BUILD_ROOT
108install -d $RPM_BUILD_ROOT%{_bindir}
77d2e1b5 109ln -s %{_libdir}/%{name}/dropboxd $RPM_BUILD_ROOT%{_bindir}/dropboxd
da4b87b9
ER
110
111# install everything else
77d2e1b5 112install -d $RPM_BUILD_ROOT%{_libdir}/%{name}
5f7a680f 113cp -a * $RPM_BUILD_ROOT%{_libdir}/%{name}
da4b87b9
ER
114
115# in doc
77d2e1b5 116%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/{ACKNOWLEDGEMENTS,VERSION,README}
da4b87b9
ER
117
118%clean
119rm -rf $RPM_BUILD_ROOT
120
121%files
122%defattr(644,root,root,755)
14bae0cf 123%doc ACKNOWLEDGEMENTS VERSION README
da4b87b9 124%attr(755,root,root) %{_bindir}/dropboxd
77d2e1b5 125%dir %{_libdir}/%{name}
6cecb0b6 126%attr(755,root,root) %{_libdir}/%{name}/*-linux-gnu.so
77d2e1b5
ER
127%attr(755,root,root) %{_libdir}/%{name}/dropbox
128%attr(755,root,root) %{_libdir}/%{name}/dropboxd
f2abb7e5 129%attr(755,root,root) %{_libdir}/%{name}/libatomic.so.1
08d27aed
ER
130%attr(755,root,root) %{_libdir}/%{name}/libdropbox_apex.so
131%attr(755,root,root) %{_libdir}/%{name}/libdropbox_nucleus.so
6cecb0b6 132%attr(755,root,root) %{_libdir}/%{name}/libdropbox_sqlite_ext.so
08d27aed 133%attr(755,root,root) %{_libdir}/%{name}/libdropbox_tprt.so
2c70e7ec 134%attr(755,root,root) %{_libdir}/%{name}/libffi.so.6
6cecb0b6
ER
135%attr(755,root,root) %{_libdir}/%{name}/libicudata.so.*
136%attr(755,root,root) %{_libdir}/%{name}/libicui18n.so.*
137%attr(755,root,root) %{_libdir}/%{name}/libicuuc.so.*
138%attr(755,root,root) %{_libdir}/%{name}/librsync.so.1
f2abb7e5 139%{_libdir}/%{name}/python-packages.zip
77d2e1b5 140
dbd4f1f7
ER
141# need +x bits for .so files
142%defattr(-,root,root,-)
dbd4f1f7 143
d4b9c773
ER
144# GUI parts
145%exclude %{_libdir}/%{name}/PyQt5.*.so
eec680ba
ER
146
147%files gui
148%defattr(644,root,root,755)
d4b9c773 149%attr(755,root,root) %{_libdir}/%{name}/PyQt5.*.so
6cecb0b6 150%attr(755,root,root) %{_libdir}/%{name}/wmctrl
77d2e1b5
ER
151%dir %{_libdir}/%{name}/images
152%{_libdir}/%{name}/images/emblems
153%{_libdir}/%{name}/images/hicolor
e2a81b70 154%{_libdir}/%{name}/resources
This page took 0.157124 seconds and 4 git commands to generate.