]> git.pld-linux.org Git - packages/dpkg.git/blame - dpkg.spec
disable alternatives, add bcond
[packages/dpkg.git] / dpkg.spec
CommitLineData
4f40d504
ER
1#
2# Conditional build:
3%bcond_with alternatives # build alternatives package
4
1c3e1c0e 5%include /usr/lib/rpm/macros.perl
aea5b33f 6Summary: Package maintenance system for Debian Linux
b81e7419 7Summary(pl.UTF-8): Program do obsługi pakietów Debiana
aea5b33f 8Name: dpkg
8d2420e2 9Version: 1.18.4
4f40d504 10Release: 3
99403999 11License: GPL v2+
71d0ff61 12Group: Applications/File
3477ad18 13Source0: ftp://ftp.debian.org/debian/pool/main/d/dpkg/%{name}_%{version}.tar.xz
8d2420e2 14# Source0-md5: e95b513c89693f6ec3ab53b6b1c3defd
42d55ea9 15Patch0: %{name}-md5.patch
99403999 16URL: http://packages.debian.org/search?keywords=dpkg
dcaefd63 17BuildRequires: bzip2-devel
abb5ca11 18BuildRequires: gettext-tools >= 0.18.2
dcaefd63 19BuildRequires: libselinux-devel
dc9ed1c4 20BuildRequires: perl-tools-pod
1c3e1c0e 21BuildRequires: pkgconfig
1c3e1c0e 22BuildRequires: rpm-perlprov
1750f640 23BuildRequires: rpmbuild(macros) >= 1.654
3477ad18
JB
24BuildRequires: tar >= 1:1.22
25BuildRequires: xz
26BuildRequires: xz-devel
589726b5 27BuildRequires: zlib-devel
80622688 28Requires: perl-base
607070d7 29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
aea5b33f 30
392fa822 31# blacklist false positives
c4540769 32%define _noautoreq_perl extra file in Tie::ExtraHash
392fa822 33
aea5b33f 34%description
99403999
JB
35This package contains the programs to handle deb packages known from
36Debian.
aea5b33f 37
f8701fb4
JR
38%description -l pl.UTF-8
39Ten pakiet zawiera narzędzia do obsługi pakietów deb znanych z
71d0ff61 40Debiana.
289d26c0 41
99403999
JB
42%package -n libdpkg-devel
43Summary: dpkg library and header files
44Summary(pl.UTF-8): Biblioteka i pliki nagłówkowe dpkg
45Group: Development/Libraries
184a11e8
JB
46Requires: bzip2-devel
47Requires: xz-devel
48Requires: zlib-devel
99403999
JB
49
50%description -n libdpkg-devel
51dpkg library and header files.
52
53%description -n libdpkg-devel -l pl.UTF-8
54Biblioteka i pliki nagłówkowe dpkg.
55
1750f640
ER
56%package alternatives
57Summary: Maintain symbolic links determining default commands
58Summary(pl.UTF-8): Utrzymywanie dowiązań symbolicznych określających domyślne polecenia
59Group: Applications/System
60Requires: %{name} = %{version}-%{release}
61
62%description alternatives
63alternatives creates, removes, maintains and displays information
64about the symbolic links comprising the alternatives system. The
65alternatives system is a reimplementation of the Debian alternatives
66system.
67
68%description alternatives -l pl.UTF-8
69alternatives tworzy, usuwa, utrzymuje i wyświetla informacje o
70dowiązaniach symbolicznych obejmujących system alternatyw. System
71alternatyw to reimplementacja systemu alternatyw ("alternatives") z
72Debiana.
73
aea5b33f
JR
74%prep
75%setup -q
42d55ea9 76%patch0 -p1
aea5b33f
JR
77
78%build
663dd486
JB
79# "ac_cv_header_md5_h=no" to disable error on md5.h from libmd5
80# (dpkg expects this header from FreeBSD-compatible libmd, having different API)
71d0ff61 81%configure \
663dd486 82 ac_cv_header_md5_h=no \
e2582a24 83 PO4A="true" \
3477ad18 84 --disable-dselect \
4f40d504 85 %{!?with_alternatives:--disable-update-alternatives} \
99403999 86 --disable-silent-rules \
3477ad18 87 --disable-start-stop-daemon \
99403999 88 --with-admindir=/var/lib/%{name}
aea5b33f 89
dcaefd63 90%{__make}
aea5b33f
JR
91
92%install
93rm -rf $RPM_BUILD_ROOT
aea5b33f
JR
94%{__make} install \
95 DESTDIR=$RPM_BUILD_ROOT
96
4f40d504 97%if %{with alternatives}
99403999 98%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/alternatives/README
4f40d504 99%endif
47be6b2f 100
ddae01a5
JB
101# obsoleted by pkg-config
102%{__rm} $RPM_BUILD_ROOT%{_libdir}/libdpkg.la
103
99403999
JB
104# dpkg for main part, dpkg-dev for perl-based build script
105# don't use --all-name to avoid e.g. dselect inclusion
aea5b33f 106%find_lang dpkg
99403999
JB
107%find_lang dpkg-dev
108cat dpkg-dev.lang >>dpkg.lang
aea5b33f
JR
109
110%clean
111rm -rf $RPM_BUILD_ROOT
112
113%files -f dpkg.lang
114%defattr(644,root,root,755)
99403999 115%doc AUTHORS ChangeLog README THANKS TODO
aea5b33f 116%attr(755,root,root) %{_bindir}/dpkg*
47be6b2f 117%dir %{_sysconfdir}/dpkg
99403999 118%dir %{_sysconfdir}/dpkg/dpkg.cfg.d
47be6b2f 119
aea5b33f 120%dir %{_libdir}/dpkg
aea5b33f 121%dir %{_libdir}/dpkg/parsechangelog
47be6b2f 122%attr(755,root,root) %{_libdir}/dpkg/parsechangelog/debian
47be6b2f 123%dir %{_datadir}/dpkg
fa52672c 124%{_datadir}/dpkg/abitable
47be6b2f
ER
125%{_datadir}/dpkg/cputable
126%{_datadir}/dpkg/ostable
127%{_datadir}/dpkg/triplettable
3e75a3a3 128%{_datadir}/dpkg/*.mk
99403999
JB
129
130%{perl_vendorlib}/Dpkg.pm
d52c6c83 131%{perl_vendorlib}/Dpkg
47be6b2f 132
aea5b33f 133%dir /var/lib/dpkg
99403999
JB
134%dir /var/lib/dpkg/info
135%dir /var/lib/dpkg/parts
136%dir /var/lib/dpkg/updates
137
138%{_mandir}/man1/dpkg*.1*
b8a00aaf 139%{_mandir}/man3/Dpkg.3*
99403999
JB
140%{_mandir}/man3/Dpkg::*.3*
141%{_mandir}/man5/deb*.5*
142%{_mandir}/man5/dpkg.cfg.5*
99403999
JB
143%lang(de) %{_mandir}/de/man1/dpkg*.1*
144%lang(de) %{_mandir}/de/man5/deb*.5*
145%lang(de) %{_mandir}/de/man5/dpkg.cfg.5*
99403999
JB
146%lang(es) %{_mandir}/es/man1/dpkg*.1*
147%lang(es) %{_mandir}/es/man5/deb*.5*
148%lang(es) %{_mandir}/es/man5/dpkg.cfg.5*
99403999
JB
149%lang(fr) %{_mandir}/fr/man1/dpkg*.1*
150%lang(fr) %{_mandir}/fr/man5/deb*.5*
151%lang(fr) %{_mandir}/fr/man5/dpkg.cfg.5*
99403999 152%lang(hu) %{_mandir}/hu/man5/dpkg.cfg.5*
42d55ea9
JB
153%lang(it) %{_mandir}/it/man1/dpkg*.1*
154%lang(it) %{_mandir}/it/man5/deb*.5*
155%lang(it) %{_mandir}/it/man5/dpkg.cfg.5*
3e75a3a3
JB
156%lang(ja) %{_mandir}/ja/man1/dpkg*.1*
157%lang(ja) %{_mandir}/ja/man5/deb*.5*
158%lang(ja) %{_mandir}/ja/man5/dpkg.cfg.5*
99403999
JB
159%lang(pl) %{_mandir}/pl/man1/dpkg*.1*
160%lang(pl) %{_mandir}/pl/man5/deb*.5*
161%lang(pl) %{_mandir}/pl/man5/dpkg.cfg.5*
99403999
JB
162%lang(sv) %{_mandir}/sv/man1/dpkg*.1*
163%lang(sv) %{_mandir}/sv/man5/deb*.5*
164%lang(sv) %{_mandir}/sv/man5/dpkg.cfg.5*
99403999
JB
165
166%files -n libdpkg-devel
167%defattr(644,root,root,755)
168%{_libdir}/libdpkg.a
169%{_includedir}/dpkg
170%{_pkgconfigdir}/libdpkg.pc
1750f640 171
4f40d504 172%if %{with alternatives}
1750f640
ER
173%files alternatives
174%defattr(644,root,root,755)
175%dir %{_sysconfdir}/alternatives
176%attr(755,root,root) %{_bindir}/update-alternatives
177%{_mandir}/man1/update-alternatives.1*
178%lang(de) %{_mandir}/de/man1/update-alternatives.1*
179%lang(es) %{_mandir}/es/man1/update-alternatives.1*
180%lang(fr) %{_mandir}/fr/man1/update-alternatives.1*
181%lang(it) %{_mandir}/it/man1/update-alternatives.1*
182%lang(ja) %{_mandir}/ja/man1/update-alternatives.1*
183%lang(pl) %{_mandir}/pl/man1/update-alternatives.1*
184%lang(sv) %{_mandir}/sv/man1/update-alternatives.1*
4f40d504
ER
185%dir /var/lib/dpkg/alternatives
186%endif
This page took 0.433756 seconds and 4 git commands to generate.