]> git.pld-linux.org Git - packages/doomsday.git/blame - doomsday.spec
track only sonames, glob the rest
[packages/doomsday.git] / doomsday.spec
CommitLineData
1748e707 1# TODO
96e1b283 2# - sync pl
9d6c2050 3# - clean up spec. cleanup what?
65f3387c 4%define subver stable
613b8bc6 5Summary: jDoom, jHeretic and jHexen for Linux
5398b956 6Summary(pl.UTF-8): jDoom, jHeretic i jHexen dla Linuksa
613b8bc6 7Name: doomsday
65f3387c
LM
8Version: 1.15.4
9Release: 0.1
a4a33ef2 10License: GPL v2 / CC 3.0 (icons)
613b8bc6 11Group: Applications/Games
65f3387c
LM
12Source0: http://downloads.sourceforge.net/deng/%{name}-%{subver}-%{version}.tar.gz
13# Source0-md5: 8329eacdea73edca7aea4034ca8d78aa
a4a33ef2 14Source1: http://www.iconarchive.com/icons/3xhumed/mega-games-pack-26/Doom-1-48x48.png
76bc3a41 15# Source1-md5: b7b7a9389eba56679e5db65d95c06803
a4a33ef2 16Source2: http://www.iconarchive.com/icons/3xhumed/mega-games-pack-23/Hexen-1-48x48.png
76bc3a41 17# Source2-md5: 573845e6e747f68617ac67f3a87dc78e
a4a33ef2 18Source3: http://www.iconarchive.com/icons/3xhumed/mega-games-pack-28/Heretic-I-1-48x48.png
76bc3a41 19# Source3-md5: c89e36c49eabe2846137f313a5250308
9d6c2050 20#Patch0: %{name}-libpng15.patch
9f0bf5c3 21Patch1: %{name}-format.patch
96e1b283 22URL: http://www.dengine.net/
613b8bc6 23BuildRequires: OpenAL-devel
2a1961bd 24BuildRequires: OpenGL-GLU-devel
613b8bc6 25BuildRequires: OpenGL-devel
65f3387c
LM
26BuildRequires: SDL2-devel
27BuildRequires: SDL2_mixer-devel
28BuildRequires: qt4-qmake
29BuildRequires: assimp-devel
2a1961bd 30BuildRequires: curl-devel
8755e793 31BuildRequires: libpng-devel
32BuildRequires: ncurses-devel
33BuildRequires: python
34BuildRequires: python-modules
96e1b283 35BuildRequires: rpmbuild(macros) >= 1.595
85be4bea 36Requires(post): /sbin/ldconfig
663fb57e 37Requires: TiMidity++
613b8bc6 38BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
613b8bc6 40%description
96e1b283
ER
41The Doomsday Engine allows you to play the classic first-person
42shooters DOOM, Heretic, and Hexen using modern technology, with
43hardware accelerated 3D graphics, surround sound and much more.
613b8bc6 44
39e9285b 45%description -l pl.UTF-8
6f1050b2 46jDoom, jHeretic i jHexen dla Linuksa.
613b8bc6 47
48%prep
65f3387c
LM
49%setup -q -n doomsday-%{subver}-%{version}
50#%patch0 -p1
51#%patch1 -p1
613b8bc6 52
53%build
663fb57e
ER
54install -d build
55cd build
96e1b283 56LDFLAGS="-lm"
65f3387c
LM
57qmake-qt4 CONFIG+=deng_notools \
58 -r ../doomsday/doomsday.pro
613b8bc6 59%{__make}
60
61%install
62rm -rf $RPM_BUILD_ROOT
1748e707 63install -d $RPM_BUILD_ROOT%{_desktopdir}
9d6c2050
ER
64%{__make} -C build install \
65 INSTALL_ROOT=$RPM_BUILD_ROOT
613b8bc6 66
a4a33ef2 67install -d $RPM_BUILD_ROOT%{_pixmapsdir}
9d6c2050
ER
68cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_pixmapsdir}/doom.png
69cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}/hexen.png
70cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}/heretic.png
a4a33ef2 71
1748e707
ER
72cat <<EOF > $RPM_BUILD_ROOT%{_desktopdir}/%{name}-doom.desktop
73[Desktop Entry]
74Name=Doom
75Comment=Doom for linux
76Exec=doomsday -game jdoom
a4a33ef2 77Icon=doom.png
1748e707
ER
78Terminal=false
79Type=Application
f6ee92a4 80Categories=Game;FirstPersonGame;
1748e707 81Encoding=UTF-8
1748e707
ER
82EOF
83
84cat <<EOF > $RPM_BUILD_ROOT%{_desktopdir}/%{name}-hexen.desktop
85[Desktop Entry]
86Name=Hexen
87Comment=Hexen for linux
88Exec=doomsday -game jhexen
a4a33ef2 89Icon=hexen.png
1748e707
ER
90Terminal=false
91Type=Application
f6ee92a4 92Categories=Game;FirstPersonGame;
1748e707 93Encoding=UTF-8
1748e707
ER
94EOF
95
96cat <<EOF > $RPM_BUILD_ROOT%{_desktopdir}/%{name}-heretic.desktop
97[Desktop Entry]
98Name=Heretic
99Comment=Heretic for linux
100Exec=doomsday -game jheretic
a4a33ef2 101Icon=heretic.png
1748e707
ER
102Terminal=false
103Type=Application
f6ee92a4 104Categories=Game;FirstPersonGame;
1748e707 105Encoding=UTF-8
1748e707
ER
106EOF
107
613b8bc6 108%clean
6f1050b2 109rm -rf $RPM_BUILD_ROOT
613b8bc6 110
85be4bea
ER
111%post
112/sbin/ldconfig
96e1b283
ER
113%banner -o -e %{name} <<-EOF
114To run doomsday you need some WAD file: either freedoom package
115or some shareware or commercial WAD from Doom or Heretic:
116Doom.wad, Doom1.wad, Doom2.wad, Tnt.wad, Plutonia.wad,
117Heretic.wad or Heretic1.wad.
118When you have them, run doomsday with:
119doomsday -game [ jdoom | jheretic | jhexen ]
1748e707 120EOF
613b8bc6 121
65f3387c
LM
122%postun -p /sbin/ldconfig
123
613b8bc6 124%files
125%defattr(644,root,root,755)
65f3387c 126#%doc doomsday/build/README
613b8bc6 127%attr(755,root,root) %{_bindir}/doomsday
65f3387c
LM
128%attr(755,root,root) %{_bindir}/doomsday-server
129%attr(755,root,root) %{_bindir}/launch-doomsday
130
b72a2307 131%attr(755,root,root) %{_libdir}/libdeng_core.so.*.*.*
65f3387c 132%attr(755,root,root) %ghost %{_libdir}/libdeng_core.so.2
b72a2307 133%attr(755,root,root) %{_libdir}/libdeng_appfw.so.*.*.*
65f3387c 134%attr(755,root,root) %ghost %{_libdir}/libdeng_appfw.so.1
b72a2307 135%attr(755,root,root) %{_libdir}/libdeng_doomsday.so.*.*.*
65f3387c 136%attr(755,root,root) %ghost %{_libdir}/libdeng_doomsday.so.1
b72a2307 137%attr(755,root,root) %{_libdir}/libdeng_gui.so.*.*.*
65f3387c 138%attr(755,root,root) %ghost %{_libdir}/libdeng_gui.so.1
b72a2307 139%attr(755,root,root) %{_libdir}/libdeng_legacy.so.*.*.*
65f3387c 140%attr(755,root,root) %ghost %{_libdir}/libdeng_legacy.so.1
b72a2307 141%attr(755,root,root) %{_libdir}/libdeng_shell.so.*.*.*
65f3387c
LM
142%attr(755,root,root) %ghost %{_libdir}/libdeng_shell.so.1
143
144%{_libdir}/doomsday
145%{_datadir}/doomsday
1748e707 146%{_desktopdir}/*.desktop
a4a33ef2 147%{_pixmapsdir}/*.png
65f3387c 148%{_mandir}/man6/*
This page took 0.07547 seconds and 4 git commands to generate.