]> git.pld-linux.org Git - packages/docker-compose.git/blame - docker-compose.spec
Release 4 (by relup.sh)
[packages/docker-compose.git] / docker-compose.spec
CommitLineData
a4a04e42
ER
1#
2# Conditional build:
3%bcond_with tests # do not perform "make test"
4
390264ed
ER
5%define module compose
6%define egg_name docker_compose
0293309f 7%define pypi_name docker-compose
a4a04e42
ER
8Summary: Multi-container orchestration for Docker
9Name: docker-compose
0dd93762 10Version: 1.29.2
1985061d 11Release: 4
a4a04e42 12License: Apache v2.0
a4a04e42 13Group: Applications/System
1ea8eb34 14# https://github.com/docker/compose/releases
0293309f 15Source0: https://files.pythonhosted.org/packages/source/d/%{pypi_name}/%{pypi_name}-%{version}.tar.gz
0dd93762 16# Source0-md5: 95accbca655abf086a61b94d6c3d94ca
a4a04e42 17Patch0: remove-requires-upper-bound.patch
1ea8eb34 18URL: https://docs.docker.com/compose/
a4a04e42 19%if %{with tests}
0d46711e
JP
20BuildRequires: python3-PyYAML
21BuildRequires: python3-docker
22BuildRequires: python3-docopt
23BuildRequires: python3-paramiko
24BuildRequires: python3-requests
25BuildRequires: python3-setuptools
26BuildRequires: python3-texttable
27BuildRequires: python3-websocket-client
a4a04e42
ER
28%endif
29BuildRequires: rpm-pythonprov
30BuildRequires: rpmbuild(macros) >= 1.714
d412c73f 31Requires: docker(engine) >= 1.10.0
089a701d 32Requires: python3-docker >= 4.4.4
0d46711e
JP
33Requires: python3-paramiko >= 2.4.2
34Requires: python3-setuptools
a4a04e42
ER
35BuildArch: noarch
36BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38%description
39Multi-container orchestration for Docker
40
41Docker-compose allows you to:
42- Define your application's environment with Docker so it can be
43 reproduced anywhere.
44- Define the services that make up your app so they can be run
45 together in an isolated environment.
46- Run 'docker-compose up', and docker-compose will start and run your
47 entire app.
48
49%prep
50%setup -q
51%patch0 -p1
52
a4a04e42
ER
53rm -r docker_compose.egg-info
54
55%build
0d46711e 56%py3_build
a4a04e42
ER
57
58%install
59rm -rf $RPM_BUILD_ROOT
0d46711e 60%py3_install
a4a04e42
ER
61
62%clean
63rm -rf $RPM_BUILD_ROOT
64
65%files
66%defattr(644,root,root,755)
873d6b15 67%doc CHANGELOG.md CONTRIBUTING.md README.md SWARM.md LICENSE
a4a04e42 68%attr(755,root,root) %{_bindir}/%{name}
0d46711e
JP
69%{py3_sitescriptdir}/%{module}
70%{py3_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
This page took 0.101328 seconds and 4 git commands to generate.