]> git.pld-linux.org Git - packages/dnssec-tools.git/blame - dnssec-tools.spec
- updated to 2.1 (note: new sonames)
[packages/dnssec-tools.git] / dnssec-tools.spec
CommitLineData
bdde702d
JR
1# TODO:
2# - fix linking, it should link with just built, not with system, libs
b8f9ed2a
JB
3#
4# Conditional build:
5%bcond_without qt # Qt-based GUI tools
6#
d29da4dc
JB
7%include /usr/lib/rpm/macros.perl
8Summary: DNSSEC tools
9Summary(pl.UTF-8): Narzędzia DNSSEC
10Name: dnssec-tools
42a2d0d0
JB
11Version: 2.1
12Release: 1
d29da4dc 13License: BSD
e355058c 14Group: Applications/Networking
d29da4dc 15Source0: http://www.dnssec-tools.org/download/%{name}-%{version}.tar.gz
42a2d0d0 16# Source0-md5: b4c76b325c380780682a548730d3e09a
d29da4dc 17Patch0: %{name}-link.patch
b8f9ed2a 18Patch1: %{name}-qt.patch
d29da4dc
JB
19URL: http://www.dnssec-tools.org/
20BuildRequires: openssl-devel
21BuildRequires: perl-ExtUtils-MakeMaker
22BuildRequires: perl-Net-DNS
23BuildRequires: perl-Net-DNS-SEC
24BuildRequires: perl-TimeDate
25BuildRequires: perl-base
26BuildRequires: perl-devel >= 1:5.8.0
27BuildRequires: rpm-perlprov >= 4.1-13
b8f9ed2a 28%if %{with qt}
42a2d0d0
JB
29BuildRequires: Qt5Core-devel >= 5
30BuildRequires: Qt5Declarative-devel >= 5
31BuildRequires: Qt5Gui-devel >= 5
32BuildRequires: Qt5Network-devel >= 5
33BuildRequires: Qt5Qml-devel >= 5
34BuildRequires: Qt5Quick-devel >= 5
35BuildRequires: Qt5Svg-devel >= 5
36BuildRequires: Qt5Widgets-devel >= 5
37BuildRequires: Qt5Xml-devel >= 5
38BuildRequires: qt5-qmake >= 5
b8f9ed2a 39%endif
d29da4dc
JB
40Requires: %{name}-libs = %{version}-%{release}
41Requires: perl-%{name} = %{version}-%{release}
42BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44%description
45The goal of the DNSSEC-Tools project is to create a set of tools,
46patches, applications, wrappers, extensions, and plugins that will
47help ease the deployment of DNSSEC-related technologies.
48
49%description -l pl.UTF-8
50Celem projektu DNSSEC-Tools jest stworzenie zbioru narzędzi, łatek,
51aplikacji, wrapperów, rozszerzeń i wtyczek pomagających przy wdrażaniu
52technologii związanych z DNSSEC.
53
b8f9ed2a
JB
54%package gui
55Summary: DNSSEC tools with GUI
56Summary(pl.UTF-8): Narzędzia DNSSEC z GUI
57Group: X11/Applications
58Requires: %{name}-libs = %{version}-%{release}
59
60%description gui
61DNSSEC tools with Qt-based GUI: dnssec-check, dnssec-nodes,
62dnssec-system-tray and lookup.
63
64%description gui -l pl.UTF-8
65Narzędzia DNSSEC z opartym na Qt graficznym interfejsem użytkownika:
66dnssec-check, dnssec-nodes, dnssec-system-tray oraz lookup.
67
d29da4dc
JB
68%package libs
69Summary: DNSSEC libraries
70Summary(pl.UTF-8): Biblioteki DNSSEC
71Group: Libraries
72
73%description libs
74DNSSEC libraries.
75
76%description libs -l pl.UTF-8
77Biblioteki DNSSEC.
78
79%package devel
80Summary: Header files for DNSSEC libraries
81Summary(pl.UTF-8): Pliki nagłówkowe bibliotek DNSSEC
82Group: Development/Libraries
83Requires: %{name}-libs = %{version}-%{release}
84Requires: openssl-devel
85
86%description devel
87Header files for DNSSEC libraries.
88
89%description devel -l pl.UTF-8
90Pliki nagłówkowe bibliotek DNSSEC.
91
92%package static
93Summary: Static DNSSEC libraries
94Summary(pl.UTF-8): Statyczne biblioteki DNSSEC
95Group: Development/Libraries
96Requires: %{name}-devel = %{version}-%{release}
97
98%description static
99Static DNSSEC libraries.
100
101%description static -l pl.UTF-8
102Statyczne biblioteki DNSSEC.
103
104%package -n perl-%{name}
105Summary: Perl modules supporting DNSSEC
106Summary(pl.UTF-8): Moduły Perla wspierające DNSSEC
107Group: Development/Languages/Perl
108Requires: %{name}-libs = %{version}-%{release}
109Requires: perl-Net-DNS
110Requires: perl-Net-DNS-SEC
111
112%description -n perl-%{name}
113Perl modules supporting DNSSEC.
114
115%description -n perl-%{name} -l pl.UTF-8
116Moduły Perla wspierające DNSSEC.
117
118%prep
119%setup -q
120%patch0 -p1
b8f9ed2a 121%patch1 -p1
d29da4dc
JB
122
123%build
124%configure \
42a2d0d0 125 ac_cv_lib_nsl_inet_ntop=no \
d29da4dc
JB
126 --disable-bind-checks \
127 --with-dlv \
128 --with-ipv6 \
129 --with-nsec3 \
130 --with-perl-build-args='INSTALLDIRS=vendor'
131%{__make}
132
b8f9ed2a
JB
133%if %{with qt}
134cd validator/apps
135for d in dnssec-check dnssec-nodes dnssec-system-tray lookup ; do
136 cd $d
42a2d0d0
JB
137 qmake-qt5 \
138 PREFIX=%{_prefix} \
b8f9ed2a
JB
139 QMAKE_CXX="%{__cxx}" \
140 QMAKE_CXXFLAGS_RELEASE="%{rpmcxxflags}" \
141 QMAKE_LFLAGS_RELEASE="%{rpmldflags}"
142 %{__make}
143 cd ..
144done
145%endif
146
d29da4dc
JB
147%install
148rm -rf $RPM_BUILD_ROOT
d29da4dc
JB
149%{__make} -j1 install \
150 DESTDIR=$RPM_BUILD_ROOT
151
b8f9ed2a
JB
152%if %{with qt}
153for d in dnssec-check dnssec-nodes dnssec-system-tray lookup ; do
154 %{__make} install -C validator/apps/$d \
42a2d0d0 155 DESTDIR=$RPM_BUILD_ROOT \
b8f9ed2a
JB
156 INSTALL_ROOT=$RPM_BUILD_ROOT
157done
42a2d0d0
JB
158
159# omitted from make install
160install -Dp validator/apps/dnssec-check/images/dnssec-check-32x32.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/32x32/apps/dnssec-check.png
161install -Dp validator/apps/dnssec-check/images/dnssec-check-48x48.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/48x48/apps/dnssec-check.png
162install -Dp validator/apps/dnssec-check/images/dnssec-check-64x64.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/64x64/apps/dnssec-check.png
163install -Dp validator/apps/dnssec-check/images/dnssec-check-512.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/512x512/apps/dnssec-check.png
164install -Dp validator/apps/dnssec-check/images/dnssec-check.svg $RPM_BUILD_ROOT%{_iconsdir}/hicolor/scalable/apps/dnssec-check.svg
165sed -e 's,^Exec=.*,Exec=%{_bindir}/dnssec-check,' validator/apps/dnssec-check/dnssec-check.desktop >$RPM_BUILD_ROOT%{_desktopdir}/dnssec-check.desktop
b8f9ed2a
JB
166%endif
167
42a2d0d0
JB
168%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Net/DNS/SEC/examples.pl \
169 $RPM_BUILD_ROOT%{_mandir}/man3/Net::DNS::SEC::examples.3pm
d29da4dc
JB
170find $RPM_BUILD_ROOT%{perl_vendorarch}/auto -name .packlist | xargs -r %{__rm}
171
172%clean
173rm -rf $RPM_BUILD_ROOT
174
175%post libs -p /sbin/ldconfig
176%postun libs -p /sbin/ldconfig
177
178%files
179%defattr(644,root,root,755)
180%doc COPYING ChangeLog NEWS README
181%attr(755,root,root) %{_bindir}/blinkenlights
182%attr(755,root,root) %{_bindir}/bubbles
421c53e3
JB
183%attr(755,root,root) %{_bindir}/buildrealms
184%attr(755,root,root) %{_bindir}/check-zone-expiration
d29da4dc
JB
185%attr(755,root,root) %{_bindir}/cleanarch
186%attr(755,root,root) %{_bindir}/cleankrf
187%attr(755,root,root) %{_bindir}/convertar
188%attr(755,root,root) %{_bindir}/dnspktflow
189%attr(755,root,root) %{_bindir}/donuts
190%attr(755,root,root) %{_bindir}/donutsd
191%attr(755,root,root) %{_bindir}/drawvalmap
7c2c9caa 192%attr(755,root,root) %{_bindir}/dt-danechk
421c53e3
JB
193%attr(755,root,root) %{_bindir}/dt-getaddr
194%attr(755,root,root) %{_bindir}/dt-gethost
195%attr(755,root,root) %{_bindir}/dt-getname
196%attr(755,root,root) %{_bindir}/dt-getquery
197%attr(755,root,root) %{_bindir}/dt-getrrset
42a2d0d0 198%attr(755,root,root) %{_bindir}/dt-libval_check_conf
421c53e3 199%attr(755,root,root) %{_bindir}/dt-validate
d29da4dc
JB
200%attr(755,root,root) %{_bindir}/dtck
201%attr(755,root,root) %{_bindir}/dtconf
202%attr(755,root,root) %{_bindir}/dtconfchk
203%attr(755,root,root) %{_bindir}/dtdefs
204%attr(755,root,root) %{_bindir}/dtinitconf
421c53e3 205%attr(755,root,root) %{_bindir}/dtrealms
d29da4dc
JB
206%attr(755,root,root) %{_bindir}/expchk
207%attr(755,root,root) %{_bindir}/fixkrf
208%attr(755,root,root) %{_bindir}/genkrf
d29da4dc
JB
209%attr(755,root,root) %{_bindir}/getdnskeys
210%attr(755,root,root) %{_bindir}/getds
421c53e3 211%attr(755,root,root) %{_bindir}/grandvizier
d29da4dc 212%attr(755,root,root) %{_bindir}/keyarch
421c53e3 213%attr(755,root,root) %{_bindir}/keymod
d29da4dc 214%attr(755,root,root) %{_bindir}/krfcheck
d29da4dc
JB
215%attr(755,root,root) %{_bindir}/lights
216%attr(755,root,root) %{_bindir}/lsdnssec
217%attr(755,root,root) %{_bindir}/lskrf
421c53e3 218%attr(755,root,root) %{_bindir}/lsrealm
d29da4dc
JB
219%attr(755,root,root) %{_bindir}/lsroll
220%attr(755,root,root) %{_bindir}/maketestzone
221%attr(755,root,root) %{_bindir}/mapper
421c53e3
JB
222%attr(755,root,root) %{_bindir}/realmchk
223%attr(755,root,root) %{_bindir}/realmctl
224%attr(755,root,root) %{_bindir}/realminit
225%attr(755,root,root) %{_bindir}/realmset
d29da4dc
JB
226%attr(755,root,root) %{_bindir}/rollchk
227%attr(755,root,root) %{_bindir}/rollctl
228%attr(755,root,root) %{_bindir}/rollerd
229%attr(755,root,root) %{_bindir}/rollinit
230%attr(755,root,root) %{_bindir}/rolllog
231%attr(755,root,root) %{_bindir}/rollrec-editor
232%attr(755,root,root) %{_bindir}/rollset
233%attr(755,root,root) %{_bindir}/signset-editor
234%attr(755,root,root) %{_bindir}/tachk
235%attr(755,root,root) %{_bindir}/timetrans
236%attr(755,root,root) %{_bindir}/trustman
d29da4dc
JB
237%attr(755,root,root) %{_bindir}/zonesigner
238%dir %{_sysconfdir}/dnssec-tools
239%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/dnssec-tools/dnssec-tools.conf
240%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/dnssec-tools/validator-testcases
241%{_datadir}/%{name}
242%{_mandir}/man1/blinkenlights.1p*
421c53e3 243%{_mandir}/man1/buildrealms.1p*
d29da4dc 244%{_mandir}/man1/bubbles.1p*
421c53e3 245%{_mandir}/man1/check-zone-expiration.1p*
d29da4dc
JB
246%{_mandir}/man1/cleanarch.1p*
247%{_mandir}/man1/cleankrf.1p*
248%{_mandir}/man1/convertar.1p*
249%{_mandir}/man1/dnspktflow.1p*
250%{_mandir}/man1/dnssec-tools.1*
251%{_mandir}/man1/donuts.1p*
252%{_mandir}/man1/donutsd.1p*
253%{_mandir}/man1/drawvalmap.1p*
42a2d0d0
JB
254%{_mandir}/man1/dt-danechk.1*
255%{_mandir}/man1/dt-libval_check_conf.1*
421c53e3
JB
256%{_mandir}/man1/dt-getaddr.1*
257%{_mandir}/man1/dt-gethost.1*
258%{_mandir}/man1/dt-getname.1*
259%{_mandir}/man1/dt-getquery.1*
260%{_mandir}/man1/dt-getrrset.1*
261%{_mandir}/man1/dt-validate.1*
d29da4dc
JB
262%{_mandir}/man1/dtck.1p*
263%{_mandir}/man1/dtconf.1p*
264%{_mandir}/man1/dtconfchk.1p*
265%{_mandir}/man1/dtdefs.1p*
266%{_mandir}/man1/dtinitconf.1p*
421c53e3 267%{_mandir}/man1/dtrealms.1p*
d29da4dc
JB
268%{_mandir}/man1/expchk.1p*
269%{_mandir}/man1/fixkrf.1p*
270%{_mandir}/man1/genkrf.1p*
d29da4dc
JB
271%{_mandir}/man1/getdnskeys.1p*
272%{_mandir}/man1/getds.1p*
421c53e3 273%{_mandir}/man1/grandvizier.1p*
d29da4dc 274%{_mandir}/man1/keyarch.1p*
421c53e3 275%{_mandir}/man1/keymod.1p*
d29da4dc 276%{_mandir}/man1/krfcheck.1p*
d29da4dc
JB
277%{_mandir}/man1/lights.1p*
278%{_mandir}/man1/lsdnssec.1p*
279%{_mandir}/man1/lskrf.1p*
421c53e3 280%{_mandir}/man1/lsrealm.1p*
d29da4dc
JB
281%{_mandir}/man1/lsroll.1p*
282%{_mandir}/man1/maketestzone.1p*
283%{_mandir}/man1/mapper.1p*
421c53e3
JB
284%{_mandir}/man1/realmchk.1p*
285%{_mandir}/man1/realmctl.1p*
286%{_mandir}/man1/realminit.1p*
287%{_mandir}/man1/realmset.1p*
d29da4dc
JB
288%{_mandir}/man1/rollchk.1p*
289%{_mandir}/man1/rollctl.1p*
290%{_mandir}/man1/rollerd.1p*
291%{_mandir}/man1/rollinit.1p*
292%{_mandir}/man1/rolllog.1p*
293%{_mandir}/man1/rollrec-editor.1p*
294%{_mandir}/man1/rollset.1p*
295%{_mandir}/man1/signset-editor.1p*
296%{_mandir}/man1/tachk.1p*
297%{_mandir}/man1/timetrans.1p*
298%{_mandir}/man1/trustman.1p*
d29da4dc
JB
299%{_mandir}/man1/zonesigner.1p*
300
b8f9ed2a
JB
301%if %{with qt}
302%files gui
303%defattr(644,root,root,755)
304%attr(755,root,root) %{_bindir}/dnssec-check
305%attr(755,root,root) %{_bindir}/dnssec-nodes
306%attr(755,root,root) %{_bindir}/dnssec-system-tray
307%attr(755,root,root) %{_bindir}/lookup
308%{_desktopdir}/dnssec-check.desktop
42a2d0d0 309%{_desktopdir}/dnssec-nodes.desktop
b8f9ed2a
JB
310%{_desktopdir}/lookup.desktop
311%{_iconsdir}/hicolor/48x48/apps/lookup.png
42a2d0d0
JB
312%{_iconsdir}/hicolor/*x*/apps/dnssec-check.png
313%{_iconsdir}/hicolor/scalable/apps/dnssec-check.svg
b8f9ed2a
JB
314%{_pixmapsdir}/lookup.xpm
315%endif
316
d29da4dc
JB
317%files libs
318%defattr(644,root,root,755)
319%attr(755,root,root) %{_libdir}/libsres.so.*.*.*
42a2d0d0 320%attr(755,root,root) %ghost %{_libdir}/libsres.so.15
d29da4dc 321%attr(755,root,root) %{_libdir}/libval-threads.so.*.*.*
42a2d0d0 322%attr(755,root,root) %ghost %{_libdir}/libval-threads.so.15
d29da4dc 323%attr(755,root,root) %{_libdir}/libval_shim.so.*.*.*
42a2d0d0 324%attr(755,root,root) %ghost %{_libdir}/libval_shim.so.15
d29da4dc
JB
325
326%files devel
327%defattr(644,root,root,755)
328%attr(755,root,root) %{_bindir}/libval-config
329%attr(755,root,root) %{_libdir}/libsres.so
330%attr(755,root,root) %{_libdir}/libval-threads.so
331%attr(755,root,root) %{_libdir}/libval_shim.so
332%{_libdir}/libsres.la
333%{_libdir}/libval-threads.la
334%{_libdir}/libval_shim.la
335%{_includedir}/validator
336%{_mandir}/man3/dnsval.conf.3*
337%{_mandir}/man3/dnsval_conf*.3*
338%{_mandir}/man3/libsres.3*
339%{_mandir}/man3/libval.3*
42a2d0d0 340%{_mandir}/man3/libval_async.3*
d29da4dc
JB
341%{_mandir}/man3/libval_shim.3*
342%{_mandir}/man3/p_ac_status.3*
42a2d0d0 343%{_mandir}/man3/p_dane_error.3*
d29da4dc
JB
344%{_mandir}/man3/p_val_status.3*
345%{_mandir}/man3/resolv_conf_*.3*
346%{_mandir}/man3/root_hints_*.3*
347%{_mandir}/man3/val_*.3*
348
349%files static
350%defattr(644,root,root,755)
351%{_libdir}/libsres.a
352%{_libdir}/libval-threads.a
353%{_libdir}/libval_shim.a
354
355%files -n perl-%{name}
356%defattr(644,root,root,755)
357%dir %{perl_vendorarch}/Net/DNS/SEC
358%{perl_vendorarch}/Net/DNS/SEC/Tools
359%{perl_vendorarch}/Net/DNS/SEC/Validator.pm
360%{perl_vendorarch}/Net/DNS/SEC/defines.pl
361%{perl_vendorarch}/Net/DNS/ZoneFile
362%{perl_vendorarch}/Net/addrinfo.pm
363%dir %{perl_vendorarch}/auto/Net/DNS/SEC
364%dir %{perl_vendorarch}/auto/Net/DNS/SEC/Validator
d29da4dc 365%attr(755,root,root) %{perl_vendorarch}/auto/Net/DNS/SEC/Validator/Validator.so
e355058c 366%dir %{perl_vendorarch}/auto/Net/addrinfo
d29da4dc
JB
367%attr(755,root,root) %{perl_vendorarch}/auto/Net/addrinfo/addrinfo.so
368%{perl_vendorlib}/Net/DNS/SEC/Tools
369%{_mandir}/man3/Net::DNS::SEC::Tools::*.3pm*
370%{_mandir}/man3/Net::DNS::SEC::Validator.3pm*
371%{_mandir}/man3/Net::DNS::ZoneFile::Fast.3pm*
372%{_mandir}/man3/Net::addrinfo.3pm*
This page took 0.11176 seconds and 4 git commands to generate.