]> git.pld-linux.org Git - packages/dbh.git/blame - dbh.spec
- added bsd patch (fixes BSD configure check to get proper mandir on Linux)
[packages/dbh.git] / dbh.spec
CommitLineData
4093aa60 1#
a50c1e46 2# Conditional build:
260958ac 3%bcond_without static_libs # don't build static library
a50c1e46 4#
0967af91 5Summary: Disk based hash library
a8c99960 6Summary(pl.UTF-8): Biblioteka obsługująca tablice haszujące na dysku
0967af91 7Name: dbh
5e61905f 8Version: 5.0.7
82feb4a6 9Release: 1
3d89a354 10License: LGPL
0967af91 11Group: Libraries
6923bdb8 12Source0: http://downloads.sourceforge.net/dbh/%{name}-%{version}.tar.gz
5e61905f
WF
13# Source0-md5: 15e1bd22aca735415dfb5ec60f48181b
14Patch0: am.patch
6923bdb8 15Patch1: %{name}-bsd.patch
3d89a354
JB
16URL: http://dbh.sourceforge.net/
17BuildRequires: autoconf >= 2.52
18BuildRequires: automake
6923bdb8 19BuildRequires: gtk-doc >= 1.15
3d89a354 20BuildRequires: libtool
0967af91 21BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23f41503 23%description
3d89a354
JB
24Disk based hashes is a method to create multidimensional binary trees
25on disk. This library permits the extension of database concept to a
26plethora of electronic data, such as graphic information. With the
27multidimensional binary tree it is possible to mathematically prove
28that access time to any particular record is minimized (using the
29concept of critical points from calculus), which provides the means to
23f41503 30construct optimized databases for particular applications.
3d89a354 31
4764622c 32%description -l pl.UTF-8
3d89a354 33Hasze przechowywane na dysku to metoda tworzenia wielowymiarowych
4764622c 34drzew binarnych na dysku. Biblioteka pozwala rozszerzać pojęcie bazy
3d89a354 35danych o bogactwo danych elektronicznych, takich jak informacje
4764622c
JR
36graficzne. Można udowodnić matematycznie, że przy użyciu
37wielowymiarowego drzewa binarnego czas dostępu do każdego konkretnego
38rekordu jest minimalny (używając zasady punktów krytycznych), co
39daje środki do tworzenia zoptymalizowanych baz danych dla aplikacji.
0967af91 40
41%package devel
42Summary: Disk based hash library development files
a8c99960 43Summary(pl.UTF-8): Pliki nagłówkowe biblioteki dbh
3d89a354 44Group: Development/Libraries
c623df28 45Requires: %{name} = %{version}-%{release}
3d89a354 46Obsoletes: dbh-examples
0967af91 47
48%description devel
3d89a354
JB
49Disk based hash library development files.
50
4764622c
JR
51%description devel -l pl.UTF-8
52Pliki nagłówkowe biblioteki dbh.
0967af91 53
54%package static
3d89a354 55Summary: Disk based hash static library
a8c99960 56Summary(pl.UTF-8): Statyczna biblioteka dbh
3d89a354 57Group: Development/Libraries
c623df28 58Requires: %{name}-devel = %{version}-%{release}
0967af91 59
60%description static
3d89a354 61Disk based hash static library.
0967af91 62
4764622c 63%description static -l pl.UTF-8
3d89a354 64Statyczna biblioteka dbh.
0967af91 65
6923bdb8
JB
66%package apidocs
67Summary: API documentation for dbh library
68Summary(pl.UTF-8): Dokumentacja API biblioteki dbh
69Group: Documentation
70
71%description apidocs
72API documentation for dbh library.
73
74%description apidocs -l pl.UTF-8
75Dokumentacja API biblioteki dbh.
76
0967af91 77%prep
fff9e962 78%setup -q
5e61905f 79%patch0 -p1
6923bdb8 80%patch1 -p1
0967af91 81
82%build
83%{__libtoolize}
6267da87 84%{__aclocal} -I m4
0967af91 85%{__autoconf}
5e61905f
WF
86%{__autoheader}
87%{__automake}
260958ac 88%configure \
6923bdb8
JB
89 %{!?with_static_libs:--disable-static} \
90 --without-examples
3d89a354 91
0967af91 92%{__make}
93
94%install
95rm -rf $RPM_BUILD_ROOT
3d89a354
JB
96install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
97
98%{__make} install \
23f41503 99 DESTDIR=$RPM_BUILD_ROOT
0967af91 100
6923bdb8
JB
101cp -p examples/{filesystem,simple_hash}.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
102
103# belongs to man3
104%{__mv} $RPM_BUILD_ROOT%{_mandir}/man1/dbh.h.1 $RPM_BUILD_ROOT%{_mandir}/man3/dbh.h.3
105# just a copy of dbh.h.1, useless
106%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/dbh.1
0967af91 107
108%clean
109rm -rf $RPM_BUILD_ROOT
110
3d89a354
JB
111%post -p /sbin/ldconfig
112%postun -p /sbin/ldconfig
0967af91 113
114%files
115%defattr(644,root,root,755)
6923bdb8
JB
116%doc AUTHORS ChangeLog NEWS
117%attr(755,root,root) %{_libdir}/libdbh2.so.*.*.*
118%attr(755,root,root) %ghost %{_libdir}/libdbh2.so.0
0967af91 119
120%files devel
121%defattr(644,root,root,755)
6923bdb8
JB
122%attr(755,root,root) %{_libdir}/libdbh2.so
123%{_libdir}/libdbh2.la
5e61905f 124%{_includedir}/dbh
6923bdb8 125%{_pkgconfigdir}/dbh2.pc
3d89a354 126%{_examplesdir}/%{name}-%{version}
6923bdb8
JB
127%{_mandir}/man3/dbh.h.3*
128%{_mandir}/man3/dbh_*.3*
0967af91 129
260958ac 130%if %{with static_libs}
0967af91 131%files static
132%defattr(644,root,root,755)
6923bdb8 133%{_libdir}/libdbh2.a
260958ac 134%endif
6923bdb8
JB
135
136%files apidocs
137%defattr(644,root,root,755)
138%{_gtkdocdir}/dbh
This page took 0.186203 seconds and 4 git commands to generate.