]> git.pld-linux.org Git - packages/dahdi-linux.git/blame - dahdi-linux.spec
- rel 4
[packages/dahdi-linux.git] / dahdi-linux.spec
CommitLineData
563fc4ec 1#
2# TODO:
f50e30c4 3# - IMPORTANT rename: http://www.asterisk.org/zaptel-to-dahdi
cc9ccfe5 4# - Fix --without xpp:
5# + check_modules
6# unpackaged module: drivers/dahdi/xpp/xpd_bri
7# unpackaged module: drivers/dahdi/xpp/xpd_fxo
8# unpackaged module: drivers/dahdi/xpp/xpd_fxs
9# unpackaged module: drivers/dahdi/xpp/xpd_pri
10# unpackaged module: drivers/dahdi/xpp/xpp
11# unpackaged module: drivers/dahdi/xpp/xpp_usb
563fc4ec 12#
563fc4ec 13# Conditional build:
f3ae6389 14%bcond_without kernel # don't build kernel modules
563fc4ec 15%bcond_with oslec # with Open Source Line Echo Canceller
563fc4ec 16%bcond_without xpp # without Astribank
56c839b0 17%bcond_without userspace # don't build userspace packages
563fc4ec 18%bcond_with verbose
19
563fc4ec 20%ifarch alpha
21%undefine with_xpp
22%endif
228a18e7 23
228a18e7
JR
24# The goal here is to have main, userspace, package built once with
25# simple release number, and only rebuild kernel packages with kernel
26# version as part of release number, without the need to bump release
27# with every kernel change.
28%if 0%{?_pld_builder:1} && %{with kernel} && %{with userspace}
29%{error:kernel and userspace cannot be built at the same time on PLD builders}
30exit 1
31%endif
32
228a18e7
JR
33%if %{without userspace}
34# nothing to be placed to debuginfo package
35%define _enable_debug_packages 0
36%endif
37
a71d7816 38%define rel 4
563fc4ec 39%define pname dahdi-linux
40%define FIRMWARE_URL http://downloads.digium.com/pub/telephony/firmware/releases
41Summary: DAHDI telephony device support
42Summary(pl.UTF-8): Obsługa urządzeń telefonicznych DAHDI
1a93d7c5 43Name: %{pname}%{?_pld_builder:%{?with_kernel:-kernel}}%{_alt_kernel}
cdd97bd2 44Version: 3.1.0
1a93d7c5 45Release: %{rel}%{?_pld_builder:%{?with_kernel:@%{_kernel_ver_str}}}
c792012c 46License: GPL v2
563fc4ec 47Group: Base/Kernel
64471470 48Source0: http://downloads.asterisk.org/pub/telephony/dahdi-linux/releases/dahdi-linux-%{version}.tar.gz
cdd97bd2 49# Source0-md5: 17d7542e613afd6cf860516fe785d56c
563fc4ec 50Source3: %{FIRMWARE_URL}/dahdi-fw-oct6114-064-1.05.01.tar.gz
51# Source3-md5: 88db9b7a07d8392736171b1b3e6bcc66
52Source4: %{FIRMWARE_URL}/dahdi-fw-oct6114-128-1.05.01.tar.gz
53# Source4-md5: c1f1a18d3e20d283f42c71e580a64b5a
54Source5: %{FIRMWARE_URL}/dahdi-fw-vpmadt032-1.07.tar.gz
55# Source5-md5: e1c7231d6225ac999cb18f4e858f66b6
56Source6: %{FIRMWARE_URL}/dahdi-fw-tc400m-MR6.12.tar.gz
57# Source6-md5: 2ea860bb8a9d8ede2858b9557b74ee3c
d2a401d3 58Source7: %{FIRMWARE_URL}/dahdi-fw-hx8-2.06.tar.gz
59# Source7-md5: a7f3886942bb3e9fed349a41b3390c9f
cdd97bd2
JR
60Patch0: kernel-4.14.patch
61Patch1: kernel-5.4.patch
e40e5478 62Patch2: math64.patch
22d881ca 63Patch3: kernel-5.6.patch
9a3e0e89 64Patch4: kernel-5.9.patch
563fc4ec 65URL: http://www.asterisk.org/
453aa04e 66%{?with_kernel:%{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2}}
563fc4ec 67BuildRequires: perl-base
fcd3b77f 68BuildRequires: rpmbuild(macros) >= 1.701
563fc4ec 69BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
70
71# Rules:
72# - modules_X: single modules, just name module with no suffix
73# - modules_X: subdir modules are just directory name with slash like dirname/
74# - keep X and X_in in sync
75# - X is used for actual building (entries separated with space), X_in for pld macros (entries separated with comma)
76
33dcd229
JR
77%define modules_1 dahdi.o dahdi_dynamic.o dahdi_dynamic_eth.o dahdi_dynamic_ethmf.o dahdi_dynamic_loc.o dahdi_echocan_jpah.o dahdi_echocan_kb1.o dahdi_echocan_mg2.o dahdi_echocan_sec.o dahdi_echocan_sec2.o wcaxx.o wcte13xp.o wcte43x.o
78%define modules_1_in dahdi,dahdi_dynamic,dahdi_dynamic_eth,dahdi_dynamic_ethmf,dahdi_dynamic_loc,dahdi_echocan_jpah,dahdi_echocan_kb1,dahdi_echocan_mg2,dahdi_echocan_sec,dahdi_echocan_sec2,wcaxx,wcte13xp,wcte43x
79%define modules_2 voicebus/ oct612x/ wct4xxp/ %{?with_xpp:xpp/}
80%define modules_2_in voicebus/dahdi_voicebus,oct612x/oct612x,wct4xxp/wct4xxp,%{?with_xpp:xpp/xpd_bri,xpp/xpd_echo,xpp/xpd_fxo,xpp/xpd_fxs,xpp/xpd_pri,xpp/xpp,xpp/xpp_usb}
81
563fc4ec 82%ifnarch alpha
83%define modules_nalpha wctc4xxp/ wctdm24xxp/ dahdi_transcode.o wcb4xxp/
84%define modules_nalpha_in wctc4xxp/wctc4xxp,wctdm24xxp/wctdm24xxp,dahdi_transcode,wcb4xxp/wcb4xxp
563fc4ec 85%endif
b800683f 86%define modules %{modules_1} %{modules_2}%{?modules_nalpha: %{modules_nalpha}}
87%define modules_in %{modules_1_in},%{modules_2_in}%{?modules_nalpha:,%{modules_nalpha_in}}
563fc4ec 88
89%description
90DAHDI telephony device driver.
91
92%description -l pl.UTF-8
93Sterownik do urządzeń telefonicznych DAHDI.
94
95%package devel
96Summary: Header files for dahdi interface
3f765485 97Summary(pl.UTF-8): Pliki nagłówkowe interfejsu dahdi
563fc4ec 98Group: Development/Libraries
563fc4ec 99
100%description devel
101Header files for dahdi interface.
102
3f765485
JB
103%description devel -l pl.UTF-8
104Pliki nagłówkowe interfejsu dahdi.
105
228a18e7
JR
106%define kernel_pkg()\
107%package -n kernel%{_alt_kernel}-%{pname}\
108Summary: DAHDI Linux kernel driver\
109Summary(pl.UTF-8): Sterownik DAHDI dla jądra Linuksa\
110Release: %{rel}@%{_kernel_ver_str}\
111Group: Base/Kernel\
112Requires(post,postun): /sbin/depmod\
228a18e7
JR
113%requires_releq_kernel\
114Requires(postun): %releq_kernel\
115%{?with_oslec:Requires: kernel-misc-oslec = 20070608-0.1@%{_kernel_ver_str}}\
228a18e7
JR
116\
117%description -n kernel%{_alt_kernel}-%{pname}\
118DAHDI telephony Linux kernel driver.\
119\
120%description -n kernel%{_alt_kernel}-%{pname} -l pl.UTF-8\
121Sterownik dla jądra Linuksa do urządzeń telefonicznych DAHDI.\
122\
123%if %{with kernel}\
124%files -n kernel%{_alt_kernel}-%{pname}\
125%defattr(644,root,root,755)\
126/lib/modules/%{_kernel_ver}/misc/dahdi*.ko*\
228a18e7 127/lib/modules/%{_kernel_ver}/misc/wcb4xxp.ko*\
228a18e7
JR
128/lib/modules/%{_kernel_ver}/misc/wct4xxp.ko*\
129/lib/modules/%{_kernel_ver}/misc/wctc4xxp.ko*\
228a18e7 130/lib/modules/%{_kernel_ver}/misc/wctdm24xxp.ko*\
33dcd229
JR
131/lib/modules/%{_kernel_ver}/misc/wcte13xp.ko*\
132/lib/modules/%{_kernel_ver}/misc/oct612x.ko*\
133/lib/modules/%{_kernel_ver}/misc/wcaxx.ko*\
134/lib/modules/%{_kernel_ver}/misc/wcte43x.ko*\
228a18e7
JR
135%if %{with xpp}\
136/lib/modules/%{_kernel_ver}/misc/xpd_*.ko*\
137/lib/modules/%{_kernel_ver}/misc/xpp.ko*\
138/lib/modules/%{_kernel_ver}/misc/xpp_usb.ko*\
139%endif\
140%endif\
141\
142%post -n kernel%{_alt_kernel}-%{pname}\
143%depmod %{_kernel_ver}\
144\
145%postun -n kernel%{_alt_kernel}-%{pname}\
146%depmod %{_kernel_ver}\
147%{nil}
148
149%define build_kernel_pkg()\
150%if %{with kernel}\
e6cd4785 151%build_kernel_modules SUBDIRS=$PWD/drivers/dahdi DAHDI_BUILD_ALL=m HOTPLUG_FIRMWARE=yes DAHDI_MODULES_EXTRA=" " -m %{modules_in} KSRC=$PWD/o -C drivers/dahdi DAHDI_INCLUDE=$PWD/../../include\
228a18e7
JR
152cd drivers/dahdi\
153%install_kernel_modules -D ../../installed -m %{modules_in} -d misc\
154cd ../..\
155%endif\
156%{nil}
157
453aa04e 158%{?with_kernel:%{expand:%create_kernel_packages}}
563fc4ec 159
160%prep
161%setup -q -n %{pname}-%{version}
33dcd229 162%patch0 -p1
10f904f3 163%patch1 -p1
e40e5478
JR
164%ifarch %{ix86}
165%patch2 -p1
166%endif
22d881ca 167%patch3 -p1
9a3e0e89 168%patch4 -p1
563fc4ec 169
d2a401d3 170for a in %{SOURCE3} %{SOURCE4} %{SOURCE5} %{SOURCE6} %{SOURCE7}; do
563fc4ec 171 ln -s $a drivers/dahdi/firmware
172 tar -C drivers/dahdi/firmware -xzf $a
173done
174
175cat > download-logger <<'EOF'
176#!/bin/sh
177# keep log of files make wanted to download in firmware/ dir
178echo "$@" >> download.log
179EOF
180chmod a+rx download-logger
181
182%build
183%{__make} include/dahdi/version.h
184
453aa04e 185%{?with_kernel:%{expand:%build_kernel_packages}}
563fc4ec 186
187%install
188rm -rf $RPM_BUILD_ROOT
228a18e7 189install -d $RPM_BUILD_ROOT%{_includedir}/dahdi
563fc4ec 190
56c839b0 191%if %{with userspace}
739efdd0 192%{__make} install-include \
3f765485 193 DESTDIR=$RPM_BUILD_ROOT
56c839b0 194%endif
563fc4ec 195
228a18e7
JR
196%if %{with kernel}
197cp -a installed/* $RPM_BUILD_ROOT
198%endif
199
563fc4ec 200%clean
201rm -rf $RPM_BUILD_ROOT
202
56c839b0 203%if %{with userspace}
563fc4ec 204%files devel
b603dc42 205%defattr(644,root,root,755)
563fc4ec 206%{_includedir}/dahdi
56c839b0 207%endif
This page took 0.122608 seconds and 4 git commands to generate.