]> git.pld-linux.org Git - packages/dahdi-linux.git/blame - dahdi-linux.spec
- fix building with kernl 5.0
[packages/dahdi-linux.git] / dahdi-linux.spec
CommitLineData
563fc4ec 1#
2# TODO:
f50e30c4 3# - IMPORTANT rename: http://www.asterisk.org/zaptel-to-dahdi
cc9ccfe5 4# - Fix --without xpp:
5# + check_modules
6# unpackaged module: drivers/dahdi/xpp/xpd_bri
7# unpackaged module: drivers/dahdi/xpp/xpd_fxo
8# unpackaged module: drivers/dahdi/xpp/xpd_fxs
9# unpackaged module: drivers/dahdi/xpp/xpd_pri
10# unpackaged module: drivers/dahdi/xpp/xpp
11# unpackaged module: drivers/dahdi/xpp/xpp_usb
563fc4ec 12#
563fc4ec 13# Conditional build:
f3ae6389 14%bcond_without kernel # don't build kernel modules
563fc4ec 15%bcond_with oslec # with Open Source Line Echo Canceller
563fc4ec 16%bcond_without xpp # without Astribank
56c839b0 17%bcond_without userspace # don't build userspace packages
563fc4ec 18%bcond_with verbose
19
563fc4ec 20%ifarch alpha
21%undefine with_xpp
22%endif
228a18e7 23
228a18e7
JR
24# The goal here is to have main, userspace, package built once with
25# simple release number, and only rebuild kernel packages with kernel
26# version as part of release number, without the need to bump release
27# with every kernel change.
28%if 0%{?_pld_builder:1} && %{with kernel} && %{with userspace}
29%{error:kernel and userspace cannot be built at the same time on PLD builders}
30exit 1
31%endif
32
228a18e7
JR
33%if %{without userspace}
34# nothing to be placed to debuginfo package
35%define _enable_debug_packages 0
36%endif
37
446f5676 38%define rel 0.1
563fc4ec 39%define pname dahdi-linux
40%define FIRMWARE_URL http://downloads.digium.com/pub/telephony/firmware/releases
41Summary: DAHDI telephony device support
42Summary(pl.UTF-8): Obsługa urządzeń telefonicznych DAHDI
1a93d7c5 43Name: %{pname}%{?_pld_builder:%{?with_kernel:-kernel}}%{_alt_kernel}
446f5676 44Version: 3.0.0
1a93d7c5 45Release: %{rel}%{?_pld_builder:%{?with_kernel:@%{_kernel_ver_str}}}
c792012c 46License: GPL v2
563fc4ec 47Group: Base/Kernel
64471470 48Source0: http://downloads.asterisk.org/pub/telephony/dahdi-linux/releases/dahdi-linux-%{version}.tar.gz
446f5676 49# Source0-md5: 496baef9d2a3bec5a3380ade8efdc5e7
563fc4ec 50Source3: %{FIRMWARE_URL}/dahdi-fw-oct6114-064-1.05.01.tar.gz
51# Source3-md5: 88db9b7a07d8392736171b1b3e6bcc66
52Source4: %{FIRMWARE_URL}/dahdi-fw-oct6114-128-1.05.01.tar.gz
53# Source4-md5: c1f1a18d3e20d283f42c71e580a64b5a
54Source5: %{FIRMWARE_URL}/dahdi-fw-vpmadt032-1.07.tar.gz
55# Source5-md5: e1c7231d6225ac999cb18f4e858f66b6
56Source6: %{FIRMWARE_URL}/dahdi-fw-tc400m-MR6.12.tar.gz
57# Source6-md5: 2ea860bb8a9d8ede2858b9557b74ee3c
d2a401d3 58Source7: %{FIRMWARE_URL}/dahdi-fw-hx8-2.06.tar.gz
59# Source7-md5: a7f3886942bb3e9fed349a41b3390c9f
33dcd229 60Patch0: kernel-5.0.patch
563fc4ec 61URL: http://www.asterisk.org/
453aa04e 62%{?with_kernel:%{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2}}
563fc4ec 63BuildRequires: perl-base
fcd3b77f 64BuildRequires: rpmbuild(macros) >= 1.701
563fc4ec 65BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
66
67# Rules:
68# - modules_X: single modules, just name module with no suffix
69# - modules_X: subdir modules are just directory name with slash like dirname/
70# - keep X and X_in in sync
71# - X is used for actual building (entries separated with space), X_in for pld macros (entries separated with comma)
72
33dcd229
JR
73%define modules_1 dahdi.o dahdi_dynamic.o dahdi_dynamic_eth.o dahdi_dynamic_ethmf.o dahdi_dynamic_loc.o dahdi_echocan_jpah.o dahdi_echocan_kb1.o dahdi_echocan_mg2.o dahdi_echocan_sec.o dahdi_echocan_sec2.o wcaxx.o wcte13xp.o wcte43x.o
74%define modules_1_in dahdi,dahdi_dynamic,dahdi_dynamic_eth,dahdi_dynamic_ethmf,dahdi_dynamic_loc,dahdi_echocan_jpah,dahdi_echocan_kb1,dahdi_echocan_mg2,dahdi_echocan_sec,dahdi_echocan_sec2,wcaxx,wcte13xp,wcte43x
75%define modules_2 voicebus/ oct612x/ wct4xxp/ %{?with_xpp:xpp/}
76%define modules_2_in voicebus/dahdi_voicebus,oct612x/oct612x,wct4xxp/wct4xxp,%{?with_xpp:xpp/xpd_bri,xpp/xpd_echo,xpp/xpd_fxo,xpp/xpd_fxs,xpp/xpd_pri,xpp/xpp,xpp/xpp_usb}
77
563fc4ec 78%ifnarch alpha
79%define modules_nalpha wctc4xxp/ wctdm24xxp/ dahdi_transcode.o wcb4xxp/
80%define modules_nalpha_in wctc4xxp/wctc4xxp,wctdm24xxp/wctdm24xxp,dahdi_transcode,wcb4xxp/wcb4xxp
563fc4ec 81%endif
b800683f 82%define modules %{modules_1} %{modules_2}%{?modules_nalpha: %{modules_nalpha}}
83%define modules_in %{modules_1_in},%{modules_2_in}%{?modules_nalpha:,%{modules_nalpha_in}}
563fc4ec 84
85%description
86DAHDI telephony device driver.
87
88%description -l pl.UTF-8
89Sterownik do urządzeń telefonicznych DAHDI.
90
91%package devel
92Summary: Header files for dahdi interface
3f765485 93Summary(pl.UTF-8): Pliki nagłówkowe interfejsu dahdi
563fc4ec 94Group: Development/Libraries
563fc4ec 95
96%description devel
97Header files for dahdi interface.
98
3f765485
JB
99%description devel -l pl.UTF-8
100Pliki nagłówkowe interfejsu dahdi.
101
228a18e7
JR
102%define kernel_pkg()\
103%package -n kernel%{_alt_kernel}-%{pname}\
104Summary: DAHDI Linux kernel driver\
105Summary(pl.UTF-8): Sterownik DAHDI dla jądra Linuksa\
106Release: %{rel}@%{_kernel_ver_str}\
107Group: Base/Kernel\
108Requires(post,postun): /sbin/depmod\
228a18e7
JR
109%requires_releq_kernel\
110Requires(postun): %releq_kernel\
111%{?with_oslec:Requires: kernel-misc-oslec = 20070608-0.1@%{_kernel_ver_str}}\
228a18e7
JR
112\
113%description -n kernel%{_alt_kernel}-%{pname}\
114DAHDI telephony Linux kernel driver.\
115\
116%description -n kernel%{_alt_kernel}-%{pname} -l pl.UTF-8\
117Sterownik dla jądra Linuksa do urządzeń telefonicznych DAHDI.\
118\
119%if %{with kernel}\
120%files -n kernel%{_alt_kernel}-%{pname}\
121%defattr(644,root,root,755)\
122/lib/modules/%{_kernel_ver}/misc/dahdi*.ko*\
228a18e7 123/lib/modules/%{_kernel_ver}/misc/wcb4xxp.ko*\
228a18e7
JR
124/lib/modules/%{_kernel_ver}/misc/wct4xxp.ko*\
125/lib/modules/%{_kernel_ver}/misc/wctc4xxp.ko*\
228a18e7 126/lib/modules/%{_kernel_ver}/misc/wctdm24xxp.ko*\
33dcd229
JR
127/lib/modules/%{_kernel_ver}/misc/wcte13xp.ko*\
128/lib/modules/%{_kernel_ver}/misc/oct612x.ko*\
129/lib/modules/%{_kernel_ver}/misc/wcaxx.ko*\
130/lib/modules/%{_kernel_ver}/misc/wcte43x.ko*\
228a18e7
JR
131%if %{with xpp}\
132/lib/modules/%{_kernel_ver}/misc/xpd_*.ko*\
133/lib/modules/%{_kernel_ver}/misc/xpp.ko*\
134/lib/modules/%{_kernel_ver}/misc/xpp_usb.ko*\
135%endif\
136%endif\
137\
138%post -n kernel%{_alt_kernel}-%{pname}\
139%depmod %{_kernel_ver}\
140\
141%postun -n kernel%{_alt_kernel}-%{pname}\
142%depmod %{_kernel_ver}\
143%{nil}
144
145%define build_kernel_pkg()\
146%if %{with kernel}\
e6cd4785 147%build_kernel_modules SUBDIRS=$PWD/drivers/dahdi DAHDI_BUILD_ALL=m HOTPLUG_FIRMWARE=yes DAHDI_MODULES_EXTRA=" " -m %{modules_in} KSRC=$PWD/o -C drivers/dahdi DAHDI_INCLUDE=$PWD/../../include\
228a18e7
JR
148cd drivers/dahdi\
149%install_kernel_modules -D ../../installed -m %{modules_in} -d misc\
150cd ../..\
151%endif\
152%{nil}
153
453aa04e 154%{?with_kernel:%{expand:%create_kernel_packages}}
563fc4ec 155
156%prep
157%setup -q -n %{pname}-%{version}
33dcd229 158%patch0 -p1
563fc4ec 159
d2a401d3 160for a in %{SOURCE3} %{SOURCE4} %{SOURCE5} %{SOURCE6} %{SOURCE7}; do
563fc4ec 161 ln -s $a drivers/dahdi/firmware
162 tar -C drivers/dahdi/firmware -xzf $a
163done
164
165cat > download-logger <<'EOF'
166#!/bin/sh
167# keep log of files make wanted to download in firmware/ dir
168echo "$@" >> download.log
169EOF
170chmod a+rx download-logger
171
172%build
173%{__make} include/dahdi/version.h
174
453aa04e 175%{?with_kernel:%{expand:%build_kernel_packages}}
563fc4ec 176
177%install
178rm -rf $RPM_BUILD_ROOT
228a18e7 179install -d $RPM_BUILD_ROOT%{_includedir}/dahdi
563fc4ec 180
56c839b0 181%if %{with userspace}
739efdd0 182%{__make} install-include \
3f765485 183 DESTDIR=$RPM_BUILD_ROOT
56c839b0 184%endif
563fc4ec 185
228a18e7
JR
186%if %{with kernel}
187cp -a installed/* $RPM_BUILD_ROOT
188%endif
189
563fc4ec 190%clean
191rm -rf $RPM_BUILD_ROOT
192
56c839b0 193%if %{with userspace}
563fc4ec 194%files devel
b603dc42 195%defattr(644,root,root,755)
563fc4ec 196%{_includedir}/dahdi
56c839b0 197%endif
This page took 0.06923 seconds and 4 git commands to generate.