]> git.pld-linux.org Git - packages/czmq.git/blame - czmq.spec
- enable DRAFT APIs (required by rsyslog modules); release 2
[packages/czmq.git] / czmq.spec
CommitLineData
ba51478b
JB
1#
2# Conditional build:
3%bcond_without python2 # CPython 2.x module
4%bcond_without python3 # CPython 3.x module
5
edd49c66
JB
6Summary: High-level C binding for 0MQ
7Summary(pl.UTF-8): Wysokopoziomowe wiązania C dla 0MQ
8Name: czmq
ba51478b 9Version: 4.2.0
49717577 10Release: 2
edd49c66
JB
11License: LGPL v3+
12Group: Libraries
ba51478b
JB
13#Source0Download: https://github.com/zeromq/czmq/releases
14Source0: https://github.com/zeromq/czmq/releases/download/v%{version}/%{name}-%{version}.tar.gz
15# Source0-md5: 7e09997db6ac3b25e8ed104053040722
2c3c5470 16Patch1: %{name}-link.patch
edd49c66 17URL: http://zeromq.org/
2e771b95 18BuildRequires: asciidoc
2c3c5470
JB
19BuildRequires: autoconf >= 2.61
20BuildRequires: automake
ba51478b
JB
21BuildRequires: curl-devel >= 7.28.0
22BuildRequires: libmicrohttpd-devel
2c3c5470 23BuildRequires: libtool
16913628 24BuildRequires: libuuid-devel
ba51478b
JB
25BuildRequires: lz4-devel
26%if %{with python2}
27BuildRequires: python-devel >= 1:2.5
28BuildRequires: python-setuptools
29%endif
30%if %{with python3}
31BuildRequires: python3-devel >= 1:3.2
32BuildRequires: python3-setuptools
33%endif
34BuildRequires: rpm-pythonprov
35BuildRequires: rpmbuild(macros) >= 1.714
36BuildRequires: systemd-devel >= 1:200
2e771b95
JB
37BuildRequires: xmlto
38BuildRequires: zeromq-devel >= 4
ba51478b
JB
39Requires: curl-libs >= 7.28.0
40Requires: systemd-libs >= 1:200
2e771b95 41Requires: zeromq >= 4
edd49c66
JB
42BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44%description
45High-level C binding for 0MQ.
46
47%description -l pl.UTF-8
48Wysokopoziomowe wiązania C dla 0MQ.
49
50%package devel
51Summary: Header files for CZMQ library
52Summary(pl.UTF-8): Pliki nagłówkowe biblioteki CZMQ
53Group: Development/Libraries
54Requires: %{name} = %{version}-%{release}
ba51478b
JB
55Requires: curl-devel >= 7.28.0
56Requires: libmicrohttpd-devel
57Requires: libuuid-devel
58Requires: lz4-devel
59Requires: systemd-devel >= 1:200
2e771b95 60Requires: zeromq-devel >= 4
edd49c66
JB
61
62%description devel
63Header files for CZMQ library.
64
65%description devel -l pl.UTF-8
66Pliki nagłówkowe biblioteki CZMQ.
67
68%package static
69Summary: Static CZMQ library
70Summary(pl.UTF-8): Statyczna biblioteka CZMQ
71Group: Development/Libraries
72Requires: %{name}-devel = %{version}-%{release}
73
74%description static
75Static CZMQ library.
76
77%description static -l pl.UTF-8
78Statyczna biblioteka CZMQ.
79
ba51478b
JB
80%package -n python-czmq
81Summary: Python 2 bindings for CZMQ
82Summary(pl.UTF-8): Wiązania Pythona 2 do CZMQ
83Group: Libraries/Python
84Requires: %{name} = %{version}-%{release}
85
86%description -n python-czmq
87Python 2 bindings for CZMQ - the high level C binding for 0MQ.
88
89%description -n python-czmq -l pl.UTF-8
90Wiązania Pythona 2 do CZMQ - wysokopoziomowego wiązania C do 0MQ.
91
92%package -n python3-czmq
93Summary: Python 3 bindings for CZMQ
94Summary(pl.UTF-8): Wiązania Pythona 3 do CZMQ
95Group: Libraries/Python
96Requires: %{name} = %{version}-%{release}
97
98%description -n python3-czmq
99Python 3 bindings for CZMQ - the high level C binding for 0MQ.
100
101%description -n python3-czmq -l pl.UTF-8
102Wiązania Pythona 3 do CZMQ - wysokopoziomowego wiązania C do 0MQ.
103
edd49c66
JB
104%prep
105%setup -q
2c3c5470 106%patch1 -p1
edd49c66
JB
107
108%build
2c3c5470
JB
109%{__libtoolize}
110%{__aclocal} -I config
111%{__autoconf}
112%{__autoheader}
113%{__automake}
edd49c66
JB
114# use include subdir - file names could be too common (zfile.h etc.)
115%configure \
ba51478b 116 --enable-bindings-python \
49717577 117 --enable-drafts \
16913628 118 --disable-silent-rules \
edd49c66
JB
119 --includedir=%{_includedir}/czmq
120%{__make}
121
ba51478b
JB
122cd bindings/python
123
124%if %{with python2}
125%py_build
126%endif
127
128%if %{with python3}
129%py3_build
130%endif
131
edd49c66
JB
132%install
133rm -rf $RPM_BUILD_ROOT
134
135%{__make} install \
136 DESTDIR=$RPM_BUILD_ROOT
137
ba51478b
JB
138cd bindings/python
139
140%if %{with python2}
141%py_install
142
143%py_postclean
144%endif
145
146%if %{with python3}
147%py3_install
148%endif
149
edd49c66
JB
150# obsoleted by pkg-config
151%{__rm} $RPM_BUILD_ROOT%{_libdir}/libczmq.la
152
153%clean
154rm -rf $RPM_BUILD_ROOT
155
156%files
157%defattr(644,root,root,755)
2c3c5470 158%doc AUTHORS NEWS README.md
ba51478b 159%attr(755,root,root) %{_bindir}/zmakecert
edd49c66 160%attr(755,root,root) %{_libdir}/libczmq.so.*.*.*
ba51478b
JB
161%attr(755,root,root) %ghost %{_libdir}/libczmq.so.4
162%{_mandir}/man1/zmakecert.1*
edd49c66
JB
163
164%files devel
165%defattr(644,root,root,755)
166%attr(755,root,root) %{_libdir}/libczmq.so
167%{_includedir}/czmq
168%{_pkgconfigdir}/libczmq.pc
ba51478b
JB
169%dir %{_datadir}/zproject
170%{_datadir}/zproject/czmq
2c3c5470 171%{_mandir}/man3/zactor.3*
ba51478b 172%{_mandir}/man3/zargs.3*
2c3c5470 173%{_mandir}/man3/zarmour.3*
2e771b95 174%{_mandir}/man3/zauth.3*
edd49c66 175%{_mandir}/man3/zbeacon.3*
2e771b95
JB
176%{_mandir}/man3/zcert.3*
177%{_mandir}/man3/zcertstore.3*
178%{_mandir}/man3/zchunk.3*
edd49c66 179%{_mandir}/man3/zclock.3*
2e771b95 180%{_mandir}/man3/zconfig.3*
16913628 181%{_mandir}/man3/zdigest.3*
2e771b95 182%{_mandir}/man3/zdir.3*
16913628 183%{_mandir}/man3/zdir_patch.3*
edd49c66
JB
184%{_mandir}/man3/zfile.3*
185%{_mandir}/man3/zframe.3*
2c3c5470 186%{_mandir}/man3/zgossip.3*
edd49c66 187%{_mandir}/man3/zhash.3*
2c3c5470 188%{_mandir}/man3/zhashx.3*
ba51478b
JB
189%{_mandir}/man3/zhttp_client.3*
190%{_mandir}/man3/zhttp_request.3*
191%{_mandir}/man3/zhttp_response.3*
192%{_mandir}/man3/zhttp_server.3*
193%{_mandir}/man3/zhttp_server_options.3*
2c3c5470 194%{_mandir}/man3/ziflist.3*
edd49c66 195%{_mandir}/man3/zlist.3*
2c3c5470 196%{_mandir}/man3/zlistx.3*
edd49c66 197%{_mandir}/man3/zloop.3*
16913628 198%{_mandir}/man3/zmonitor.3*
edd49c66 199%{_mandir}/man3/zmsg.3*
2e771b95 200%{_mandir}/man3/zpoller.3*
ba51478b 201%{_mandir}/man3/zproc.3*
16913628
JB
202%{_mandir}/man3/zproxy.3*
203%{_mandir}/man3/zrex.3*
2c3c5470 204%{_mandir}/man3/zsock.3*
edd49c66
JB
205%{_mandir}/man3/zstr.3*
206%{_mandir}/man3/zsys.3*
ba51478b
JB
207%{_mandir}/man3/ztimerset.3*
208%{_mandir}/man3/ztrie.3*
16913628 209%{_mandir}/man3/zuuid.3*
edd49c66
JB
210%{_mandir}/man7/czmq.7*
211
212%files static
213%defattr(644,root,root,755)
214%{_libdir}/libczmq.a
ba51478b
JB
215
216%if %{with python2}
217%files -n python-czmq
218%defattr(644,root,root,755)
219%{py_sitescriptdir}/czmq
220%{py_sitescriptdir}/czmq-%{version}-py*.egg-info
221%endif
222
223%if %{with python3}
224%files -n python3-czmq
225%defattr(644,root,root,755)
226%{py3_sitescriptdir}/czmq
227%{py3_sitescriptdir}/czmq-%{version}-py*.egg-info
228%endif
This page took 0.096469 seconds and 4 git commands to generate.