]> git.pld-linux.org Git - packages/curl.git/blame - curl.spec
- added http3 bcond (currently not buildable with unpatched openssl, only gnutls...
[packages/curl.git] / curl.spec
CommitLineData
40f52e62 1# TODO: ngtpc2/nghttp3 or quiche for HTTP3?
195ea5a8
JB
2#
3# Conditional build:
358ad66a
JB
4%bcond_without ssh # SSH support
5%bcond_without ssl # SSL support
6%bcond_with gnutls # GnuTLS instead of OpenSSL
eef5da07 7%bcond_without gsasl # SCRAM support with gsasl
358ad66a
JB
8%bcond_without kerberos5 # Heimdal Kerberos 5 support
9%bcond_without ldap # LDAP support
8424568c 10%bcond_without http2 # HTTP/2.0 support (nghttp2 based)
40f52e62 11%bcond_with http3 # HTTP/3.0 support (nghttp3/ngtcp2 based)
de17b215 12%if "%{pld_release}" != "ac"
358ad66a
JB
13%bcond_without ares # c-ares (asynchronous DNS operations) library support
14%bcond_without rtmp # Real Time Media Protocol support
de17b215 15%else
358ad66a
JB
16%bcond_with ares # c-ares (asynchronous DNS operations) library support
17%bcond_with rtmp # Real Time Media Protocol support
de17b215
ER
18%endif
19
f7f276d9 20Summary: A utility for getting files from remote servers (FTP, HTTP, and others)
ce380d80
ER
21Summary(es.UTF-8): Un cliente para bajar archivos de servidores (FTP, HTTP, y otros)
22Summary(pl.UTF-8): Narzędzie do ściągania plików z serwerów (FTP, HTTP i innych)
23Summary(pt_BR.UTF-8): Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e HTTPS)
24Summary(ru.UTF-8): Утилита для получения файлов с серверов FTP, HTTP и других
25Summary(uk.UTF-8): Утиліта для отримання файлів з серверів FTP, HTTP та інших
5767e1a7 26Name: curl
db4ef43c 27Version: 7.82.0
d472c855 28Release: 1
c091c0ac 29License: MIT-like
5767e1a7 30Group: Applications/Networking
d8be0059 31Source0: https://curl.haxx.se/download/%{name}-%{version}.tar.xz
db4ef43c 32# Source0-md5: ce05eb61ef7c398feb7dbe23122d0bd9
d0cec3a8
JB
33Patch0: %{name}-ac.patch
34Patch1: %{name}-krb5flags.patch
4557544f 35URL: http://curl.haxx.se/
c091c0ac 36BuildRequires: autoconf >= 2.57
66cf63f1 37BuildRequires: automake
0da7572a 38%{?with_ares:BuildRequires: c-ares-devel >= 1.17.0}
eef5da07 39%{?with_gsasl:BuildRequires: gsasl-devel}
f73c4120 40%{?with_kerberos5:BuildRequires: heimdal-devel}
8a129a6b 41BuildRequires: libbrotli-devel >= 1.0.0
04f3f89d 42BuildRequires: libidn2-devel
e80259d2 43BuildRequires: libpsl-devel
9defadab 44%{?with_rtmp:BuildRequires: librtmp-devel}
b83a223e 45%{?with_ssh:BuildRequires: libssh2-devel >= 1.2.8}
c091c0ac 46BuildRequires: libtool
0f90f9c0 47BuildRequires: nettle-devel
e37f03dc 48%{?with_http2:BuildRequires: nghttp2-devel >= 1.12.0}
40f52e62
JB
49%{?with_http3:BuildRequires: nghttp3-devel}
50# with gnutls or openssl crypto, conforming to chosen curl crypto library
51%{?with_http3:BuildRequires: ngtcp2-devel}
588be88f 52%{?with_ldap:BuildRequires: openldap-devel}
c260acfc 53BuildRequires: pkgconfig
de17b215 54BuildRequires: rpm >= 4.4.9-56
4416762d 55BuildRequires: rpm-build >= 4.6
838a6eda 56BuildRequires: rpmbuild(macros) >= 1.527
5559a124
AM
57%if %{with ssl}
58%if %{with gnutls}
e37f03dc 59BuildRequires: gnutls-devel >= 3.1.10
5559a124 60%else
549c5328 61BuildRequires: openssl-devel >= 1.0.1
5559a124
AM
62%endif
63%endif
d04a5e91 64BuildRequires: tar >= 1:1.22
eef5da07 65BuildRequires: xz
6903f0dc 66BuildRequires: zlib-devel
0ee795f8 67BuildRequires: zstd-devel
3fb47407 68Requires: %{name}-libs = %{version}-%{release}
cfa95fc0 69Obsoletes: libcurl2
8aa4e5ec 70BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
81714278 71
72%description
655b91ad 73cURL is a tool for getting files with URL syntax, supporting FTP,
74HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP. cURL supports HTTP
75POST, HTTP PUT, FTP uploading, HTTP form based upload, proxies,
76cookies, user+password authentication and a busload of other useful
77tricks. The main use for curl is when you want to get or send files
78automatically to or from a site using one of the supported protocols.
79
80cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
81Dict servers, using any of the supported protocols. cURL is designed
82to work without user interaction or any kind of interactivity. cURL
83offers many useful capabilities, like proxy support, user
e566d906 84authentication, FTP upload, HTTP post, and file transfer resume.
81714278 85
d63bcf1b
JR
86%description -l pl.UTF-8
87cURL jest narzędziem do ściągania plików o składni URL. Obsługuje FTP,
88HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obsługuje również
89HTTP POST, HTTP PUT, załadowywanie (uploading) FTP, załadowywanie HTTP
655b91ad 90oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
d63bcf1b
JR
91użytkownik/hasło oraz wiele innych użytecznych sztuczek. Curla używa
92się głównie wtedy, kiedy chce się automatycznie ściągnąć lub wysłać
93pliki z/na serwer używając jednego z dostępnych protokołów.
94%{?with_ssl:Ten pakiet obsługuje także SSL.}
1310544e 95
d63bcf1b
JR
96%description -l pt_BR.UTF-8
97Curl é um cliente para baixar/enviar arquivos de/para servidores
98usando um dos protocolos suportados. É projetado para funcionar sem a
99interação do usuário.
1310544e 100
d63bcf1b
JR
101Curl trabalha com proxy, autenticação, FTP put, HTTP post, e pode
102continuar transferências interrompidas, e mais...
1310544e 103
d63bcf1b
JR
104%description -l ru.UTF-8
105curl - это клиент с множеством поддерживаемых протоколов для получения
106файлов с серверов, спроектированный для работы как в неинтерактивном
107режиме, так и с возможностью диалога с пользователем.
f05b825f 108
d63bcf1b
JR
109curl поддерживает много полезных возможностей, среди которых поддержка
110прокси, авторизация пользователя, закачивание по FTP, поддержка HTTP
111POST, восстановление прерванной пересылки и многое другое.
f05b825f 112
d63bcf1b
JR
113curl - це кл╕╓нт з багатьма п╕дтримуваними протоколами для отримання
114файл╕в з сервер╕в, спроектований для роботи як в не╕нтерактивному
115режим╕, так ╕ з можлив╕стю д╕алогу з користувачем.
f05b825f 116
d63bcf1b
JR
117curl п╕дтриму╓ багато корисних можливостей, серед яких п╕дтримка
118прокс╕, авторизац╕я користувача, в╕двантаження по FTP, HTTP POST,
119в╕дновлення перервано╖ пересилки та багато ╕ншого.
f05b825f 120
814b6f7d
JB
121%package libs
122Summary: curl library
ce380d80 123Summary(pl.UTF-8): Biblioteka curl
814b6f7d 124Group: Libraries
0da7572a 125%{?with_ares:Requires: c-ares >= 1.17.0}
e37f03dc 126%{?with_gnutls:Requires: gnutls-libs >= 3.1.10}
549c5328 127%{?with_ssh:Requires: libssh2 >= 1.2.8}
e37f03dc 128%{?with_http2:Requires: nghttp2-libs >= 1.12.0}
fddc44fa 129%if %{with ssl} && %{without gnutls}
00b2a6eb 130Requires: libbrotli >= 1.0.0
549c5328 131Requires: openssl >= 1.0.1
fddc44fa 132%endif
dfeb0d8d
PG
133Suggests: ca-certificates
134Conflicts: ca-certificates < 20080809-4
814b6f7d
JB
135
136%description libs
137curl library.
138
d63bcf1b 139%description libs -l pl.UTF-8
814b6f7d
JB
140Biblioteka curl.
141
1f54b511 142%package devel
143Summary: Header files and development documentation for curl library
ce380d80
ER
144Summary(pl.UTF-8): Pliki nagłówkowe i dokumentacja do biblioteki curl
145Summary(pt_BR.UTF-8): Arquivos de cabeçalho e bibliotecas de desenvolvimento
146Summary(ru.UTF-8): Файлы для разработки с использованием библиотеки curl
147Summary(uk.UTF-8): Файли для розробки з використанням бібліотеки curl
1f54b511 148Group: Development/Libraries
3fb47407 149Requires: %{name}-libs = %{version}-%{release}
bd2c841c 150%{?with_ares:Requires: c-ares-devel}
eef5da07 151%{?with_gsasl:Requires: gsasl-devel}
f73c4120 152%{?with_kerberos5:Requires: heimdal-devel}
72fe5a16 153Requires: libbrotli-devel >= 1.0.0
04f3f89d 154Requires: libidn2-devel
e80259d2 155Requires: libpsl-devel
70778617 156%{?with_rtmp:Requires: librtmp-devel}
b83a223e 157%{?with_ssh:Requires: libssh2-devel >= 1.2.8}
e37f03dc 158%{?with_http2:Requires: nghttp2-devel >= 1.12.0}
588be88f 159%{?with_ldap:Requires: openldap-devel}
5559a124
AM
160%if %{with ssl}
161%if %{with gnutls}
e37f03dc 162Requires: gnutls-devel >= 3.1.10
5559a124
AM
163%else
164Requires: openssl-devel >= 0.9.7c
165%endif
166%endif
5e1699d5 167Requires: zlib-devel
0ee795f8 168Requires: zstd-devel
cfa95fc0 169Obsoletes: libcurl2-devel
1f54b511 170
171%description devel
172Header files and development documentation for curl library.
173
d63bcf1b
JR
174%description devel -l pl.UTF-8
175Pliki nagłówkowe i dokumentacja do biblioteki curl.
cec38cdf 176
d63bcf1b
JR
177%description devel -l pt_BR.UTF-8
178Arquivos de cabeçalho e bibliotecas de desenvolvimento.
1310544e 179
d63bcf1b
JR
180%description devel -l ru.UTF-8
181Этот пакет содержит файлы, необходимые для разработки программ с
182использованием библиотеки curl.
f05b825f 183
d63bcf1b
JR
184%description devel -l uk.UTF-8
185Цей пакет містить файли, необхідні для розробки програм з
186використанням бібліотеки curl.
f05b825f 187
1f54b511 188%package static
189Summary: Static version of curl library
ce380d80
ER
190Summary(pl.UTF-8): Statyczna wersja biblioteki curl
191Summary(pt_BR.UTF-8): Bibliotecas estáticas para desenvolvimento com o curl
192Summary(ru.UTF-8): Статические библиотеки для разработки с использованием библиотеки curl
193Summary(uk.UTF-8): Статичні бібліотеки для розробки з використанням бібліотеки curl
1f54b511 194Group: Development/Libraries
6e6a5186 195Requires: %{name}-devel = %{version}-%{release}
1f54b511 196
197%description static
d06d2fe1 198Static version of curl library.
1f54b511 199
d63bcf1b 200%description static -l pl.UTF-8
cec38cdf 201Statyczna wersja biblioteki curl.
b73e2a73 202
d63bcf1b
JR
203%description static -l pt_BR.UTF-8
204Bibliotecas estáticas para desenvolvimento com o curl.
1310544e 205
d63bcf1b
JR
206%description static -l ru.UTF-8
207Этот пакет содержит статическую библиотеку для разработки программ с
208использованием библиотеки curl.
f05b825f 209
d63bcf1b
JR
210%description static -l uk.UTF-8
211Цей пакет містить статичну бібліотеку для розробки програм з
212використанням бібліотеки curl.
f05b825f 213
8a62d0ef
AG
214%package -n fish-completion-%{name}
215Summary: Fish completion for curl command
216Summary(pl.UTF-8): Dopełnianie parametrów w fish dla polecenia curl
217Group: Applications/Shells
218Requires: %{name} = %{version}-%{release}
219Requires: fish
4416762d 220BuildArch: noarch
8a62d0ef
AG
221
222%description -n fish-completion-%{name}
223Fish completion for curl command.
224
225%description -n fish-completion-%{name} -l pl.UTF-8
226Dopełnianie parametrów w fish dla polecenia curl.
227
e80259d2
JB
228%package -n zsh-completion-curl
229Summary: ZSH completion for curl command
230Summary(pl.UTF-8): Dopełnianianie parametrów w ZSH dla polecenia curl
231Group: Applications/Shells
232Requires: %{name} = %{version}-%{release}
233Requires: zsh
4416762d 234BuildArch: noarch
e80259d2
JB
235
236%description -n zsh-completion-curl
237ZSH completion for curl command.
238
239%description -n zsh-completion-curl -l pl.UTF-8
240Dopełnianianie parametrów w ZSH dla polecenia curl.
241
81714278 242%prep
13caa23a 243%setup -q
d0cec3a8 244%patch0 -p1
d4dc980e 245%patch1 -p1
81714278 246
358ad66a 247%{__rm} m4/lt*.m4 m4/libtool.m4
36cd7270 248
81714278 249%build
c091c0ac 250%{__libtoolize}
03613829 251%{__aclocal} -I m4
d4dc980e
AM
252%{__autoconf}
253%{__autoheader}
c091c0ac 254%{__automake}
e566d906 255%configure \
ef822e11 256 ac_cv_header_gss_h=no \
e80259d2 257 %{__enable_disable ares} \
eef5da07 258 %{__enable_disable gsasl} \
e80259d2
JB
259 --enable-ipv6 \
260 %{__enable_disable ldap} \
261 %{__enable_disable ldap ldaps} \
262 --disable-silent-rules \
5559a124 263%if %{with ssl}
03613829 264 --with-ca-bundle=/etc/certs/ca-certificates.crt \
5559a124 265%if %{with gnutls}
8210eba8 266 --with-gnutls --without-openssl \
5559a124 267%else
8210eba8 268 --with-openssl=%{_prefix} \
5559a124 269%endif
0eee87e5 270%else
8210eba8 271 --without-ssl \
5559a124 272%endif
8a62d0ef 273 --with-fish-functions-dir=%{fish_compdir} \
838a6eda 274 %{__with_without kerberos5 gssapi %{_prefix}} \
838a6eda
JK
275 %{__with_without rtmp librtmp} \
276 %{__with_without http2 nghttp2} \
40f52e62
JB
277 %{__with_without http3 nghttp3} \
278 %{__with_without http3 ngtcp2} \
e80259d2 279 %{__with_without ssh libssh2}
a436679a 280
c2167492 281%{__make}
81714278 282
283%install
5767e1a7 284rm -rf $RPM_BUILD_ROOT
08c6da60 285
56f17d66
AM
286%{__make} install \
287 DESTDIR=$RPM_BUILD_ROOT
288
4f6d4393
JB
289%{__make} -C scripts install \
290 DESTDIR=$RPM_BUILD_ROOT
291
08c6da60
JB
292# obsoleted by pkg-config
293%{__rm} $RPM_BUILD_ROOT%{_libdir}/libcurl.la
294
34ca770a 295# no longer in upstream but a lot of apps tries to include it so we create fake one
925b36ff
AM
296[ -e $RPM_BUILD_ROOT%{_includedir}/curl/types.h ] && exit 1
297echo '#warning curl/types.h IS OBSOLETE FROM 2004. STOP USING IT' > $RPM_BUILD_ROOT%{_includedir}/curl/types.h
34ca770a 298
81714278 299%clean
300rm -rf $RPM_BUILD_ROOT
81714278 301
3fb47407
ER
302%post libs -p /sbin/ldconfig
303%postun libs -p /sbin/ldconfig
1f54b511 304
81714278 305%files
5767e1a7 306%defattr(644,root,root,755)
4c2e4e93 307%doc CHANGES COPYING README docs/{BUGS.md,FAQ,FEATURES.md,HISTORY.md,KNOWN_BUGS,SSLCERTS.md,THANKS,TODO,TheArtOfHttpScripting.md}
c091c0ac 308%attr(755,root,root) %{_bindir}/curl
c091c0ac 309%{_mandir}/man1/curl.1*
1f54b511 310
814b6f7d
JB
311%files libs
312%defattr(644,root,root,755)
313%attr(755,root,root) %{_libdir}/libcurl.so.*.*.*
b3964ccb 314%attr(755,root,root) %ghost %{_libdir}/libcurl.so.4
814b6f7d 315
1f54b511 316%files devel
317%defattr(644,root,root,755)
c6b65fdb 318%doc docs/{CONTRIBUTE.md,INTERNALS.md}
c091c0ac
JB
319%attr(755,root,root) %{_bindir}/curl-config
320%attr(755,root,root) %{_libdir}/libcurl.so
c091c0ac 321%{_includedir}/curl
8ad78925 322%{_pkgconfigdir}/libcurl.pc
1399f3ff 323%{_aclocaldir}/libcurl.m4
c091c0ac 324%{_mandir}/man1/curl-config.1*
b3964ccb
JB
325%{_mandir}/man3/curl_*.3*
326%{_mandir}/man3/libcurl*.3*
0efd10e8 327%{_mandir}/man3/CURLINFO_*.3*
67744768 328%{_mandir}/man3/CURLOPT_*.3*
eb7a78c8 329%{_mandir}/man3/CURLMOPT_*.3*
fae826e9 330%{_mandir}/man3/CURLSHOPT_*.3*
1f54b511 331
332%files static
333%defattr(644,root,root,755)
c091c0ac 334%{_libdir}/libcurl.a
e80259d2 335
8a62d0ef
AG
336%files -n fish-completion-%{name}
337%defattr(644,root,root,755)
4416762d 338%{fish_compdir}/curl.fish
8a62d0ef 339
e80259d2
JB
340%files -n zsh-completion-curl
341%defattr(644,root,root,755)
342%{_datadir}/zsh/site-functions/_curl
This page took 0.102216 seconds and 4 git commands to generate.