]> git.pld-linux.org Git - packages/curl.git/blame - curl.spec
- up to 7.67.0
[packages/curl.git] / curl.spec
CommitLineData
8a9e937b 1# TODO: ngtpc2/nghttp3 when ready (packages released, support working in curl)
195ea5a8
JB
2#
3# Conditional build:
358ad66a
JB
4%bcond_without ssh # SSH support
5%bcond_without ssl # SSL support
6%bcond_with gnutls # GnuTLS instead of OpenSSL
7%bcond_without kerberos5 # Heimdal Kerberos 5 support
8%bcond_without ldap # LDAP support
8424568c 9%bcond_without http2 # HTTP/2.0 support (nghttp2 based)
358ad66a 10%bcond_without metalink # metalink support
de17b215 11%if "%{pld_release}" != "ac"
358ad66a
JB
12%bcond_without ares # c-ares (asynchronous DNS operations) library support
13%bcond_without rtmp # Real Time Media Protocol support
de17b215 14%else
358ad66a
JB
15%bcond_with ares # c-ares (asynchronous DNS operations) library support
16%bcond_with rtmp # Real Time Media Protocol support
de17b215
ER
17%endif
18
f7f276d9 19Summary: A utility for getting files from remote servers (FTP, HTTP, and others)
ce380d80
ER
20Summary(es.UTF-8): Un cliente para bajar archivos de servidores (FTP, HTTP, y otros)
21Summary(pl.UTF-8): Narzędzie do ściągania plików z serwerów (FTP, HTTP i innych)
22Summary(pt_BR.UTF-8): Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e HTTPS)
23Summary(ru.UTF-8): Утилита для получения файлов с серверов FTP, HTTP и других
24Summary(uk.UTF-8): Утиліта для отримання файлів з серверів FTP, HTTP та інших
5767e1a7 25Name: curl
db307259 26Version: 7.67.0
d1d43e0c 27Release: 1
c091c0ac 28License: MIT-like
5767e1a7 29Group: Applications/Networking
d8be0059 30Source0: https://curl.haxx.se/download/%{name}-%{version}.tar.xz
db307259 31# Source0-md5: d55351b88dec558dd3a24dabb2c2d899
d0cec3a8
JB
32Patch0: %{name}-ac.patch
33Patch1: %{name}-krb5flags.patch
4557544f 34URL: http://curl.haxx.se/
c091c0ac 35BuildRequires: autoconf >= 2.57
66cf63f1 36BuildRequires: automake
7c7ffb45 37%{?with_ares:BuildRequires: c-ares-devel >= 1.7.0}
f73c4120 38%{?with_kerberos5:BuildRequires: heimdal-devel}
8a129a6b 39BuildRequires: libbrotli-devel >= 1.0.0
04f3f89d 40BuildRequires: libidn2-devel
e80259d2
JB
41%{?with_metalink:BuildRequires: libmetalink-devel >= 0.1.0}
42BuildRequires: libpsl-devel
9defadab 43%{?with_rtmp:BuildRequires: librtmp-devel}
b83a223e 44%{?with_ssh:BuildRequires: libssh2-devel >= 1.2.8}
c091c0ac 45BuildRequires: libtool
0f90f9c0 46BuildRequires: nettle-devel
9204ae0d 47%{?with_http2:BuildRequires: nghttp2-devel >= 1.9.0}
588be88f 48%{?with_ldap:BuildRequires: openldap-devel}
c260acfc 49BuildRequires: pkgconfig
de17b215 50BuildRequires: rpm >= 4.4.9-56
838a6eda 51BuildRequires: rpmbuild(macros) >= 1.527
5559a124
AM
52%if %{with ssl}
53%if %{with gnutls}
54BuildRequires: gnutls-devel
55%else
549c5328 56BuildRequires: openssl-devel >= 1.0.1
5559a124
AM
57%endif
58%endif
d04a5e91 59BuildRequires: tar >= 1:1.22
6903f0dc 60BuildRequires: zlib-devel
3fb47407 61Requires: %{name}-libs = %{version}-%{release}
cfa95fc0 62Obsoletes: libcurl2
8aa4e5ec 63BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
81714278 64
65%description
655b91ad 66cURL is a tool for getting files with URL syntax, supporting FTP,
67HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP. cURL supports HTTP
68POST, HTTP PUT, FTP uploading, HTTP form based upload, proxies,
69cookies, user+password authentication and a busload of other useful
70tricks. The main use for curl is when you want to get or send files
71automatically to or from a site using one of the supported protocols.
72
73cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
74Dict servers, using any of the supported protocols. cURL is designed
75to work without user interaction or any kind of interactivity. cURL
76offers many useful capabilities, like proxy support, user
e566d906 77authentication, FTP upload, HTTP post, and file transfer resume.
81714278 78
d63bcf1b
JR
79%description -l pl.UTF-8
80cURL jest narzędziem do ściągania plików o składni URL. Obsługuje FTP,
81HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obsługuje również
82HTTP POST, HTTP PUT, załadowywanie (uploading) FTP, załadowywanie HTTP
655b91ad 83oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
d63bcf1b
JR
84użytkownik/hasło oraz wiele innych użytecznych sztuczek. Curla używa
85się głównie wtedy, kiedy chce się automatycznie ściągnąć lub wysłać
86pliki z/na serwer używając jednego z dostępnych protokołów.
87%{?with_ssl:Ten pakiet obsługuje także SSL.}
1310544e 88
d63bcf1b
JR
89%description -l pt_BR.UTF-8
90Curl é um cliente para baixar/enviar arquivos de/para servidores
91usando um dos protocolos suportados. É projetado para funcionar sem a
92interação do usuário.
1310544e 93
d63bcf1b
JR
94Curl trabalha com proxy, autenticação, FTP put, HTTP post, e pode
95continuar transferências interrompidas, e mais...
1310544e 96
d63bcf1b
JR
97%description -l ru.UTF-8
98curl - это клиент с множеством поддерживаемых протоколов для получения
99файлов с серверов, спроектированный для работы как в неинтерактивном
100режиме, так и с возможностью диалога с пользователем.
f05b825f 101
d63bcf1b
JR
102curl поддерживает много полезных возможностей, среди которых поддержка
103прокси, авторизация пользователя, закачивание по FTP, поддержка HTTP
104POST, восстановление прерванной пересылки и многое другое.
f05b825f 105
d63bcf1b
JR
106curl - це кл╕╓нт з багатьма п╕дтримуваними протоколами для отримання
107файл╕в з сервер╕в, спроектований для роботи як в не╕нтерактивному
108режим╕, так ╕ з можлив╕стю д╕алогу з користувачем.
f05b825f 109
d63bcf1b
JR
110curl п╕дтриму╓ багато корисних можливостей, серед яких п╕дтримка
111прокс╕, авторизац╕я користувача, в╕двантаження по FTP, HTTP POST,
112в╕дновлення перервано╖ пересилки та багато ╕ншого.
f05b825f 113
814b6f7d
JB
114%package libs
115Summary: curl library
ce380d80 116Summary(pl.UTF-8): Biblioteka curl
814b6f7d 117Group: Libraries
de17b215 118%{?with_ares:Requires: c-ares >= 1.7.0}
549c5328 119%{?with_ssh:Requires: libssh2 >= 1.2.8}
f2dad801 120%{?with_http2:Requires: nghttp2-libs >= 1.9.0}
fddc44fa 121%if %{with ssl} && %{without gnutls}
549c5328 122Requires: openssl >= 1.0.1
fddc44fa 123%endif
dfeb0d8d
PG
124Suggests: ca-certificates
125Conflicts: ca-certificates < 20080809-4
814b6f7d
JB
126
127%description libs
128curl library.
129
d63bcf1b 130%description libs -l pl.UTF-8
814b6f7d
JB
131Biblioteka curl.
132
1f54b511 133%package devel
134Summary: Header files and development documentation for curl library
ce380d80
ER
135Summary(pl.UTF-8): Pliki nagłówkowe i dokumentacja do biblioteki curl
136Summary(pt_BR.UTF-8): Arquivos de cabeçalho e bibliotecas de desenvolvimento
137Summary(ru.UTF-8): Файлы для разработки с использованием библиотеки curl
138Summary(uk.UTF-8): Файли для розробки з використанням бібліотеки curl
1f54b511 139Group: Development/Libraries
3fb47407 140Requires: %{name}-libs = %{version}-%{release}
bd2c841c 141%{?with_ares:Requires: c-ares-devel}
f73c4120 142%{?with_kerberos5:Requires: heimdal-devel}
72fe5a16 143Requires: libbrotli-devel >= 1.0.0
04f3f89d 144Requires: libidn2-devel
e80259d2 145Requires: libpsl-devel
70778617 146%{?with_rtmp:Requires: librtmp-devel}
b83a223e 147%{?with_ssh:Requires: libssh2-devel >= 1.2.8}
9204ae0d 148%{?with_http2:Requires: nghttp2-devel >= 1.9.0}
588be88f 149%{?with_ldap:Requires: openldap-devel}
5559a124
AM
150%if %{with ssl}
151%if %{with gnutls}
152Requires: gnutls-devel
153%else
154Requires: openssl-devel >= 0.9.7c
155%endif
156%endif
5e1699d5 157Requires: zlib-devel
cfa95fc0 158Obsoletes: libcurl2-devel
1f54b511 159
160%description devel
161Header files and development documentation for curl library.
162
d63bcf1b
JR
163%description devel -l pl.UTF-8
164Pliki nagłówkowe i dokumentacja do biblioteki curl.
cec38cdf 165
d63bcf1b
JR
166%description devel -l pt_BR.UTF-8
167Arquivos de cabeçalho e bibliotecas de desenvolvimento.
1310544e 168
d63bcf1b
JR
169%description devel -l ru.UTF-8
170Этот пакет содержит файлы, необходимые для разработки программ с
171использованием библиотеки curl.
f05b825f 172
d63bcf1b
JR
173%description devel -l uk.UTF-8
174Цей пакет містить файли, необхідні для розробки програм з
175використанням бібліотеки curl.
f05b825f 176
1f54b511 177%package static
178Summary: Static version of curl library
ce380d80
ER
179Summary(pl.UTF-8): Statyczna wersja biblioteki curl
180Summary(pt_BR.UTF-8): Bibliotecas estáticas para desenvolvimento com o curl
181Summary(ru.UTF-8): Статические библиотеки для разработки с использованием библиотеки curl
182Summary(uk.UTF-8): Статичні бібліотеки для розробки з використанням бібліотеки curl
1f54b511 183Group: Development/Libraries
6e6a5186 184Requires: %{name}-devel = %{version}-%{release}
1f54b511 185
186%description static
d06d2fe1 187Static version of curl library.
1f54b511 188
d63bcf1b 189%description static -l pl.UTF-8
cec38cdf 190Statyczna wersja biblioteki curl.
b73e2a73 191
d63bcf1b
JR
192%description static -l pt_BR.UTF-8
193Bibliotecas estáticas para desenvolvimento com o curl.
1310544e 194
d63bcf1b
JR
195%description static -l ru.UTF-8
196Этот пакет содержит статическую библиотеку для разработки программ с
197использованием библиотеки curl.
f05b825f 198
d63bcf1b
JR
199%description static -l uk.UTF-8
200Цей пакет містить статичну бібліотеку для розробки програм з
201використанням бібліотеки curl.
f05b825f 202
8a62d0ef
AG
203%package -n fish-completion-%{name}
204Summary: Fish completion for curl command
205Summary(pl.UTF-8): Dopełnianie parametrów w fish dla polecenia curl
206Group: Applications/Shells
207Requires: %{name} = %{version}-%{release}
208Requires: fish
209
210%description -n fish-completion-%{name}
211Fish completion for curl command.
212
213%description -n fish-completion-%{name} -l pl.UTF-8
214Dopełnianie parametrów w fish dla polecenia curl.
215
e80259d2
JB
216%package -n zsh-completion-curl
217Summary: ZSH completion for curl command
218Summary(pl.UTF-8): Dopełnianianie parametrów w ZSH dla polecenia curl
219Group: Applications/Shells
220Requires: %{name} = %{version}-%{release}
221Requires: zsh
222
223%description -n zsh-completion-curl
224ZSH completion for curl command.
225
226%description -n zsh-completion-curl -l pl.UTF-8
227Dopełnianianie parametrów w ZSH dla polecenia curl.
228
81714278 229%prep
13caa23a 230%setup -q
d0cec3a8 231%patch0 -p1
d4dc980e 232%patch1 -p1
81714278 233
358ad66a 234%{__rm} m4/lt*.m4 m4/libtool.m4
36cd7270 235
81714278 236%build
c091c0ac 237%{__libtoolize}
03613829 238%{__aclocal} -I m4
d4dc980e
AM
239%{__autoconf}
240%{__autoheader}
c091c0ac 241%{__automake}
e566d906 242%configure \
ef822e11 243 ac_cv_header_gss_h=no \
e80259d2
JB
244 %{__enable_disable ares} \
245 --enable-ipv6 \
246 %{__enable_disable ldap} \
247 %{__enable_disable ldap ldaps} \
248 --disable-silent-rules \
5559a124 249%if %{with ssl}
03613829 250 --with-ca-bundle=/etc/certs/ca-certificates.crt \
5559a124 251%if %{with gnutls}
28c87603 252 --with-gnutls --without-ssl \
5559a124
AM
253%else
254 --with-ssl=%{_prefix} \
255%endif
0eee87e5
AM
256%else
257 --without-ssl --without-gnutls \
5559a124 258%endif
8a62d0ef 259 --with-fish-functions-dir=%{fish_compdir} \
838a6eda
JK
260 %{__with_without kerberos5 gssapi %{_prefix}} \
261 %{__with_without metalink libmetalink} \
262 %{__with_without rtmp librtmp} \
263 %{__with_without http2 nghttp2} \
e80259d2 264 %{__with_without ssh libssh2}
a436679a 265
c2167492 266%{__make}
81714278 267
268%install
5767e1a7 269rm -rf $RPM_BUILD_ROOT
56f17d66
AM
270%{__make} install \
271 DESTDIR=$RPM_BUILD_ROOT
272
4f6d4393
JB
273%{__make} -C scripts install \
274 DESTDIR=$RPM_BUILD_ROOT
275
34ca770a 276# no longer in upstream but a lot of apps tries to include it so we create fake one
925b36ff
AM
277[ -e $RPM_BUILD_ROOT%{_includedir}/curl/types.h ] && exit 1
278echo '#warning curl/types.h IS OBSOLETE FROM 2004. STOP USING IT' > $RPM_BUILD_ROOT%{_includedir}/curl/types.h
34ca770a 279
81714278 280%clean
281rm -rf $RPM_BUILD_ROOT
81714278 282
3fb47407
ER
283%post libs -p /sbin/ldconfig
284%postun libs -p /sbin/ldconfig
1f54b511 285
81714278 286%files
5767e1a7 287%defattr(644,root,root,755)
d1d43e0c 288%doc CHANGES COPYING README docs/{BUGS,FAQ,FEATURES,HISTORY.md,KNOWN_BUGS,SSLCERTS.md,THANKS,TODO,TheArtOfHttpScripting}
c091c0ac 289%attr(755,root,root) %{_bindir}/curl
c091c0ac 290%{_mandir}/man1/curl.1*
1f54b511 291
814b6f7d
JB
292%files libs
293%defattr(644,root,root,755)
294%attr(755,root,root) %{_libdir}/libcurl.so.*.*.*
b3964ccb 295%attr(755,root,root) %ghost %{_libdir}/libcurl.so.4
814b6f7d 296
1f54b511 297%files devel
298%defattr(644,root,root,755)
f319ccdb 299%doc docs/{CONTRIBUTE.md,INTERNALS.md,LICENSE-MIXING.md,RESOURCES}
c091c0ac
JB
300%attr(755,root,root) %{_bindir}/curl-config
301%attr(755,root,root) %{_libdir}/libcurl.so
302%{_libdir}/libcurl.la
303%{_includedir}/curl
8ad78925 304%{_pkgconfigdir}/libcurl.pc
1399f3ff 305%{_aclocaldir}/libcurl.m4
c091c0ac 306%{_mandir}/man1/curl-config.1*
b3964ccb
JB
307%{_mandir}/man3/curl_*.3*
308%{_mandir}/man3/libcurl*.3*
0efd10e8 309%{_mandir}/man3/CURLINFO_*.3*
67744768 310%{_mandir}/man3/CURLOPT_*.3*
eb7a78c8 311%{_mandir}/man3/CURLMOPT_*.3*
1f54b511 312
313%files static
314%defattr(644,root,root,755)
c091c0ac 315%{_libdir}/libcurl.a
e80259d2 316
8a62d0ef
AG
317%files -n fish-completion-%{name}
318%defattr(644,root,root,755)
319%{fish_compdir}/%{name}.fish
320
e80259d2
JB
321%files -n zsh-completion-curl
322%defattr(644,root,root,755)
323%{_datadir}/zsh/site-functions/_curl
This page took 0.11212 seconds and 4 git commands to generate.