]> git.pld-linux.org Git - packages/curl.git/blame - curl.spec
- bcond to enable HTTP/2.0 support (broken pkgconfig check atm.)
[packages/curl.git] / curl.spec
CommitLineData
195ea5a8
JB
1#
2# Conditional build:
120855f9
JB
3%bcond_without ssh # without SSH support
4%bcond_without ssl # without SSL support
f73c4120 5%bcond_without kerberos5 # without Heimdal Kerberos 5 support
588be88f 6%bcond_without ldap # without LDAP support
2ea4eb23 7%bcond_with http2 # without HTTP/2.0 support (nghttp2 based)
a17d9303 8%bcond_without metalink # without metalink support
de17b215
ER
9%if "%{pld_release}" != "ac"
10%bcond_without ares # with c-ares (asynchronous DNS operations) library
2a41c99b 11%bcond_with gnutls # use GnuTLS instead of OpenSSL
de17b215
ER
12%bcond_without rtmp # without Real Time Media Protocol
13%else
14%bcond_with ares # with c-ares (asynchronous DNS operations) library
15%bcond_with gnutls # use GnuTLS instead of OpenSSL
16%bcond_with rtmp # without Real Time Media Protocol
17%endif
18
f7f276d9 19Summary: A utility for getting files from remote servers (FTP, HTTP, and others)
ce380d80
ER
20Summary(es.UTF-8): Un cliente para bajar archivos de servidores (FTP, HTTP, y otros)
21Summary(pl.UTF-8): Narzędzie do ściągania plików z serwerów (FTP, HTTP i innych)
22Summary(pt_BR.UTF-8): Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e HTTPS)
23Summary(ru.UTF-8): Утилита для получения файлов с серверов FTP, HTTP и других
24Summary(uk.UTF-8): Утиліта для отримання файлів з серверів FTP, HTTP та інших
5767e1a7 25Name: curl
3b76884a 26Version: 7.33.0
d0cec3a8 27Release: 1
c091c0ac 28License: MIT-like
5767e1a7 29Group: Applications/Networking
0307878f 30Source0: http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
3b76884a 31# Source0-md5: eb463192f37c260163e006d6c4d3f114
d0cec3a8
JB
32Patch0: %{name}-ac.patch
33Patch1: %{name}-krb5flags.patch
a17d9303
ER
34# make the curl tool link SSL libraries also used by src/tool_metalink.c
35Patch2: metalink.patch
4557544f 36URL: http://curl.haxx.se/
c091c0ac 37BuildRequires: autoconf >= 2.57
66cf63f1 38BuildRequires: automake
7c7ffb45 39%{?with_ares:BuildRequires: c-ares-devel >= 1.7.0}
f73c4120 40%{?with_kerberos5:BuildRequires: heimdal-devel}
2ea4eb23 41%{?with_http2:BuildRequires: nghttp2-devel}
5d94786d 42BuildRequires: libidn-devel >= 0.4.1
a17d9303 43%{?with_metalink:BuildRequires: libmetalink-devel}
9defadab 44%{?with_rtmp:BuildRequires: librtmp-devel}
b83a223e 45%{?with_ssh:BuildRequires: libssh2-devel >= 1.2.8}
c091c0ac 46BuildRequires: libtool
0f90f9c0 47BuildRequires: nettle-devel
588be88f 48%{?with_ldap:BuildRequires: openldap-devel}
c260acfc 49BuildRequires: pkgconfig
de17b215
ER
50BuildRequires: rpm >= 4.4.9-56
51BuildRequires: rpmbuild(macros) >= 1.453
5559a124
AM
52%if %{with ssl}
53%if %{with gnutls}
54BuildRequires: gnutls-devel
55%else
56BuildRequires: openssl-devel >= 0.9.7d
57%endif
58%endif
d04a5e91 59BuildRequires: tar >= 1:1.22
6903f0dc 60BuildRequires: zlib-devel
3fb47407 61Requires: %{name}-libs = %{version}-%{release}
5d94786d 62Requires: libidn >= 0.4.1
b83a223e 63%{?with_ssh:Requires: libssh2 >= 1.2.8}
cfa95fc0 64Obsoletes: libcurl2
8aa4e5ec 65BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
81714278 66
67%description
655b91ad 68cURL is a tool for getting files with URL syntax, supporting FTP,
69HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP. cURL supports HTTP
70POST, HTTP PUT, FTP uploading, HTTP form based upload, proxies,
71cookies, user+password authentication and a busload of other useful
72tricks. The main use for curl is when you want to get or send files
73automatically to or from a site using one of the supported protocols.
74
75cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
76Dict servers, using any of the supported protocols. cURL is designed
77to work without user interaction or any kind of interactivity. cURL
78offers many useful capabilities, like proxy support, user
e566d906 79authentication, FTP upload, HTTP post, and file transfer resume.
81714278 80
d63bcf1b
JR
81%description -l pl.UTF-8
82cURL jest narzędziem do ściągania plików o składni URL. Obsługuje FTP,
83HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obsługuje również
84HTTP POST, HTTP PUT, załadowywanie (uploading) FTP, załadowywanie HTTP
655b91ad 85oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
d63bcf1b
JR
86użytkownik/hasło oraz wiele innych użytecznych sztuczek. Curla używa
87się głównie wtedy, kiedy chce się automatycznie ściągnąć lub wysłać
88pliki z/na serwer używając jednego z dostępnych protokołów.
89%{?with_ssl:Ten pakiet obsługuje także SSL.}
1310544e 90
d63bcf1b
JR
91%description -l pt_BR.UTF-8
92Curl é um cliente para baixar/enviar arquivos de/para servidores
93usando um dos protocolos suportados. É projetado para funcionar sem a
94interação do usuário.
1310544e 95
d63bcf1b
JR
96Curl trabalha com proxy, autenticação, FTP put, HTTP post, e pode
97continuar transferências interrompidas, e mais...
1310544e 98
d63bcf1b
JR
99%description -l ru.UTF-8
100curl - это клиент с множеством поддерживаемых протоколов для получения
101файлов с серверов, спроектированный для работы как в неинтерактивном
102режиме, так и с возможностью диалога с пользователем.
f05b825f 103
d63bcf1b
JR
104curl поддерживает много полезных возможностей, среди которых поддержка
105прокси, авторизация пользователя, закачивание по FTP, поддержка HTTP
106POST, восстановление прерванной пересылки и многое другое.
f05b825f 107
d63bcf1b
JR
108curl - це кл╕╓нт з багатьма п╕дтримуваними протоколами для отримання
109файл╕в з сервер╕в, спроектований для роботи як в не╕нтерактивному
110режим╕, так ╕ з можлив╕стю д╕алогу з користувачем.
f05b825f 111
d63bcf1b
JR
112curl п╕дтриму╓ багато корисних можливостей, серед яких п╕дтримка
113прокс╕, авторизац╕я користувача, в╕двантаження по FTP, HTTP POST,
114в╕дновлення перервано╖ пересилки та багато ╕ншого.
f05b825f 115
814b6f7d
JB
116%package libs
117Summary: curl library
ce380d80 118Summary(pl.UTF-8): Biblioteka curl
814b6f7d 119Group: Libraries
de17b215 120%{?with_ares:Requires: c-ares >= 1.7.0}
dfeb0d8d
PG
121Suggests: ca-certificates
122Conflicts: ca-certificates < 20080809-4
814b6f7d
JB
123
124%description libs
125curl library.
126
d63bcf1b 127%description libs -l pl.UTF-8
814b6f7d
JB
128Biblioteka curl.
129
1f54b511 130%package devel
131Summary: Header files and development documentation for curl library
ce380d80
ER
132Summary(pl.UTF-8): Pliki nagłówkowe i dokumentacja do biblioteki curl
133Summary(pt_BR.UTF-8): Arquivos de cabeçalho e bibliotecas de desenvolvimento
134Summary(ru.UTF-8): Файлы для разработки с использованием библиотеки curl
135Summary(uk.UTF-8): Файли для розробки з використанням бібліотеки curl
1f54b511 136Group: Development/Libraries
3fb47407 137Requires: %{name}-libs = %{version}-%{release}
bd2c841c 138%{?with_ares:Requires: c-ares-devel}
f73c4120 139%{?with_kerberos5:Requires: heimdal-devel}
5d94786d 140Requires: libidn-devel >= 0.4.1
70778617 141%{?with_rtmp:Requires: librtmp-devel}
b83a223e 142%{?with_ssh:Requires: libssh2-devel >= 1.2.8}
588be88f 143%{?with_ldap:Requires: openldap-devel}
5559a124
AM
144%if %{with ssl}
145%if %{with gnutls}
146Requires: gnutls-devel
147%else
148Requires: openssl-devel >= 0.9.7c
149%endif
150%endif
5e1699d5 151Requires: zlib-devel
cfa95fc0 152Obsoletes: libcurl2-devel
1f54b511 153
154%description devel
155Header files and development documentation for curl library.
156
d63bcf1b
JR
157%description devel -l pl.UTF-8
158Pliki nagłówkowe i dokumentacja do biblioteki curl.
cec38cdf 159
d63bcf1b
JR
160%description devel -l pt_BR.UTF-8
161Arquivos de cabeçalho e bibliotecas de desenvolvimento.
1310544e 162
d63bcf1b
JR
163%description devel -l ru.UTF-8
164Этот пакет содержит файлы, необходимые для разработки программ с
165использованием библиотеки curl.
f05b825f 166
d63bcf1b
JR
167%description devel -l uk.UTF-8
168Цей пакет містить файли, необхідні для розробки програм з
169використанням бібліотеки curl.
f05b825f 170
1f54b511 171%package static
172Summary: Static version of curl library
ce380d80
ER
173Summary(pl.UTF-8): Statyczna wersja biblioteki curl
174Summary(pt_BR.UTF-8): Bibliotecas estáticas para desenvolvimento com o curl
175Summary(ru.UTF-8): Статические библиотеки для разработки с использованием библиотеки curl
176Summary(uk.UTF-8): Статичні бібліотеки для розробки з використанням бібліотеки curl
1f54b511 177Group: Development/Libraries
6e6a5186 178Requires: %{name}-devel = %{version}-%{release}
1f54b511 179
180%description static
d06d2fe1 181Static version of curl library.
1f54b511 182
d63bcf1b 183%description static -l pl.UTF-8
cec38cdf 184Statyczna wersja biblioteki curl.
b73e2a73 185
d63bcf1b
JR
186%description static -l pt_BR.UTF-8
187Bibliotecas estáticas para desenvolvimento com o curl.
1310544e 188
d63bcf1b
JR
189%description static -l ru.UTF-8
190Этот пакет содержит статическую библиотеку для разработки программ с
191использованием библиотеки curl.
f05b825f 192
d63bcf1b
JR
193%description static -l uk.UTF-8
194Цей пакет містить статичну бібліотеку для розробки програм з
195використанням бібліотеки curl.
f05b825f 196
81714278 197%prep
13caa23a 198%setup -q
d0cec3a8 199%patch0 -p1
d4dc980e 200%patch1 -p1
81714278 201
36cd7270
ER
202%{__rm} -v m4/lt*.m4 m4/libtool.m4
203
81714278 204%build
c091c0ac 205%{__libtoolize}
03613829 206%{__aclocal} -I m4
d4dc980e
AM
207%{__autoconf}
208%{__autoheader}
c091c0ac 209%{__automake}
e566d906 210%configure \
ef822e11 211 ac_cv_header_gss_h=no \
5559a124 212%if %{with ssl}
03613829 213 --with-ca-bundle=/etc/certs/ca-certificates.crt \
5559a124 214%if %{with gnutls}
28c87603 215 --with-gnutls --without-ssl \
5559a124
AM
216%else
217 --with-ssl=%{_prefix} \
218%endif
219%endif
7d46ac1d 220 %{?with_kerberos5:--with-gssapi=%{_prefix}} \
a17d9303 221 %{?with_metalink:--with-libmetalink} \
2ea4eb23
JB
222 %{?with_rtmp:--with-librtmp} \
223 %{?with_http2:--with-nghttp2} \
28c87603 224 %{?with_ares:--enable-ares} \
2ea4eb23
JB
225 --enable-ipv6 \
226 %{!?with_ldap:--disable-ldap}%{?with_ldap:--enable-ldaps}
a436679a 227
c2167492 228%{__make}
81714278 229
230%install
5767e1a7 231rm -rf $RPM_BUILD_ROOT
56f17d66
AM
232%{__make} install \
233 DESTDIR=$RPM_BUILD_ROOT
234
34ca770a 235# no longer in upstream but a lot of apps tries to include it so we create fake one
925b36ff
AM
236[ -e $RPM_BUILD_ROOT%{_includedir}/curl/types.h ] && exit 1
237echo '#warning curl/types.h IS OBSOLETE FROM 2004. STOP USING IT' > $RPM_BUILD_ROOT%{_includedir}/curl/types.h
34ca770a 238
81714278 239%clean
240rm -rf $RPM_BUILD_ROOT
81714278 241
3fb47407
ER
242%post libs -p /sbin/ldconfig
243%postun libs -p /sbin/ldconfig
1f54b511 244
81714278 245%files
5767e1a7 246%defattr(644,root,root,755)
c091c0ac
JB
247%doc CHANGES COPYING README docs/{BUGS,FAQ,FEATURES,HISTORY,KNOWN_BUGS,MANUAL,SSLCERTS,THANKS,TODO,TheArtOfHttpScripting}
248%attr(755,root,root) %{_bindir}/curl
c091c0ac 249%{_mandir}/man1/curl.1*
1f54b511 250
814b6f7d
JB
251%files libs
252%defattr(644,root,root,755)
253%attr(755,root,root) %{_libdir}/libcurl.so.*.*.*
b3964ccb 254%attr(755,root,root) %ghost %{_libdir}/libcurl.so.4
814b6f7d 255
1f54b511 256%files devel
257%defattr(644,root,root,755)
c091c0ac
JB
258%doc docs/{CONTRIBUTE,INTERNALS,LICENSE-MIXING,RESOURCES}
259%attr(755,root,root) %{_bindir}/curl-config
260%attr(755,root,root) %{_libdir}/libcurl.so
261%{_libdir}/libcurl.la
262%{_includedir}/curl
8ad78925 263%{_pkgconfigdir}/libcurl.pc
c091c0ac 264%{_mandir}/man1/curl-config.1*
b3964ccb
JB
265%{_mandir}/man3/curl_*.3*
266%{_mandir}/man3/libcurl*.3*
1f54b511 267
268%files static
269%defattr(644,root,root,755)
c091c0ac 270%{_libdir}/libcurl.a
This page took 0.377069 seconds and 4 git commands to generate.