]> git.pld-linux.org Git - packages/crossavr-binutils.git/blame - crossavr-binutils.spec
- updated gettext BR
[packages/crossavr-binutils.git] / crossavr-binutils.spec
CommitLineData
15547bba 1Summary: Cross AVR GNU binary utility development utilities - binutils
80e2ec2d
ER
2Summary(es.UTF-8): Utilitarios para desarrollo de binarios de la GNU - AVR binutils
3Summary(fr.UTF-8): Utilitaires de développement binaire de GNU - AVR binutils
4Summary(pl.UTF-8): Skrośne narzędzia programistyczne GNU dla AVR - binutils
5Summary(pt_BR.UTF-8): Utilitários para desenvolvimento de binários da GNU - AVR binutils
6Summary(tr.UTF-8): GNU geliştirme araçları - AVR binutils
c31c0377 7Name: crossavr-binutils
31ce1ede
JR
8Version: 2.23.1
9Release: 1
3ccd393f 10Epoch: 1
b52dee9a 11Patch0: am.patch
31ce1ede
JR
12# Patches 1xx are taken form Atmel official AVR8-GNU toolchain version 3.4.2
13# http://distribute.atmel.no/tools/opensource/Atmel-AVR-Toolchain-3.4.2/avr/avr-patches.tar.gz
14Patch100: 001-xmega-Makefile_am-typo.patch
15Patch101: 002-tinycore-support.patch
16Patch102: 003-RMW-insn-constriant.patch
17Patch103: 004-new-part-supports.patch
18Patch104: 005-additional-part-supports.patch
19Patch105: 006-xmega-showuage-typo.patch
20Patch106: 007-ata6289-architecture-correction.patch
21Patch107: 008-add-usersig-section.patch
22Patch108: 009-dwarf-relax-fix.patch
23Patch109: 010-disable-demand-paging.patch
24Patch110: 200-binutils-avr-size.patch
25Patch111: 201-binutils-dwarf2-AVRStudio-workaround.patch
26Patch112: 202-binutils-bug13113.patch
27Patch113: 400-binutils-atmxt336s.patch
28Patch114: 401-binutils-atmega48hvf.patch
29Patch115: 402-binutils-atmega26hvg.patch
30Patch116: 403-binutils-atmxt224_224e.patch
31Patch117: 404-binutils-atmxt112sl.patch
32Patch118: 405-binutils-atmxt540s.patch
33Patch119: 406-binutils-ata5831.patch
34Patch120: 407-binutils-attiny841.patch
35Patch121: 408-binutils-atmegarfa2.patch
36Patch122: 409-binutils-ata5790n.patch
37Patch123: 410-binutils-atmega64hve2.patch
38Patch124: 411-binutils-attiny474.patch
39Patch125: 412-binutils-atmxts200.patch
40Patch126: 500-binutils-avrtc530-backported.patch
c31c0377
WK
41License: GPL
42Group: Development/Tools
323ea808 43Source0: ftp://ftp.gnu.org/gnu/binutils/binutils-%{version}.tar.bz2
31ce1ede 44# Source0-md5: 33adb18c3048d057ac58d07a3f1adb38
c3700061 45URL: http://sources.redhat.com/binutils/
4f1d398f 46BuildRequires: automake
c3700061 47BuildRequires: bash
c31c0377 48BuildRequires: bison
c3700061 49BuildRequires: flex
e63d7f14 50BuildRequires: gettext-tools
30f666e7 51BuildRequires: gcc-c++
e09b612e 52BuildRequires: perl-tools-pod
f4a6ca9d 53BuildRequires: texinfo
c31c0377
WK
54%ifarch sparc sparc32
55BuildRequires: sparc32
56%endif
57BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
58
59%define target avr
60%define arch %{_prefix}/%{target}
61
62%description
63Binutils is a collection of binary utilities, including:
64- ar - create, modify and extract from archives,
65- nm - lists symbols from object files,
66- objcopy - copy and translate object files,
67- objdump - display information from object files,
68- ranlib - generate an index for the contents of an archive,
69- size - list the section sizes of an object or archive file,
70- strings - list printable strings from files,
71- strip - discard symbols,
72- c++filt - a filter for demangling encoded C++ symbols,
73- addr2line - convert addresses to file and line,
74- nlmconv - convert object code into an NLM.
75
15547bba 76This package contains the cross version for Atmel AVR.
c31c0377 77
f3e2688f
JR
78%description -l pl.UTF-8
79Pakiet binutils zawiera zestaw narzędzi umożliwiających kompilację
80programów. Znajdują się tutaj między innymi assembler, konsolidator
81(linker), a także inne narzędzia do manipulowania binarnymi plikami
82programów i bibliotek.
c31c0377 83
f3e2688f 84Ten pakiet zawiera wersję skrośną generującą kod dla Atmel AVR.
c31c0377
WK
85
86%prep
87%setup -q -n binutils-%{version}
b52dee9a 88%patch0 -p1
3ccd393f 89%patch100 -p0
90%patch101 -p0
91%patch102 -p0
92%patch103 -p0
93%patch104 -p0
94%patch105 -p0
95%patch106 -p0
96%patch107 -p0
97%patch108 -p0
98%patch109 -p0
99%patch110 -p0
100%patch111 -p0
101%patch112 -p0
102%patch113 -p0
103%patch114 -p0
104%patch115 -p0
105%patch116 -p0
106%patch117 -p0
107%patch118 -p0
108%patch119 -p0
109%patch120 -p0
110%patch121 -p0
111%patch122 -p0
112%patch123 -p0
113%patch124 -p0
114%patch125 -p0
115%patch126 -p0
fbe885ec
PZ
116
117# Remove hacks for specific autoconf version.
118echo > config/override.m4
c31c0377
WK
119
120%build
fbe885ec
PZ
121%{__aclocal}
122%{__autoconf}
123for subdir in bfd binutils ld; do
124 cd $subdir
125 %{__aclocal} -I.. -I../bfd -I../config
126 %{__automake}
127 %{__autoconf}
128 cd -
129done
4f1d398f 130
c31c0377 131# ldscripts won't be generated properly if SHELL is not bash...
c3700061
JB
132CFLAGS="%{rpmcflags}" \
133LDFLAGS="%{rpmldflags}" \
c31c0377
WK
134CONFIG_SHELL="/bin/bash" \
135%ifarch sparc
136sparc32 \
137%endif
138./configure \
30f666e7 139 --enable-gold \
2de3da85 140 --disable-shared \
3ccd393f 141 --disable-werror \
c31c0377 142 --prefix=%{_prefix} \
4f1d398f 143 --libdir=%{_libdir} \
c31c0377 144 --mandir=%{_mandir} \
4f1d398f 145 --infodir=%{_infodir} \
d7e2b08f 146 --host=%{_target_platform} \
147 --build=%{_target_platform} \
c31c0377
WK
148 --target=%{target}
149
323ea808 150# We have to regenerate headers after patching.
151%{__make} configure-host \
152 tooldir=%{_prefix} \
153 EXEEXT=""
154
155%{__make} -C bfd headers \
156 tooldir=%{_prefix} \
157 EXEEXT=""
158
c3700061
JB
159%{__make} all \
160 tooldir=%{_prefix} \
161 EXEEXT=""
c31c0377
WK
162
163%install
164rm -rf $RPM_BUILD_ROOT
165install -d $RPM_BUILD_ROOT%{_prefix}
166
167%{__make} install \
168 prefix=$RPM_BUILD_ROOT%{_prefix} \
f0155d93 169 mandir=$RPM_BUILD_ROOT%{_mandir} \
14538aa8 170 infodir=$RPM_BUILD_ROOT%{_infodir} \
171 libdir=$RPM_BUILD_ROOT%{_libdir}
c31c0377 172
4f1d398f 173# remove these man pages unless we cross-build for win*/netware platforms.
174# however, this should be done in Makefiles.
175rm -f $RPM_BUILD_ROOT%{_mandir}/man1/{*dlltool,*nlmconv,*windres}.1
176
95d38776
ER
177rm -f $RPM_BUILD_ROOT%{_datadir}/locale/*/LC_MESSAGES/*.mo
178rm -f $RPM_BUILD_ROOT%{_libdir}/libiberty.a
179rm -rf $RPM_BUILD_ROOT%{_infodir}
180
c31c0377
WK
181%clean
182rm -rf $RPM_BUILD_ROOT
183
184%files
185%defattr(644,root,root,755)
9959e179 186%doc README
c31c0377 187%attr(755,root,root) %{_bindir}/%{target}-*
9959e179 188%dir %{arch}
c31c0377
WK
189%dir %{arch}/bin
190%attr(755,root,root) %{arch}/bin/*
191%dir %{arch}/lib
192%dir %{arch}/lib/*
f53587c5 193%{arch}/lib/*/*
c31c0377 194%{_mandir}/man?/%{target}-*
This page took 0.534901 seconds and 4 git commands to generate.