]> git.pld-linux.org Git - packages/cogl.git/blame - cogl.spec
- initial PLD release
[packages/cogl.git] / cogl.spec
CommitLineData
a8e45d23
PZ
1Summary: A library for using 3D graphics hardware to draw pretty pictures
2Name: cogl
3Version: 1.7.4
4Release: 1
5License: LGPL v2+
6Group: Development/Libraries
7Source0: http://www.clutter-project.org/sources/cogl/1.7/%{name}-%{version}.tar.xz
8# Source0-md5: ad6937676e0df43be5befe7dc13084cd
9URL: http://www.clutter-project.org/
10BuildRequires: OpenGL-GLX-devel
11BuildRequires: cairo-devel
12BuildRequires: glib2-devel
13BuildRequires: gobject-introspection-devel
14BuildRequires: gtk-doc
15BuildRequires: pango-devel
16BuildRequires: pkgconfig
17BuildRequires: xorg-lib-libXcomposite-devel
18BuildRequires: xorg-lib-libXdamage-devel
19BuildRequires: xorg-lib-libXext-devel
20BuildRequires: xorg-lib-libXfixes-devel
21
22%description
23Cogl is a small open source library for using 3D graphics hardware to
24draw pretty pictures. The API departs from the flat state machine
25style of OpenGL and is designed to make it easy to write orthogonal
26components that can render without stepping on each others toes.
27
28As well aiming for a nice API, we think having a single library as
29opposed to an API specification like OpenGL has a few advantages too;
30like being able to paper over the inconsistencies/bugs of different
31OpenGL implementations in a centralized place, not to mention the
32myriad of OpenGL extensions. It also means we are in a better position
33to provide utility APIs that help software developers since they only
34need to be implemented once and there is no risk of inconsistency
35between implementations.
36
37Having other backends, besides OpenGL, such as drm, Gallium or D3D are
38options we are interested in for the future.
39
40%package devel
41Summary: %{name} development environment
42Group: Development/Libraries
43Requires: %{name} = %{version}-%{release}
44Requires: OpenGL-GLX-devel
45Requires: cairo-devel
46Requires: glib2-devel
47Requires: gobject-introspection-devel
48Requires: pango-devel
49Requires: pkgconfig
50
51%description devel
52Header files and libraries for building and developing apps with
53%{name}.
54
55%package doc
56Summary: Documentation for %{name}
57Group: Documentation
58Requires: %{name} = %{version}-%{release}
59
60%description doc
61This package contains documentation for %{name}.
62
63%prep
64%setup -q
65
66%build
67CFLAGS="$RPM_OPT_FLAGS -fPIC"
68
69%configure \
70 --enable-cairo=yes \
71 --enable-gdk-pixbuf=no \
72 --enable-cogl-pango=yes \
73 --enable-glx=yes \
74 --enable-gtk-doc \
75 --enable-introspection=yes \
76 --with-html-dir=%{_gtkdocdir}
77%{__make}
78
79%install
80rm -rf $RPM_BUILD_ROOT
81%{__make} install \
82 DESTDIR=$RPM_BUILD_ROOT
83
84%{__rm} $RPM_BUILD_ROOT%{_libdir}/libcogl.la
85%{__rm} $RPM_BUILD_ROOT%{_libdir}/libcogl-pango.la
86
87%find_lang %{name}
88
89%post -p /sbin/ldconfig
90
91%postun -p /sbin/ldconfig
92
93%files -f %{name}.lang
94%defattr(644,root,root,755)
95%doc COPYING NEWS README ChangeLog
96%attr(755,root,root) %{_libdir}/libcogl.so.*.*.*
97%attr(755,root,root) %ghost %{_libdir}/libcogl.so.2
98%attr(755,root,root) %{_libdir}/libcogl-pango.so.*.*.*
99%attr(755,root,root) %ghost %{_libdir}/libcogl-pango.so.0
100%{_libdir}/girepository-1.0/Cogl-1.0.typelib
101%{_libdir}/girepository-1.0/CoglPango-1.0.typelib
102
103%files devel
104%defattr(644,root,root,755)
105%{_includedir}/cogl
106%{_libdir}/libcogl.so
107%{_libdir}/libcogl-pango.so
108%{_pkgconfigdir}/cogl-1.0.pc
109%{_pkgconfigdir}/cogl-2.0-experimental.pc
110%{_pkgconfigdir}/cogl-gl-1.0.pc
111%{_pkgconfigdir}/cogl-pango-1.0.pc
112%{_pkgconfigdir}/cogl-pango-2.0-experimental.pc
113%{_datadir}/gir-1.0/Cogl-1.0.gir
114%{_datadir}/gir-1.0/CoglPango-1.0.gir
115
116%files doc
117%defattr(644,root,root,755)
118%{_gtkdocdir}/cogl
119%{_gtkdocdir}/cogl-2.0-experimental
This page took 0.050791 seconds and 4 git commands to generate.