]> git.pld-linux.org Git - packages/clementine.git/blame - clementine.spec
fix build with libimobiledevice-1.1.5; patch from fedora
[packages/clementine.git] / clementine.spec
CommitLineData
2c687024 1# TODO:
f2d911f2 2# - Gstreamer error: "A text/uri-list decoder plugin is required to play this stream, but not installed."
f2d911f2 3# - apply patches to libprojectM.spec and use
6b78beb2
ER
4# - checking for module 'libspotify>=12.1.45' - Spotify support: non-GPL binary helper (missing libspotify)
5# - checking for module 'libchromaprint'
6# - Google Drive support (missing Google sparsehash)
7# - package for kde4 stuff (or nuke them):
8# /usr/share/kde4/services/clementine-feed.protocol
9# /usr/share/kde4/services/clementine-itms.protocol
10# /usr/share/kde4/services/clementine-itpc.protocol
11# /usr/share/kde4/services/clementine-zune.protocol
2c687024 12#
13# Conditional build:
c6f8dd12 14%bcond_without static_sqlite # with static sqlite3
3834eb29 15%bcond_with static_projectm # with static projectM
0b056df0 16
064e709c 17%define qtver %(pkg-config --silence-errors --modversion QtCore 2>/dev/null || echo ERROR)
bf1e6952 18Summary: A music player and library organiser
df3c0ac1 19Summary(hu.UTF-8): Egy zenelejátszó és gyűjtemény-kezelő
bf1e6952 20Name: clementine
dbbdd85a 21Version: 1.1.1
4a572e41 22Release: 6
bf1e6952
ER
23License: GPL v3 and GPL v2+
24Group: Applications/Multimedia
f823a794 25URL: http://www.clementine-player.org/
bf272879 26Source0: http://clementine-player.googlecode.com/files/%{name}-%{version}.tar.gz
dbbdd85a 27# Source0-md5: 28e4afb822388bd337a761db8f86febf
f823a794 28Patch0: desktop-install.patch
10ecf727 29Patch1: unbundle-po.patch
4a572e41 30Patch2: %{name}-1.1.1-libimobiledevice-fix.patch
64d9867e
ER
31BuildRequires: QtCore-devel >= %{qtver}
32BuildRequires: QtDBus-devel >= %{qtver}
33BuildRequires: QtGui-devel >= %{qtver}
f2d911f2 34BuildRequires: QtIOCompressor-devel
64d9867e
ER
35BuildRequires: QtNetwork-devel >= %{qtver}
36BuildRequires: QtOpenGL-devel >= %{qtver}
acb98f48 37BuildRequires: QtSingleApplication-devel >= 2.6-4
64d9867e
ER
38BuildRequires: QtSql-devel >= %{qtver}
39%{?with_tests:BuildRequires: QtTest-devel >= %{qtver}}
40BuildRequires: QtXml-devel >= %{qtver}
7dce7848 41BuildRequires: QtXmlPatterns-devel >= %{qtver}
bf1e6952 42BuildRequires: boost-devel
7279ad3f 43BuildRequires: cmake >= 2.6
f823a794 44#%{?with_static_projectm:BuildRequires: ftgl-devel >= 2.1.3}
75ec0859 45BuildRequires: gettext-devel
f823a794 46%{?with_static_projectm:BuildRequires: glew-devel}
8f83a8c0 47BuildRequires: glib2-devel
dbbdd85a
JK
48BuildRequires: gstreamer0.10-devel
49BuildRequires: gstreamer0.10-plugins-base-devel
bf1e6952 50BuildRequires: gtest-devel
8f83a8c0
ER
51BuildRequires: libgpod-devel >= 0.7.92
52BuildRequires: libimobiledevice-devel
2eedc3b1 53BuildRequires: libindicate-qt-devel
e0ba0da9 54BuildRequires: liblastfm-devel >= 0.3.3
8f83a8c0 55BuildRequires: libmtp-devel
8f83a8c0 56BuildRequires: libplist-devel
f823a794 57%{!?with_static_projectm:BuildRequires: libprojectM-devel >= 1:2.0.1-4}
bf1e6952 58BuildRequires: libqxt-devel
8f83a8c0 59BuildRequires: libxml2-devel
75ec0859 60BuildRequires: pkgconfig
2eedc3b1 61BuildRequires: pkgconfig
e0ba0da9 62BuildRequires: protobuf-devel
49968d1b 63BuildRequires: qca-devel
e0ba0da9 64BuildRequires: qjson-devel
64d9867e 65BuildRequires: qt4-build >= %{qtver}
b6199a83 66BuildRequires: qt4-linguist
67BuildRequires: qt4-qmake
7aaa97de 68BuildRequires: rpmbuild(find_lang) >= 1.33
2eedc3b1 69BuildRequires: rpmbuild(macros) >= 1.596
bf1e6952 70BuildRequires: sed >= 4.0
742e4e0a 71%{!?with_static_sqlite:BuildRequires: sqlite3-devel}
f2d911f2 72BuildRequires: taglib-devel >= 1.6
8f83a8c0 73BuildRequires: usbmuxd-devel
726826ed 74Requires(post,postun): desktop-file-utils
23941661
AF
75Requires(post,postun): gtk-update-icon-cache
76Requires(post,postun): hicolor-icon-theme
acb98f48 77Requires: QtSingleApplication >= 2.6-4
64d9867e 78%{!?with_static_sqlite:Requires: QtSql-sqlite3 >= %{qtver}}
dbbdd85a 79Requires: gstreamer0.10-audio-effects-base
862961b4 80Requires: gstreamer0.10-mad
f2d911f2
ER
81# while we do not link (yet), we use datafiles
82Requires: libprojectM
bf1e6952
ER
83BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
84
f2d911f2
ER
85# see libprojectM.spec for explanation
86%define filterout_ld -Wl,--as-needed -Wl,--no-copy-dt-needed-entries
87
bf1e6952
ER
88%description
89Clementine is a modern music player and library organiser. It is
90largely a port of Amarok 1.4, with some features rewritten to take
91advantage of Qt4.
92
df3c0ac1
ZU
93%description -l hu.UTF-8
94Clementine egy modern zenelejátszó és gyűjtemény kezelő. Túlnyomórészt
95az Amarok 1.4 port-ja, néhány funkciója újraírva, hogy kihasználhassa
96a Qt4 előnyeit.
97
bf1e6952 98%prep
862961b4 99%setup -q
f2d911f2 100%patch0 -p1
10ecf727 101%patch1 -p1
4a572e41 102%patch2 -p1
bf1e6952
ER
103
104# We already don't use these but just to make sure
f2d911f2 105rm -rf 3rdparty/gmock
742e4e0a 106%{!?with_static_sqlite:rm -rf 3rdparty/qsqlite}
f2d911f2
ER
107rm -rf 3rdparty/qtsingleapplication
108rm -rf 3rdparty/qxt
109rm -rf 3rdparty/qtiocompressor
aca708d9 110%{!?with_static_projectm:rm -rf 3rdparty/libprojectM}
bf1e6952 111
7279ad3f 112# Don't build tests. They require gmock
f2d911f2 113sed -i -e '/add_subdirectory(tests)/d' CMakeLists.txt
ea86e9d9
BZ
114# remove -Wall
115sed -i -e 's/-Wall//' src/CMakeLists.txt
064e709c
JR
116# ...and -Werror
117sed -i -e 's/-Werror//' src/CMakeLists.txt
bf1e6952
ER
118
119%build
120install -d build
7aaa97de 121install -d build/src/translations
bf1e6952 122cd build
6b78beb2
ER
123# as our buildtype is not Release, need to pass these manually. see CMakeLists.txt ~125
124CXXFLAGS="%{rpmcxxflags} -DNDEBUG -DQT_NO_DEBUG_OUTPUT"
88ca6f4b 125%cmake \
f2d911f2 126 -DBUNDLE_PROJECTM_PRESETS=OFF \
f823a794 127 -DUSE_SYSTEM_QTSINGLEAPPLICATION=ON \
862961b4 128 -DQTSINGLEAPPLICATION_INCLUDE_DIRS=%{_includedir}/qt4/QtSolutions/ \
f823a794
ER
129 -DUSE_SYSTEM_QXT=ON \
130 -DUSE_SYSTEM_PROJECTM=ON \
742e4e0a 131 -DSTATIC_SQLITE=%{?with_static_sqlite:ON}%{!?with_static_sqlite:OFF} \
88ca6f4b 132 ..
bf1e6952
ER
133%{__make}
134
135%install
136rm -rf $RPM_BUILD_ROOT
137%{__make} -C build install \
138 DESTDIR=$RPM_BUILD_ROOT
139
f823a794
ER
140rm $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/scalable/apps/application-x-clementine.svg
141
dbbdd85a
JK
142# not in our glibc?
143rm -r $RPM_BUILD_ROOT%{_localedir}/tr_TR
144
10ecf727
ER
145%find_lang %{name} --with-qm
146
23f69c7b
BZ
147install -d $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps
148cp -a dist/icons/ubuntu-mono-light/clementine-panel-grey.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps/clementine-panel-grey.png
149cp -a dist/icons/ubuntu-mono-light/clementine-panel.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps/clementine-panel.png
150
bf1e6952
ER
151%clean
152rm -rf $RPM_BUILD_ROOT
153
726826ed
ER
154%post
155%update_desktop_database_post
2eedc3b1 156%update_icon_cache hicolor
726826ed
ER
157
158%postun
159%update_desktop_database_postun
2eedc3b1 160%update_icon_cache hicolor
726826ed 161
10ecf727 162%files -f %{name}.lang
bf1e6952 163%defattr(644,root,root,755)
e0ba0da9 164%doc Changelog
bf1e6952 165%attr(755,root,root) %{_bindir}/clementine
dbbdd85a 166%attr(755,root,root) %{_bindir}/clementine-tagreader
bf1e6952 167%{_desktopdir}/clementine.desktop
7279ad3f 168%{_pixmapsdir}/clementine.png
23f69c7b
BZ
169%{_iconsdir}/hicolor/*/apps/clementine-panel-grey.png
170%{_iconsdir}/hicolor/*/apps/clementine-panel.png
This page took 0.060578 seconds and 4 git commands to generate.