]> git.pld-linux.org Git - packages/cjs.git/blame - cjs.spec
new, version 2.4.1
[packages/cjs.git] / cjs.spec
CommitLineData
9f107e75
ER
1#
2# Conditional build:
3%bcond_without tests # build without tests
4
5Summary: Javascript Bindings for Cinnamon
6Name: cjs
7Version: 2.4.1
8Release: 1
9Group: Libraries
10# The following files contain code from Mozilla which
11# is triple licensed under MPL1.1/LGPLv2+/GPLv2+:
12# The console module (modules/console.c)
13# Stack printer (gjs/stack.c)
14License: MIT and (MPLv1.1 or GPLv2+ or LGPLv2+)
15Source0: https://github.com/linuxmint/cjs/archive/%{version}/%{name}-%{version}.tar.gz
16# Source0-md5: 846940e9cf97b15a5b3940cf5c7b2591
17URL: http://cinnamon.linuxmint.com/
18BuildRequires: cairo-gobject-devel
19BuildRequires: dbus-glib-devel
20BuildRequires: gobject-introspection-devel >= 1.38.0
21BuildRequires: gtk+3-devel
22BuildRequires: intltool
23BuildRequires: mozjs24-devel
24BuildRequires: readline-devel
25BuildRequires: sed >= 4.0
26# Require for checks
27BuildRequires: dbus-x11
28# Bootstrap requirements
29BuildRequires: gnome-common
30BuildRequires: gtk-doc
31BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33%description
34Cjs allows using Cinnamon libraries from Javascript. It's based on the
35Spidermonkey Javascript engine from Mozilla and the GObject
36introspection framework.
37
38%package devel
39Summary: Development package for %{name}
40Group: Development/Libraries
41Requires: %{name} = %{version}-%{release}
42
43%description devel
44Files for development with %{name}.
45
46%package tests
47Summary: Tests for the cjs package
48Group: Development/Libraries
49Requires: %{name}-devel = %{version}-%{release}
50
51%description tests
52The cjs-tests package contains tests that can be used to verify the
53functionality of the installed cjs package.
54
55%prep
56%setup -q
57sed -i -e 's@{ACLOCAL_FLAGS}@{ACLOCAL_FLAGS} -I m4@g' Makefile.am
58echo "AC_CONFIG_MACRO_DIR([m4])" >> configure.ac
59
60%build
61NOCONFIGURE=1 ./autogen.sh
62%configure \
63 --disable-silent-rules \
64 --disable-static \
65 --enable-installed-tests \
66
67%{__make}
68
69%if %{with tests}
70%{__make} check
71%endif
72
73%install
74rm -rf $RPM_BUILD_ROOT
75%{__make} install \
76 DESTDIR=$RPM_BUILD_ROOT
77
78%{__rm} $RPM_BUILD_ROOT%{_libdir}/libcjs.la
79%{__rm} $RPM_BUILD_ROOT%{_libdir}/cjs/lib*.la
80
81%clean
82rm -rf $RPM_BUILD_ROOT
83
84%post -p /sbin/ldconfig
85%postun -p /sbin/ldconfig
86
87%files
88%defattr(644,root,root,755)
89%doc COPYING COPYING.LGPL NEWS README
90%attr(755,root,root) %{_bindir}/cjs
91%attr(755,root,root) %{_bindir}/cjs-console
92%attr(755,root,root) %{_libdir}/libcjs.so.*.*.*
93%ghost %{_libdir}/libcjs.so.0
94%dir %{_libdir}/cjs
95%dir %{_libdir}/cjs/girepository-1.0
96%{_libdir}/cjs/girepository-1.0/CjsPrivate-1.0.typelib
97
98%files devel
99%defattr(644,root,root,755)
100%doc examples/*
101%{_includedir}/cjs-1.0
102%{_libdir}/libcjs.so
103%{_pkgconfigdir}/cjs-1.0.pc
104%{_pkgconfigdir}/cjs-internals-1.0.pc
105%attr(755,root,root) %{_libdir}/cjs/libgimarshallingtests.so
106%attr(755,root,root) %{_libdir}/cjs/libregress.so
107%attr(755,root,root) %{_libdir}/cjs/libwarnlib.so
108
109%files tests
110%defattr(644,root,root,755)
111%{_libdir}/cjs/installed-tests
112%{_datadir}/installed-tests
This page took 0.065812 seconds and 4 git commands to generate.