]> git.pld-linux.org Git - packages/chromium-browser.git/blame - chromium-browser.spec
ensure patched re2 is used at runtime
[packages/chromium-browser.git] / chromium-browser.spec
CommitLineData
0c480b89
ER
1#
2# Conditional build:
ba685303 3%bcond_without cups # with cups
2108baf2 4%bcond_without debuginfo # disable debuginfo creation (it is huge)
ba685303 5%bcond_without gconf # with GConf
75f96a39 6%bcond_without kerberos # build with kerberos support (dlopened if support compiled, library names in net/http/http_auth_gssapi_posix.cc)
2108baf2 7%bcond_without keyring # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
71d49434 8%bcond_with gps # with gps support (linked), if enabled must use exactly same gpsd as shm structures may change leading to unexpected results (crash)
ba685303 9%bcond_without libjpegturbo # use libjpeg-turbo features
6c8531c6 10%bcond_without nacl # build Native Client support
ba685303 11%bcond_without pulseaudio # with pulseaudio
2108baf2
ER
12%bcond_without sandboxing # with sandboxing
13%bcond_with selinux # with SELinux (need policy first)
14%bcond_with shared_libs # with shared libs
15%bcond_with sse2 # use SSE2 instructions
ba685303 16%bcond_without system_flac # system flac
4e881737 17%bcond_without system_ffmpeg # system ffmpeg instead of ffmpegsumo
108c5f7c 18%bcond_without system_harfbuzz # system harfbuzz
ba685303 19%bcond_without system_jsoncpp # system jsoncpp
62950103
ER
20%bcond_without system_libexif # system libexif
21%bcond_without system_libmtp # system libmtp
ba685303
ER
22%bcond_without system_libusb # system libusb-1
23%bcond_without system_libwebp # system libwebp
4884fc99 24%bcond_without system_libxnvctrl # system libxnvctrl
25d4e23c 25%bcond_without system_mesa # system Mesa
126ea630 26%bcond_without system_minizip # system minizip
62950103 27%bcond_without system_opus # system opus codec support, http://www.opus-codec.org/examples/
108c5f7c 28%bcond_without system_protobuf # system protobuf
543e99ac 29%bcond_without system_re2 # system re2
ba685303
ER
30%bcond_without system_speex # system speex
31%bcond_with system_sqlite # system sqlite
9bd2659c 32%bcond_without system_libsrtp # system srtp (can be used if using bundled libjingle)
ba685303 33%bcond_with system_v8 # system v8
41d6a4b1 34%bcond_without system_libvpx # system libvpx
ba685303 35%bcond_without system_yasm # system yasm
1c00315b 36%bcond_without system_zlib # system zlib
d2781a31 37%bcond_without tcmalloc # use tcmalloc
7e136323 38%bcond_without verbose # verbose build (V=1)
0c480b89 39
b3fc6cb2
ER
40%ifarch %{ix86}
41# GLsizeiptr different size, track: http://bugs.gentoo.org/457130
42%undefine with_system_mesa
43%endif
44
6d92f81c 45# TODO
b363f856 46# - find system deps: find -type f -name '*.gyp*' | xargs grep -oh 'use_system_.*%' | sort -u
b363f856 47# - use_system_skia
a3140cd1 48# - use_system_ssl (use_openssl: http://crbug.com/62803)
b363f856 49# - use_system_stlport (android specific)
7b8f219a 50# - vpx: invert (remove) media_use_libvpx when libvpx with vp9 support is released
a3140cd1 51
e53ecfb5 52# NOTES:
4fe038cb
ER
53# - mute BEEP mixer if you do not want to hear horrible system bell when
54# pressing home/end in url bar or more ^F search results on page.
7c638678 55# - space considerations:
0bb93ab2 56# - unpacked sources: ~490MiB
c1ecd31f 57# - built code: ~1.4GiB (x86_64/i686)
f1b276d4 58# - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
84fa20a9 59# - to look for new tarball, use update-source.sh script
f1b276d4 60
e68aa7e7 61# NOTE TO USERS:
c8b02491 62# To use chromium nightly beta builds for pld-th save to /etc/poldek/repos.d (as chromium-nightly.conf):
a3cc7091 63# http://carme.pld-linux.org/~glen/chromium-browser/th/x86_64/chromium-nightly.conf
c8b02491 64# http://carme.pld-linux.org/~glen/chromium-browser/th/i686/chromium-nightly.conf
e68aa7e7 65
f2f193c6 66%define branch 26.0.1410
d47abc08 67%define basever 40
92fcbe12 68#define patchver 70
a3140cd1 69%define gyp_rev 1014
11ad81c4 70Summary: A WebKit powered web browser
05f72ae2 71Name: chromium-browser
f73369da
ER
72%if "%{?patchver}" != ""
73Version: %{branch}.%{patchver}
74%else
75Version: %{branch}.%{basever}
76%endif
b2c4ae39 77Release: 0.35
05f72ae2 78License: BSD, LGPL v2+ (ffmpeg)
e53ecfb5 79Group: X11/Applications/Networking
25d4e23c 80Source0: http://carme.pld-linux.org/~glen/chromium-browser/src/beta/%{name}-%{branch}.%{basever}.tar.gz
e272851e 81# Source0-md5: e42f86208205701bd23b34ba963e7d83
3c73e180
ER
82%if "%{?patchver}" != ""
83Patch0: http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
f6284fe2 84# Patch0-md5: 37675cd75c578d26d6210259877f3947
3c73e180 85%endif
37ceaf05 86Source1: %{name}.default
8b53130d
ER
87Source2: %{name}.sh
88Source3: %{name}.desktop
56c6e811
ER
89Source5: find-lang.sh
90Source6: update-source.sh
91Source7: clean-source.sh
836b1cac 92Source8: get-source.sh
0562b864 93Source9: master_preferences.json
48b341f5 94Patch1: plugin-searchdirs.patch
70258ccd 95#Patch2: system-nspr.patch
7abc645c 96Patch3: disable_dlog_and_dcheck_in_release_builds.patch
72cb20c1 97Patch4: path-libpdf.patch
0e5636cb 98Patch6: get-webkit_revision.patch
5aa5df39 99Patch7: dlopen_sonamed_gl.patch
4765ddf1 100Patch8: chromium_useragent.patch.in
c0808220 101Patch9: chromium-ppapi.patch
8456d676 102Patch10: system-libxnvctrl.patch
1347c76c
AM
103# https://bugs.gentoo.org/show_bug.cgi?id=393471
104# libjpeg-turbo >= 1.1.90 supports that feature
f4a8da6a 105Patch11: chromium-revert-jpeg-swizzle-r2.patch
108c5f7c 106Patch12: system-ffmpeg.patch
5997e180
ER
107Patch15: nacl-build-irt.patch
108Patch16: nacl-linkingfix.patch
9516ca97 109Patch18: nacl-no-untar.patch
08b25440 110Patch19: system-jsoncpp.patch
6897926c 111Patch24: nacl-verbose.patch
c5b396f3
ER
112Patch25: gnome3-volume-control.patch
113Patch26: master-prefs-path.patch
d2781a31 114Patch27: tcmalloc-glibc2.16.patch
25d4e23c 115Patch28: system-mesa.patch
eda1bb04 116Patch29: speechd-0.8.patch
750b48f7 117URL: http://www.chromium.org/Home
ae3fe89f 118%{?with_gconf:BuildRequires: GConf2-devel}
a28c0ac3
ER
119%{?with_system_mesa:BuildRequires: Mesa-libGL-devel >= 9.1}
120%{?with_system_mesa:BuildRequires: Mesa-libGLES-devel >= 9.1}
7b8f219a 121%{?with_system_mesa:BuildRequires: Mesa-libGLU-devel}
a28c0ac3 122%{?with_system_mesa:BuildRequires: Mesa-libOSMesa-devel >= 9.1}
05f72ae2
ER
123BuildRequires: alsa-lib-devel
124BuildRequires: atk-devel
125BuildRequires: bison
11ad81c4 126BuildRequires: bzip2-devel
5997e180
ER
127%{?with_nacl:BuildRequires: crossnacl-binutils >= 2.20.1}
128%{?with_nacl:BuildRequires: crossnacl-gcc >= 4.4.3}
129%{?with_nacl:BuildRequires: crossnacl-gcc-c++ >= 4.4.3}
9516ca97 130%{?with_nacl:BuildRequires: crossnacl-newlib >= 1.20.0-3}
ae3fe89f 131%{?with_cups:BuildRequires: cups-devel}
92965b0e 132BuildRequires: elfutils-devel
77f32fa3 133BuildRequires: expat-devel
7d0dbc8d 134%{?with_system_ffmpeg:BuildRequires: ffmpeg-devel >= 1.0}
8f5f6775 135%{?with_system_flac:BuildRequires: flac-devel >= 1.2.1-7}
11ad81c4 136BuildRequires: fontconfig-devel
f1b276d4 137BuildRequires: glib2-devel
05f72ae2 138BuildRequires: gperf
71d49434 139%{?with_gps:BuildRequires: gpsd-devel}
bbad64b7 140BuildRequires: gtest-devel
8b53130d 141BuildRequires: gtk+2-devel
01b4dc8e 142%{?with_system_harfbuzz:BuildRequires: harfbuzz-devel}
a3140cd1 143%{?with_kerberos:BuildRequires: heimdal-devel}
0eb19b0b 144BuildRequires: hicolor-icon-theme
ed514974 145%{?with_system_jsoncpp:BuildRequires: jsoncpp-devel}
ef121064 146%{?with_system_libxnvctrl:BuildRequires: libXNVCtrl-devel >= 310.19}
05f72ae2 147BuildRequires: libevent-devel
8456d676 148%{?with_system_libexif:BuildRequires: libexif-devel >= 1:0.6.21}
7f40f3f4 149%{?with_keyring:BuildRequires: libgnome-keyring-devel}
0b214002 150BuildRequires: libicu-devel >= 4.6
39c71b4c 151%{!?with_libjpegturbo:BuildRequires: libjpeg-devel}
f4a8da6a 152%{?with_libjpegturbo:BuildRequires: libjpeg-turbo-devel >= 1.2.0}
8456d676 153%{?with_system_libmtp:BuildRequires: libmtp-devel >= 1.1.3}
05f72ae2 154BuildRequires: libpng-devel
e266589e 155%{?with_selinux:BuildRequires: libselinux-devel}
05f72ae2 156BuildRequires: libstdc++-devel
ba685303 157%{?with_system_libusb:BuildRequires: libusb-devel >= 1.0}
4b411ffe 158%{?with_system_libvpx:BuildRequires: libvpx-devel >= 0.9.5-2}
dd1509bd 159%{?with_system_libwebp:BuildRequires: libwebp-devel >= 0.1.99}
f1b276d4 160BuildRequires: libxml2-devel
11ad81c4 161BuildRequires: libxslt-devel
535cb410 162BuildRequires: man-db
62950103 163%{?with_system_minizip:BuildRequires: minizip-devel}
05f72ae2 164BuildRequires: nspr-devel
f1b276d4 165BuildRequires: nss-devel >= 1:3.12.3
8456d676 166%{?with_system_opus:BuildRequires: opus-devel >= 1.0.2}
35902862 167BuildRequires: pam-devel
f1b276d4 168BuildRequires: pango-devel
ef121064 169BuildRequires: pciutils-devel
48b341f5 170BuildRequires: perl-modules
171BuildRequires: pkgconfig
75a27c2e 172%{?with_system_protobuf:BuildRequires: protobuf-devel}
ae3fe89f 173%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
f1b276d4 174BuildRequires: python
46cdefee 175#BuildRequires: python-gyp >= 1-%{gyp_rev}
48b341f5 176BuildRequires: python-modules
92965b0e 177BuildRequires: python-ply
543e99ac 178%{?with_system_re2:BuildRequires: re2-devel >= 20130115-2}
0cad051b 179BuildRequires: rpm >= 4.4.9-56
f1b276d4 180BuildRequires: rpmbuild(macros) >= 1.453
eda1bb04 181BuildRequires: speech-dispatcher-devel >= 0.8
0cad051b 182%{?with_system_speex:BuildRequires: speex-devel >= 1:1.2-rc1}
f1b276d4 183BuildRequires: sqlite3-devel >= 3.6.1
9bd2659c 184%{?with_system_libsrtp:BuildRequires: srtp-devel >= 1.4.4}
89f0dde4 185BuildRequires: subversion
0cad051b 186BuildRequires: tar >= 1:1.22
0a424ee2 187BuildRequires: udev-devel
7d1152d4 188BuildRequires: usbutils
2303ed45 189BuildRequires: util-linux
c14cd342 190%{?with_system_v8:BuildRequires: v8-devel >= 3.7}
0826c245 191BuildRequires: which
f1b276d4 192BuildRequires: xorg-lib-libXScrnSaver-devel
836b1cac 193BuildRequires: xz
a3140cd1 194%{?with_system_yasm:BuildRequires: yasm}
f1b276d4 195%{?with_system_zlib:BuildRequires: zlib-devel}
e53ecfb5 196Requires: browser-plugins >= 2.0
0cad051b 197Requires: desktop-file-utils
8f5f6775 198%{?with_system_flac:Requires: flac >= 1.2.1-7}
ae20377c
ER
199# crashes if no fontconfig font present
200Requires: fonts-Type1-urw
0eb19b0b 201Requires: hicolor-icon-theme
56403697 202Requires: libevent >= 2.0.21
c1edaafa 203%{?with_libjpegturbo:Requires: libjpeg-turbo >= 1.2.0}
4b411ffe 204%{?with_system_libvpx:Requires: libvpx >= 0.9.5-2}
b809ab60 205Requires: lsb-release
b2c4ae39 206%{?with_system_re2:Requires: re2 >= 20130115-2}
3700ba38 207Requires: shared-mime-info
4dc49133 208Requires: xdg-utils >= 1.0.2-4
2cbfc1a4 209Requires: xorg-lib-libX11 >= 1.4.99.1
e53ecfb5 210Provides: wwwbrowser
c3582150 211Obsoletes: chromium-browser-bookmark_manager < 5.0.388.0
a3140cd1 212Obsoletes: chromium-browser-inspector < 15.0.863.0
2351db3b 213ExclusiveArch: %{ix86} %{x8664} arm
11ad81c4 214BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11ad81c4 215
589d90ea 216%define find_lang sh find-lang.sh %{buildroot}
2446ebb3 217
e7fa0817
ER
218# Usage: gyp_with BCOND_NAME [OPTION_NAME]
219%define gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
589d90ea 220
6b113615
ER
221%if %{without debuginfo}
222%define _enable_debug_packages 0
223%endif
224
11ad81c4 225%description
80838854
ER
226Chromium is an open-source browser project that aims to build a safer,
227faster, and more stable way for all Internet users to experience the
228web.
229
230Chromium serves as a base for Google Chrome, which is Chromium
231rebranded (name and logo) with very few additions such as usage
232tracking and an auto-updater system.
233
f1b276d4
ER
234%package l10n
235Summary: chromium-browser language packages
236Group: I18n
237Requires: %{name} = %{version}-%{release}
238
239%description l10n
240Chromium is an open-source browser project that aims to build a safer,
241faster, and more stable way for all Internet users to experience the
242web.
243
244This package contains language packages for 50 languages:
245
e7fa0817
ER
246ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
247he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
248pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
249zh-TW
f1b276d4
ER
250
251%prep
3c73e180
ER
252%setup -qc
253%if "%{?patchver}" != ""
254cd %{name}-%{branch}.%{basever}
255%patch0 -p1
256cd ..
257%endif
75f96a39 258mv %{name}-%{branch}.%{basever}/* .
589d90ea 259
05f72ae2
ER
260# Google's versioning is interesting. They never reset "BUILD", which is how we jumped
261# from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
75f96a39 262. ./chrome/VERSION
0c480b89 263ver=$MAJOR.$MINOR.$BUILD.$PATCH
a3140cd1
ER
264test "$ver" = %{version}
265
75f96a39 266gyp_rev=$(grep googlecode_url.*gyp DEPS | cut -d'"' -f6 | cut -d@ -f2)
2d2c8139 267test "$gyp_rev" = %{gyp_rev} || :
05f72ae2 268
75f96a39 269v8_ver=$(awk 'NR=1 {print $NF; exit}' v8/ChangeLog || :)
33b04c7d 270
4765ddf1
ER
271# add chromium and pld to useragent
272%define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
273sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
25d4e23c
ER
274 -e 's/@BUILD_DIST_NAME@/PLD/g' \
275 -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
75f96a39 276 < %{PATCH8} | %{__patch} -p2
4765ddf1 277
56c6e811 278%{__sed} -e 's,@localedir@,%{_libdir}/%{name},' %{SOURCE5} > find-lang.sh
75f96a39
ER
279ln -s %{SOURCE7} .
280
281%patch1 -p2
282%patch3 -p2
283%patch4 -p3
284%patch6 -p2
285%patch7 -p2
286%patch10 -p2
287%patch15 -p2
c0808220 288%patch9 -p0
70258ccd 289#%patch2 -p1
f4a8da6a 290%{!?with_libjpegturbo:%patch11 -p0}
108c5f7c 291%patch12 -p1
5997e180 292%patch16 -p1
2d65d095 293%patch19 -p2
d2781a31 294%patch27 -p1
41d6a4b1 295%patch28 -p1
75f96a39
ER
296%patch25 -p2
297%patch18 -p2
298%patch24 -p2
299%patch26 -p2
300%patch29 -p2
e9abb380 301
75a27c2e
ER
302sh -x clean-source.sh \
303 %{!?with_nacl:nacl=0} \
bbdce24d
ER
304 %{!?with_system_libvpx:libvpx=0} \
305 %{!?with_system_libxnvctrl:libXNVCtrl=0} \
25d4e23c 306 %{!?with_system_mesa:mesa=0} \
75a27c2e 307 %{!?with_system_protobuf:protobuf=0} \
bbdce24d 308 %{!?with_system_re2:re2=0} \
75a27c2e
ER
309 %{!?with_system_v8:v8=0} \
310 %{!?with_system_zlib:zlib=0} \
311 %{nil}
fded59be 312
e266589e 313%build
5997e180 314%if %{with nacl}
108c5f7c 315rm -rf native_client/toolchain/linux_x86_newlib
fded59be 316if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
dcea0d6b 317# Make symlinks for NaCL
108c5f7c 318install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,nacl}
2e4113fd 319
108c5f7c
ER
320cd native_client/toolchain/linux_x86_newlib
321ln -s x86_64-nacl/bin bin
322cd x86_64-nacl/bin
2e4113fd 323__cc='%{__cc}'
f64e73f6 324if [ "${__cc#ccache}" != "$__cc" ]; then
2e4113fd
ER
325 echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
326 echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
327 %{__sed} -i -e '1i#!/bin/sh' gcc g++
328 chmod +x gcc g++
329else
330 ln -s %{_bindir}/x86_64-nacl-gcc gcc
331 ln -s %{_bindir}/x86_64-nacl-g++ g++
332fi
108c5f7c
ER
333ln -s gcc x86_64-nacl-gcc
334ln -s g++ x86_64-nacl-g++
335ln -s %{_bindir}/x86_64-nacl-ar .
5997e180
ER
336ln -s %{_bindir}/x86_64-nacl-ar ar
337ln -s %{_bindir}/x86_64-nacl-as as
108c5f7c 338ln -s %{_bindir}/x86_64-nacl-ranlib .
5997e180 339ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
108c5f7c 340ln -s %{_bindir}/x86_64-nacl-strip .
5997e180 341ln -s %{_bindir}/x86_64-nacl-strip strip
108c5f7c
ER
342ln -s %{_prefix}/x86_64-nacl/lib ../lib
343ln -s %{_prefix}/x86_64-nacl/lib32 ../lib32
dcea0d6b
ER
344ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
345cd ../../../../..
fded59be 346fi
5997e180
ER
347%endif
348
c5b396f3 349test %{_specdir}/%{name}.spec -nt Makefile && %{__rm} -f Makefile
b4d75247
ER
350test -e Makefile || \
351 CC="%{__cc}" \
352 CXX="%{__cxx}" \
353 LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
354 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
355 CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
356%{__python} build/gyp_chromium \
673aee14 357 --format=make \
75f96a39 358 --depth=. \
673aee14 359 build/all.gyp \
f1b276d4
ER
360%ifarch %{ix86}
361 -Dtarget_arch=ia32 \
362%endif
363%ifarch %{x8664}
0c480b89
ER
364 -Dtarget_arch=x64 \
365%endif
7b454a31
AM
366%if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
367 -Dno_strict_aliasing=1 -Dgcc_version=44 \
f1b276d4
ER
368%endif
369%if %{with sandboxing}
370 -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
371 -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
372%endif
373 %{!?debug:-Dwerror=} \
c980b122 374 %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
f1b276d4 375 %{?with_shared_libs:-Dlibrary=shared_library} \
6e2c5572 376 %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1 -Dproprietary_codecs=1} \
b5a3dda3 377 -Dinclude_tests=0 \
c0808220 378%if %{with nacl}
038f76b9 379 -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
9516ca97
ER
380 -Ddisable_glibc_untar=1 \
381 -Ddisable_newlib_untar=1 \
8fb1dc98
ER
382 -Ddisable_glibc=1 \
383 -Ddisable_pnacl=1 \
384 -Dbuild_pnacl_newlib=0 \
c0808220 385%else
8fb1dc98 386 -Ddisable_pnacl_untar=1 \
c0808220
ER
387 -Ddisable_nacl=1 \
388%endif
a3140cd1
ER
389 %{!?with_sse2:-Ddisable_sse2=1} \
390 %{?with_selinux:-Dselinux=1} \
7d1152d4 391 -Dusb_ids_path=$(pkg-config --variable usbids usbutils) \
05998197 392 -Dlinux_link_libpci=1 \
bd827d58 393 -Dlinux_link_libspeechd=1 \
05998197 394 %{!?with_tcmalloc:-Dlinux_use_tcmalloc=0} \
71d49434 395 %{?with_gps:-Dlinux_use_libgps=1 -Dlinux_link_libgps=1} \
05998197
ER
396 -Dlinux_use_gold_binary=0 \
397 -Dlinux_use_gold_flags=0 \
e7fa0817 398 %{gyp_with cups} \
8dda6bbc 399 %{gyp_with gconf} -Dlinux_link_gsettings=0 \
bd827d58 400 %{gyp_with kerberos} -Dlinux_link_kerberos=1 \
e7fa0817
ER
401 %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
402 %{gyp_with pulseaudio} \
41d6a4b1 403 %{gyp_with system_ffmpeg} -Dmedia_use_ffmpeg=1 \
8f5f6775 404 %{gyp_with system_flac} \
01b4dc8e 405 %{gyp_with system_harfbuzz} \
2d65d095 406 %{gyp_with system_jsoncpp} \
62950103
ER
407 %{gyp_with system_libexif} \
408 %{gyp_with system_libmtp} \
9bd2659c 409 %{gyp_with system_libsrtp} \
581aec44 410 %{gyp_with system_libusb} \
41d6a4b1 411 %{gyp_with system_libvpx} -Dmedia_use_libvpx=0 \
ba685303 412 %{gyp_with system_libwebp} \
4884fc99 413 %{gyp_with system_libxnvctrl} \
7b8f219a 414 %{gyp_with system_mesa} \
126ea630 415 %{gyp_with system_minizip} \
62950103 416 %{gyp_with system_opus} \
75a27c2e 417 %{gyp_with system_protobuf} \
bbdce24d 418 %{gyp_with system_re2} \
e7fa0817
ER
419 %{gyp_with system_speex} \
420 %{gyp_with system_sqlite} \
421 %{gyp_with system_v8} \
422 %{gyp_with system_yasm} \
423 %{gyp_with system_zlib} \
0c480b89 424 -Duse_system_bzip2=1 \
62950103 425 -Duse_system_expat=1 \
0b214002 426 -Duse_system_icu=1 \
f1b276d4 427 -Duse_system_libevent=1 \
0c480b89 428 -Duse_system_libjpeg=1 \
f1b276d4
ER
429 -Duse_system_libpng=1 \
430 -Duse_system_libxml=1 \
431 -Duse_system_libxslt=1 \
b363f856 432 -Duse_system_nspr=1 \
7f40f3f4 433 -Duse_system_xdg_utils=1 \
11ad81c4 434
b4d75247 435# need {CC/CXX/LDFLAGS}.host overrides for v8 build
48ffbc5e 436%{__make} -r chrome %{?with_sandboxing:chrome_sandbox} \
f1b276d4
ER
437 BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
438 %{?with_verbose:V=1} \
f1b276d4
ER
439 CC.host="%{__cc}" \
440 CXX.host="%{__cxx}" \
b4d75247 441 LDFLAGS.host="%{rpmldflags} -fuse-ld=gold" \
11ad81c4 442
75f96a39 443cd out/%{!?debug:Release}%{?debug:Debug}
535cb410
ER
444MANWIDTH=80 man ./chrome.1 > man.out
445%{__sed} -e '1,/OPTIONS/d; /ENVIRONMENT/,$d' man.out > options.txt
446
11ad81c4
AM
447%install
448rm -rf $RPM_BUILD_ROOT
56c6e811 449install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/{themes,plugins,extensions} \
37ceaf05 450 $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/%{name},%{_mandir}/man1,%{_desktopdir}}
e266589e 451
673aee14 452cd out/%{!?debug:Release}%{?debug:Debug}
37ceaf05 453cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
f1b276d4 454install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
535cb410
ER
455%{__sed} -i -e '
456 s,@libdir@,%{_libdir}/%{name},
457
458 /@OPTIONS@/ {
459 r options.txt
460 d
461 }
462' $RPM_BUILD_ROOT%{_bindir}/%{name}
97fac491 463cp -a *.pak locales resources $RPM_BUILD_ROOT%{_libdir}/%{name}
7f40f3f4 464cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
f1b276d4 465install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
e53ecfb5 466install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
fcc48c19 467%if %{without system_ffmpeg}
f1b276d4 468install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
dd46de65 469%endif
e7fa0817 470cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
0562b864 471cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
164020eb 472
c0808220
ER
473%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/resources/extension/demo
474
164020eb
ER
475%if %{with nacl}
476# Install Native Client files on platforms that support it.
477install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
478install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
479%ifarch %{x8664}
480install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
481%endif
482%ifarch %{ix86}
483install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
484%endif
485%endif
486
0c480b89
ER
487cd -
488
75f96a39 489for icon in chrome/app/theme/chromium/product_logo_[0-9]*.png; do
0eb19b0b
ER
490 size=${icon##*/product_logo_}
491 size=${size%.png}
492
493 # this will skip non-numeric (22_mono_invert, 22_mono)
494 dir=%{_iconsdir}/hicolor/${size}x${size}/apps
495 test -d "$dir" || continue
496
497 install -d $RPM_BUILD_ROOT$dir
498 cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
499done
7f40f3f4 500
13840bc2
AM
501%browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
502# http://code.google.com/p/chromium/issues/detail?id=24507
503gecko-mediaplayer*.so
504EOF
11ad81c4 505
589d90ea
ER
506# find locales
507%find_lang %{name}.lang
e7fa0817 508# always package en-US
f1b276d4 509%{__sed} -i -e '/en-US.pak/d' %{name}.lang
589d90ea 510
11ad81c4
AM
511%clean
512rm -rf $RPM_BUILD_ROOT
513
f1b276d4 514%post
0eb19b0b 515%update_icon_cache hicolor
b7a6e4ee 516%update_desktop_database
f1b276d4
ER
517%update_browser_plugins
518
519%postun
520if [ "$1" = 0 ]; then
0eb19b0b 521 %update_icon_cache hicolor
f1b276d4
ER
522 %update_browser_plugins
523fi
524
1d2b9616 525%files
11ad81c4 526%defattr(644,root,root,755)
75f96a39 527%doc AUTHORS LICENSE
f1b276d4
ER
528%{_browserpluginsconfdir}/browsers.d/%{name}.*
529%config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
37ceaf05
ER
530%dir %{_sysconfdir}/%{name}
531%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
0562b864 532%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
f1b276d4
ER
533%attr(755,root,root) %{_bindir}/%{name}
534%{_mandir}/man1/%{name}.1*
11ad81c4 535%{_desktopdir}/*.desktop
0eb19b0b 536%{_iconsdir}/hicolor/*/apps/%{name}.png
0c480b89 537%dir %{_libdir}/%{name}
e9abb380 538%{_libdir}/%{name}/chrome*.pak
c14cd342 539%{_libdir}/%{name}/content_resources.pak
97fac491 540%{_libdir}/%{name}/resources.pak
589d90ea 541%dir %{_libdir}/%{name}/locales
f1b276d4
ER
542%{_libdir}/%{name}/locales/en-US.pak
543%dir %{_libdir}/%{name}/resources
a3140cd1 544%{_libdir}/%{name}/resources/inspector
f1b276d4
ER
545%dir %{_libdir}/%{name}/themes
546%dir %{_libdir}/%{name}/extensions
547%dir %{_libdir}/%{name}/plugins
548%attr(755,root,root) %{_libdir}/%{name}/%{name}
0c480b89 549# These unique permissions are intentional and necessary for the sandboxing
e53ecfb5 550%attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
f1b276d4
ER
551
552# ffmpeg libs
fcc48c19 553%if %{without system_ffmpeg}
f1b276d4 554%attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
dd46de65 555%endif
f1b276d4 556
164020eb
ER
557%if %{with nacl}
558%attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
559%attr(755,root,root) %{_libdir}/%{name}/nacl_helper
560%attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
561%attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
562%endif
563
f1b276d4
ER
564%files l10n -f %{name}.lang
565%defattr(644,root,root,755)
This page took 0.379439 seconds and 4 git commands to generate.