]> git.pld-linux.org Git - packages/chromium-browser.git/blame - chromium-browser.spec
up to 27.0.1453.93
[packages/chromium-browser.git] / chromium-browser.spec
CommitLineData
0c480b89
ER
1#
2# Conditional build:
ba685303 3%bcond_without cups # with cups
2108baf2 4%bcond_without debuginfo # disable debuginfo creation (it is huge)
ba685303 5%bcond_without gconf # with GConf
75f96a39 6%bcond_without kerberos # build with kerberos support (dlopened if support compiled, library names in net/http/http_auth_gssapi_posix.cc)
2108baf2 7%bcond_without keyring # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
71d49434 8%bcond_with gps # with gps support (linked), if enabled must use exactly same gpsd as shm structures may change leading to unexpected results (crash)
ba685303 9%bcond_without libjpegturbo # use libjpeg-turbo features
6c8531c6 10%bcond_without nacl # build Native Client support
ba685303 11%bcond_without pulseaudio # with pulseaudio
2108baf2
ER
12%bcond_without sandboxing # with sandboxing
13%bcond_with selinux # with SELinux (need policy first)
14%bcond_with shared_libs # with shared libs
15%bcond_with sse2 # use SSE2 instructions
ba685303 16%bcond_without system_flac # system flac
4e881737 17%bcond_without system_ffmpeg # system ffmpeg instead of ffmpegsumo
108c5f7c 18%bcond_without system_harfbuzz # system harfbuzz
ba685303 19%bcond_without system_jsoncpp # system jsoncpp
62950103
ER
20%bcond_without system_libexif # system libexif
21%bcond_without system_libmtp # system libmtp
ba685303
ER
22%bcond_without system_libusb # system libusb-1
23%bcond_without system_libwebp # system libwebp
4884fc99 24%bcond_without system_libxnvctrl # system libxnvctrl
25d4e23c 25%bcond_without system_mesa # system Mesa
126ea630 26%bcond_without system_minizip # system minizip
62950103 27%bcond_without system_opus # system opus codec support, http://www.opus-codec.org/examples/
108c5f7c 28%bcond_without system_protobuf # system protobuf
543e99ac 29%bcond_without system_re2 # system re2
ba685303 30%bcond_without system_speex # system speex
a8f4f3ac 31%bcond_with system_sqlite # system sqlite WebSQL (http://www.w3.org/TR/webdatabase/) will not work
9bd2659c 32%bcond_without system_libsrtp # system srtp (can be used if using bundled libjingle)
ba685303 33%bcond_with system_v8 # system v8
4b411ffe 34%bcond_without system_libvpx # system libvpx
ba685303 35%bcond_without system_yasm # system yasm
1c00315b 36%bcond_without system_zlib # system zlib
d2781a31 37%bcond_without tcmalloc # use tcmalloc
7e136323 38%bcond_without verbose # verbose build (V=1)
0c480b89 39
b3fc6cb2
ER
40%ifarch %{ix86}
41# GLsizeiptr different size, track: http://bugs.gentoo.org/457130
42%undefine with_system_mesa
43%endif
44
6d92f81c 45# TODO
b363f856 46# - find system deps: find -type f -name '*.gyp*' | xargs grep -oh 'use_system_.*%' | sort -u
b363f856 47# - use_system_skia
a3140cd1 48# - use_system_ssl (use_openssl: http://crbug.com/62803)
b363f856 49# - use_system_stlport (android specific)
7b8f219a 50# - vpx: invert (remove) media_use_libvpx when libvpx with vp9 support is released
a3140cd1 51
e53ecfb5 52# NOTES:
4fe038cb
ER
53# - mute BEEP mixer if you do not want to hear horrible system bell when
54# pressing home/end in url bar or more ^F search results on page.
7c638678 55# - space considerations:
0bb93ab2 56# - unpacked sources: ~490MiB
c1ecd31f 57# - built code: ~1.4GiB (x86_64/i686)
f1b276d4 58# - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
84fa20a9 59# - to look for new tarball, use update-source.sh script
f1b276d4 60
66bf40a1 61%define branch 27.0.1453
87dd4362 62%define basever 93
92fcbe12 63#define patchver 70
a3140cd1 64%define gyp_rev 1014
11ad81c4 65Summary: A WebKit powered web browser
05f72ae2 66Name: chromium-browser
f73369da
ER
67%if "%{?patchver}" != ""
68Version: %{branch}.%{patchver}
69%else
70Version: %{branch}.%{basever}
71%endif
effb85eb 72Release: 0.16
05f72ae2 73License: BSD, LGPL v2+ (ffmpeg)
e53ecfb5 74Group: X11/Applications/Networking
b7c95c4f 75Source0: http://carme.pld-linux.org/~glen/chromium-browser/src/beta/%{name}-%{branch}.%{basever}.tar.gz
9d8fb756 76# Source0-md5: eafd6a919faadc8a7446cd673f460c4c
3c73e180
ER
77%if "%{?patchver}" != ""
78Patch0: http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
e920d86e 79# Patch0-md5: 7e2f26d76ca6241961276a328a9230cf
3c73e180 80%endif
37ceaf05 81Source1: %{name}.default
8b53130d
ER
82Source2: %{name}.sh
83Source3: %{name}.desktop
56c6e811
ER
84Source5: find-lang.sh
85Source6: update-source.sh
86Source7: clean-source.sh
836b1cac 87Source8: get-source.sh
0562b864 88Source9: master_preferences.json
48b341f5 89Patch1: plugin-searchdirs.patch
7abc645c 90Patch3: disable_dlog_and_dcheck_in_release_builds.patch
72cb20c1 91Patch4: path-libpdf.patch
0e5636cb 92Patch6: get-webkit_revision.patch
5aa5df39 93Patch7: dlopen_sonamed_gl.patch
4765ddf1 94Patch8: chromium_useragent.patch.in
8456d676 95Patch10: system-libxnvctrl.patch
1347c76c
AM
96# https://bugs.gentoo.org/show_bug.cgi?id=393471
97# libjpeg-turbo >= 1.1.90 supports that feature
f4a8da6a 98Patch11: chromium-revert-jpeg-swizzle-r2.patch
108c5f7c 99Patch12: system-ffmpeg.patch
5997e180
ER
100Patch15: nacl-build-irt.patch
101Patch16: nacl-linkingfix.patch
9516ca97 102Patch18: nacl-no-untar.patch
6897926c 103Patch24: nacl-verbose.patch
c5b396f3
ER
104Patch25: gnome3-volume-control.patch
105Patch26: master-prefs-path.patch
25d4e23c 106Patch28: system-mesa.patch
eda1bb04 107Patch29: speechd-0.8.patch
65de9065 108Patch30: no-pnacl.patch
06e6d11b 109Patch31: sync-session-name.patch
750b48f7 110URL: http://www.chromium.org/Home
ae3fe89f 111%{?with_gconf:BuildRequires: GConf2-devel}
a28c0ac3
ER
112%{?with_system_mesa:BuildRequires: Mesa-libGL-devel >= 9.1}
113%{?with_system_mesa:BuildRequires: Mesa-libGLES-devel >= 9.1}
7b8f219a 114%{?with_system_mesa:BuildRequires: Mesa-libGLU-devel}
a28c0ac3 115%{?with_system_mesa:BuildRequires: Mesa-libOSMesa-devel >= 9.1}
05f72ae2
ER
116BuildRequires: alsa-lib-devel
117BuildRequires: atk-devel
118BuildRequires: bison
11ad81c4 119BuildRequires: bzip2-devel
5997e180
ER
120%{?with_nacl:BuildRequires: crossnacl-binutils >= 2.20.1}
121%{?with_nacl:BuildRequires: crossnacl-gcc >= 4.4.3}
122%{?with_nacl:BuildRequires: crossnacl-gcc-c++ >= 4.4.3}
9516ca97 123%{?with_nacl:BuildRequires: crossnacl-newlib >= 1.20.0-3}
ae3fe89f 124%{?with_cups:BuildRequires: cups-devel}
92965b0e 125BuildRequires: elfutils-devel
77f32fa3 126BuildRequires: expat-devel
7d0dbc8d 127%{?with_system_ffmpeg:BuildRequires: ffmpeg-devel >= 1.0}
8f5f6775 128%{?with_system_flac:BuildRequires: flac-devel >= 1.2.1-7}
11ad81c4 129BuildRequires: fontconfig-devel
f1b276d4 130BuildRequires: glib2-devel
05f72ae2 131BuildRequires: gperf
71d49434 132%{?with_gps:BuildRequires: gpsd-devel}
bbad64b7 133BuildRequires: gtest-devel
8b53130d 134BuildRequires: gtk+2-devel
01b4dc8e 135%{?with_system_harfbuzz:BuildRequires: harfbuzz-devel}
a3140cd1 136%{?with_kerberos:BuildRequires: heimdal-devel}
0eb19b0b 137BuildRequires: hicolor-icon-theme
ed514974 138%{?with_system_jsoncpp:BuildRequires: jsoncpp-devel}
ef121064 139%{?with_system_libxnvctrl:BuildRequires: libXNVCtrl-devel >= 310.19}
05f72ae2 140BuildRequires: libevent-devel
8456d676 141%{?with_system_libexif:BuildRequires: libexif-devel >= 1:0.6.21}
7f40f3f4 142%{?with_keyring:BuildRequires: libgnome-keyring-devel}
0b214002 143BuildRequires: libicu-devel >= 4.6
39c71b4c 144%{!?with_libjpegturbo:BuildRequires: libjpeg-devel}
f4a8da6a 145%{?with_libjpegturbo:BuildRequires: libjpeg-turbo-devel >= 1.2.0}
8456d676 146%{?with_system_libmtp:BuildRequires: libmtp-devel >= 1.1.3}
05f72ae2 147BuildRequires: libpng-devel
e266589e 148%{?with_selinux:BuildRequires: libselinux-devel}
05f72ae2 149BuildRequires: libstdc++-devel
ba685303 150%{?with_system_libusb:BuildRequires: libusb-devel >= 1.0}
4b411ffe 151%{?with_system_libvpx:BuildRequires: libvpx-devel >= 0.9.5-2}
dd1509bd 152%{?with_system_libwebp:BuildRequires: libwebp-devel >= 0.1.99}
f1b276d4 153BuildRequires: libxml2-devel
11ad81c4 154BuildRequires: libxslt-devel
535cb410 155BuildRequires: man-db
62950103 156%{?with_system_minizip:BuildRequires: minizip-devel}
05f72ae2 157BuildRequires: nspr-devel
f1b276d4 158BuildRequires: nss-devel >= 1:3.12.3
8456d676 159%{?with_system_opus:BuildRequires: opus-devel >= 1.0.2}
35902862 160BuildRequires: pam-devel
f1b276d4 161BuildRequires: pango-devel
ef121064 162BuildRequires: pciutils-devel
48b341f5 163BuildRequires: perl-modules
164BuildRequires: pkgconfig
75a27c2e 165%{?with_system_protobuf:BuildRequires: protobuf-devel}
ae3fe89f 166%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
f1b276d4 167BuildRequires: python
46cdefee 168#BuildRequires: python-gyp >= 1-%{gyp_rev}
48b341f5 169BuildRequires: python-modules
92965b0e 170BuildRequires: python-ply
543e99ac 171%{?with_system_re2:BuildRequires: re2-devel >= 20130115-2}
0cad051b 172BuildRequires: rpm >= 4.4.9-56
f1b276d4 173BuildRequires: rpmbuild(macros) >= 1.453
eda1bb04 174BuildRequires: speech-dispatcher-devel >= 0.8
0cad051b 175%{?with_system_speex:BuildRequires: speex-devel >= 1:1.2-rc1}
5048b37a 176%{?with_system_sqlite:BuildRequires: sqlite3-devel >= 3.7}
9bd2659c 177%{?with_system_libsrtp:BuildRequires: srtp-devel >= 1.4.4}
89f0dde4 178BuildRequires: subversion
0cad051b 179BuildRequires: tar >= 1:1.22
0a424ee2 180BuildRequires: udev-devel
7d1152d4 181BuildRequires: usbutils
2303ed45 182BuildRequires: util-linux
c14cd342 183%{?with_system_v8:BuildRequires: v8-devel >= 3.7}
0826c245 184BuildRequires: which
f1b276d4 185BuildRequires: xorg-lib-libXScrnSaver-devel
836b1cac 186BuildRequires: xz
a3140cd1 187%{?with_system_yasm:BuildRequires: yasm}
f1b276d4 188%{?with_system_zlib:BuildRequires: zlib-devel}
e53ecfb5 189Requires: browser-plugins >= 2.0
0cad051b 190Requires: desktop-file-utils
8f5f6775 191%{?with_system_flac:Requires: flac >= 1.2.1-7}
ae20377c
ER
192# crashes if no fontconfig font present
193Requires: fonts-Type1-urw
0eb19b0b 194Requires: hicolor-icon-theme
56403697 195Requires: libevent >= 2.0.21
c1edaafa 196%{?with_libjpegturbo:Requires: libjpeg-turbo >= 1.2.0}
4b411ffe 197%{?with_system_libvpx:Requires: libvpx >= 0.9.5-2}
b809ab60 198Requires: lsb-release
b2c4ae39 199%{?with_system_re2:Requires: re2 >= 20130115-2}
3700ba38 200Requires: shared-mime-info
f7b16691 201%{?with_system_sqlite:Requires: sqlite3(icu)}
4dc49133 202Requires: xdg-utils >= 1.0.2-4
2cbfc1a4 203Requires: xorg-lib-libX11 >= 1.4.99.1
e53ecfb5 204Provides: wwwbrowser
c3582150 205Obsoletes: chromium-browser-bookmark_manager < 5.0.388.0
a3140cd1 206Obsoletes: chromium-browser-inspector < 15.0.863.0
2351db3b 207ExclusiveArch: %{ix86} %{x8664} arm
11ad81c4 208BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11ad81c4 209
589d90ea 210%define find_lang sh find-lang.sh %{buildroot}
2446ebb3 211
e7fa0817
ER
212# Usage: gyp_with BCOND_NAME [OPTION_NAME]
213%define gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
589d90ea 214
6b113615
ER
215%if %{without debuginfo}
216%define _enable_debug_packages 0
217%endif
218
11ad81c4 219%description
80838854
ER
220Chromium is an open-source browser project that aims to build a safer,
221faster, and more stable way for all Internet users to experience the
222web.
223
224Chromium serves as a base for Google Chrome, which is Chromium
225rebranded (name and logo) with very few additions such as usage
226tracking and an auto-updater system.
227
f1b276d4
ER
228%package l10n
229Summary: chromium-browser language packages
230Group: I18n
231Requires: %{name} = %{version}-%{release}
8da7b90b
ER
232%if "%{_rpmversion}" >= "5"
233BuildArch: noarch
234%endif
f1b276d4
ER
235
236%description l10n
237Chromium is an open-source browser project that aims to build a safer,
238faster, and more stable way for all Internet users to experience the
239web.
240
241This package contains language packages for 50 languages:
242
e7fa0817
ER
243ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
244he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
245pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
246zh-TW
f1b276d4
ER
247
248%prep
3c73e180
ER
249%setup -qc
250%if "%{?patchver}" != ""
251cd %{name}-%{branch}.%{basever}
252%patch0 -p1
253cd ..
254%endif
75f96a39 255mv %{name}-%{branch}.%{basever}/* .
589d90ea 256
05f72ae2
ER
257# Google's versioning is interesting. They never reset "BUILD", which is how we jumped
258# from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
75f96a39 259. ./chrome/VERSION
e00e4177
ER
260chrome=$MAJOR.$MINOR.$BUILD.$PATCH
261test "$chrome" = %{version}
a3140cd1 262
75f96a39 263gyp_rev=$(grep googlecode_url.*gyp DEPS | cut -d'"' -f6 | cut -d@ -f2)
2d2c8139 264test "$gyp_rev" = %{gyp_rev} || :
05f72ae2 265
e00e4177
ER
266. ./v8.sh
267v8=$MAJOR_VERSION.$MINOR_VERSION.$BUILD_NUMBER.$PATCH_LEVEL
33b04c7d 268
4765ddf1
ER
269# add chromium and pld to useragent
270%define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
271sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
25d4e23c
ER
272 -e 's/@BUILD_DIST_NAME@/PLD/g' \
273 -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
75f96a39 274 < %{PATCH8} | %{__patch} -p2
4765ddf1 275
8da7b90b 276%{__sed} -e 's,@localedir@,%{_datadir}/%{name},' %{SOURCE5} > find-lang.sh
75f96a39
ER
277ln -s %{SOURCE7} .
278
279%patch1 -p2
280%patch3 -p2
281%patch4 -p3
282%patch6 -p2
283%patch7 -p2
284%patch10 -p2
285%patch15 -p2
f4a8da6a 286%{!?with_libjpegturbo:%patch11 -p0}
108c5f7c 287%patch12 -p1
5997e180 288%patch16 -p1
41d6a4b1 289%patch28 -p1
75f96a39
ER
290%patch25 -p2
291%patch18 -p2
292%patch24 -p2
293%patch26 -p2
294%patch29 -p2
65de9065 295%patch30 -p0
effb85eb 296%patch31 -p0
e9abb380 297
75a27c2e
ER
298sh -x clean-source.sh \
299 %{!?with_nacl:nacl=0} \
bbdce24d
ER
300 %{!?with_system_libvpx:libvpx=0} \
301 %{!?with_system_libxnvctrl:libXNVCtrl=0} \
25d4e23c 302 %{!?with_system_mesa:mesa=0} \
75a27c2e 303 %{!?with_system_protobuf:protobuf=0} \
bbdce24d 304 %{!?with_system_re2:re2=0} \
5048b37a 305 %{!?with_system_sqlite:sqlite=0} \
75a27c2e
ER
306 %{!?with_system_v8:v8=0} \
307 %{!?with_system_zlib:zlib=0} \
308 %{nil}
fded59be 309
e266589e 310%build
5997e180 311%if %{with nacl}
108c5f7c 312rm -rf native_client/toolchain/linux_x86_newlib
fded59be 313if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
dcea0d6b 314# Make symlinks for NaCL
108c5f7c 315install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,nacl}
2e4113fd 316
108c5f7c
ER
317cd native_client/toolchain/linux_x86_newlib
318ln -s x86_64-nacl/bin bin
319cd x86_64-nacl/bin
2e4113fd 320__cc='%{__cc}'
f64e73f6 321if [ "${__cc#ccache}" != "$__cc" ]; then
2e4113fd
ER
322 echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
323 echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
324 %{__sed} -i -e '1i#!/bin/sh' gcc g++
325 chmod +x gcc g++
326else
327 ln -s %{_bindir}/x86_64-nacl-gcc gcc
328 ln -s %{_bindir}/x86_64-nacl-g++ g++
329fi
108c5f7c
ER
330ln -s gcc x86_64-nacl-gcc
331ln -s g++ x86_64-nacl-g++
332ln -s %{_bindir}/x86_64-nacl-ar .
5997e180
ER
333ln -s %{_bindir}/x86_64-nacl-ar ar
334ln -s %{_bindir}/x86_64-nacl-as as
108c5f7c 335ln -s %{_bindir}/x86_64-nacl-ranlib .
5997e180 336ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
108c5f7c 337ln -s %{_bindir}/x86_64-nacl-strip .
5997e180 338ln -s %{_bindir}/x86_64-nacl-strip strip
108c5f7c
ER
339ln -s %{_prefix}/x86_64-nacl/lib ../lib
340ln -s %{_prefix}/x86_64-nacl/lib32 ../lib32
dcea0d6b
ER
341ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
342cd ../../../../..
fded59be 343fi
5997e180
ER
344%endif
345
c5b396f3 346test %{_specdir}/%{name}.spec -nt Makefile && %{__rm} -f Makefile
b4d75247
ER
347test -e Makefile || \
348 CC="%{__cc}" \
349 CXX="%{__cxx}" \
350 LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
351 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
352 CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
353%{__python} build/gyp_chromium \
673aee14 354 --format=make \
75f96a39 355 --depth=. \
673aee14 356 build/all.gyp \
f1b276d4
ER
357%ifarch %{ix86}
358 -Dtarget_arch=ia32 \
359%endif
360%ifarch %{x8664}
0c480b89
ER
361 -Dtarget_arch=x64 \
362%endif
7b454a31
AM
363%if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
364 -Dno_strict_aliasing=1 -Dgcc_version=44 \
f1b276d4
ER
365%endif
366%if %{with sandboxing}
367 -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
368 -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
369%endif
370 %{!?debug:-Dwerror=} \
c980b122 371 %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
f1b276d4 372 %{?with_shared_libs:-Dlibrary=shared_library} \
9da385b7 373 %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1} -Dproprietary_codecs=1 \
b5a3dda3 374 -Dinclude_tests=0 \
c0808220 375%if %{with nacl}
038f76b9 376 -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
9516ca97
ER
377 -Ddisable_glibc_untar=1 \
378 -Ddisable_newlib_untar=1 \
8fb1dc98
ER
379 -Ddisable_glibc=1 \
380 -Ddisable_pnacl=1 \
381 -Dbuild_pnacl_newlib=0 \
c0808220 382%else
8fb1dc98 383 -Ddisable_pnacl_untar=1 \
c0808220
ER
384 -Ddisable_nacl=1 \
385%endif
a3140cd1
ER
386 %{!?with_sse2:-Ddisable_sse2=1} \
387 %{?with_selinux:-Dselinux=1} \
7d1152d4 388 -Dusb_ids_path=$(pkg-config --variable usbids usbutils) \
05998197 389 -Dlinux_link_libpci=1 \
bd827d58 390 -Dlinux_link_libspeechd=1 \
05998197 391 %{!?with_tcmalloc:-Dlinux_use_tcmalloc=0} \
71d49434 392 %{?with_gps:-Dlinux_use_libgps=1 -Dlinux_link_libgps=1} \
05998197
ER
393 -Dlinux_use_gold_binary=0 \
394 -Dlinux_use_gold_flags=0 \
e7fa0817 395 %{gyp_with cups} \
8dda6bbc 396 %{gyp_with gconf} -Dlinux_link_gsettings=0 \
bd827d58 397 %{gyp_with kerberos} -Dlinux_link_kerberos=1 \
e7fa0817
ER
398 %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
399 %{gyp_with pulseaudio} \
41d6a4b1 400 %{gyp_with system_ffmpeg} -Dmedia_use_ffmpeg=1 \
8f5f6775 401 %{gyp_with system_flac} \
01b4dc8e 402 %{gyp_with system_harfbuzz} \
2d65d095 403 %{gyp_with system_jsoncpp} \
62950103
ER
404 %{gyp_with system_libexif} \
405 %{gyp_with system_libmtp} \
9bd2659c 406 %{gyp_with system_libsrtp} \
581aec44 407 %{gyp_with system_libusb} \
41d6a4b1 408 %{gyp_with system_libvpx} -Dmedia_use_libvpx=0 \
ba685303 409 %{gyp_with system_libwebp} \
4884fc99 410 %{gyp_with system_libxnvctrl} \
7b8f219a 411 %{gyp_with system_mesa} \
126ea630 412 %{gyp_with system_minizip} \
62950103 413 %{gyp_with system_opus} \
75a27c2e 414 %{gyp_with system_protobuf} \
bbdce24d 415 %{gyp_with system_re2} \
e7fa0817 416 %{gyp_with system_speex} \
914ee37c 417 %{gyp_with system_sqlite} %{?with_system_sqlite:-Denable_sql_database=0} \
e7fa0817
ER
418 %{gyp_with system_v8} \
419 %{gyp_with system_yasm} \
420 %{gyp_with system_zlib} \
0c480b89 421 -Duse_system_bzip2=1 \
62950103 422 -Duse_system_expat=1 \
0b214002 423 -Duse_system_icu=1 \
f1b276d4 424 -Duse_system_libevent=1 \
0c480b89 425 -Duse_system_libjpeg=1 \
f1b276d4
ER
426 -Duse_system_libpng=1 \
427 -Duse_system_libxml=1 \
428 -Duse_system_libxslt=1 \
b363f856 429 -Duse_system_nspr=1 \
7f40f3f4 430 -Duse_system_xdg_utils=1 \
11ad81c4 431
b4d75247 432# need {CC/CXX/LDFLAGS}.host overrides for v8 build
48ffbc5e 433%{__make} -r chrome %{?with_sandboxing:chrome_sandbox} \
f1b276d4
ER
434 BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
435 %{?with_verbose:V=1} \
f1b276d4
ER
436 CC.host="%{__cc}" \
437 CXX.host="%{__cxx}" \
b4d75247 438 LDFLAGS.host="%{rpmldflags} -fuse-ld=gold" \
11ad81c4 439
75f96a39 440cd out/%{!?debug:Release}%{?debug:Debug}
535cb410
ER
441MANWIDTH=80 man ./chrome.1 > man.out
442%{__sed} -e '1,/OPTIONS/d; /ENVIRONMENT/,$d' man.out > options.txt
443
11ad81c4
AM
444%install
445rm -rf $RPM_BUILD_ROOT
8da7b90b
ER
446install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins \
447 $RPM_BUILD_ROOT%{_datadir}/%{name}/{locales,resources} \
37ceaf05 448 $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/%{name},%{_mandir}/man1,%{_desktopdir}}
e266589e 449
673aee14 450cd out/%{!?debug:Release}%{?debug:Debug}
37ceaf05 451cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
f1b276d4 452install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
535cb410
ER
453%{__sed} -i -e '
454 s,@libdir@,%{_libdir}/%{name},
455
456 /@OPTIONS@/ {
457 r options.txt
458 d
459 }
460' $RPM_BUILD_ROOT%{_bindir}/%{name}
8da7b90b
ER
461cp -a locales resources $RPM_BUILD_ROOT%{_datadir}/%{name}
462cp -a *.pak $RPM_BUILD_ROOT%{_libdir}/%{name}
463ln -s %{_datadir}/%{name}/locales $RPM_BUILD_ROOT%{_libdir}/%{name}/locales
464ln -s %{_datadir}/%{name}/resources $RPM_BUILD_ROOT%{_libdir}/%{name}/resources
7f40f3f4 465cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
f1b276d4 466install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
e53ecfb5 467install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
fcc48c19 468%if %{without system_ffmpeg}
f1b276d4 469install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
dd46de65 470%endif
e7fa0817 471cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
0562b864 472cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
164020eb 473
8da7b90b 474%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/resources/extension/demo
c0808220 475
164020eb
ER
476%if %{with nacl}
477# Install Native Client files on platforms that support it.
478install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
479install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
480%ifarch %{x8664}
481install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
482%endif
483%ifarch %{ix86}
484install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
485%endif
486%endif
487
0c480b89
ER
488cd -
489
75f96a39 490for icon in chrome/app/theme/chromium/product_logo_[0-9]*.png; do
0eb19b0b
ER
491 size=${icon##*/product_logo_}
492 size=${size%.png}
493
494 # this will skip non-numeric (22_mono_invert, 22_mono)
495 dir=%{_iconsdir}/hicolor/${size}x${size}/apps
496 test -d "$dir" || continue
497
498 install -d $RPM_BUILD_ROOT$dir
499 cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
500done
7f40f3f4 501
13840bc2
AM
502%browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
503# http://code.google.com/p/chromium/issues/detail?id=24507
504gecko-mediaplayer*.so
505EOF
11ad81c4 506
589d90ea
ER
507# find locales
508%find_lang %{name}.lang
e7fa0817 509# always package en-US
f1b276d4 510%{__sed} -i -e '/en-US.pak/d' %{name}.lang
589d90ea 511
11ad81c4
AM
512%clean
513rm -rf $RPM_BUILD_ROOT
514
8da7b90b
ER
515%pretrans
516for d in locales resources; do
517 if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
518 install -d %{_datadir}/%{name}
519 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
520 fi
521done
522exit 0
523
f1b276d4 524%post
0eb19b0b 525%update_icon_cache hicolor
b7a6e4ee 526%update_desktop_database
f1b276d4
ER
527%update_browser_plugins
528
529%postun
530if [ "$1" = 0 ]; then
0eb19b0b 531 %update_icon_cache hicolor
f1b276d4
ER
532 %update_browser_plugins
533fi
534
1d2b9616 535%files
11ad81c4 536%defattr(644,root,root,755)
75f96a39 537%doc AUTHORS LICENSE
f1b276d4
ER
538%{_browserpluginsconfdir}/browsers.d/%{name}.*
539%config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
37ceaf05
ER
540%dir %{_sysconfdir}/%{name}
541%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
0562b864 542%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
f1b276d4
ER
543%attr(755,root,root) %{_bindir}/%{name}
544%{_mandir}/man1/%{name}.1*
11ad81c4 545%{_desktopdir}/*.desktop
0eb19b0b 546%{_iconsdir}/hicolor/*/apps/%{name}.png
0c480b89 547%dir %{_libdir}/%{name}
e9abb380 548%{_libdir}/%{name}/chrome*.pak
c14cd342 549%{_libdir}/%{name}/content_resources.pak
97fac491 550%{_libdir}/%{name}/resources.pak
8da7b90b
ER
551%{_libdir}/%{name}/locales
552%{_libdir}/%{name}/resources
553
554%dir %{_datadir}/%{name}
555%dir %{_datadir}/%{name}/locales
556%{_datadir}/%{name}/locales/en-US.pak
557%dir %{_datadir}/%{name}/resources
558%{_datadir}/%{name}/resources/inspector
559
f1b276d4
ER
560%dir %{_libdir}/%{name}/plugins
561%attr(755,root,root) %{_libdir}/%{name}/%{name}
0c480b89 562# These unique permissions are intentional and necessary for the sandboxing
e53ecfb5 563%attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
f1b276d4
ER
564
565# ffmpeg libs
fcc48c19 566%if %{without system_ffmpeg}
f1b276d4 567%attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
dd46de65 568%endif
f1b276d4 569
164020eb
ER
570%if %{with nacl}
571%attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
572%attr(755,root,root) %{_libdir}/%{name}/nacl_helper
573%attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
574%attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
575%endif
576
f1b276d4
ER
577%files l10n -f %{name}.lang
578%defattr(644,root,root,755)
This page took 0.236617 seconds and 4 git commands to generate.